Jump to content
Sign in to follow this  
spikesonline

"My Account" and "Checkout" 404 Error

Recommended Posts

ok so I'm new to OSC but I think I've done well so far. One thing I can't figure out is why when I click on either "My Account" or "Checkout", I get a 404 Error (not found) and a Forbidden message. I've double checked that the access to these files are all set to have full permission. I've also made sure that these files are on the server. Somebody please tell me how to fix it. The site is SpikesOnline.ca.

Share this post


Link to post
Share on other sites

Those links are pointing to https:// pages (secure pages).

 

My guess is one of two things

 

you either have SSL enabled, but you don't have SSL

 

OR

 

you do have SSL and it's not configured correctly

 

ok so I'm new to OSC but I think I've done well so far. One thing I can't figure out is why when I click on either "My Account" or "Checkout", I get a 404 Error (not found) and a Forbidden message. I've double checked that the access to these files are all set to have full permission. I've also made sure that these files are on the server. Somebody please tell me how to fix it. The site is SpikesOnline.ca.

Share this post


Link to post
Share on other sites
Those links are pointing to https:// pages (secure pages).

 

My guess is one of two things

 

you either have SSL enabled, but you don't have SSL

 

OR

 

you do have SSL and it's not configured correctly

 

So how do I check whether it is/isn't turned on and how do I go about fixing this? Any suggestions?

Share this post


Link to post
Share on other sites

In catalog/includes/configure.php

 

The third line down

 

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 

check and see if it's true or false there

Share this post


Link to post
Share on other sites
In catalog/includes/configure.php

 

The third line down

 

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 

check and see if it's true or false there

 

I looked in that file and it's set to true...but when I tried to change it to false, it came up another error about a misconfiguration. I did however find on the cpanel for the site that I can setup an SSL but I have no idea how that stuff works.

Share this post


Link to post
Share on other sites

What you see there on the cpanel is probably a set up for a self signed certificate which is not worth the trouble

 

What error did you get, exactly?

 

I looked in that file and it's set to true...but when I tried to change it to false, it came up another error about a misconfiguration. I did however find on the cpanel for the site that I can setup an SSL but I have no idea how that stuff works.
Edited by choosealogin

Share this post


Link to post
Share on other sites
What you see there on the cpanel is probably a set up for a self signed certificate which is not worth the trouble

 

What error did you get, exactly?

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@spikesonline.stellarreviews.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Share this post


Link to post
Share on other sites

do you have an htaccess file in your catalog directory? And if so, why? Such as, for the SEO urls contribution, or to turn 'register globals' on, etc ??

Share this post


Link to post
Share on other sites
do you have an htaccess file in your catalog directory? And if so, why? Such as, for the SEO urls contribution, or to turn 'register globals' on, etc ??

 

I do have one....but it was put there by the auto install from my host's cpanel...i haven't edited it.

Share this post


Link to post
Share on other sites

I don't know if this will fix it, but try renaming it...to anything.

 

See if that makes the error go away

 

I do have one....but it was put there by the auto install from my host's cpanel...i haven't edited it.

Share this post


Link to post
Share on other sites
I don't know if this will fix it, but try renaming it...to anything.

 

See if that makes the error go away

 

 

I tried deleting it and I still get the error. I even tried the links when the includes/configure.php was set to true and when it was set to false....same errors that I got before

Share this post


Link to post
Share on other sites

If you don't have an SSL certificate, the line I quoted above in configure.php needs to be false.

 

check both configure.php files (one in catalog/includes and one in catalog/admin/includes), and set SSL to false...then see where we are.

Edited by choosealogin

Share this post


Link to post
Share on other sites
If you don't have an SSL certificate, the line I quoted above in configure.php needs to be false.

 

check both configure.php files (one in catalog/includes and one in catalog/admin/includes), and set SSL to false...then see where we are.

 

 

no dice...same errors

Share this post


Link to post
Share on other sites

Are any of the files (especially the ones causing errors) set to 777 permission? or are they 755?

 

I'm about out of ideas :'(

 

Might be time to contact your host.

 

Or if you have access to the error log, see what it's logging.

 

no dice...same errors

Share this post


Link to post
Share on other sites
Are any of the files (especially the ones causing errors) set to 777 permission? or are they 755?

 

I'm about out of ideas :'(

 

Might be time to contact your host.

 

Or if you have access to the error log, see what it's logging.

 

I set them all to 777 just to see if that would work..nope. anyways...thanks for the help. i'll just keep on trying.

Share this post


Link to post
Share on other sites

I just finally noticed something.

 

On your internal server error page, it says

 

contact ... webmaster@spikesonline.stellarreviews.com

 

Where's the stellarreviews part coming from? Is that in your paths somewhere in your configure files?

Share this post


Link to post
Share on other sites

Ok, well...I didn't mean for you to set them to 777. Something I read indicated having them set that 'freely' might cause the 500 error. Put the permission settings back down :)

Share this post


Link to post
Share on other sites
Ok, well...I didn't mean for you to set them to 777. Something I read indicated having them set that 'freely' might cause the 500 error. Put the permission settings back down :)

 

Yeah i will set them back down...as for the stellarreviews thing...that's the original host name....but i setup an addon domain that references spikesonline.ca...i have all the locations of the files set up correctly i think....spikesonline.ca is setup to be a folder on stellarreviews...everything appears under spikesonline...

Share this post


Link to post
Share on other sites
Yeah i will set them back down...as for the stellarreviews thing...that's the original host name....but i setup an addon domain that references spikesonline.ca...i have all the locations of the files set up correctly i think....spikesonline.ca is setup to be a folder on stellarreviews...everything appears under spikesonline...

 

 

OH SNAP!!!! i just changed them all back to 755 and it works! Serious thanks to you!

Share this post


Link to post
Share on other sites
OH SNAP!!!! i just changed them all back to 755 and it works! Serious thanks to you!

 

 

Great help with this problem! Thankyou much

Share this post


Link to post
Share on other sites

oh dear i seem to be having the same problem but i cant seem to fix it even following this help. I have tried setting the true ssl to false and when i save it and reopen it it has somehow become true again.....how is this???

 

HHHHHHhhhhhhhhhhhheeeeeeelllllllppppppppp!!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×