Jump to content
Sign in to follow this  
cgmsys

Catagory Description v1.03 by mightyx Question

Recommended Posts

IRT Cateogory Description v1.03 by mightyx

 

Hello, I was trying to add the catagory Descritpion contribution. I got stuck on the part below.

 

The last part of the contribution states:

 

 

FIND 2nd and if you have 3rd  HEADING_TITLE neer row 240-260


REPLACE WITH:
  <tr>
  <td class="pageHeading"><?php echo $category['categories_name']; ?></td>
  <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
	</tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
	<tr>
  <td class="productListing-data"><?php echo $categories_desc['categories_description']; ?></td>	
	</tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>

 

When I look at my index file, I see the following at about line 240

 

	 <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="0">
	  <tr>
		<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

 

I'm not clear on what part of the code actually gets replaced. The contribution just says to find the HEADING _TITLE and does not list any specific code to find and replace. I'd appreciate any clarification.

 

thanks

 

chris

Share this post


Link to post
Share on other sites

I would say the last two lines of what you posted get replaced, and probably the next line as well. You want to start with <tr> and end with [</tr>[/b] to avoid messing up the HTML. To put it another way, the first and last lines of the code that you replace should match the first and last lines of what you replace it with.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

i am getting this error when i try to create a new category also the cat box to edit the description does not appear ?

 

Fatal error: Call to undefined function: tep_get_category_description() in /home/eran26/public_html/store/admin/categories.php on line 907

 

on line 907 is this

 

$category_desc_inputs_string .= '<br>' . tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']) . ' ' . tep_draw_textarea_field('categories_description[' . $languages[$i]['id'] . ']', '', 20, 5, tep_get_category_description($cInfo->categories_id, $languages[$i]['id']));

 

}

 

any help would be appreciated thanks

 

RT

Edited by artpics

Share this post


Link to post
Share on other sites
i am getting this error when i try to create a new category also the cat box to edit the description does not appear ?

 

Fatal error: Call to undefined function: tep_get_category_description() in /home/eran26/public_html/store/admin/categories.php on line 907

<snip>

You need to add the tep_get_category_description() function to includes/functions/general.php. The instructions for this should be in the contribution package.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

thanks jim for your help, this contrib is still not working for me,

 

1. the only way i can edit the cat description is to create a new category. the input box appears.

2. i cannot get it to output the description on the new category i made.

3. i cannot edit the category description once created.

 

i do not get any warning messages though,

 

thanks for your time

 

RT

Share this post


Link to post
Share on other sites
thanks jim for your help, this contrib is still not working for me,

 

1. the only way i can edit the cat description is to create a new category. the input box appears.

2. i cannot get it to output the description on the new category i made.

3. i cannot edit the category description once created.

 

i do not get any warning messages though,

 

thanks for your time

 

RT

You have at least two errors in your edits. Check your changes to admin/categories.php and catalog/index.php. Check that the changes that you have made are in the proper locations.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

thanks jim for your replys, all is working now, but i had trouble with the index file as i had other contribs installed, in the end i managed to get the mess sorted, but when i go back to edit the cat description it does not hole the data from last time any way i can live with that thanks again for your time

 

RT :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×