Jump to content
Sign in to follow this  
nate_02631

"Dynamenu" for osCommerce

Recommended Posts

I'm not sure exactly what you mean by merging a format with your template? If you follow the install instructions the menu should show up where you want it at in your template, and then you just adjust the appearance through the stylesheet.

 

Please don't forget about me :'( Isn't there someone out there who has experience merging dynamenu with their template? :(


~Tracy
 

Share this post


Link to post
Share on other sites

Hi,

 

I don't have much experience with this contribution, the only section I'm familiar with at this point from playing with the files is the Vertical Menu option. What is your exact problem?

 

Regards,

 

Jane

 

 

I'm not sure exactly what you mean by merging a format with your template? If you follow the install instructions the menu should show up where you want it at in your template, and then you just adjust the appearance through the stylesheet.

 

 

Thank you two for responding, hopefully you can help me. I used this oscommerce template (please notice the "category" menu on the left) but when I installed the tree menu, it turned into purple folders, green checkmarks and dotted lines and kind of throws my website off. Is implementing dynamenu into that menu look possible? If it's with the .css would you know what I need to edit? The instruction manual doesn't really provide a clear explanation as to how to go about that so I'm stuck unfortunately. Thanks again for your time, I really appreciate it :D

Edited by csbutler3

Share this post


Link to post
Share on other sites

Some of this is adjusted in your catalog/includes/boxes/dm_categories.php file, at the top where you need to read through the commented out text to see what settings you want to adjust for the menu type you choose to use. This section for example may change what you're seeing:

// Show icons on tree menus? If set to false, only expand/collapse icons and connecting lines are shown
$GLOBALS['dm_tree_folder_icons'] = true;

 

and this:

// Misc setting to make folder icon clickable to expand tree menu nodes
$GLOBALS['dm_tree_titleclick'] = true;	

 

If you look in the Dynamenu Contribution images folder you will find all of the icons that are used in the tree menu, including the purple folders. You can create an image in whatever color you like and save it with the same name and upload it to your site.

 

Hope that helps.

 

Thank you two for responding, hopefully you can help me. I used this oscommerce template (please notice the "category" menu on the left) but when I installed the tree menu, it turned into purple folders, green checkmarks and dotted lines and kind of throws my website off. Is implementing dynamenu into that menu look possible? If it's with the .css would you know what I need to edit? The instruction manual doesn't really provide a clear explanation as to how to go about that so I'm stuck unfortunately. Thanks again for your time, I really appreciate it :D


~Tracy
 

Share this post


Link to post
Share on other sites

Thank you two for responding, hopefully you can help me. I used this oscommerce template (please notice the "category" menu on the left) but when I installed the tree menu, it turned into purple folders, green checkmarks and dotted lines and kind of throws my website off. Is implementing dynamenu into that menu look possible? If it's with the .css would you know what I need to edit? The instruction manual doesn't really provide a clear explanation as to how to go about that so I'm stuck unfortunately. Thanks again for your time, I really appreciate it :D

 

Sorry I'm a few days late, had my head stuck in some PHP coding.

 

Anyway, lets get to business, I can try to help you. The "Purple Folders" in the Tree Menu are images that you would have copied over from the contribution setup files (category/images) to your main image folder (category/images or /images) therefore just create the image you want to appear in place of the folder (looking at your screen shot it would be an arrow) and keep the file name the same file and just replace the "arrow" image with it. Basically overwrite the file with just a different image but same file name.

 

I'm not so sure why it would show "Green Checkmarks" I do know that in the stylesheet under the "Tree and Plain Menu Style" under the code

a.phplm:link, a.phplm:visited	{      /* Font color, style of linked & visited menu items */

the color code listed there is green so that could been the section you need to look at.

 

Dotted Lines - maybe it's an image in the same image folder and the "Purple Folders." I would just change the image to just be plain white.

 

AGAIN - not a pro or too familiar with this contribution, just trying to help point you in the right direction.

 

Hope I was able to help somehow.

 

Good Luck!

 

Jane

Share this post


Link to post
Share on other sites

Some of this is adjusted in your catalog/includes/boxes/dm_categories.php file, at the top where you need to read through the commented out text to see what settings you want to adjust for the menu type you choose to use. This section for example may change what you're seeing:

// Show icons on tree menus? If set to false, only expand/collapse icons and connecting lines are shown
$GLOBALS['dm_tree_folder_icons'] = true;

 

and this:

// Misc setting to make folder icon clickable to expand tree menu nodes
$GLOBALS['dm_tree_titleclick'] = true;	

 

If you look in the Dynamenu Contribution images folder you will find all of the icons that are used in the tree menu, including the purple folders. You can create an image in whatever color you like and save it with the same name and upload it to your site.

 

Hope that helps.

 

 

Yeah, this helped me =) I got rid of the icons until Im able to make my own, but it looks a LOT better as-is :thumbsup: Thanks for the help on this issue, now I just have one more if you don't mind. Usually when you click a item category name, it expands and shows the sub categories, but when I click one name it won't expand, I have to click the "+" next to it to get it to open up. Any ideas on how to remedy this?

 

Sorry I'm a few days late, had my head stuck in some PHP coding.

 

Anyway, lets get to business, I can try to help you. The "Purple Folders" in the Tree Menu are images that you would have copied over from the contribution setup files (category/images) to your main image folder (category/images or /images) therefore just create the image you want to appear in place of the folder (looking at your screen shot it would be an arrow) and keep the file name the same file and just replace the "arrow" image with it. Basically overwrite the file with just a different image but same file name.

 

I'm not so sure why it would show "Green Checkmarks" I do know that in the stylesheet under the "Tree and Plain Menu Style" under the code

a.phplm:link, a.phplm:visited	{      /* Font color, style of linked & visited menu items */

the color code listed there is green so that could been the section you need to look at.

 

Dotted Lines - maybe it's an image in the same image folder and the "Purple Folders." I would just change the image to just be plain white.

 

AGAIN - not a pro or too familiar with this contribution, just trying to help point you in the right direction.

 

Hope I was able to help somehow.

 

Good Luck!

 

Jane

Share this post


Link to post
Share on other sites

The only thing I would know of is to look at the dynamenu templates and see if the <a> tag is set to wrap the + and the name or just the + and adjust it to how you want it.

 

Yeah, this helped me =) I got rid of the icons until Im able to make my own, but it looks a LOT better as-is :thumbsup: Thanks for the help on this issue, now I just have one more if you don't mind. Usually when you click a item category name, it expands and shows the sub categories, but when I click one name it won't expand, I have to click the "+" next to it to get it to open up. Any ideas on how to remedy this?


~Tracy
 

Share this post


Link to post
Share on other sites

The only thing I would know of is to look at the dynamenu templates and see if the <a> tag is set to wrap the + and the name or just the + and adjust it to how you want it.

 

 

I see... When you say dynamenu templates, which file are you referring to? I chekced dm_categories.php, but I didnt see any <a> tag nor +. =(

Share this post


Link to post
Share on other sites

catalog/includes/functions/dynamenu there are a few folders in here that may have what your looking for, lib, libjs and templates

 

I see... When you say dynamenu templates, which file are you referring to? I chekced dm_categories.php, but I didnt see any <a> tag nor +. =(


~Tracy
 

Share this post


Link to post
Share on other sites

I have dynamenu installed. It has been working great, but suddenly it will not expand in one category. When you click the text link (not the + Image), it will not expand to show the subcategories. My other categories are working fine!!

 

It has to be a database issue, but I'm stumped where to look!

 

Someone just started helping maintain the site, but they don't "remember" doing anything that would affect the categories.

 

ANY HELP PLEASE!!!

 

Also, easy question ... how do I get rid of the item count at the end of each category line?

 

THANK YOU

Share this post


Link to post
Share on other sites

Update...

It is happening to the first category in my list. I added a new category - with a subcategory to my categories. Then THAT new one would not expand, but my "problem" category was expanding because it was second in my list of categories.

 

Does this make any sense?? My first category in my tree menu WILL not expand. What have I done to break dynamenu???

 

 

 

I have dynamenu installed. It has been working great, but suddenly it will not expand in one category. When you click the text link (not the + Image), it will not expand to show the subcategories. My other categories are working fine!!

 

It has to be a database issue, but I'm stumped where to look!

 

Someone just started helping maintain the site, but they don't "remember" doing anything that would affect the categories.

 

ANY HELP PLEASE!!!

 

Also, easy question ... how do I get rid of the item count at the end of each category line?

 

THANK YOU

Share this post


Link to post
Share on other sites

Update...

It is happening to the first category in my list. I added a new category - with a subcategory to my categories. Then THAT new one would not expand, but my "problem" category was expanding because it was second in my list of categories.

 

Does this make any sense?? My first category in my tree menu WILL not expand. What have I done to break dynamenu???

Share this post


Link to post
Share on other sites

I'm having an issue with Internet Explorer (IE8) using the vertical fly-out menu. I attached a screenshot to show what I mean.

 

vfomenu.th.jpg

Edited by MrE03

Share this post


Link to post
Share on other sites

I finally managed to install dynamenu successfully thanks to the post http://forums.oscommerce.com/topic/209045-dynamenu-for-oscommerce/page__st__560__p__1250197entry1250197 so thanks :)

 

Now I have 1 question and 1 remark:

 

1)

I want that when I click on a sucategory and it moves to that subcategory page, the menu actually expands to show all the subcategories of this category and stays expanded (like in the basic osC menu, not in the fly-out style), while the other categories are still fly out menus. I thought this might be in the configuration at the beginning of dm_categories.php but actually nothing gave this result....also couldn't find anything on the forum. Any help is appreciated!

 

 

2)

When I installed successfully the menu, it worked fine with firefox and IE, but with chrome it would give me this error:

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/presence/public_html/eshop/includes/application_top.php on line 312

 

how I resolved this was to add "if($navigation) {" just before the place where the error occured.

 

How come only Chrome has this error? Now however it works fine. So just wanted to let everybody know ;)

 


// navigation history
if (tep_session_is_registered('navigation')) {
   if (PHP_VERSION < 4) {
     $broken_navigation = $navigation;
     $navigation = new navigationHistory;
     $navigation->unserialize($broken_navigation);
   }
} else {
   tep_session_register('navigation');
   $navigation = new navigationHistory;
}
if($navigation) {
$navigation->add_current_page();
}

Share this post


Link to post
Share on other sites

Hi all

 

i am trying to get this contribution to work for a couple of days now but no joy yet.

 

I do have a error in my error log that says:

[23-Sep-2010 12:02:01] PHP Deprecated: Function ereg_replace() is deprecated in /home/landyspe/public_html/includes/functions/dynamenu/lib/layersmenu-common.inc.php on line 793

 

I have a patch installed for the ereg problem but it doesn´t seem to work on this.

 

This is line 793

 

$this->tree[$cnt]['parsed_href'] = (ereg_replace(' ', '', $this->tree[$cnt]['href']) == '') ? '#' : $this->prependedUrl . $this->tree[$cnt]['href'];

 

I have no idea what it means tho.

Can anybody shed some light on this as i am in the dark big t9ime here ;-)

 

Many thanks in advance,

 

Rob

Share this post


Link to post
Share on other sites

This is line 793

 

$this->tree[$cnt]['parsed_href'] = (ereg_replace(' ', '', $this->tree[$cnt]['href']) == '') ? '#' : $this->prependedUrl . $this->tree[$cnt]['href'];

 

I have no idea what it means tho.

 

Try to use preg_replace instead..


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

@Sijo

 

Thanks , i hope this stops the errorfile from filling up.

 

It doesn´t make a difference with Dynamenu tho , it doesn´t want to work it seems.

 

regards,

 

Rob

Share this post


Link to post
Share on other sites

Hi All,

 

I've spent the last four hours trying to get this installation to work, and I can't get past the basic hurdle of getting the flyout menu to flyout.

 

I read this entire thread and tried many of the suggestions herein.

 

I have STS 4.6 installed and I think I followed bkellums advice on how to make dynamenu work with sts to the letter, but I've evidently done something wrong and now I'm just tired and frustrated.

 

If anyone can be kind enough to tell me what I'm doing wrong, I would be eternally grateful.

 

Please, please help.

 

Tom

 

P.S. My site is here: http://www.obtds.co.uk

 

P.P.S. Is there some kind of documentation that comes with dynamenu that explains how to use templates etc? I read several references to documentation like this in this thread, but nothing like that was included in my download folder.

Share this post


Link to post
Share on other sites

I've spent the last four hours trying to get this installation to work, and I can't get past the basic hurdle of getting the flyout menu to flyout.

 

Do you have this code at the end of both these files:

catalog\includes\footer.php

catalog\includes\application_bottom.php

// Output the footer for Dynamenu for osCommerc
echo $GLOBALS['dmfooter'];
?>


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Do you have this code at the end of both these files:

catalog\includes\footer.php

catalog\includes\application_bottom.php

// Output the footer for Dynamenu for osCommerc
echo $GLOBALS['dmfooter'];
?>

 

 

I do!

 

It must be something simple as , like discobob83 , i have read the whole thread and followed every suggestion or hint i could find but still no joy...

 

So, any help would be great!!

 

My website is here

 

Gr, Rob

Edited by Rob1962

Share this post


Link to post
Share on other sites

It must be something simple as , like discobob83 , i have read the whole thread and followed every suggestion or hint i could find but still no joy...

 

As I can see, you have not activated Dynamenu on your site?

But I did find this error:

href="//includes/sts_templates/multiple/stylesheet.css">

 

You have double '//' in your path..


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Hi

 

I found my problem , have a look here:the file to work on is NOT " column_left.php BUT STS_column_left.

 

Also i have put a $ before and after the dmbox placeholder like : $dmbox$

 

This did the trick for me so far.

 

 

 

View Postbkellum, on May 18 2008, 05:41 PM, said:

To those having issues with the flyouts using STS:

 

I just installed osCommerce RC2a, added Dynamenu (Nate's May 27, 2006 version) and flyouts work perfectly.

 

I then added STSv4.5.8. The menu no longer appears because I have to do a few extra additions as follows:

 

* Create the new dynamenu infobox tag (I did this in sts_column_left.php, just under the manufactures tag:

 

// Get manufacturer box from db or cache

if ((USE_CACHE == 'true') && empty($SID)) {

echo tep_cache_manufacturers_box();

} else {

include(DIR_WS_BOXES . 'manufacturers.php');

}

$sts->restart_capture ('manufacturerbox', 'box');require(DIR_WS_BOXES . 'dm_categories.php');

$sts->restart_capture('dmbox', 'box'); // Get Dynamenu Category box

 

require(DIR_WS_BOXES . 'whats_new.php');

$sts->restart_capture ('whatsnewbox', 'box'); // Get What's new box

 

 

* I then have to add duplicate the footer.php mods in the application_bottom.php file as so (add the following lines at the very end of the file just before the last closing tag - it will look like this):

 

// Output the footer for Dynamenu for osCommerce

echo $GLOBALS['dmfooter'];

?>

 

 

* I then copy all of the stylesheet mods from dynamenu to my stylesheet.css file at the very end of the file.

* I then add the $dmbox tag to each of my templates where I want to display the dynamenu category box.

* STS is setup by default to look for the stylesheet.css file in the root directory. Change this in your template if you need it to point somewhere else.

 

Now the flyouts work perfectly using Dynamenu, osC RC2a and STSv4.5.8.

There are no incompatibilities with Dyanmenu and STSv4.5.8. If you do the above, then it shouls work perfectly for you.

 

Hope this helped clear things up for you,

Share this post


Link to post
Share on other sites

As I can see, you have not activated Dynamenu on your site?

But I did find this error:

href="//includes/sts_templates/multiple/stylesheet.css">

 

You have double '//' in your path..

 

 

Hi Sijo

 

Thanks for your time and thanks for the observation of the double //

 

Hmmm , can you explain what that does and how to correct that or what it should be , i am a big noob at this!!

 

Regards,

 

Rob

Share this post


Link to post
Share on other sites

Thanks for your time and thanks for the observation of the double //

Hmmm , can you explain what that does and how to correct that or what it should be , i am a big noob at this!!

 

 

You could use a grep program to search through your files to find this.

Most likely it is in your index.php file or your template index file.

You'll find it in the header: (On your sites frontpage, right-click mouse, click 'View Source')

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>LandySpecials Lda</title>
<base href="[url="http://www.landyspecials4x4.com//"]http://www.landyspecials4x4.com//[/url]">

<!-- start get_javascript(applicationtop2header) //-->

<!-- end get_javascript(applicationtop2header) //-->


 <link rel="stylesheet" type="text/css" href="stylesheet.css">
 <link rel="stylesheet" type="text/css" href="//includes/sts_templates/multiple/stylesheet.css">
</head>

 

In your:

<base href="http://www.landyspecials4x4.com//">

you have '//' after .com - remove them..

 

In the last line:

<link rel="stylesheet" type="text/css" href="//includes/sts_templates/multiple/stylesheet.css">

you have href="// - those two '//' should not be there.


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Hi Sijo,

 

Thanks so much for replying!

 

I do have that code at the bottom of both of those files, but is it possible I've placed it wrongly or something?

 

I really can't tell you how much I appreciate you trying to help me. :)

 

This is what the files look like at the moment:

 

footer.php:

 

<?php

/*

$Id: footer.php 1739 2007-12-20 00:52:16Z hpdl $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

// START STS 4.5

if ($sts->display_template_output) {

// Get content here, in case column_right is not called.

if (!isset($sts->template['content'])) $sts->restart_capture

 

('content');

} else {

//END STS

 

require(DIR_WS_INCLUDES . 'counter.php');

?>

<table border="0" width="100%" cellspacing="0" cellpadding="1">

<tr class="footer">

<td class="footer">  <?php echo strftime

 

(DATE_FORMAT_LONG); ?>  </td>

<td align="right" class="footer">  <?php echo $counter_now

 

. ' ' . FOOTER_TEXT_REQUESTS_SINCE . ' ' . $counter_startdate_formatted;

 

?>  </td>

</tr>

</table>

<br>

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td align="center" class="smallText"><?php echo FOOTER_TEXT_BODY; ?

 

></td>

</tr>

</table>

<?php

if ($banner = tep_banner_exists('dynamic', '468x50')) {

?>

<br>

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td align="center"><?php echo tep_display_banner('static', $banner);

 

?></td>

</tr>

</table>

<?php

}

// START STS 4.1

}

// END STS 4.1

// Output the footer for Dynamenu for osCommercecho $GLOBALS

 

['dmfooter'];

?>

 

application_bottom.php (entire file):

 

<?php

/*

$Id: application_bottom.php 1739 2007-12-20 00:52:16Z hpdl $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

// START STS 4.4

if ($sts->display_template_output) {

$sts->stop_capture();

include DIR_WS_MODULES.'sts_inc/sts_display_output.php';

}

//END STS 4.4

 

// close session (store variables)

tep_session_close();

 

if (STORE_PAGE_PARSE_TIME == 'true') {

$time_start = explode(' ', PAGE_PARSE_START_TIME);

$time_end = explode(' ', microtime());

$parse_time = number_format(($time_end[1] + $time_end[0] -

 

($time_start[1] + $time_start[0])), 3);

error_log(strftime(STORE_PARSE_DATE_TIME_FORMAT) . ' - ' . getenv

 

('REQUEST_URI') . ' (' . $parse_time . 's)' . "\n", 3,

 

STORE_PAGE_PARSE_TIME_LOG);

 

if (DISPLAY_PAGE_PARSE_TIME == 'true') {

echo '<span class="smallText">Parse Time: ' . $parse_time .

 

's</span>';

}

}

 

if ( (GZIP_COMPRESSION == 'true') && ($ext_zlib_loaded == true) &&

 

($ini_zlib_output_compression < 1) ) {

if ( (PHP_VERSION < '4.0.4') && (PHP_VERSION >= '4') ) {

tep_gzip_output(GZIP_LEVEL);

}

}

// Output the footer for Dynamenu for osCommercecho $GLOBALS

 

['dmfooter'];

?>

 

Best Wishes,

 

Tom

 

 

 

 

Do you have this code at the end of both these files:

catalog\includes\footer.php

catalog\includes\application_bottom.php

// Output the footer for Dynamenu for osCommerc
echo $GLOBALS['dmfooter'];
?>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×