Jump to content
Latest News: (loading..)
Sign in to follow this  
nate_02631

"Dynamenu" for osCommerce

Recommended Posts

I must add this lack of styling is only in firefox, in i.e. the secure https pages retain my dynamenu styling and flyout menus....... so i've localised it to this browser. Any thoughts?

Share this post


Link to post
Share on other sites
I must add this lack of styling is only in firefox, in i.e. the secure https pages retain my dynamenu styling and flyout menus....... so i've localised it to this browser. Any thoughts?

 

This is fixed by moving the <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?> inside the closing <body> tag..... fixed. now i'm happy.

Share this post


Link to post
Share on other sites
This is fixed by moving the <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?> inside the closing <body> tag..... fixed. now i'm happy.

Right, i fixed my own problem first time. Here's my next issue guys. If i use this

 

$show_dmcats_as_box = true;

 

The vertical flyouts will work brilliantly - if i change it to false so it's not inside a box the flyouts will stop working. Can anyone suggest why it may be happening like this? Is it something to do with STS.

Share this post


Link to post
Share on other sites
Right, i fixed my own problem first time. Here's my next issue guys. If i use this

 

$show_dmcats_as_box = true;

 

The vertical flyouts will work brilliantly - if i change it to false so it's not inside a box the flyouts will stop working. Can anyone suggest why it may be happening like this? Is it something to do with STS.

 

 

STS works perfectly with this contribution. See my tips in the STS Power Pack site for more details (site for STS add-ons).


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
STS works perfectly with this contribution. See my tips in the STS Power Pack site for more details (site for STS add-ons).

 

Hey there - thanks for the heads up. I think i've done all the requirements to the letter and I get it all working fine - the only issue I am facing is when i go into the file called dm_categories and I change the value

 

$show_dmcats_as_box = true;

 

to

 

$show_dmcats_as_box = false;

 

Then the vertical fly outs stop working. When i change it back to true they work again. I'm okay having it contained within the box with the header and all, but it would be nice so the categories are on their own without the box around them.

Share this post


Link to post
Share on other sites

Ok I followed the instructions to install this add-on. I am using STS I have a question on something. I have made my own index page and am a little confused do I place this at the top of the left column <?php include(DIR_WS_BOXES . 'dm_categories.php'); ?> along with $categorybox. I have also made this change

Open /includes/modules/sts_inc/sts_column_left.php

 

Find:

// Get categories box from db or cache

if ((USE_CACHE == 'true') && empty($SID)) {

echo tep_cache_categories_box();

} else {

include(DIR_WS_BOXES . 'categories.php');

}

 

Change to:

// Get categories box from db or cache

if ((USE_CACHE == 'true') && empty($SID)) {

echo tep_cache_categories_box();

} else {

include(DIR_WS_BOXES . 'dm_categories.php');

When I do that I still get my text list showing. I have done the configureeation and celected the drop down menua and what I wanted.

if I place,

<?php include(DIR_WS_BOXES . 'dm_categories.php'); ?>

I get this error message,,,, Fatal error: Call to a member function image() on a non-object in C:\xampp\htdocs\oscommerce\catalog\includes\functions\html_output.php on line 78

Anyone have any idea what may be wrong.

Pat

Share this post


Link to post
Share on other sites

Ok Thanks to Bills wonderful instructions I was able to get it sort of working. I have done my configuration stuff but still dont get a drop down menu. I have 4 categories all list one under the other. I have also started receiving this error message if i dont comment this line out //$navigation->add_current_page();

error message

Fatal error: Call to a member function add_current_page() on a non-object in/shopping/includes/application_top.php on line 312

Does anyone have any idea what I may have done wrong, or missed? I have printed, read then re-read the install instructions but I still get this message.

Pat

Share this post


Link to post
Share on other sites

Dynamenu shows up in the standard grey categorybox with header. I just need the dynamenu without categroybox field. I searched several threads but didnt find the answer. :blink: Any ideas?

 

Installation of Dynamenu was very easy with Bill Kellums instruction "DYNAMENU&STSv4" found here: http://www.oscommerce.com/community/contributions,4456

 

Thanks for the great contribution.

Adrian

Share this post


Link to post
Share on other sites
Dynamenu shows up in the standard grey categorybox with header. I just need the dynamenu without categroybox field. I searched several threads but didnt find the answer. :blink: Any ideas?

 

Installation of Dynamenu was very easy with Bill Kellums instruction "DYNAMENU&STSv4" found here: http://www.oscommerce.com/community/contributions,4456

 

Thanks for the great contribution.

Adrian

 

 

you can remove the box and header with kymations solution found here: http://forums.oscommerce.com/index.php?sho...t=#entry1401769

Share this post


Link to post
Share on other sites

Dynamenu without number of subcategories in brackets and down arrow would be terrific.

 

I looked at catalog/includes/boxes/categories.php, catalog/includes/boxes/dm_categories.php and catalog/includes/functions/dynamenu/lib/layersmenu.inc.php to remove the numbers in brackets and the downarrow but didnt get it done. For example if you change in catalog/includes/boxes/dm_categories.php

$menu_downarrowimg = 'down-arrow.png';

to

//$menu_downarrowimg = 'down-arrow.png';

the downarrow is gone but replaced by two ">>"" Where do they come from? And how to remove the number of subcategories in brackets?

 

Unfortunately its not as easy to take out as in a regular menu as shown here in the knowledgebase. http://www.oscommerce.info/kb/osCommerce/G..._and_Tricks/247

Share this post


Link to post
Share on other sites

If you go for the horizontal drop down, you will have a black down arrow (down-arrow.png) next to the main categoryname in the header. I would like to completely remove this down arrow but do not know where it is placed in the code. :blink: Any ideas where I could look? I browsed the dynamenu files already, mainly dm_categries.php but didnt get the clou. if you comment out in catalog/includes/boxes/dm_categories.php

$menu_downarrowimg = 'down-arrow.png';

there will be ">>" as replacement. How do I take this off too? :blink:

Share this post


Link to post
Share on other sites

Remove

<!-- BEGIN cell_arrow --> <img
class="horizfwdarr" src="{imgwww}{arrowsrc}" width="{arrowwidth}" height="{arrowheight}"
border="0" alt=">>" /><!-- END cell_arrow -->

from includes/functions/dynamenu/templates/layersmenu-horiz-sub-menu.html

Share this post


Link to post
Share on other sites
Remove

<!-- BEGIN cell_arrow --> <img
class="horizfwdarr" src="{imgwww}{arrowsrc}" width="{arrowwidth}" height="{arrowheight}"
border="0" alt=">>" /><!-- END cell_arrow -->

from includes/functions/dynamenu/templates/layersmenu-horiz-sub-menu.html

 

Hello Jono,

thanks for that. This is a good hint. I am on the right track now. when I removed the above mentioned code, from catalog/includes/functions/dynamenu/templates/layersmenu-horizontal_menu.ihtml the arrow is gone. (when I removed from layersmenu-horiz-sub-menu.html I didnt get the effect.) but I get an errormessage above the menu, saying: Template Error:loadfile: cell_arrow is not a valid handle. TemplateError:subst: unable to load cell_arrow

 

Is this conflicting with the sts template I have installed?

Thanks,

Adrian

Share this post


Link to post
Share on other sites
Hello Jono,

thanks for that. This is a good hint. I am on the right track now. when I removed the above mentioned code, from catalog/includes/functions/dynamenu/templates/layersmenu-horizontal_menu.ihtml the arrow is gone. (when I removed from layersmenu-horiz-sub-menu.html I didnt get the effect.) but I get an errormessage above the menu, saying: Template Error:loadfile: cell_arrow is not a valid handle. TemplateError:subst: unable to load cell_arrow

 

Is this conflicting with the sts template I have installed?

Thanks,

Adrian

Found the solution. (BACKUP FIRST!)

To remove the down arrow in the horizontal drop down menu header do this:

1. in catalog/includes/functions/dynamenu/templates/layersmenu-horizontal_menu.ihtml remove

<!-- BEGIN cell_arrow --> <img
class="horizfwdarr" src="{imgwww}{arrowsrc}" width="{arrowwidth}" height="{arrowheight}"
border="0" alt=">>" /><!-- END cell_arrow -->

 

2. in catalog/includes/functions/dynamenu/lib/layersmenu.inc.php comment out:

$t->setBlock('cell_link', 'cell_arrow', 'cell_arrow_blck');

to

// $t->setBlock('cell_link', 'cell_arrow', 'cell_arrow_blck');

 

$t->parse('cell_arrow_blck', 'cell_arrow');

to

// $t->parse('cell_arrow_blck', 'cell_arrow');

 

Thanks again for the hint Jono. :)

Best regards, Adrian

Share this post


Link to post
Share on other sites

thanks for this helpful contribution, here i have two questions , that i hope u can help me or give me some suggestions.

 

1. how to insert the <li> tag into categories.php, so i can give the categories a new look in stytlesheet.css.

 

2. I don't need the fly-out model, i want one is when i move the mouse to the categories box , the background will change background color to what I set in the stytlesheet.css.

 

thanks a lot .

 

 

 

JUN

Share this post


Link to post
Share on other sites

First of all, nice contribution! Got it working in just a few minutes :)

 

The only issue I'm having is that it doesn't quite show properly on Internet Explorer (using IE6). It works perfectly in Firefox.

 

So here's the issue:

My layout is the typical Category box on the left column, then directly underneath it the Manufacturer box. When I mouse over any of the menu in Category, it properly shows the corresponding submenus. Let's say I have quite a number of categories (submenus). But the manufacturer box (the stock drop down box) blocks my submenus. In Firefox, it doesn't, so you can see the submenus perfectly fine.

 

Any ideas?.

 

Thanks!

Share this post


Link to post
Share on other sites

Great Contribution works perfectly on my old Site.

 

Now on a new version I installed AJAX shoppin cart that I believe also uses JavaScript.

 

But since I installed Dynamenu the /catalog/shopping_cart.php doesn't show my cart, ie. it only displays "What's In My Cart?" with the continue shopping & checkout buttons.

 

Any1 know how to fix this?

 

AJAX alters only catalog/shopping_cart.php by replacing it with their version.

 

My Dynamenu only alters Header with:

include(DIR_WS_BOXES . 'dm_categories.php');

 

and only the Footer with:

echo $GLOBALS['dmfooter'];

 

Dynamenu still works 100% when Ajax stops working. Dynamenu FTW!

 

It worked 100% before dynamenu and when I change the Header edit to "<?php //include(DIR_WS_BOXES . 'dm_categories.php'); ?>" AJAX works perfectly.

Mode 0 & 1 Bugs out, but 3 & 4 works perfectly with AJAX.

Edited by Stephan (VS)

"I have no special talent. I am only passionately curious"

- Albert Einstein

Share this post


Link to post
Share on other sites

Hi all, is it possible with dynamenu to customise it to go between 2 of the options.

 

i.e. i have a category with 3 sub categories - is it possible to have the first level as a tree and then the second level as a drop down menu.

 

i will be trying to figure this out myself but i first need to find out how to split my sql file so i can test it locally :)

 

thanks for any advice

 

Dan

Share this post


Link to post
Share on other sites

greetings, first of all thanks for the great contrib.

I have just one little problem, after i've installed all and using the flyout css, my submenu works well if in a little browser window, else if i expand the window in full screen the submenu appears far away from the menu... to make u understand better i post a link to the menu

 

http://www.surfmaster.altervista.org/

 

i've checked the css and seems to be all good..rly dunno how to solve this, i hope u can help

 

cheers

Paolo

Share this post


Link to post
Share on other sites
greetings, first of all thanks for the great contrib.

I have just one little problem, after i've installed all and using the flyout css, my submenu works well if in a little browser window, else if i expand the window in full screen the submenu appears far away from the menu... to make u understand better i post a link to the menu

 

http://www.surfmaster.altervista.org/

 

i've checked the css and seems to be all good..rly dunno how to solve this, i hope u can help

 

cheers

Paolo

 

i found the problem, it's that i have my oscommerce close in a wrapper, how can i modify the menu to adapt it to my page?

 

thanks for any help

Share this post


Link to post
Share on other sites

got another quick question, managed to get my site working locally, but the vertical and horzontal fly out dont display properly in wamp server -

had a quick look through the pages but couldnt see anything, anybody else had this problem?

 

dan

Share this post


Link to post
Share on other sites

Question to TracyS and/or Nate,

 

I'm using STS w/ Dynamenu, plus ProductsInDynamenu. I've chosen the plain vertical menu.

 

My question is, how do I set the look of the categories different from the products?

Share this post


Link to post
Share on other sites
You can do almost anything from the stylesheet alone. .vertitem a defines the main menu items; .vertsubitem a defines the subcategory items. I've used this to add backgrounds and borders, turning the categories into buttons.

 

Regards

Jim

 

 

Hi Jim, can I do this for the plain vertical menu? Currently the top menu and submenus have the same look (color, background-color).

Share this post


Link to post
Share on other sites

The stylesheet for the Plain menu uses the same CSS selectors for all menu items, so you would have to make changes to the code to do this. You can probably do this in the template. I haven't actually tried this so I can't be certain, but that's where I would start looking.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×