Jump to content
Sign in to follow this  
nate_02631

"Dynamenu" for osCommerce

Recommended Posts

I just installed this contribution and ran into this same problem. I fixed it by making sure there was no white space at the end of the ProductsInCategory.php file.

 

I had blank page on checkout but this solved my problem. Thanks!!!

Share this post


Link to post
Share on other sites

Can some one please tell me why Dynamenu dosen't play well with Firefox?

Check out this site Code Blue

 

It looks great in IE 7 but not Firefox.

 

Thanks, Rickey

Share this post


Link to post
Share on other sites

Most likely has to do with the style sheet settings. CSS is read differently in different browsers. Also, after looking at your site in both IE and FF, I can see you must have a missing closing tag in your template because you have a ton of unneeded space at the bottom of your page in FF.

 

I would suggest starting by printing out your source code in FF and going through everything to make sure you have correctly formatted HTML with all the tags being closed where they should be. I know I had to do this a couple of times because so much of the HTML is written by various different php pages (each box for example) that it makes it hard to tell just by looking at your template.

 

Can some one please tell me why Dynamenu dosen't play well with Firefox?

Check out this site Code Blue

 

It looks great in IE 7 but not Firefox.

 

Thanks, Rickey


~Tracy
 

Share this post


Link to post
Share on other sites
Most likely has to do with the style sheet settings. CSS is read differently in different browsers. Also, after looking at your site in both IE and FF, I can see you must have a missing closing tag in your template because you have a ton of unneeded space at the bottom of your page in FF.

 

I would suggest starting by printing out your source code in FF and going through everything to make sure you have correctly formatted HTML with all the tags being closed where they should be. I know I had to do this a couple of times because so much of the HTML is written by various different php pages (each box for example) that it makes it hard to tell just by looking at your template.

 

I have went over the code and I cant find anything, this has me stumped. The client wants to use Dynamenu on his site but he wants it to look the same in FF as IE.

Share this post


Link to post
Share on other sites
I have went over the code and I cant find anything, this has me stumped. The client wants to use Dynamenu on his site but he wants it to look the same in FF as IE.

 

I forgot to ask, is there a different css format for FF as for IE?

Share this post


Link to post
Share on other sites

Try turning "display in box" settings on or off to see if that makes a difference (in the dynamenu php file).

 

Some CSS commands work in specific browsers only - review the suckerfish menu as an example ;)

 

I forgot to ask, is there a different css format for FF as for IE?

~Tracy
 

Share this post


Link to post
Share on other sites

Alright,

 

I have a little problem. I've searched the forum but no answer has been given yet. At least not one that's worked for me.

 

I have STS and the vertical fly-out menu is not working. The sub category is not working (where its meant to pop out).

 

I've tried everything with the footer and app_bottom adding;

 

	// Output the footer for Dynamenu for osCommerce
echo $GLOBALS['dmfooter'];

 

To the bottom but it's still not working. I've even downloaded bills STS & DynaMenu Bundle and compared the footer files with WinMerge. Still not working.

 

 

Any advice would be much appreciated.

Edited by jakedavi

Share this post


Link to post
Share on other sites

This realy don't make any sence, when i remove the include(DIR_WS_BOXES . 'dm_categories.php'); from the column_left.php, the page looks normal in firefox. With it in there, it drops all the subcategories and manufactures down to the bottom of the page. I just cant figure it out.

Share this post


Link to post
Share on other sites
This realy don't make any sence, when i remove the include(DIR_WS_BOXES . 'dm_categories.php'); from the column_left.php, the page looks normal in firefox. With it in there, it drops all the subcategories and manufactures down to the bottom of the page. I just cant figure it out.

 

 

Could someone please look at this site: Code Blue Store in FireFox and tell me why dynamenu is causing this page to load like this? If I remove dm_categories.php from column_left.php and put the default OSC category box back, it works fine. Any and all help would be really appreciated.

 

Thanks, Rickey

Share this post


Link to post
Share on other sites

Have you tried changing the settings in the includes/boxes/dm_categories.php file on this line:

$show_dmcats_as_box = true;

 

Try true and try false and see if you get any difference. You can also add HTML to show up before or after the dynamenu category box if you have the above line set to false by changing these lines:

$before_nobox_html = '';
$after_nobox_html = '';

 

You need to look at the source code showing in the browser in order to learn where your HTML is being affected negatively and causing the problems - this will better allow you to know what you need to change in order to correct the issue.

 

Could someone please look at this site: Code Blue Store in FireFox and tell me why dynamenu is causing this page to load like this? If I remove dm_categories.php from column_left.php and put the default OSC category box back, it works fine. Any and all help would be really appreciated.

 

Thanks, Rickey


~Tracy
 

Share this post


Link to post
Share on other sites

I've always had to add this line:

echo $GLOBALS['dmfooter'];

to the bottom of the includes/application_bottom.php file.

 

Then, in order to get things to come out correctly in HTML I have to go through all of the php pages in the root folder (or catalog folder if you are using one) and change the call for application_bottom.php to be above the closing body and html tags like this:

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>
</body>
</html>

 

This can be sped up with a find/replace tool :)

 

Alright,

 

I have a little problem. I've searched the forum but no answer has been given yet. At least not one that's worked for me.

 

I have STS and the vertical fly-out menu is not working. The sub category is not working (where its meant to pop out).

 

I've tried everything with the footer and app_bottom adding;

 

	// Output the footer for Dynamenu for osCommerce
echo $GLOBALS['dmfooter'];

 

To the bottom but it's still not working. I've even downloaded bills STS & DynaMenu Bundle and compared the footer files with WinMerge. Still not working.

 

 

Any advice would be much appreciated.


~Tracy
 

Share this post


Link to post
Share on other sites

You have three different sets of styles for this menu in your stylesheet, so they're conflicting. Pick one and get rid of the rest.

 

You also have PHP code at the bottom of your stylesheet. This isn't working because the PHP parser doesn't look at .css files.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
This can be sped up with a find/replace tool :)

 

Is this the only advice your gonna give me lmao.. Well I'm not going to bother with installing it now, but when I launch a new store I will indeed use it.

 

Jake.

Share this post


Link to post
Share on other sites

Did you not read the entire post - I also gave you this advice:

 

I've always had to add this line:

 

echo $GLOBALS['dmfooter'];

to the bottom of the includes/application_bottom.php file.

 

Then, in order to get things to come out correctly in HTML I have to go through all of the php pages in the root folder (or catalog folder if you are using one) and change the call for application_bottom.php to be above the closing body and html tags like this:

 

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>
</body>
</html>

 

The find/replace tool can speed up moving the call to application_bottom in all of the pages at once rather than you having to go through them manually. Following the above advice should only take maybe 5 minutes.

 

Not sure why you are upset with receiving information on how to get the fly-outs to work properly, plus the bonus of how to get the HTML for the Dynamenu to show up before the </body> tag rather than after it, which is something I never found in the forums but learned through my own trial and error.

 

 

Is this the only advice your gonna give me lmao.. Well I'm not going to bother with installing it now, but when I launch a new store I will indeed use it.

 

Jake.


~Tracy
 

Share this post


Link to post
Share on other sites

Sorry for the little.. misunderstanding before. That's an awesome post and I'm sure everyone who has the same problem will appreciated it as much as I do. I will try it out tomorrow, and hopefully it will work.

 

Many thanks TracyS.

Share this post


Link to post
Share on other sites

Hello everyone. I am using the vertical fly out version.

For the menu bars I need a fix height and width, which is not addicted to the lenght of the category title.

Does anybody have an idea where and how I can do that?

 

Thanks in advance

Share this post


Link to post
Share on other sites

If you figure it out I'd love to know. I think it might have something to do with the way the template pages for Dynamenu are setup. (catalog/includes/functions/dynamenu/templates/) Maybe removing this bit of code from the templates?

nowrap="nowrap"

 

Hello everyone. I am using the vertical fly out version.

For the menu bars I need a fix height and width, which is not addicted to the lenght of the category title.

Does anybody have an idea where and how I can do that?

 

Thanks in advance


~Tracy
 

Share this post


Link to post
Share on other sites
If you figure it out I'd love to know. I think it might have something to do with the way the template pages for Dynamenu are setup. (catalog/includes/functions/dynamenu/templates/) Maybe removing this bit of code from the templates?
nowrap="nowrap"

I have still no solution. If you figure something out please let me know, too. Thanks.

Share this post


Link to post
Share on other sites

You can do almost anything from the stylesheet alone. .vertitem a defines the main menu items; .vertsubitem a defines the subcategory items. I've used this to add backgrounds and borders, turning the categories into buttons.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Have you figured out how to get the category names to wrap onto two lines or more rather than stretching on just one line? I've tried with the stylesheet and in the templates and just have had no luck at getting the category names to wrap into two lines :blink:

 

You can do almost anything from the stylesheet alone. .vertitem a defines the main menu items; .vertsubitem a defines the subcategory items. I've used this to add backgrounds and borders, turning the categories into buttons.

 

Regards

Jim


~Tracy
 

Share this post


Link to post
Share on other sites

I did have that working at one time, then had to remove it, and I don't remember exactly how I did it.You should remove that silly nowrap="nowrap" from the template in any case. Then, find this code in your stylesheet (two places)

white-space: nowrap;

and change it to this

white-space: normal;

That should fix the problem.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

I need a little help, if some one could assist, I would appreciate it.

I am using the tree menu and would like to have a different css for top menu, sub menu, sub sub menu etc,.

 

Something like this:

 

Menu 1 -- css1

: -- sub menu 1 --- css2

: ----- sub sub menu 1 -- css 3

:

Menu 2 - css 1

: -- sub menu 2 --- css2

: ----- sub sub menu 2 -- css 3

 

Thank you!

Share this post


Link to post
Share on other sites

Great contribution but i have a bit of an issue. I have STS and have used the fix to make the vertical fly outs work. This now happens and all renders correctly.

 

My issue is when I navigate to pages on my SSL server e.g. my account and checkout areas. All the formatting of the dynamenu disappears and all flyouts stop working on these pages on my https://

 

I am not quite sure where to tweak it so it renders correctly on secure pages. (I have STS and dynamenu installed).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×