Jump to content
Sign in to follow this  
nico1814

Multi images extra contribution

Recommended Posts

No help required Guys, I fixed it.

 

How did you manage to fix that. I kept getting that msg all night trying to fix the problem.

Share this post


Link to post
Share on other sites

I need help with this Warning please.

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/content/catalog/includes/configure.php:2) in

/home/content/catalog/includes/functions/sessions.php on line 97

 

Can anyone help?

 

God bless

jsd219

Edited by jsd219

Share this post


Link to post
Share on other sites
Hello,

Here is my problem,

When I add a product with extra images, everything seems to be ok untill the preview page : I see the extra images.

But when I click on "Insert", Everything seems to be ok, the extra images are uploaded but nothing happened to my table products_images and no erro message is displayed so the extra images is'nt added to the product.

Thanks

 

Hello Eldros were you able to fix that problem? I visited your site but it's all in german, I didn't see any extra images but anyhow I thought I'd ask. How do you post a "THIS CONTRIB HSA NO SUPPORT" on the contribs section?

Share this post


Link to post
Share on other sites

When installing step 10, images can't be deleted anymore.

But without step 10 images aren't saved to the database.

 

Anyone knows how to solve this?

 

Or, could someone place his working catalog\admin\categories.php file here?


Building great webshops for customers with opensource backoffice application for a robotic accounting solution including POS
Migrating osC 2.x webshops to 2.3.4.x
osCommerce dedicated hosting/colocation + turnkey solutions + building addons per request

Share this post


Link to post
Share on other sites

Found the problem.

 

In the installation instructions :

j. catalog\admin\categories.php

Step 7

after the installation of this contribution search for : $var_detete_image = "delete_image".$nb;

and replace for : $var_delete_image = "delete_image".$nb;


Building great webshops for customers with opensource backoffice application for a robotic accounting solution including POS
Migrating osC 2.x webshops to 2.3.4.x
osCommerce dedicated hosting/colocation + turnkey solutions + building addons per request

Share this post


Link to post
Share on other sites

hi!

I just installed multi image extra....

I am geting

 

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/chen/public_html/store/admin/categories.php on line 288

 

but line 288 is

 

$sql_data_array = array_merge($sql_data_array, $insert_sql_data);

 

looks right to me...so I am not too sure where is the problem..thanks for any help..

Share this post


Link to post
Share on other sites
hi!

I just installed multi image extra....

I am geting

 

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/chen/public_html/store/admin/categories.php on line 288

 

but line 288 is

 

$sql_data_array = array_merge($sql_data_array, $insert_sql_data);

 

looks right to me...so I am not too sure where is the problem..thanks for any help..

 

ok, I found out what's wrong...will see if there is quick fix...

the uploaded image has to be "equal" to the number of extra image set in the admin..

I would like it to be "equal or less".....

 

I mean, I don't expect all the product has the same number of extra image...

Share this post


Link to post
Share on other sites
ok, I found out what's wrong...will see if there is quick fix...

the uploaded image has to be "equal" to the number of extra image set in the admin..

I would like it to be "equal or less".....

 

I mean, I don't expect all the product has the same number of extra image...

 

Can someone please tell me where the code is getting the name of those extra images?

I want to put a default value (like a file name no-image.jpg) for those extra images for default setting. thanks

Share this post


Link to post
Share on other sites

If you have a UNIX based server then please check out my contribution.

 

oscExtraImages - As many images as you want

http://www.oscommerce.com/community/contri.../search,oscextr

 

You need to have oscFileBrowser contribution (http://www.oscommerce.com/community/contributions,4568) installed for this to work which is the reason it won’t run on Windows installation.

 

Together these two contributions make adding images so painless.

 

I would love some feedback, good or bad.

Share this post


Link to post
Share on other sites
If you have a UNIX based server then please check out my contribution.

 

oscExtraImages - As many images as you want

http://www.oscommerce.com/community/contri.../search,oscextr

 

You need to have oscFileBrowser contribution (http://www.oscommerce.com/community/contributions,4568) installed for this to work which is the reason it won’t run on Windows installation.

 

Together these two contributions make adding images so painless.

 

I would love some feedback, good or bad.

 

superFreakE,

 

In the instructions it states that "GD image library is required for this mod". Is this another contribution for OSC or is this something that should be installed server side by your host? Could you elaborate on what GD image library is or where we can find it.

 

Thank you,

 

Gary

Share this post


Link to post
Share on other sites
If you have a UNIX based server then please check out my contribution.

 

oscExtraImages - As many images as you want

http://www.oscommerce.com/community/contri.../search,oscextr

 

You need to have oscFileBrowser contribution (http://www.oscommerce.com/community/contributions,4568) installed for this to work which is the reason it won’t run on Windows installation.

 

Together these two contributions make adding images so painless.

 

I would love some feedback, good or bad.

 

superFreakE,

 

In the instructions it states that "GD image library is required for this mod". Is this another contribution for OSC or is this something that should be installed server side by your host? Could you elaborate on what GD image library is or where we can find it.

 

Thank you,

 

Gary

Share this post


Link to post
Share on other sites

Hi Gary

 

GD is an open source code library for the dynamic creation of images. It needs to be installed on the web server. Most shared web hosting providers would have this installed already alongside with PHP.

 

More info at http://www.boutell.com/gd/

 

Regards

Jim

 

superFreakE,

 

In the instructions it states that "GD image library is required for this mod". Is this another contribution for OSC or is this something that should be installed server side by your host? Could you elaborate on what GD image library is or where we can find it.

 

Thank you,

 

Gary

Share this post


Link to post
Share on other sites
Got everything working, except that when I click on any of the additional images to enlarge, I get this error:

 

1054 - Unknown column 'pi.products_image' in 'field list'

 

SELECT pd.products_name, pi.products_image FROM products_images pi, products p, products_description pd WHERE p.products_id = pd.products_id AND p.products_id = pi.products_id AND p.products_status = '1' AND p.products_id = '107' AND pd.language_id = '1'

 

[TEP STOP]

 

This does not happen on the main image when clicking on it to enlarge. Anybody?

 

 

The problem i safe links. You change it in administration panel. Set "false"


 

Tworzenie sklepów internetowych

Share this post


Link to post
Share on other sites
Got everything working, except that when I click on any of the additional images to enlarge, I get this error:

 

1054 - Unknown column 'pi.products_image' in 'field list'

 

SELECT pd.products_name, pi.products_image FROM products_images pi, products p, products_description pd WHERE p.products_id = pd.products_id AND p.products_id = pi.products_id AND p.products_status = '1' AND p.products_id = '107' AND pd.language_id = '1'

 

[TEP STOP]

 

This does not happen on the main image when clicking on it to enlarge. Anybody?

 

 

Safe links are problem. You change it in administration panel. Set "false"

Edited by Howard van der Burgt

Share this post


Link to post
Share on other sites
Hi Gary

 

GD is an open source code library for the dynamic creation of images. It needs to be installed on the web server. Most shared web hosting providers would have this installed already alongside with PHP.

 

More info at http://www.boutell.com/gd/

 

Regards

Jim

 

OK, that's what I figured but just wanted to be sure. So (for the benefit to others) if you want to be sure that your host has GD installed, you will need to contact your hosting provider. Otherwise you can assume that it is unless you run into problems. Correct?

 

Thanks Jim,

 

Gary

Share this post


Link to post
Share on other sites

When I import products with Easy Populate, everything goes well, and I can buy new products,

list them...

 

but when I enter in product information page (product_info.php) there is no description, price appears to zero , boxes of right side are downside boxes of left side...

 

If I edit any of these products with oscommerce admin, without changing anything, everything

goes well and the problem dissapears.

I use EP 2.76 d

I have your contrib Multi images extra.

 

I'm trying to edit product_info.php with thebigia's bug fix without success.

 

 

thankyou very much

Share this post


Link to post
Share on other sites

NICO CAN YOU SPECIFY PLEASE THIS?

 

-PLEASE HELP :thumbsup:

 

 

(1)YOU SAID 2 QUERIES? SHOULD I INSERT THIS WHOLE CODE INTO THE DATA BASE?? OR SEPARATELY?

(2) WHEN I RUN THE QUERY ON MY DB IT IS ASKING ME "IN WHAT COLUM" MEANING WHAT FILE?

 

 

CREATE TABLE `products_images` (

`products_id` int(11) NOT NULL auto_increment,

`products_image1` varchar(64) default NULL,

`products_image2` varchar(64) NOT NULL default '',

`products_image3` varchar(64) NOT NULL default '',

`products_image4` varchar(64) NOT NULL default '',

`products_image5` varchar(64) NOT NULL default '',

`products_image6` varchar(64) NOT NULL default '',

`products_image7` varchar(64) NOT NULL default '',

`products_image8` varchar(64) NOT NULL default '',

`products_image9` varchar(64) NOT NULL default '',

PRIMARY KEY (`products_id`)

);

 

INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )

VALUES (

'', 'Number of extra images', 'NB_IMAGE_EXTRA', '4', 'Number of extra images (0 to 9)', '4', '9', NULL , '2006-04-17 14:10:42', NULL , NULL

);

Share this post


Link to post
Share on other sites

Hi, I am trying to find support for the oscfilebrowser contribution.

 

I need to see if I can get it to work with the big image contribution I already had installed.

Also is there a way to install it without 'On the Fly' Auto Thumbnailer?

 

I already tried the image subdirectories contribution and I can't get that to work with big image, at least not on my own.

 

I just need to have sub-folders to store my hundreds of images in instead of just the images directory.

 

Can anyone possibly point me in the correct direction please?


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

Hi

 

I have installed multi images 1.02. When I try to update one product (adding extra images or not), I get this error:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

 

update products set products_quantity = '1', products_model = 'add', products_price = '8.6207', products_date_available = '2007-12-25', products_weight = '1.00', products_status = '1', products_tax_class_id = '1', manufacturers_id = '11', products_image = '12_noviembre_2006.jpg', products_last_modified = now(),

 

[TEP STOP]

 

 

 

I don't know why. Only happens with updates; new products are added OK.

 

Files are the files of the contribution, and Osc was installed cleanly.

 

Thank you!

Share this post


Link to post
Share on other sites
I'm still trying to see why I can't delete any images :)

 

Hi all, I use this contribution and it's very good, exactly what I need for my store! (OSC 2.2rc1 custom)

 

The only problem I have is the same: I can't delete the extra images. Anyone have a solution?

 

Thank you in advance,

Nik

Share this post


Link to post
Share on other sites

Have installed this contrib. all seems to go well... but have only one little problem:

 

The extra images are showed normally when click on it,while the main image when I click on it is not showed...popup open without images(white background)...

 

Any suggest???

 

Thanks

Share this post


Link to post
Share on other sites

That's because you are using SEO urls.

 

Is somebody able to make this mod SEO urls COMPATIBLE???

 

thanks.

Share this post


Link to post
Share on other sites

Hi there.

 

I've installed this contribution and It works ok for me, the only problem is that I need a diferent size for the first image still remain as a square of 80x80px and all the extra images size bigger. What I would like to know is how could I add other line in the admin images configuration to enter the diferents sizes I need, since I only have a tag for Small Image and other for Subcategory Image.

 

Thanks a lot for this contribution and for further help you can give me about this issue :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×