Jump to content
Sign in to follow this  
kenuk1

Secpay Help!

Recommended Posts

hi all, I know that SECPay is mentioned in loads of places but I still need help if anyones out there.

 

Firstly I installed the contribution and I as a customer doing the test I can do everything up to entering the test card details and clicking submit, it's all secure and works well.

 

Once I have submitted I am returned back to my payment page with the following error:

 

It is worth bearing in mind that I am running "Always Successful"

 

Card Error, please try again.

 

Problems

 

1 - As a customer I try again but as the shope owner I have had a confirmation email from Secpay to say the order has gone through.

 

2 - My OSC admin has no order details at all.

 

I am going "live" next Wednesday and wondered if anyone had come across this issue before?

 

Regards

 

Ken

www.troutline.co.uk

Share this post


Link to post
Share on other sites
hi all, I know that SECPay is mentioned in loads of places but I still need help if anyones out there.

 

Firstly I installed the contribution and I as a customer doing the test I can do everything up to entering the test card details and clicking submit, it's all secure and works well.

 

Once I have submitted I am returned back to my payment page with the following error:

 

It is worth bearing in mind that I am running "Always Successful"

 

Card Error, please try again.

 

Problems

 

1 - As a customer I try again but as the shope owner I have had a confirmation email from Secpay to say the order has gone through.

 

2 - My OSC admin has no order details at all.

 

I am going "live" next Wednesday and wondered if anyone had come across this issue before?

 

Regards

 

Ken

www.troutline.co.uk

 

Hi Ken

 

Did you manage to sort out your problem with SECPay? If yes, what did you have to do or change? I am having a similar problem.

 

Cheers

Share this post


Link to post
Share on other sites
Hi Ken

 

Did you manage to sort out your problem with SECPay? If yes, what did you have to do or change? I am having a similar problem.

 

Cheers

 

Hi Guys,

 

I was having the same problem as you.

 

After 7 hours writing the coding here and there, I spoke to Secpay's tech support. I put all the pages back to their orignal php and added the following bit of text after the merchant ID (in the admin section)

 

"-jredir"

 

Log in to Admin > Modules > Payment > SECpay > click edit > Under Merchant ID type the text above after your merchant id.

 

For example if my merchant ID was: funboy01

 

The new ID would read: funboy01-jredir

 

According to SECpay this makes the callback a java redirect.

 

It worked for me!! http://forums.oscommerce.com/style_images/...icons/icon6.gif

Share this post


Link to post
Share on other sites

Hi

 

I have everything appearing to work apart from secpay are treating real transactions as tests. They say "remove test status flag from the options field" does anybody know how to do this??

 

 

Kenny

Share this post


Link to post
Share on other sites

Put osCommerce into Production Mode.

 

Or you might have your SECPay account status set to test - you can change that through their admin area.

Share this post


Link to post
Share on other sites

Hi

 

It may also be worth adding to this thread that you must not have any gaps in your shop name when using SecPay (it took me sometime to work this out >_< ).

 

Cheers

Katie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×