Jump to content
Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

Thanx.. I have enabled it, and it works great exept for hven a custumer use the Gift Vocher to pay.. it goes through right, but they still have the same aount in theyre account..

I will try the things you mentient and will se how it works out..

 

Did you enable Gift Vouchers in osC admin, under Modules --> Order Total, because Gift Vouchers are products and can be bought like any other product - but the system won't fully work unless they have been enabled. Also please make sure that the Model Number for the Gift Vouchers starts with GIFT

 

As your site does not have an SSL certificate your settings should be as follows:

define('HTTP_SERVER', 'http://timogtina.com');

define('HTTPS_SERVER', '');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', 'timogtina.com');

define('HTTPS_COOKIE_DOMAIN', '');

 

Vger

Share this post


Link to post
Share on other sites

Hi Vger,

 

I have the contribution installed and running on my testing server, but I use Paypal IPN specifically for the fact that then I have 2 records of the cart contents. So I really hate to pass the cart to paypal as a whole.

 

Anyways I was thinking on how I could mod the contrib to make it work. But I see that passing the discount as a line amount won't work because paypal won't accept negative items. You have done it the best way possible. You have done a great job with this contrib.

 

one little bug fix:

 

In catalog\admin\includes\boxes\gv_admin.php, in the first herf_link the wrong text definition is given:

 

if ($selected_box == 'gv_admin') {
$contents[] = array('text'  => '<a href="' . tep_href_link(FILENAME_COUPON_ADMIN) . '" class="menuBoxContentLink">' . BOX_COUPON_ADMIN . '</a><br>' .
							   '<a href="' . tep_href_link(FILENAME_GV_QUEUE) . '" class="menuBoxContentLink">' . BOX_GV_ADMIN_QUEUE . '</a><br>' .
							   '<a href="' . tep_href_link(FILENAME_GV_MAIL) . '" class="menuBoxContentLink">' . BOX_GV_ADMIN_MAIL . '</a><br>' . 
							   '<a href="' . tep_href_link(FILENAME_GV_SENT) . '" class="menuBoxContentLink">' . BOX_GV_ADMIN_SENT . '</a>');

 

It should be:

 

if ($selected_box == 'gv_admin') {
$contents[] = array('text'  => '<a href="' . tep_href_link(FILENAME_COUPON_ADMIN) . '" class="menuBoxContentLink">' . BOX_GV_ADMIN_COUPON_ADMIN . '</a><br>' .
							   '<a href="' . tep_href_link(FILENAME_GV_QUEUE) . '" class="menuBoxContentLink">' . BOX_GV_ADMIN_QUEUE . '</a><br>' .
							   '<a href="' . tep_href_link(FILENAME_GV_MAIL) . '" class="menuBoxContentLink">' . BOX_GV_ADMIN_MAIL . '</a><br>' . 
							   '<a href="' . tep_href_link(FILENAME_GV_SENT) . '" class="menuBoxContentLink">' . BOX_GV_ADMIN_SENT . '</a>');

 

The definition in catalog\admin\includes\languages\add_ccgvdc_english.php is:

 

define('BOX_GV_ADMIN_COUPON_ADMIN','Coupon Admin');

 

 

Next rollup maybe :D

 

Thanks for the great contrib,

 

Stephanie

Share this post


Link to post
Share on other sites

Okey.. I think I have misunderstod a little bit..

 

Are there soppuse to be gift vouchers in the shop if things are working? Couse I made my own, and then I send out GV when I resive the money.... :huh:

 

I have set up that all new customers get a gift voucher when they register and that works fine, but the amount stays still inn the balanse when they buy produkts.. So the way things are now, all my custumers get 50,- discount everytime they buy something..

Share this post


Link to post
Share on other sites
Hi have installed the latest release from the thread dated april 12th on a fresh install of OSC everything is working great except the GVque When GV are purchased nothing is going into the que. This is not a big deal sense I can just creat a GV for the client once I receive confirmation of payment. But I would like to have this work any thoughts. my site www.productdeliveryservice.com -- thank you.

 

How do your custumers purchase GV?

Share this post


Link to post
Share on other sites

Below the instructions on how to install this contribution are the instructions on how to use it. You need to read those and you'll find your answer.

 

Vger

How do your custumers purchase GV?

Share this post


Link to post
Share on other sites

Hi

 

Many thanks for posting this contribution, I found it before I worked up the courage to install CCGV.

 

I have run through all the instructions and everything appears to be installed correctly. However, when I log in to the shop I see the following error:

 

1146 - Table 'ecoflow.table_coupon_gv_customer' doesn't exist

 

select amount from table_coupon_gv_customer where customer_id = '3'

 

The SQL script ran without errors and according to PHPMyAdmin that table does exist. I suspect I have missed something but can't find what.

 

Your help would be most appreciated.

Share this post


Link to post
Share on other sites

Try removing and then installing again in osCommerce admin --> Modules --> Order Total

 

Vger

Share this post


Link to post
Share on other sites

Hello, this is a very great contrib and so far everything works great except for one thing :) When I go to my cart if my item is $5.00 the sub-total says $10.00. Any idea of what I have done wrong? Other then this problem everything else is ok.

 

Thanks

Cliff

Share this post


Link to post
Share on other sites

Make sure that Downloads is enabled, that all physical products have a weight and that the Gift Vouchers do not have a weight.

 

Vger

Share this post


Link to post
Share on other sites
Make sure that Downloads is enabled, that all physical products have a weight and that the Gift Vouchers do not have a weight.

 

Vger

 

Thank you for the quick response. I have checked the downloads option and it was false, so I made it true but that did not fix anything. I have now also noticed that it is not only when I go to the cart. It is as soon as I click on "buy now". When I click on buy now the info box on the left that shows the cart contents says "1 x item" and under it show the price which is double the original price of the item.

 

As for physical weights, not really understanding what you are saying? You mean every item in my store needs a weight or the items in the cart? If it is items in the cart then yes they do have weights.

 

As for the Gift Voucher, I do not have any created as of yet only a Discount Coupon.

 

Any other Ideas? :)

 

Thanks again for the help.

Cliff

Share this post


Link to post
Share on other sites
As for physical weights, not really understanding what you are saying? You mean every item in my store needs a weight or the items in the cart? If it is items in the cart then yes they do have weights.

Downloadable products (songs/videos/pdf catalogs/word docs/etc,etc) can be added to the cart and still have no weight!

 

When you go to your store and create an item, you add a description and add a price, right? At the very foot of that page you can add the weight of the item... downloadable products should have no weight, you should their weight to zero


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi,

 

the contrib seems to have installed properly (thanks to your ealier help!) but I seem to have come across an issue that I am unable to resolve. I have two discount coupons setup.

 

1. A 10% discount applicable on product categories 1, 2, 3

2. A 5% discount applicable on product categories 4 & 5

 

Without any values entered in the valid categories field, the discounts work exactly as expected. BUT, as soon as I put a list of categories in, the discounts just fail to register at checkout.

 

I have checked all the config, and am fairly confident that this is all set correctly. For info, the order totals order is:

 

Subtotal - 1

Shipping - 2

Tax - 3

Discount - 9

 

All other settings are as default, with the exception of the shipping, I have set the discount shipping to false.

 

Any help greatly appreciated!

 

ND

Share this post


Link to post
Share on other sites
Downloadable products (songs/videos/pdf catalogs/word docs/etc,etc) can be added to the cart and still have no weight!

 

When you go to your store and create an item, you add a description and add a price, right? At the very foot of that page you can add the weight of the item... downloadable products should have no weight, you should their weight to zero

 

I have no downloadable products in my store. Any other ideas?

 

Thanks

Cliff

Share this post


Link to post
Share on other sites

I know this is a great contribution but after 2 attempts to install it I think I need to move on. After thinking about it I really only want to discount coupon feature. I have searched through the forums for which is the best discount coupon contribution. Any suggestions?

 

-ladybird

Share this post


Link to post
Share on other sites

Gift Vouchers are 'electronic Gift Vouchers' e.g. downloadable products. They don't require Shipping charged to them because they are emailed out and not posted.

 

Vger

I have no downloadable products in my store. Any other ideas?

 

Thanks

Cliff

Share this post


Link to post
Share on other sites
Gift Vouchers are 'electronic Gift Vouchers' e.g. downloadable products. They don't require Shipping charged to them because they are emailed out and not posted.

 

Vger

 

Yes I know this, but my problem is that any item i add to my cart the price is doubled in the sub-total. You said before to make sure that download items have zero weight and I said that as of right now I do not have any downloadable items including vouchers yet. Where is the script for the sub-total? Maybe i have a line entered twice thus the reason for the double in price?

 

Thanks

Cliff

Share this post


Link to post
Share on other sites

If the price is doubled of every item added to your cart then this is not a CCGV(trad) support issue. Please post your problem in General or Installation & Configuration forums.

 

Vger

Share this post


Link to post
Share on other sites
If the price is doubled of every item added to your cart then this is not a CCGV(trad) support issue. Please post your problem in General or Installation & Configuration forums.

 

Vger

 

But the problem only accured when I added CCGV(trad). I made a backup of my files first so I was able to go back to the way it was before CCGV(trad) and when i restore the backup everything works fine again, so this is why I feel it is a CCGV(trad) support issue.

 

Thanks

Cliff

Share this post


Link to post
Share on other sites

Many others have added CCGV(trad) without anything like this happening - so it is either not being added correctly, or else there is some other contribution that conflicts with it, or there is a coding problem on your site which only shows up when CCGV is added. You honestly can't expect me to guess in which file or which line of code you have a problem.

 

Vger

Share this post


Link to post
Share on other sites
Many others have added CCGV(trad) without anything like this happening - so it is either not being added correctly, or else there is some other contribution that conflicts with it, or there is a coding problem on your site which only shows up when CCGV is added. You honestly can't expect me to guess in which file or which line of code you have a problem.

 

Vger

 

I am sorry, but i just thought that maybe you could honestly tell me. Like i said before maybe I entered a line twice and thought that maybe the line of code that gets the sub-total is only in one place and you might have known where that is. I will go thru all the files again and see if I can figure out where i went wrong. The only other contrib that I have installed is the "make an offer" contrib, so maybe you are right when you say it is causing a conflict. You were giving such good support to the other people in this thread I didn't think my problem would be that big of a deal to you. I am sorry if I bothered you. This is such a great contrib and I would have like to get it to work and thought you would help me like you have been helping the rest.

 

Cliff

Share this post


Link to post
Share on other sites
I am sorry, but i just thought that maybe you could honestly tell me. Like i said before maybe I entered a line twice and thought that maybe the line of code that gets the sub-total is only in one place and you might have known where that is. I will go thru all the files again and see if I can figure out where i went wrong. The only other contrib that I have installed is the "make an offer" contrib, so maybe you are right when you say it is causing a conflict. You were giving such good support to the other people in this thread I didn't think my problem would be that big of a deal to you. I am sorry if I bothered you. This is such a great contrib and I would have like to get it to work and thought you would help me like you have been helping the rest.

 

Cliff

First things first, anyone who posts questions for help get a fair response from Vger and there are many others that give some form of tips and advice too.... In my honest opinion Vger is up there in the top 4-5 most helpful people in the whole forum - and they all do it for free for the community.

 

The original CCGV stayed good until around late 2005 where people just ruined it with minor tweaks, rubbish coding and such. I saw that at least two other forum members tried to re-start the CCGV from fresh with a fully working contribution but they eventually failed - if it wasn't for Vger then we wouldn't have this working contribution or this thread and people would still be using the distorted CCGV (non TRAD) and getting in to trouble trying to fix it or un-install it.

 

With all due respect to all.... asking for help doesn't mean you'll get it, it just lets people know that you have an issue or problem and if anyone is in a position to help after they have actually understood the problem, they can post a reply if they want to - nobody is under any obligation to do anything but most people choose to try to help one another.

 

In your case I didn't realise your subtotal was doubling. As Vger said this can't be a CCGV issue and by the sounds of it, it can't be an issue with your 'make an offer' contribution either - and as you haven't added any other contributions then I guess it has to come down to human error....

 

...... Do one of two things: Revert to your original files (backed up files that were pre-CCGV) and then re-install the CCGV (TRAD) from scratch WITHOUT using any saved files with CCGV in them. Just follow the install read me doc again and re-install it.

 

or

 

PM me with your URL so I can look at the issue and advise you

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
1. A 10% discount applicable on product categories 1, 2, 3

2. A 5% discount applicable on product categories 4 & 5

 

Without any values entered in the valid categories field, the discounts work exactly as expected. BUT, as soon as I put a list of categories in, the discounts just fail to register at checkout.

When you say the discount fails to register, do you mean there is also no pop-up coupon link showing what the actual discount is and on what items/categories it can be applied to as well?

 

Just in case you got it wrong - the coupons can only be applied to the categories/products that you select. Any category or product not selected will not accept the coupon:

 

Your 10% discount coupon can only be applied to items within categories 1, 2 and 3. If you select no categories or items then the coupon can be applied to all items and if you select categories 1, 2 and 3 then it will not work on any items other then within categories 1, 2 and 3.

 

Are you sure you are adding items from categories 1, 2 and 3 to your cart and not from any other categories? Please double-check your settings and update it here

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
First things first, anyone who posts questions for help get a fair response from Vger and there are many others that give some form of tips and advice too.... In my honest opinion Vger is up there in the top 4-5 most helpful people in the whole forum - and they all do it for free for the community.

 

The original CCGV stayed good until around late 2005 where people just ruined it with minor tweaks, rubbish coding and such. I saw that at least two other forum members tried to re-start the CCGV from fresh with a fully working contribution but they eventually failed - if it wasn't for Vger then we wouldn't have this working contribution or this thread and people would still be using the distorted CCGV (non TRAD) and getting in to trouble trying to fix it or un-install it.

 

With all due respect to all.... asking for help doesn't mean you'll get it, it just lets people know that you have an issue or problem and if anyone is in a position to help after they have actually understood the problem, they can post a reply if they want to - nobody is under any obligation to do anything but most people choose to try to help one another.

 

In your case I didn't realise your subtotal was doubling. As Vger said this can't be a CCGV issue and by the sounds of it, it can't be an issue with your 'make an offer' contribution either - and as you haven't added any other contributions then I guess it has to come down to human error....

 

...... Do one of two things: Revert to your original files (backed up files that were pre-CCGV) and then re-install the CCGV (TRAD) from scratch WITHOUT using any saved files with CCGV in them. Just follow the install read me doc again and re-install it.

 

or

 

PM me with your URL so I can look at the issue and advise you

 

 

Thank You, I wasn't trying to get anyone upset. I was only asking a simple question. I do not know php coding so I do not know "honestly" what can and can not be done. I do realize that these forms are for help if someone can give it. Vger did offer some help, but from the replies I was getting, it seemed to me that my problem was not understood and when I tried to explane it again Vger got upset.

 

I appreciate what everyone like Vger are doing to help the OSC community and I am only here looking for assisnatce if someone can offer it. Again my appoligies if anyone took what I said the wrong way, I am not here to cause anyone trouble please forgive me if I have. :D

 

I will start going thru all the files that need to be updated with the CCGV(trad) coding again.

 

As for my URL, my site is live so I had to revert back to before CCGV(trad).

 

Thank You

Cliff

Share this post


Link to post
Share on other sites
Try removing and then installing again in osCommerce admin --> Modules --> Order Total

 

I did that but still get the error saying the table doesn't exist. I'm going through the install steps again to see if I missed anything but any guidance would be appreciated.

Share this post


Link to post
Share on other sites
Hi,

 

the contrib seems to have installed properly (thanks to your ealier help!) but I seem to have come across an issue that I am unable to resolve. I have two discount coupons setup.

 

1. A 10% discount applicable on product categories 1, 2, 3

2. A 5% discount applicable on product categories 4 & 5

 

Without any values entered in the valid categories field, the discounts work exactly as expected. BUT, as soon as I put a list of categories in, the discounts just fail to register at checkout.

 

I have checked all the config, and am fairly confident that this is all set correctly. For info, the order totals order is:

 

Subtotal - 1

Shipping - 2

Tax - 3

Discount - 9

 

All other settings are as default, with the exception of the shipping, I have set the discount shipping to false.

 

Any help greatly appreciated!

 

ND

 

 

Sorry to bump, but just in case you missed this in the middle of the other questions! I have continued to check through the documentation provided and have read this thread in it's entirety just in case someone else has experienced this but to no avail...Does anyone have any pointers?

 

Many thanks,

 

ND

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×