Jump to content
Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

would you please post what code should i insert into checkout_*****.php files?

 

thanx

Share this post


Link to post
Share on other sites

HI

 

Is there a way of shifting the gift voucher/discount coupon code entry box from the credit card page to the checkout_shipping page (or before the checkout_shipping page) ?

 

(I have looked through the postings throughout the thread but honestly couldn't see a similar question)

 

many thanks

 

John Keiller

Share this post


Link to post
Share on other sites

Hi,

 

I have two problem where you enter the cupon codes at checkout (see picture)

 

1. The header of the text (MODULE_ORDER_TOTAL_COUPON_HEADER) is in bold (that is where the mousepointer is over now), how to I remove the bold from the header text? I have searched and the only refernse to this is in the file "catalog/includes/modules/order_totalot_coupon.php"

 

$this->header = MODULE_ORDER_TOTAL_COUPON_HEADER;

 

I can't find anywhere where this is set to bold.

 

2. Everytime I put the cursor on this text it become light blue, how do I remove that effect.

 

Thanks

 

CCGV.jpg

Share this post


Link to post
Share on other sites

I should make it clear to people posting in this thread that this thread only deals with problems people have when installing CCGV(trad).

 

1. If people wish to modify it then do not expect me to reply (though someone else might)

2. If, as above, you have questions about bolding of text or css issues then these are general matters that can be discussed anywhere.

 

Vger

Share this post


Link to post
Share on other sites
I should make it clear to people posting in this thread that this thread only deals with problems people have when installing CCGV(trad).

 

1. If people wish to modify it then do not expect me to reply (though someone else might)

2. If, as above, you have questions about bolding of text or css issues then these are general matters that can be discussed anywhere.

 

Vger

 

 

my apologies

i won't do it again

honest

 

John K

:)

Share this post


Link to post
Share on other sites

I have installed this module and retraced the installation steps a couple of times but I am still receiving this error on the checkout payments page.

 

1146 - Table 'latori_osc1.TABLE_COUPON_GV_CUSTOMER' doesn't exist

 

select amount from TABLE_COUPON_GV_CUSTOMER where customer_id='2'

 

Also in the admin page, when I click on VOUCHERS/COUPONS I have page cannot be found.

 

The URL has

 

shop/admin/FILENAME_COUPON_ADMIN?selected_box=gv_admin

 

Obviously there are some undefined table names somewhere but I cannot find in the instructions where these are.

 

This site is due to go live next week. Any help would be much appreciated.

 

PS. I am doing a mannual install as I have a modded cart.

Share this post


Link to post
Share on other sites
TABLE_COUPON_GV_CUSTOMER' doesn't exist

 

Means that you have not followed the Install instructions and run the sql file into your database using phpMyAdmin. This is why this advice is written in bold in the Install instructions with added emphasis on THIS IS NOT OPTIONAL!

 

If you haven't followed those instructions then it's a fair bet you've missed out some others as well. This is a big install and frequently people get into trouble by trying to rush it and not paying enough attention to it. Go back over it - slowly.

 

Vger

Share this post


Link to post
Share on other sites

I'm just following up the problem I posted earlier about taxes not being applied to virtual products. One thing I failed to mention was that my testing store had SPPC and SPPC-Hide Products installed, which does several things with taxes.

 

I decided to move CCGV(trad) to one of my live stores and low and behold it worked just fine.

 

I wasnt able to find any mention of SPPC and SPPC-Hide Prods in this thread but I think JanZ posted something to work with the old CCGV in the SPPC thread. Once I get to it and get it working I'll post my finding and or code here.


Matt Mika

Installed Contributions: Multi-Stores, QTPro, CCGV(trad), Batch Print, EasyPopulate, Simple Manual Order Entry, Encrypting Credit Card Via Mcrypt, UPSXML, Down for Maintenance, On The Fly GD Thumbs, SPPC, SPPC Hide, and various personal tweaks

Share this post


Link to post
Share on other sites

greetings former exploratory spacecraft! your contrib has been working great for me for a while, thanks so much for your work.

 

during our last sale a week ago i ran into a problem that i hadn't seen before: entering the coupon code on the checkout_payment.php page and clicking "Redeem" doesn't add the coupon discount on the following page, checkout_confirmation.php, but if you reload the confirmation page, browse back then forward to it again, etc, it correctly applies the coupon. i have been picking through the PHP for this contrib for several hours trying to figure out what is going amiss here and would greatly appreciate it if you could point me towards a possible cause.

 

based on a reload applying the coupon correctly, i'm guessing some superglobal or session variable is not being set correctly and pointing me towards the relevant code is sufficient for me to figure this out. it is likely related to my having so many contribs installed on my store that i can't easily list them...

 

regards,

jake

Share this post


Link to post
Share on other sites
greetings former exploratory spacecraft! your contrib has been working great for me for a while, thanks so much for your work.

 

during our last sale a week ago i ran into a problem that i hadn't seen before: entering the coupon code on the checkout_payment.php page and clicking "Redeem" doesn't add the coupon discount on the following page, checkout_confirmation.php, but if you reload the confirmation page, browse back then forward to it again, etc, it correctly applies the coupon. i have been picking through the PHP for this contrib for several hours trying to figure out what is going amiss here and would greatly appreciate it if you could point me towards a possible cause.

 

based on a reload applying the coupon correctly, i'm guessing some superglobal or session variable is not being set correctly and pointing me towards the relevant code is sufficient for me to figure this out. it is likely related to my having so many contribs installed on my store that i can't easily list them...

 

regards,

jake

 

well, i tracked down the problem and fixed it. it ended up that the cc_id global variable wasn't being passed properly to the ot_coupon.php apply_credit function. storing cc_id in a $_SESSION superglobal fixed the issue.

 

perhaps this is because i have the "register globals off" contrib applied...

 

cheers,

jake

Share this post


Link to post
Share on other sites

Hello Jake,

 

I have the same problem with 'redeem'.

 

And I have also applied the contri "register globals off".

 

Can you please tell me what you changed to make this work ??

 

I'm still learning in php.

 

Greetz, Rianne

Share this post


Link to post
Share on other sites

sure thing, rianne.

 

in catalog/includes/modules/order_total/ot_coupon.php there is a line commented out in the collect_posts function that sets the cc_id variable in the $_SESSION superglobal array. uncomment it as below (near end of function):

 

$cc_id = $coupon_result['coupon_id']; //Fred ADDED, set the global and session variable

$_SESSION['cc_id'] = $coupon_result['coupon_id']; //Fred commented out, do not use $_SESSION[] due to backward comp. Reference the global var instead.

 

the first line should work when register_globals is on, but the second skirts that issue. additionally you need uncomment another similar line just below in the calculate_credit function (right at begging of function):

 

$cc_id = $_SESSION['cc_id']; //Fred commented out, do not use $_SESSION[] due to backward comp. Reference the global var instead.

$od_amount = 0;

 

this now picks up the cc_id variable and allows calculate_credit to work correctly.

 

cheers,

jake

Share this post


Link to post
Share on other sites

Hello Jake,

 

Thank you very very very much for helping me out :rolleyes:

 

It works :thumbsup:

 

Greetz, Rianne

Share this post


Link to post
Share on other sites

Hello! Has anyone figured out what heppened here? I have same issue. Did intall/re-install 2x and same result. Just want to know where to look for the problem.

 

Thanks,

 

Liza

 

P.S. Great contribution!

 

 

I have installed this module and retraced the installation steps a couple of times but I am still receiving this error on the checkout payments page.

 

1146 - Table 'latori_osc1.TABLE_COUPON_GV_CUSTOMER' doesn't exist

 

select amount from TABLE_COUPON_GV_CUSTOMER where customer_id='2'

 

Also in the admin page, when I click on VOUCHERS/COUPONS I have page cannot be found.

 

The URL has

 

shop/admin/FILENAME_COUPON_ADMIN?selected_box=gv_admin

 

Obviously there are some undefined table names somewhere but I cannot find in the instructions where these are.

 

This site is due to go live next week. Any help would be much appreciated.

 

PS. I am doing a mannual install as I have a modded cart.

Share this post


Link to post
Share on other sites

You haven't installed the sql file into the database. It's the part of the Install instructions which says "This is not optional!"

 

Vger

Hello! Has anyone figured out what heppened here? I have same issue. Did intall/re-install 2x and same result. Just want to know where to look for the problem.

 

Thanks,

 

Liza

 

P.S. Great contribution!

Share this post


Link to post
Share on other sites

I have uninstalled and installed everything twice. The sql file 3 times. I am now in the process of uninstalling EVERYTHING for the 3rd time and sql 4th time. Am I using the wrong package? it's CCGV 5.19 by Hiremat.

 

:'( Just 1 more try, since I really like this contribution and really want it to work.

 

Thanks,

 

Liza

Share this post


Link to post
Share on other sites

Oh, and during checkout, after the checkout shipping page, when I click continue I get a blank page. Also, all the tables are present in the phpmyadmin, but when I go to the osCommerce admin and click on the coupon/voucher tab, I get a 404 error.

 

I am going to try the 5.18 packet now, hopefully this works.

 

 

Thanks,

liza

Share this post


Link to post
Share on other sites

This support thread is only for CCGV(trad). You have installed CCGV - and we do not offer support for that here.

 

Vger

Share this post


Link to post
Share on other sites
You haven't installed the sql file into the database. It's the part of the Install instructions which says "This is not optional!"

 

Vger

 

I did infact run the SQL file and have read through the instructions and retraced all steps over and over again.

My client has decided to leave adding this feature to their store at a later date thank god but I would still like to know what the problem is and if I have perhaps not downloaded the right version.

Share this post


Link to post
Share on other sites

Is it possible to setup this contribution so that the gift voucher number can be edited or created manually? I just need to have control of what the number is, instead of it being generated automatically.

Share this post


Link to post
Share on other sites

You can manually assign numbers to Discount Coupons.

 

Vger

Share this post


Link to post
Share on other sites
You can manually assign numbers to Discount Coupons.

 

Vger

 

I considered that, but I really need the features of Gift Vouchers...such as the customer being able to keep a balance if they do not use the total amount of the voucher right away. So I'm guessing it's not possible?

Share this post


Link to post
Share on other sites

It's not possible with Gift Vouchers, because Gift Vouchers have to be set up as you would any other product. The only time they are assigned a code is when you offer a Gift Voucher to new customers upon sign-up - and you cannot set the code for that.

 

Vger

Share this post


Link to post
Share on other sites

Hi Vger,

 

Thanks for your CCGV(trad) contribution!

 

I have a question about displaying deducted VAT:

 

My Gift Voucher settings:

Display Total

true

Sort Order

740

Queue Purchases

true

Include Shipping

true

Include Tax

true

Re-calculate Tax

Credit Note

Tax Class

VAT 19%

Credit including Tax

true

 

Order Total MOD for Tax recalculation required:

Sub-total - Sort order = 1

Shipping - Sort order = 2

Cash on Delivery Fee - Sort order = 3 (Dutch post office collect payment option)

Gift Voucher - Sort order = 740

Discount Coupons - Sort Order =760

Tax - Sort order = 800

Total - Sort Order = 900

 

It gives checkout values as follows:

sub-total (excl. VAT) = 100.00

Gift Voucher (inc. VAT) = 10.00

tax = 19.00 <- [it should display 17.40 (19.00 - 1.60)]

total (inc. VAT) = 109.00

 

Is it because of the 'Cash on Delivery Fee' in between the Order Total MOD?

 

Best Regards,

Aton

 

 

The Sort Order should be:

 

1. Sub Total

2. Shipping

3. Tax

4. Total

9. Discount Coupons

740. Gift Vouchers

 

But 9 and 740 can be any numbers as long as they come after Total, and Discount Coupons come before Gift Vouchers.

 

If you are using Low Order Fee you must disable it - it's not accounted for in CCGV(trad) at all.

 

Vger

Share this post


Link to post
Share on other sites

Please read the Post Install User Guide, and the information it contains about the Sort Order.

 

CCGV(trad) does not work when Low Order Fee is used, so I suspect the same is true using the Cash On Delivery Fee.

 

Vger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×