Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

I'm sorry but you've just said that you've updated files which needed updating, and that it was working before then. I have absolutey no idea what you may have done that's broken CCGV(trad).

 

Vger

Share this post


Link to post
Share on other sites

How does one delete Coupons? I see the Delete button but it's not deleting the selected coupon. The coupon just ends up in the Inactive Coupons and it' s not deleted. Is deleting them in phpmyadmin the only way?

Share this post


Link to post
Share on other sites

Forgive me as I should have been a little more clear on that - the last update I did was the last one you posted for Nov 06 - in which I went back to make sure I did everything ok & in doing so I noticed that in one of the updates (includes/classes/shopping_cart.php) I somehow did not copy and paste the complete revision of the update so I made the correct changes ... so thank you for your time & help I hope this fixes the problem.

Dia

Share this post


Link to post
Share on other sites
How does one delete Coupons? I see the Delete button but it's not deleting the selected coupon. The coupon just ends up in the Inactive Coupons and it' s not deleted. Is deleting them in phpmyadmin the only way?

You are supposed to go to catalog/admin/coupon_admin.php and use the delete button however this was a bug in the original CCGV. Deleting a coupon adds it to the 'inactive coupons' instead of deleting it, and then admin cannot actually delete any coupons from the 'inactive coupons' page, they simply sit there.

 

That was happening in the older CCGV but I didn't know that was still the case. Maybe Vger can look at it and add a patch when she gets a chance?

 

I am using an older layout for the admin coupons with modifications in other parts of the admin to get it to work correctly, I do not use the coupon admin file supplied with Vger's CCGV(trad) download, therefore I don't encounter this problem but am aware it did exist in the original.

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Guest
OK - but the point I was making was that osCommerce is written to charge tax based on the Billing address.

 

Vger

 

Sorry to bring up an old topic but... Store owner is based in CA

 

Prior to CCGV trad install

Billing Address--> CA, Shipping Address--> TX --> No tax applied to order

 

After CCGV install

Billing Address --> CA, Shipping Address --> OR --> Tax was applied to order

 

Previously, osC was charging tax based on delivery address. Advice on how to return to this calculation would be appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites

There is no Delivery Address with a 'virtual product' because it doesn't physically have to be sent anywhere. And so - mainly for the benefit of USA based companies who do have to pay tax even on Gift Vouchers they sell in their State, CCGV(trad) charges tax based on the Billing Address if the only product is a virtual product.

 

You have the option when setting up Gift Vouchers of not assigning them to a tax class - in which case no Tax will be levied on them when purchased.

 

Vger

Share this post


Link to post
Share on other sites
Guest

Yes, I understand but the examples I gave were for physical products, not Gift Vouchers....

Share this post


Link to post
Share on other sites
Guest

I just overwrote the includes/classes/order.php file with the original from your contribution, and it's now working correctly. I must have missed an edit in this file in my installation, thanks for your help and quick replies on the forum. It's greatly appreciated.

Share this post


Link to post
Share on other sites

I recall someone asking in this thread about why CCGV(trad) removes HTML formatting from the shortened product description. If you take a look in /includes/modules/star_product.php, you'll find on around line 41 and 63 reference to the following (line breaks for readability - this is all one line in the php file):

 

<td height="80%" width="85%" class="star-product">'. strip_tags($star_products["products_description"]) . 
'<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, "products_id=" . $star_products["products_id"]). '">'
. STAR_READ_MORE . '</a></td>

 

Remove the strip_tags so it reads:

 

<td height="80%" width="85%" class="star-product">'. $star_products["products_description"] . 
'<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, "products_id=" . $star_products["products_id"]). '">'
. STAR_READ_MORE . '</a></td>

 

It will leave the HTML alone. I can't comment on what the implications will be to your site in terms of (potentially) broken tables or other formatting, but I hope this gives you a starting point.

 

Max.

Edited by maxxxie

Share this post


Link to post
Share on other sites
I recall someone asking in this thread about why CCGV(trad) removes HTML formatting from the shortened product description

I can't understand what part of that contribution (or the code you placed above) you think will affect CCGV(trad).

 

As far I can see there is no conflict between the two whatsoever.

 

There has been a problem will some product description contributions but they are not affected by CCGV(trad) at all - instead they are affected by things related to the size of the HTML font settings to the length of the actual descritpion (when using certain HTML editors), these all relate to the admin/categories.php and catalog/product_info.pgp files - definately not related to CCGV(trad)


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I can't understand what part of that contribution (or the code you placed above) you think will affect CCGV(trad).

 

As far I can see there is no conflict between the two whatsoever.

 

Urgh, talk about me posting in the wrong thread. Oops. :blink: Of course, it was meant to go into the Star Products support thread. My bad.

 

Max.

Share this post


Link to post
Share on other sites

Hello,

 

Does anyone know how to delete "sent vouchers" and "inactive coupons" via phpMyAdmin from the database?

 

Either the code or instructions would work.

 

Thanks,

 

Dan

Share this post


Link to post
Share on other sites

Hello,

 

Thanks to ccgv's authors, that's a nice contribution :)

I just installed the v1.2 and added french files. I edited all files because i have others contributions installed.

All seem to work : adding, deleting, sending, generating vouchers and coupons, vouchers in shopping cart an account...

 

I have only one problem on checkout, i can't see anything in order total. It's like before installing the contribution, i have no coupon input to enter the code, and nothing to choose vouchers as a paiement method. What's the problem ?

Thank you, any help will be appreciated

 

 

Damien

Share this post


Link to post
Share on other sites

When this happens it's usually that you have missed something out of the installation. I suggest you go back over the checkout files in particular to see what it is you missed.

 

Vger

Share this post


Link to post
Share on other sites

Yes sorry, i double checked and didn't see it because i'm using BTS and it was in html template code.

I juste forgot the echo $order_total_modules->credit_selection();// CCGV line.

Thank you again, great job :)

Share this post


Link to post
Share on other sites

I would like to remove the CCGV stuff from the welcome email. I have it set to no amounts, but this still shows up in the email....

 

Congratulations, to make your first visit to our online shop a more rewarding experience we are sending you an e-Discount Coupon.

Below are details of the Discount Coupon created just for you

 

 

 

To use the coupon enter the redeem code which is during checkout while making a purchase

 

 

 

How do I get that out of there?

 

 

Thanks

 

Travis

Share this post


Link to post
Share on other sites

I think that setting no amounts in configuration (welcome discount coupon and vouchers) should do the job.

If not, you could remove the code added by ccgv in create_account.php and it shouldn't add any line to the welcome email again

Share this post


Link to post
Share on other sites

Under Configuration --> My Store, where it says (at the bottom) 'Welcome discount coupon code' just Edit it and remove the code. That's all you need do.

 

Vger

Share this post


Link to post
Share on other sites

I don't seem to have that in the My Store area. I must have messed something up in my install. I'll have to take a look and see if I can find it.

 

Thanks for the help! It's much appreciated.

 

 

Travis

Share this post


Link to post
Share on other sites

In case you are wondering about the SQL file, it's the bit in the Install instructions which says:

 

"Import the SQL file into your database - THIS IS NOT OPTIONAL"

 

Vger

Share this post


Link to post
Share on other sites

I did import the SQL into the database. The other parts that should be there (I think) are there in the admin panel. I'm also using the discount coupon on the store now and everything is working. I'm not sure how just this one part of the thing didn't happen.

 

Should I try (backing up first of course) dumping the cgv fields from the database and re-importing the SQL? That is my first thought.

 

 

Thanks again for the help.

 

 

Travis

Share this post


Link to post
Share on other sites

Alright I just ended up taking the CCGV code out of the create_account file and that worked.

 

 

Thanks

 

Travis

Share this post


Link to post
Share on other sites

Help.... I have no idea what is going on. I installed CCGV(trad)_1_2_3_4_5_6_7_8_9_10.zip I ran the DB script. I added a coupon via the admin. I went to my store and went to buy something and there was no option to enter the coupon code on the site.

 

My checkout_payment.php has:

<?php

echo $order_total_modules->credit_selection();// CCGV

?>

in it where it should be.

 

I have used a diff program several times to check that i did not miss anything. I have no idea why the box to enter the the coupon during checkout will not display.

 

Any idea's please??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×