Jump to content
Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

I am having a small problem getting the coupons to work the first time my customers get to the Order Confirmation page. No discount shows up. If you refresh the page the discount shows up correctly. When I do test orders they work just fine on the orders after I have done the first refresh of the confirmation page on my first order.

For a temporary fix I put the below text Right next to the Confirm Order button.

You must click the Confirm Order button to Complete your order.

 

If you entered a coupon code and it is not showing up Refresh this page before clicking the Confirm Order button.


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites
For a temporary fix I put the below text Right next to the Confirm Order button.

Are you using CCGV(trad) or CCGV?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Over Christmas I had a few people Can anyone shed some light on this for me please?

And which contribution are you using, CCGV(trad) or CCGV?

 

And which bonus points are you refering to?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

display of "credits available" at checkout is not very intuitive. has any reworked this so that it's easier for customers to understand what to do? if so, can you share your work?

 

thanks...

Share this post


Link to post
Share on other sites
I am having a small problem getting the coupons to work the first time my customers get to the Order Confirmation page. No discount shows up. If you refresh the page the discount shows up correctly. When I do test orders they work just fine on the orders after I have done the first refresh of the confirmation page on my first order.

For a temporary fix I put the below text Right next to the Confirm Order button.

 

 

I had this problem and the following worked for me ....

 

uncomment out the following line in ot_coupon.php (129 ish)

 

 

//$_SESSION['cc_id'] = $coupon_result['coupon_id']; //Fred commented out, do not use $_SESSION[] due to backward comp. Reference the global var instead.

 

My host has register globals to off - but someone else who had the same problem reported the above worked for them

 

I haven't had any problems with doing this

Share this post


Link to post
Share on other sites

Rhea,

 

Just a quick "thank you" for all your efforts. The original ccgv contribution had got completely out of control. "Too many cooks spoil the broth".

 

This is definitely not the easiest contribution to understand - kudos to you for having the patience to sit down and straighten things out.

 

I had managed to get a version on the original ccgv download to work but only after extensive cutting-and-pasting from different versions. Not ideal.

 

Rolled back to a pre ccgv state and installed your latest version - bingo!

 

Much happier with a clean code base that I know just one person (team) has a handle on.

 

Much appreciated

 

Chris


Please use forum for support rather than PM - PMs unrelated to my contributions will be ignored.

Google Site Search is your friend

My contributions: Tracking Module | PDF Customer Invoice | Subcategory textboxes

Share this post


Link to post
Share on other sites
I had this problem and the following worked for me ....

 

uncomment out the following line in ot_coupon.php (129 ish)

//$_SESSION['cc_id'] = $coupon_result['coupon_id']; //Fred commented out, do not use $_SESSION[] due to backward comp. Reference the global var instead.

 

My host has register globals to off - but someone else who had the same problem reported the above worked for them

 

I haven't had any problems with doing this

I just uncommented that line and ran a test order and it worked!!!!


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites

$_SESSION is a "Super Global" meaning that it works when Register Globals are off in php.ini.

 

The older $HTTP_SESSION_VARS works when Register Globals is set to on in php.ini

 

Both should work on all recent versions of PHP from 4.1 upwards when Register Globals are on, but only $_SESSION when Register Globals are off.

 

As this module was never written to work with Register Globals off I am surprised it works at all if you have Register Globals off.

 

Of course it may also be the case that you have Register Globals on, but have a woefully out of date and supremely hackable version of PHP installed.

 

Vger

Share this post


Link to post
Share on other sites
display of "credits available" at checkout is not very intuitive. has any reworked this so that it's easier for customers to understand what to do? if so, can you share your work?

 

thanks...

 

has anyone done any work on how this displays the credits/redeem etc at checkout? it can be very confusing. i was hoping that i could leverage any work in this area to make it more intuitive.

 

thanks..

Share this post


Link to post
Share on other sites

Hello,

 

Ive installed CCGV(trad) its not working as it should. Ive probably left something out during installation.

My store is modified and Im not quite understanding the install/user guide. I did the manual install and installed these files only:

 

List of new files (just install)

 

catalog/add_checkout_success.php

catalog/gv_faq.php

catalog/gv_redeem.php

catalog/gv_send.php

catalog/images/gv_100.gif

catalog/images/gv_50.gif

catalog/images/gv_25.gif

catalog/includes/languages/add_ccgvdc_english.php

catalog/includes/languages/add_ccgvdc_german.php

catalog/includes/languages/add_ccgvdc_espanol.php

catalog/includes/languages/english/images/buttons/button_confirm.gif

catalog/includes/languages/english/images/buttons/button_redeem.gif

catalog/includes/languages/english/images/buttons/button_send.gif

 

List of files to be edited

 

For longer edits look for references to CCGV within the files provided - (What does this mean, where is this? or are these the included files you upload?)

 

Shorter edits are provided here in full

 

catalog/checkout_confirmation.php

catalog/checkout_payment.php

catalog/checkout_process.php

catalog/checkout_shipping.php

catalog/checkout_success.php

catalog/create_account.php

catalog/logoff.php

catalog/includes/boxes/information.php

catalog/includes/boxes/shopping_cart.php

catalog/includes/classes/order_total.php

catalog/includes/classes/order.php

catalog/includes/classes/payment.php

catalog/includes/classes/shopping_cart.php (I dont see any editing instructions for the above?)

 

catalog/includes/languages/english.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_english.php'); // CCGV

catalog/includes/languages/german.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_german.php'); // CCGV

catalog/includes/languages/espanol.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_espanol.php'); // CCGV

 

catalog/includes/languages/english/create_account.php

catalog/includes/languages/espanol/create_account.php

catalog/includes/languages/german/create_account.php (Again I dont see any edit instructions)

 

catalog/includes/application_top.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_INCLUDES . 'add_ccgvdc_application_top.php'); // CCGV

catalog/admin/includes/application_top.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_INCLUDES . 'add_ccgvdc_application_top.php'); // CCGV

catalog/admin/includes/column_left.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_BOXES . 'gv_admin.php'); // CCGV

catalog/admin/includes/languages/english.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_english.php'); // CCGV

catalog/admin/includes/languages/german.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_german.php'); // CCGV

catalog/admin/includes/languages/espanol.php (EDIT) Add the following line to the end of the file just before the closing ?> tag

require(DIR_WS_LANGUAGES . 'add_ccgvdc_espanol.php'); // CCGV

 

The files listed below for editing are for adding the Gift Voucher Balance and Send Gift Voucher link to the Customers Account page. If you don't want this feature then you can just leave out these edits.

 

Where are the edit instructions for the below files?

 

catalog/account.php

catalog/includes/languages/english/account.php

catalog/includes/languages/espanol/account.php

catalog/includes/languages/german/account.php

 

I really dont understand this, Ive only edited the files that have EDIT written next to them with their instructions.

 

The link to the Gift Voucher (in my infomation box) does not work, I dont know what I have done or what I should of done but havent done? Links only work through my site map.

 

When purchasing a GV you are charged for shipping ( I have set everything as stated in instructions)

There is no box to enter code.

When sent code/voucher via email: Recieve email, click on link, takes you to my site, then says reedemed but there are no credits in account at all not even when purchase has been approved.

 

Gift Voucher Release Queue: Nothing shows up here.

 

Creating a Gift Voucher:

 

Creating a gift voucher for a customer to buy is the same as creating a new product with the exception that the gift vouchers Model Number must start with the word GIFT in upper case. It can be GIFT_25 or GIFT25 or whatever you would like to use, as long as it starts with the word GIFT.

 

Im not quite understanding this. Ive done this but dont know how to get the images (that were uploaded from package) to show up? Ive just put my own in there as you would any other product.

 

Im sure there is something I should of done but havent, not quite sure what though! I didnt upload all files as they overwrite excisting files and I lose all my other contributions. (Is this where Ive gone wrong?) :blink:

 

In case you wish to see for yourself so you get some idea as to what Im talking about My Site

 

Much Appreciated

 

Thanks

Share this post


Link to post
Share on other sites

Looking at your website it appears to have been built using CRE Loaded and not the default osCommerce install. I only support installations of CCGV(trad) on osCommerce sites and don't touch CRE Loaded.

 

I don't see how you don't understand the install instructions, which tell you to look for instances of CCGV in the files which you need to edit - you just do a search for CCGV in those files and it will show you what you need to add or edit.

 

Once CCGV(trad) is installed all your 'physical' products must have a weight, Gift Vouchers (which is a 'virtual' product) must have zero weight, and 'Enable Downloads' must be set to true in your osCommerce admin panel. Only then will it skip shipping.

 

Vger

Share this post


Link to post
Share on other sites

My site is not CRE Loaded, It is, an oscommerce site.

 

Once CCGV(trad) is installed all your 'physical' products must have a weight, Gift Vouchers (which is a 'virtual' product) must have zero weight, and 'Enable Downloads' must be set to true in your osCommerce admin panel. Only then will it skip shipping:

 

As for this, As I stated in my last post, I have done everything as per instruction for this.

 

I don't see how you don't understand the install instructions, which tell you to look for instances of CCGV in the files which you need to edit - you just do a search for CCGV in those files and it will show you what you need to add or edit.

 

AS for this, I dont understand it as there are no instructions stating what exactly you should be doing. How does one search? What is an instantance? I am not a programmer and have absolutley no knowledge when it comes to codeing. I dont think one can be just "assuming everyone is in the know" when it comes to installing mods. I have no idea how to edit or what code I should be using to edit. I thought this is why there where instructions attached to the contribution.

 

If I knew how to do all this I wouldnt be posting. As I was reading in another thread. There is really no clear instructions about installing this mod.

Share this post


Link to post
Share on other sites
Once CCGV(trad) is installed all your 'physical' products must have a weight, Gift Vouchers (which is a 'virtual' product) must have zero weight, and 'Enable Downloads' must be set to true in your osCommerce admin panel. Only then will it skip shipping:

 

As for this, As I stated in my last post, I have done everything as per instruction for this.

Well if that is the case then there is something wrong with some part of your CCGV(trad) installation. If I were you I would re-check all the files I edited to install it and look for some errors.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
has anyone done any work on how this displays the credits/redeem etc at checkout? it can be very confusing. i was hoping that i could leverage any work in this area to make it more intuitive.

What are you asking? I am confused.... do you want someone to code that specifically for you because no-one seems to be responding to your post. Elaborate on what you mean by 'intuitive' and 'leverage'


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I have no idea how to edit or what code I should be using to edit

 

Just because osCommerce and its contributions are Open Source it doesn't mean that you can expect to be able to do everything - some knowledge is required.

 

CCGV(trad) is a major install, and if you don't even know how to search inside a file and find instances of "CCGV" (or even what "instances" are) then you really shouldn't be attempting this.

 

For the record "instances" means all the times when the words CCGV are found on the page.

 

Did you run the sql file into the database?

 

The instructions for installing CCGV(trad) are as clear a set of instructions as you will find for installing a contribution - they don't get any clearer than this!

 

If you don't have a clear set of instructions then maybe you are using CCGV and not CCGV(trad). The instruction set for CCGV is a lot less clear than for CCGV(trad).

 

Vger

Share this post


Link to post
Share on other sites
I have done everything as per instruction for this

 

You can't have done, not if you don't know how to search in the files for where CCGV is quoted. It would mean that all that part of the install is left undone. Either that or you just overwrote the files - which wouldn't be a good move with the other contributions you have installed.

 

Did you upgrade to the more recent versions of osCommerce before installing CCGV(trad), as per the instructions?

 

Vger

Share this post


Link to post
Share on other sites

Hey Vger,

 

Nice to see your still keeping up with the support of this contrib, and i'm glad you took the working bug free version from the original CCGV and modified becuase this version runs much better for me..

 

All is installed perfectly and works perfectly apart from a stupid annoying problem which i cant seem to make it stop! >_<

 

Strange thing this.. Not sure if you have a record of this happening on your copy of CCGV(TRAD) but there was on the old CCGV (which i also couldnt fix) so here goes..

 

Created voucher in the admin section, logs into test account on catalog, adds something to card which is within the price limit / specifications of the voucher i'm trying to use.. get to the payment page and enter the voucher into redeem box, hit redeem and it fires me straight to checkout confirmation without adding it to the order.. however if you click back in the browser or go back to the cart and add more items or whatever then redeem the voucher again it works perfectly.

 

Basically the redeem works second time you add it to the order and never on the first! :'(

 

Any help or suggestions would be apreciated bud :thumbsup:

Share this post


Link to post
Share on other sites

If you look at the page before this, in the post about Register Globals then you may find your answer.

 

Vger

Share this post


Link to post
Share on other sites
If you look at the page before this, in the post about Register Globals then you may find your answer.

 

Vger

 

Vger.. Your a star thank you!

 

uncomment out the following line in ot_coupon.php (129 ish)

 

 

//$_SESSION['cc_id'] = $coupon_result['coupon_id']; //Fred commented out, do not use $_SESSION[] due to backward comp. Reference the global var instead.

 

My host has register globals to off - but someone else who had the same problem reported the above worked for them

 

Works 100% Perfect for me now doing this, we have register globals set to off on our server (I had a feeling it was something to do with Register Globals)

Edited by sp_

Share this post


Link to post
Share on other sites
What are you asking? I am confused.... do you want someone to code that specifically for you because no-one seems to be responding to your post. Elaborate on what you mean by 'intuitive' and 'leverage'

 

during checkout the display box, "Credits Available" where the customer can enter a coupon code and redeem the valvue. In addition, there is a check box for using the available account balance. The problem is the redeem button for the coupon code is directly below the check box for using the account balance. My customers, check the box and then click the redeem button. This is pretty common but as we know is incorrect. So my hope is that my customers are not the only one misunderstanding what to do and that someone has restructured this display to be more intuitive. If not, perhaps someone can help me with the code. I've tried and I'm having fundamental problems understanding how it's put together and what to do to successfully come up with a more intuitive display of the options.

 

thanks...

Share this post


Link to post
Share on other sites

Hi, I installed ccgv (trad). When I go to checkout, I get this error in checkout_shipping.php:

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHINAPOST_AIR_ZONES_3 in /hsphere/local/home/wwwuse0/mto123.com/dev/includes/modules/shipping/chinapost_air.php on line 74

 

Any help would be great.. It's been bugging me for days now.

Share this post


Link to post
Share on other sites

Remove the Redeem button. It's not necessary, confuses people, and causes a payment error if people click it without first selecting a payment method. It will be removed form the next release of CCGV(trad) anyway.

 

Vger

during checkout the display box, "Credits Available" where the customer can enter a coupon code and redeem the valvue. In addition, there is a check box for using the available account balance. The problem is the redeem button for the coupon code is directly below the check box for using the account balance. My customers, check the box and then click the redeem button. This is pretty common but as we know is incorrect. So my hope is that my customers are not the only one misunderstanding what to do and that someone has restructured this display to be more intuitive. If not, perhaps someone can help me with the code. I've tried and I'm having fundamental problems understanding how it's put together and what to do to successfully come up with a more intuitive display of the options.

 

thanks...

Share this post


Link to post
Share on other sites

This is an error in your shipping module and nothing to do with CCGV(trad).

 

Vger

Hi, I installed ccgv (trad). When I go to checkout, I get this error in checkout_shipping.php:

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHINAPOST_AIR_ZONES_3 in /hsphere/local/home/wwwuse0/mto123.com/dev/includes/modules/shipping/chinapost_air.php on line 74

 

Any help would be great.. It's been bugging me for days now.

Share this post


Link to post
Share on other sites

Hi, thanks for the quick reply! The shipping module works fine before the install of ccgv... every time I change the codes of checkout_shipping.php to the original version, the error disappears... I've looked through the codes that are connected to the shipping but couldn't find where the error was...

 

Also, how do users send vouchers to friends? I tried putting a GIFT_product number in the redeem box but it didn't work. I don't quite understand how this works.

 

One last thing, I've sent out a gift voucher in the admin but I didn't see it in the gift voucher queue.

 

Sorry.. I'm quite new at installing modules.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×