Jump to content
Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

That code is correct, so there's obviously something else that's been done wrong. You may have uploaded the files using a poor FTP programme which has messed up the upload. I'd recommend that you use WS FTP Home or FileZilla. There have been no reports of problems with either of these programmes, but there have been reports of problems with Dreamweaver, Cute FTP and Smart FTP.

 

If all else fails uninstall the contribution and start again.

 

Vger

Share this post


Link to post
Share on other sites
That code is correct, so there's obviously something else that's been done wrong. You may have uploaded the files using a poor FTP programme which has messed up the upload. I'd recommend that you use WS FTP Home or FileZilla. There have been no reports of problems with either of these programmes, but there have been reports of problems with Dreamweaver, Cute FTP and Smart FTP.

 

If all else fails uninstall the contribution and start again.

 

Vger

 

 

Hi there Vger, i did edit it in Dreamweaver, and Beyond Compare but i uploaded using FileZilla, would one of these be the culprit?

Share this post


Link to post
Share on other sites

It's possible that Dreamweaver was the culprit. I'd use WinZip to unzip the original download again, and then just use Notepad (not Wordpad) to edit any files you need to, and then just use FileZilla to upload.

 

Vger

Share this post


Link to post
Share on other sites
It's possible that Dreamweaver was the culprit. I'd use WinZip to unzip the original download again, and then just use Notepad (not Wordpad) to edit any files you need to, and then just use FileZilla to upload.

 

Vger

 

 

thank you kindly, i will give it another shot, If it doesnt work, can i come back with my tail between my legs? :blush:

Share this post


Link to post
Share on other sites

had a problem, but found it, first time i have been able to edit a post :)

Edited by tec

Share this post


Link to post
Share on other sites
had a problem, but found it, first time i have been able to edit a post :)

 

i cant get it to work, maybe my day has been too long, I am not sure.

What i need is, for the admin to be able to create a coupon code, that he will then promote in flyers, so then people can input that code number when they go to check out.

It isnt the vouchers i so much need, just the ability to create a coupon in the admin and people to be able to put that code in during check out.

Share this post


Link to post
Share on other sites
i cant get it to work, maybe my day has been too long, I am not sure.

What i need is, for the admin to be able to create a coupon code, that he will then promote in flyers, so then people can input that code number when they go to check out.

It isnt the vouchers i so much need, just the ability to create a coupon in the admin and people to be able to put that code in during check out.

whats your URL? if you dont want to give in the forum you can PM me and i'll try to take a look


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
whats your URL? if you dont want to give in the forum you can PM me and i'll try to take a look

 

thank you, I have just PM'd you

Share this post


Link to post
Share on other sites
You PM'd the wrong person :D

 

Vger

 

hahaha, oops, sorry bout that, a community hello ! :D :P

Share this post


Link to post
Share on other sites

ok, all is working well, I am down to 2 problems,

 

i cant see the coupon option on the checkout_payment page and when i go to admin>modules>order total, i get a whole bunch of code at the top of the page,

 

[Shipping not included]'); define('TAX_NOT_INCLUDED', ' [Tax not included]'); define('MODULE_ORDER_TOTAL_COUPON_USER_PROMPT', ''); define('ERROR_NO_INVALID_REDEEM_COUPON', 'Invalid Coupon Code'); define('ERROR_INVALID_STARTDATE_COUPON', 'This coupon is not available yet'); define('ERROR_INVALID_FINISDATE_COUPON', 'This coupon has expired'); define('ERROR_INVALID_USES_COUPON', 'This coupon could only be used '); define('TIMES', ' times.'); define('ERROR_INVALID_USES_USER_COUPON', 'You have used the coupon the maximum number of times allowed per customer.'); define('REDEEMED_COUPON', 'a coupon worth '); define('REDEEMED_MIN_ORDER', 'on orders over '); define('REDEEMED_RESTRICTIONS', ' [Product-Category restrictions apply]'); define('TEXT_ENTER_COUPON_CODE', 'Enter Redeem Code  '); ?>

Edited by tec

Share this post


Link to post
Share on other sites
Chooch! Thanks so much... I deleted that file, and ftp'd it again and it now appears. Many thanks for the quick response.

your welcome, glad to see you got it working :-)


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Has anyone seen this error after a customer sends the gift certificate to someone?

 

Warning: mysql_insert_id(): supplied argument is not a valid MySQL-Link resource in /home/USERNAME/public_html/catalog/includes/functions/database.php on line 112

 

I followed install to t but appears may have mucked something up. Everything works fine but as the gv_send.php?action=process page showed up with the confirmation of email sent (and email was sent fine) this error is across top of page.

what is actually wriiten on your catalog/includes/functions/database.php line 12?

 

can you post that specific line here?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

tec? Your FTP programme is screwing up your uploads to the website, and missing out code tags in the process - this is probably why you are seeing code on the page. It's either that or errors are occuring when you are editing files prior to upload.

 

Vger

Share this post


Link to post
Share on other sites
tec? Your FTP programme is screwing up your uploads to the website, and missing out code tags in the process - this is probably why you are seeing code on the page. It's either that or errors are occuring when you are editing files prior to upload.

 

Vger

 

oh man, my head hurts, I am lost, I am tired. Where do you go in here to offer someone pay to help you?

 

I am getting this error, my client has called me 8 times in 3 hours about people calling in not being able to create an account. In IE the create account page comes up blank, but in firefox i get this

 

1146 - Table 'sailboats1.TABLE_EXTRA_FIELDS' doesn't exist

select ce.fields_id, ce.fields_input_type, ce.fields_required_status, cei.fields_name, ce.fields_status, ce.fields_input_type, ce.fields_size from TABLE_EXTRA_FIELDS ce, TABLE_EXTRA_FIELDS_INFO cei where ce.fields_status=1 and ce.fields_required_status=1 and cei.fields_id=ce.fields_id and cei.languages_id =1

[TEP STOP]

 

i even tried uploading the orig file from the oscommerce zip but still, same error

 

I am not christian, but god help me

Share this post


Link to post
Share on other sites
what is actually wriiten on your catalog/includes/functions/database.php line 12?

 

can you post that specific line here?

 

 

Here are lines 110-112:

 

function tep_db_insert_id( $link = 'db_link') {

global $$link;

return mysql_insert_id($$link);

}

 

I think its trying to insert the actually coupon code that is being generated into one of the databases and it doesnt like.


Paul ------------

Share this post


Link to post
Share on other sites
TABLE_EXTRA_FIELDS'

 

At some point in time a contribution called Products Extra Fields has been installed, but not the sql file that comes with it. That's why you're getting that error.

 

Vger

Share this post


Link to post
Share on other sites
At some point in time a contribution called Products Extra Fields has been installed, but not the sql file that comes with it. That's why you're getting that error.

 

Vger

 

i found it, thank god, man, does my head hurt, you are correct, the programmer who worked on the cart before me must have had it in there, then i must have overwritten some of my files with the old ones.

 

I had to find the contribution, then go through it and compare the install code with the code on the files i have and sure enough, in some of the includes/ files there was some coding in there. Functions too

 

thanks for putting up with me, i still cant get the coupon code thingy to show on the check out page though :P

Share this post


Link to post
Share on other sites

Go to osCommerce admin, go to Modules, go to Order Totals, and click on the Install links for Coupons and Vouchers.

 

In my last contribution update I altered the SQL file so that the fields for the Order Totals module would be inserted automatically, but I realise now that I did not also include the code to auto-install those two functions in the order totals module.

 

Vger

Share this post


Link to post
Share on other sites
Go to osCommerce admin, go to Modules, go to Order Totals, and click on the Install links for Coupons and Vouchers.

 

In my last contribution update I altered the SQL file so that the fields for the Order Totals module would be inserted automatically, but I realise now that I did not also include the code to auto-install those two functions in the order totals module.

 

Vger

 

 

when i go to modules>order total i get this

 

[shipping not included]'); define('TAX_NOT_INCLUDED', ' [Tax not included]'); define('MODULE_ORDER_TOTAL_COUPON_USER_PROMPT', ''); define('ERROR_NO_INVALID_REDEEM_COUPON', 'Invalid Coupon Code'); define('ERROR_INVALID_STARTDATE_COUPON', 'This coupon is not available yet'); define('ERROR_INVALID_FINISDATE_COUPON', 'This coupon has expired'); define('ERROR_INVALID_USES_COUPON', 'This coupon could only be used '); define('TIMES', ' times.'); define('ERROR_INVALID_USES_USER_COUPON', 'You have used the coupon the maximum number of times allowed per customer.'); define('REDEEMED_COUPON', 'a coupon worth '); define('REDEEMED_MIN_ORDER', 'on orders over '); define('REDEEMED_RESTRICTIONS', ' [Product-Category restrictions apply]'); define('TEXT_ENTER_COUPON_CODE', 'Enter Redeem Code '); ?>

Share this post


Link to post
Share on other sites

If you are seeing that code then the files you have uploaded have become corrupted.

 

Vger

Share this post


Link to post
Share on other sites
If you are seeing that code then the files you have uploaded have become corrupted.

 

Vger

 

 

is this a nice way of saying that i have to redo the admin part for the contribution?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×