Jump to content
Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

Where does that appear? I don't see that anywhere - it is only in the url .....

no, it appears in a red banner below your header navigation row


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
it is only in the url .....

 

This is server-specific and is down to the way your server handles error messages. Normally it will display as a red banner at the top of the page. This problem most often occurs on Windows servers.

 

Vger

Share this post


Link to post
Share on other sites

Download the latest version of osCommerce and you'll find an html file with all of the updates in a manual format.

 

Vger

Question for you, how do I go about upgrading to the most recent without loosing all of the mods I have done. We are talking probably 20+ contributions.

Share this post


Link to post
Share on other sites

Ok.. I finally installed the CCGV(trad) contribution. However I am experiencing a number of issues and would appreciate some help in resolving them. My knowledge is php is very limited.

thank you in advance!

 

issue 1:

Once I email a Gift Voucher, and the link is clicked, I get the following error:

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/fragola/public_html/includes/header.php:342) in /home/fragola/public_html/includes/boxes/categories.php on line 13

 

issue 2:

 

In admin panel, I created a discount coupon. But the discount box never shows up in the cart before checking out.

 

Please feel free to see the script in action at http://fragola.ca

I have set up a test user account with following info:

 

email: info@ddreammedia.com

pass: testing

Share this post


Link to post
Share on other sites

Both of those problems are caused by an incomplete, or incorrect, installation of CCGV(trad). You need to go over the whole of the installation again.

 

Vger

Share this post


Link to post
Share on other sites

Thanks Vger.. I got 1 issue resolved. Now the box appears but I still get the following error:

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/fragola/public_html/includes/header.php:342) in /home/fragola/public_html/includes/boxes/categories.php on line 13

 

It seems that many other contributions have this issue. Should I remove the tep_show_category linesince it already exists in header.php?

 

thanks

Share this post


Link to post
Share on other sites

That error is being caused because you have two instances of tep_show_category in use at the same time.

 

The suggestion in the last post of the other thread is made by someone who knows nothing about PHP.

 

Vger

Share this post


Link to post
Share on other sites

There are 87 lines of code in includes/header.php on a default osCommerce website. The error you have is reporting as taking place on line 342 of includes/header.php - so where's the rest of the code coming from - the other 250+ lines of code?

 

There is no tep_show_category in the default osCommerce header.php file so either you are using something other than osCommerce or else it is a very messed up file.

 

Vger

Share this post


Link to post
Share on other sites

Hello,

My site is heavly modified.. Since this seems to be for a clean non template site, do you by any chance have the edits to the files uploaded anywhere? or is it possible to aquire them?

This is an excellent mod, but if people are using other mods it may cause some problems.

I was able to fix the admin quite easily, but the catalog is different. Much harder.

If i knew the standard code osc uses for the page layout i could remove it and place my own in so the pages wouldn't be out of line.

Do you know what it is? And any chance you could tell me the edits for each file, just the catalog files?

 

Thanks.. Great mod by the way and I appreciate your work.

 

 

Lee.

Share this post


Link to post
Share on other sites

Once a credit has been successfully added for a product in the cart, what page/function is it that checks if the applicable item is still in the cart before checkout?

 

I've made modifications to the contribution and it's working fine, except that if someone uses my discount on an applicable product, removes the product, then checks out, the discount still remains, even though it shouldn't because the applicable product is gone. This doesn't happen with a standard Product or Category discount, so I'm thinking there's something I'm overlooking.

 

Any info would be much appreciated!

Share this post


Link to post
Share on other sites

Your site isn't working because you've installed a commercial template with rubbish coding in it. That's why your header.php file is so long and why CCGV won't work on your site.

 

Vger

Vger,

 

I left you a PM.

 

Thanks

Share this post


Link to post
Share on other sites

Use Win Merge to compare the two sets of files.

 

Vger

Hello,

My site is heavly modified.. Since this seems to be for a clean non template site, do you by any chance have the edits to the files uploaded anywhere? or is it possible to aquire them?

This is an excellent mod, but if people are using other mods it may cause some problems.

I was able to fix the admin quite easily, but the catalog is different. Much harder.

If i knew the standard code osc uses for the page layout i could remove it and place my own in so the pages wouldn't be out of line.

Do you know what it is? And any chance you could tell me the edits for each file, just the catalog files?

 

Thanks.. Great mod by the way and I appreciate your work.

Lee.

Share this post


Link to post
Share on other sites

Once the discount is applied it remains unless the person logs out and comes back. Someone (around 10-15 pages back in this thread) posted some code which 'unregisters' the discount or Gift Voucher when someone backtracks on the site. You may wish to use that, but I don't want to make it part of CCGV for the reasons I posted in the thread.

 

Vger

Once a credit has been successfully added for a product in the cart, what page/function is it that checks if the applicable item is still in the cart before checkout?

 

I've made modifications to the contribution and it's working fine, except that if someone uses my discount on an applicable product, removes the product, then checks out, the discount still remains, even though it shouldn't because the applicable product is gone. This doesn't happen with a standard Product or Category discount, so I'm thinking there's something I'm overlooking.

 

Any info would be much appreciated!

Edited by Vger

Share this post


Link to post
Share on other sites

Okay, I just wanted to confirm. I'm fine with the way it is.

 

One other question (pardon if this one is redundant too... I tried search but may have overlooked in the 60+ pages): it appears that when a discount coupon is set to a fixed amount for, say, a product #, if the person has 2 of that product in the cart, the discount still only applies once. Is this correct?

 

Thanks again for this great contribution!

Share this post


Link to post
Share on other sites

Hi,

It seems that this trad version of CCGV has no module payment ccerr.php.

Why? Is it because of this, so when I input a wrong redeem code in the check out process, I can see no error message?

Share this post


Link to post
Share on other sites
Hi,

It seems that this trad version of CCGV has no module payment ccerr.php.

Why? Is it because of this, so when I input a wrong redeem code in the check out process, I can see no error message?

you have posted your query on page 68 of this support thread, yet the answer has already been posted on page 67... have a read

Edited by chooch

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Okay, I just wanted to confirm. I'm fine with the way it is.

 

One other question (pardon if this one is redundant too... I tried search but may have overlooked in the 60+ pages): it appears that when a discount coupon is set to a fixed amount for, say, a product #, if the person has 2 of that product in the cart, the discount still only applies once. Is this correct?

 

Thanks again for this great contribution!

I haven't tested it in that way but would presume so, yes.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hi there,

 

I have posted my ? on the main support but thought I would try here since it is regarding this contrib.

 

I have been using the coupons all along without any problems. Now all of a sudden, they are not working. A SSL thru go daddy has been loaded recently. So I don't know if that is causing the problem. The GV's work just fine. Just not the coupons.

 

Can someone please help??

 

Thanks

Share this post


Link to post
Share on other sites

It's more likely to be a problem with your Go Daddy hosting - just like everyone else who tries to host osCommerce websites with them. I can't see why SSL would affect it.

 

Vger

Share this post


Link to post
Share on other sites
Hi there,

 

I have posted my ? on the main support but thought I would try here since it is regarding this contrib.

 

I have been using the coupons all along without any problems. Now all of a sudden, they are not working. A SSL thru go daddy has been loaded recently. So I don't know if that is causing the problem. The GV's work just fine. Just not the coupons.

 

Can someone please help??

 

Thanks

 

 

Hi,

 

But I am not hosting with them. I just have an SSL thru them.

 

thanks

Tracey

Share this post


Link to post
Share on other sites

Okay, so you don't host with Go Daddy. It's still likely to be the hosting. I don't see how an SSL cert would affect it.

 

Vger

Share this post


Link to post
Share on other sites
But I am not hosting with them. I just have an SSL thru them.

Many people have had problems using hosting and/or SSL certificates on Go-Daddy. There are a zillion and one different hosting companies out there.. surely you could set up your SSL somewhere else and forget Go-Daddy.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×