Jump to content
Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

Agh, just realised what you've done - so you should have triple-checked the install.

 

It's all down in the User Guide - that you must use GIFT as the first part of the Model Number when you add a Gift Voucher as a product to your catalogue. If you don't then it's not treated as a Gift Voucher and so is not queued.

 

Vger

Yes, I installed the latest version of CCGV (trad) I have double checked my installation.

Thanks,

Rod

Share this post


Link to post
Share on other sites

Ok, I finally got the links correct and the sql correct. Now for some reason under modules, order total, the coupons are not installed and when i click to install, nothing happnes and they dont install. I reinstalled the tables but no luck.

Share this post


Link to post
Share on other sites

This is not a problem with CCGV(trad).

 

Either you have failed to follow the Install advice correctly, or else permissions are not correct on the modules and/or the order_total folder (755).

 

Vger

Share this post


Link to post
Share on other sites
Ok, I finally got the links correct and the sql correct. Now for some reason under modules, order total, the coupons are not installed and when i click to install, nothing happnes and they dont install. I reinstalled the tables but no luck.

 

Also, the sql im using is the one that came with the new ccgv trad contrib. So I have no clue why it is not working.

Share this post


Link to post
Share on other sites
This is not a problem with CCGV(trad).

 

Either you have failed to follow the Install advice correctly, or else permissions are not correct on the modules and/or the order_total folder (755).

 

Vger

 

 

dont know whats wrong then, i double checked the install, everything was edited and added to the server according to the install manual, the folder order_total is set for 755chmod and the 2 files are set at 644.

Share this post


Link to post
Share on other sites

ok it works now, strange thing is, it says to install yet, when i click the voucher line again, it brings me into the setup config. So it is working, thank you again for a great contrib!

Share this post


Link to post
Share on other sites
Agh, just realised what you've done - so you should have triple-checked the install.

 

It's all down in the User Guide - that you must use GIFT as the first part of the Model Number when you add a Gift Voucher as a product to your catalogue. If you don't then it's not treated as a Gift Voucher and so is not queued.

 

Vger

 

 

THANKS...you were right.,..I misread the easy part of the install....I was using GIFT in the title, but not the model number..thanks for your help.

 

Rod

Share this post


Link to post
Share on other sites
This has already been covered (several times) in this thread - and was also addressed in the last update of CCGV(trad).

 

Vger

 

 

Hi Rhea,

 

Just wanted to ask you again. I followed the CCGV(trad) recommendation not to include the osCommece 051113 update regarding "Adding Non-Existing Products To Cart" in classes/shopping_cart.php

 

However, when not doing so, I can't change the product quantities in the shopping cart. This is not an CCGV/trad) issue itself but I didn't have that problem when I implemented the full update for "Adding Non-Existing Products To Cart" (before installing CCGV(trad).

 

You answer in the quote above is related to my question here

Share this post


Link to post
Share on other sites

When I built CCGV I deliberately built it using corresponding files from the latest version of osCommerce (November 2005). In the Install file for CCGV(trad) it does say to make sure you are using the updated osCommerce, and if not to update it first.

 

However there then appeared to be a problem with updating quantities in the Shopping Cart, and this was resolved by removing instances of products_id_string (added in the updated osCommerce) in the shopping cart class file and replacing with products_id (the original code). Those changes exist in the latest version of CCGV(trad) - so provided your website is using the latest version of CCGV(trad) there should not be a problem updating quantities in the shopping cart.

 

Vger

Edited by Vger

Share this post


Link to post
Share on other sites

just curious if this would be possible. I noticed on several ecommerce sites, when you buy a gift voucher and send it to someone, it formats the information (To and From and the amount) into a nice looking printable html certificate. How could this be done? Would it be difficult to implement? I think it could be a nice feature to this already awsome contrib.

Share this post


Link to post
Share on other sites

Hi guys!

 

Thanks for the great contribution, Rhea! It made my job a lot easier.

 

I am stuck with two problems, though, for which neither the User's Guide nor this forum yielded any results.

 

Due to it's size I installed CCGV(trad) over a fresh osCommerce install, btw.

 

Problem #1: In Germany we are required to show prices including the VAT. If I set my Gift Vouchers (which are sold without adding VAT, since there might be different VAT rates) to "Include Tax = true" and "Re-calculate Tax = none" it works fine.

 

For Discount coupons, though, my settings (and those are the closest I can get to what I want) of "Include Tax )

true" and "Re-calculate Tax = None" lead to following example:

 

Zwischensumme: 27.50EUR

Gutscheine:FeenCon: -2.75EUR

7.0% EU VAT/MwSt. incl.: 1.80EUR

Summe: 24.75EUR

 

While the end result is correct, the given VAT is wrong: It should be 24.75 EUR * (0.7 / 1.07) = 1.62 EUR

 

(when I change the settings, I can get the correct Tax, but then the total is wrong :( ).

 

Has anybody solved this before?

 

Problem #2: In the unlikely yet possible event that a customer has both a discount coupon (10% in this case) and a gift voucher, this rounding error can happen:

 

Zwischensumme: 57.45EUR

Gutscheine:XYZ: -5.75EUR

Gutscheine: 51.71EUR

7.0% EU VAT/MwSt. incl.: 3.76EUR

Summe: 0.01EUR

 

It should be:

 

Zwischensumme: 57.45EUR

Gutscheine:XYZ: -5.75EUR

Gutscheine: 51.70EUR

7.0% ...: 3.38EUR (That's problem #1 again)

Summe: 0.00EUR

 

 

Any idea how I can fix this rounding error?

 

 

Thanks for your patience!

Share this post


Link to post
Share on other sites
Hi,

I was testing again this contrib before applying it on my live shop.

I found that a coupon with only one use/cutomer was not applied : a customer could use the same coupon many times even if the coupon is set to 1.

When I go the the table COUPON_REDEEM_TRACK I have only an old coupon tracked (the first test I made an dtha tI 've deleted) and nothing else. And yet I've created many other coupons and used them. I think thats why the customer can use as often as he want the same coupon because there is no tracking. On the click on the button "Report" of any coupon active and already used, there is nothing.

Have you any idea why the coupon tracking is not done anymore ? Am i the only one dealing with this problem ? Thanks for your help.

Seb

Hi, I installed the CCGV trad on the live website. I have exactly the same problem as on my local website, explaine above. Still no tracking on coupons in the COUPON_REDEEM_TRACK table ! :'(

Have you an idea where to search to resolve that ?

Thanks. Seb


Osc 2.2 MS2

Share this post


Link to post
Share on other sites
Have you an idea where to search to resolve that ?

 

It's difficult for me to say, because we don't get that problem in tests, and we have the CCGV(trad) systen running on lots of customer websites without this problem surfacing.

 

Vger

Share this post


Link to post
Share on other sites

I just want to thank you Rhea. It might sound silly, but I haven't even installed this contib. :blink: When I opened the archive and saw a user guide I thought to myself, "omg" how many contibutions have I installed and not known how to use properly! So thoughtful.

 

But then I think it is also really stand up of you to have put together this module because the original thread of it was beginning to get all corrupted. It looks like this is exactly what is going on with Easy Populate. It looks like a really essential addition to OSC is turning to mush.

 

Thanks so much for having the generosity to work on this.

Share this post


Link to post
Share on other sites
Thanks so much for having the generosity to work on this.

I just wanted to double that..... thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Hey Vger,

 

Quick question. When I tried deleting some coupons that I made up a while back, they moved from "Active Coupons" to "Inactive Coupons" and then when I tried deleting it again from the Inactive Coupons section, the coupon still is there. When I selected the coupon that I wanted to delete, I clicked the delete button and then it switched to the active coupon section to confirm the deletion. When I went back to the inactive section, it's still there. I wanted to delete some of the used coupons and old ones that are no longer being used as I don't want my server to be boged down from the 2000 some odd coupons I have. Anyhow, your help would be appreciated.

 

Thanks

M

Share this post


Link to post
Share on other sites

Yes, see what you mean. I'll have to look into that. In the meantime you can delete them via phpMyAdmin.

 

Vger

Share this post


Link to post
Share on other sites

I do have a couple questions about this contribution.

 

I am having a problem with the shipping price. It seems like I can only have the gift certificates cost no money for DL if I actually add the DL attribute to them and then have a mock item to be downloaded. It's not that big a deal, but it means that at checkout there is an odd message that says "you can now download your gift certificate". Just seems like it would be confusing. I'm also assuming that is not the way this was designed to work either.

 

Also I would like to be able to show the remaining balance for vouchers. What is the code that I would have to insert to show that? Thank you very much for your help.

 

be well.

;-j

Share this post


Link to post
Share on other sites

All the questions you ask are answered in the post-install User Guide, except for the one relating to showing the Gift Voucher balance in the customer account - which is covered in the Install instructions.

 

Vger

Share this post


Link to post
Share on other sites

The last time someone reported that the email didn't include the name of the coupon it was because they had given it a name which was a word which fitted (unnoticed) into the text of the email. Try creating one called something like 123456 and then see if you can see it in the email.

 

Vger

Share this post


Link to post
Share on other sites

GREAT contrib and GREAT support :thumbsup:

 

got it upnrunning to a treat only drama is that I dont seem to have the "Welcome Gift Voucher Amount" and/or fields in the Configuration -> My Store

 

It sends an email with all the text but no voucher details. I have removed the text from the php page till I get it figured

 

Any ideas ??

 

JP

Share this post


Link to post
Share on other sites
got it upnrunning to a treat only drama is that I dont seem to have the "Welcome Gift Voucher Amount" and/or fields in the Configuration -> My Store

 

JP

 

 

Have you run the sql script?

 

Ken

Edited by GemRock

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Have you run the sql script?

 

Ken

 

Sorry, I meant especially that part of sql script as shown below:

 

INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('Welcome Gift Voucher Amount', 'NEW_SIGNUP_GIFT_VOUCHER_AMOUNT', '0', 'Welcome Gift Voucher Amount: If you do not wish to send a Gift Voucher in your create account email put 0 for no amount else if you do place the amount here i.e. 10.00 or 50.00 no currency signs', 1, 31, NULL, '2003-12-05 05:01:41', NULL, NULL);

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×