Jump to content
Vger

[CONTRIBUTION] CCGV (trad)

Recommended Posts

Awsome contrib, thanks a bunch. Everything seems to be working fine except for one error when I go to confirm the final check out, when trying to purchase a gift voucher, I get:

 

Fatal error: Call to a member function on a non-object in /var/www/html/kf/checkout_process.php on line 50

 

Line 50 reads:

$order_totals = $order_total_modules->process();

 

I'm pretty new to this, any ideas?

 

Cheers

Shane

Edited by Shanke

Share this post


Link to post
Share on other sites

Vger answered this already.

 

The update of a few days ago was incorrect, which was why I updated a new version last night - which returned that line of code in checkout_process.php to its original place.

 

Vger

 

Delete line 50, or comment it out( two // before the line). A few lines down under that it says this:

 

// commented out, code moved above for CCGV

// $order_totals = $order_total_modules->process();

 

Change it to this:

 

$order_totals = $order_total_modules->process();

 

Worked for me.

Edited by suicidal

Share this post


Link to post
Share on other sites
Vger answered this already.

Delete line 50, or comment it out( two // before the line). A few lines down under that it says this:

 

// commented out, code moved above for CCGV

// $order_totals = $order_total_modules->process();

 

Change it to this:

 

$order_totals = $order_total_modules->process();

 

Worked for me.

 

I'm a little confused now, arent you just retyping the line you just commented out. Aside from which I think I have the newest version and I dont have the two lines that are commented out below line 50. Line 50 currently reads "$order_totals = $order_total_modules->process();". I did try commenting it out, but still getting the same error. Am I just not undertanding something here??

 

Cheers

Shane

Share this post


Link to post
Share on other sites

nevermind, I'm just stupid :-" Uploaded the commented out line to the test directory I was screwing with. Thanks for the help suicidal and sorry I missed that earlier post vger - wicked contrib!

Edited by Shanke

Share this post


Link to post
Share on other sites

I can't get the discount coupon to apply to the purchase of a gift certificate. What am I doing wrong? I have the gift certificate sort set higher than the discount coupon.

Share this post


Link to post
Share on other sites
I can't get the discount coupon to apply to the purchase of a gift certificate. What am I doing wrong? I have the gift certificate sort set higher than the discount coupon.

there is a sort order condition already set... the coupon must be higher than the voucher

 

hope that helps


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

I'm having difficult to get the percentage discount work. Use Fix price disount works perfect, not for the percentage. For example,

 

Sub-Total: $137.50

Tax (15%): $20.63

Discount Coupons:111111: -$3.00 (I set the value 10% in the admin, don't know where this $3 coming from??)

Total: $215.13

 

Anything I'm missing??? Thanks

Share this post


Link to post
Share on other sites

Sub-Total: $137.50

Tax (15%): $20.63

= $158.13 and not $215.13

 

I'd say that there's something else wrong with your site.

 

Vger

Share this post


Link to post
Share on other sites

I'm sorry, I missed the shipping when I pasted last post. Here it is.

 

Sub-Total: $137.50

Table Rate (Best Way): $60.00

Tax: (15%) $29.63

Discount Coupons:1111(10%): -$6.00

Total: $221.13

 

Now the only problem is the percentage discount, any suggestions?

Share this post


Link to post
Share on other sites

It's obvious that the discount is only being applied to the shipping calculation. Please make sure that you leave the settings for Gift Vouchers and Discount Coupons as they were when CCGV was installed. It appears that you have altered the settings.

 

Another possibility is that you have not enabled discount coupons under Modules --> Order Total.

 

Vger

Share this post


Link to post
Share on other sites
It's obvious that the discount is only being applied to the shipping calculation. Please make sure that you leave the settings for Gift Vouchers and Discount Coupons as they were when CCGV was installed. It appears that you have altered the settings.

 

Another possibility is that you have not enabled discount coupons under Modules --> Order Total.

 

Vger

 

Yes, I did mess up with the shipping and tax. Thanks, and thanks for this wonderful contribution.

Share this post


Link to post
Share on other sites

You set it up so that the discount is applied to the sub-total and shipping comes afterwards.

 

Vger

Share this post


Link to post
Share on other sites
You set it up so that the discount is applied to the sub-total and shipping comes afterwards.

 

Vger

 

If you meen in order_total then it's done, but it still does the same thing.. shipping is set afterwards but the discount still substrakt from shipping also..

 

I'm also having trubble with some of the files that I have to manually edit couse i have trouble getting them opened in a editor, and therefore I think I might have missed some edit things.. Do you have the files without zip somewhere som that I can dobble check?

 

f.eks when i make an order the gift amount substrakt from the amount, but it doesnt go away from the gift voucher balanse in my profile.. so I think I might be missing some code..

Share this post


Link to post
Share on other sites

Hi Vger,

 

Are you aware of any clashes between this and other contribs? Specifically multi-stores and STS.

 

Thanks and good work,

 

Digit.

Share this post


Link to post
Share on other sites

hi,

 

i'm currently involved a web site development within a mambo / mosCommerce environment.

 

i followed your manual installation instructions to install CCVG (trad).

i had to tweak some of the code (mainly the links) to get it running in the admin section without errors.

my problem is that none of the functionality works for me.

i have followed the instructions to the letter and read through the forums, so i'm pretty sure that this is because the contribution has been written for osCommerce and not mosCommerce.

 

however, i just wanted to check if there are there any fixes or tricks that i'm missing?

i would really like to get this contribution up and running, it would be a great addition to the site.

if there is something i can do, or if anyone has this running in mosCommerce, please let me know.

any help would be greatly appreciated - even if it's just someone telling me that it's not possible and i'm wasting my time!

 

thanks in advance

 

 

mike

 

config:

CCGV(trad)

mosCommerce v.1.0.1 (osCommerce 2-2-MS2)

Mambo 4.5.2 Stable

Apache/1.3.33 PHP/4.3.10

Share this post


Link to post
Share on other sites

There's no reason why it should clash with STS, but it would definitely clash with BTS. It doesn't clash with Multi-Stores - I know I've used both on the same site. In fact, that's why I built this version - because the later ones wouldn't work with Muli-Stores.

 

Vger

Hi Vger,

 

Are you aware of any clashes between this and other contribs? Specifically multi-stores and STS.

 

Thanks and good work,

 

Digit.

Share this post


Link to post
Share on other sites

Hi, I only provide support for this contribution when used with osCommerce and can't provide support when you're using an osCommerce plug-in with a cms system

 

Vger

hi,

 

i'm currently involved a web site development within a mambo / mosCommerce environment.

 

i followed your manual installation instructions to install CCVG (trad).

i had to tweak some of the code (mainly the links) to get it running in the admin section without errors.

my problem is that none of the functionality works for me.

i have followed the instructions to the letter and read through the forums, so i'm pretty sure that this is because the contribution has been written for osCommerce and not mosCommerce.

 

however, i just wanted to check if there are there any fixes or tricks that i'm missing?

i would really like to get this contribution up and running, it would be a great addition to the site.

if there is something i can do, or if anyone has this running in mosCommerce, please let me know.

any help would be greatly appreciated - even if it's just someone telling me that it's not possible and i'm wasting my time!

 

thanks in advance

mike

 

config:

CCGV(trad)

mosCommerce v.1.0.1 (osCommerce 2-2-MS2)

Mambo 4.5.2 Stable

Apache/1.3.33 PHP/4.3.10

Share this post


Link to post
Share on other sites

Hi, If you have had trouble with editing the files then that's probably why it's not working correctly. Please remember that this contribution is also built to work with the latest version of osCommerce MS2, and it says in the Install guidelines that if you use a version of osCommerce from before November 2005 then you need to apply the upgrade first.

 

You need to go to www.oscommerce.com and download the latest version of MS2, unzip it on your computer, and then use a good plain text editor like Text Pad (free download) to work with osCommerce files.

 

Vger

If you meen in order_total then it's done, but it still does the same thing.. shipping is set afterwards but the discount still substrakt from shipping also..

 

I'm also having trubble with some of the files that I have to manually edit couse i have trouble getting them opened in a editor, and therefore I think I might have missed some edit things.. Do you have the files without zip somewhere som that I can dobble check?

 

f.eks when i make an order the gift amount substrakt from the amount, but it doesnt go away from the gift voucher balanse in my profile.. so I think I might be missing some code..

Share this post


Link to post
Share on other sites

thanks anyway rhea,

 

i think that i'll end up running mambo / osCommerce alongside each other instead of using the mosCommerce integration - things shouold be simpler that way!

 

mike

Share this post


Link to post
Share on other sites

Thanks.

 

There's no reason why it should clash with STS, but it would definitely clash with BTS. It doesn't clash with Multi-Stores - I know I've used both on the same site. In fact, that's why I built this version - because the later ones wouldn't work with Muli-Stores.

 

Vger

Share this post


Link to post
Share on other sites

The team that built Mambo left and set up Joomla. For ongoing development you may wish to use osCommerce with Joomla.

 

Vger

thanks anyway rhea,

 

i think that i'll end up running mambo / osCommerce alongside each other instead of using the mosCommerce integration - things shouold be simpler that way!

 

mike

Share this post


Link to post
Share on other sites
The team that built Mambo left and set up Joomla. For ongoing development you may wish to use osCommerce with Joomla.

 

Vger

 

i checked out josCommerce, but it doesn't look anywhere near ready yet.

it's not easy to find a way to give the client a single login, and let them manage content and product!

maybe soon!!!

 

thanks again,

 

mike

Share this post


Link to post
Share on other sites
Hi, If you have had trouble with editing the files then that's probably why it's not working correctly. Please remember that this contribution is also built to work with the latest version of osCommerce MS2, and it says in the Install guidelines that if you use a version of osCommerce from before November 2005 then you need to apply the upgrade first.

 

You need to go to www.oscommerce.com and download the latest version of MS2, unzip it on your computer, and then use a good plain text editor like Text Pad (free download) to work with osCommerce files.

 

Vger

 

I'm using 2.2 MS2 (051113) I have no idea if that is a version before November 2005 but I think they usually have the latest for download and I just made the shop a few days ago..

 

My problem is that my computer wont open the files.. s? it would have been perfekt with an insall file that has the changes included, then its also easier to find where the changes should be, insted of looking up and down for where you have made changes.. I just love the contrib that also say at what line the chages are..

:blush:

 

But I will try to find out why I cant open the files, and dobbel cheche if I have missed something..

 

Thanx for a great mode.. :thumbsup:

Share this post


Link to post
Share on other sites

You are using the correct version. If you download and install Text Pad, then open Text Pad and tell it which files to open it will open them for you.

 

Vger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×