Jump to content
Sign in to follow this  
theghost

Head tag controller problems, need help please.

Recommended Posts

Hello,

 

I have just took over a site that has Head Tage Controller V.20 installed, and I am trying to figure out how to get my products to have a seperate title and keywrds for each item. I have the boxes in the product update pages but the info I enter is not showing up.

 

I have searched through the threads and couldnt find anything exactly explaining this.

 

In my header_tags.php files for the product info it looks like this:

 

// PRODUCT_INFO.PHP
 case ( strstr($_SERVER['PHP_SELF'],'product_info.php') or strstr($PHP_SELF,'product_info.php') ):
//	$the_product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_keywords_tag, pd.products_head_desc_tag, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and pd.products_id = '" . $HTTP_GET_VARS['products_id'] . "'");
$the_product_info_query = tep_db_query("select pd.language_id, p.products_id, pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_keywords_tag, pd.products_head_desc_tag, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "'" . " and pd.language_id ='" .  (int)$languages_id . "'");
$the_product_info = tep_db_fetch_array($the_product_info_query);

if (empty($the_product_info['products_head_desc_tag'])) {
  $the_desc= HEAD_DESC_TAG_ALL;
} else {
  if ( HTDA_PRODUCT_INFO_ON=='1' ) {
	$the_desc= $the_product_info['products_head_desc_tag'] . ' ' . HEAD_DESC_TAG_ALL;
  } else {
	$the_desc= $the_product_info['products_head_desc_tag'];
  }
}

if (empty($the_product_info['products_head_keywords_tag'])) {
  $the_key_words= HEAD_KEY_TAG_ALL;
} else {
  if ( HTKA_PRODUCT_INFO_ON=='1' ) {
	$the_key_words= $the_product_info['products_head_keywords_tag'] . ' ' . HEAD_KEY_TAG_ALL;
  } else {
	$the_key_words= $the_product_info['products_head_keywords_tag'];
  }
}

if (empty($the_product_info['products_head_title_tag'])) {
  $the_title= HEAD_TITLE_TAG_ALL;
} else {
  if ( HTTA_PRODUCT_INFO_ON=='1' ) {
	$the_title= HEAD_TITLE_TAG_ALL . ' ' . clean_html_comments($the_product_info['products_head_title_tag']);
  } else {
	$the_title= clean_html_comments($the_product_info['products_head_title_tag']);
  }
}

break;

 

and on /includes/languages/english/header_tags.php my product info section looks like this:

 

// product_info.php - if left blank in products_description table these values will be used
define('HTTA_PRODUCT_INFO_ON','1');
define('HTKA_PRODUCT_INFO_ON','1');
define('HTDA_PRODUCT_INFO_ON','1');
define('HEAD_TITLE_TAG_PRODUCT_INFO','');
define('HEAD_DESC_TAG_PRODUCT_INFO','');
define('HEAD_KEY_TAG_PRODUCT_INFO','');

 

Any help would greatly be appreciated!

 

Thank you!

Share this post


Link to post
Share on other sites

It could be that the header tag code in the product_info.php file is missing. Does your title work properly for the home and category page (index.php)?

 

Jaclk


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
It could be that the header tag code in the product_info.php file is missing. Does your title work properly for the home and category page (index.php)?

 

Jaclk

 

On all pages it shows the same tag info, here is my product_infp.php

 

<?php
/*
 $Id: product_info.php,v 1.15 2002/11/19 01:48:08 dgw_ Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2002 osCommerce

 Released under the GNU General Public License
*/

define('TEXT_PRODUCT_NOT_FOUND', 'Product not found!');
define('TEXT_CURRENT_REVIEWS', 'Current Reviews:');
define('TEXT_MORE_INFORMATION', 'For more information, please visit this products <a href="%s" target="_blank"><u>webpage</u></a>.');
define('TEXT_DATE_ADDED', 'This product was added to our catalog on %s.');
define('TEXT_DATE_AVAILABLE', '<font color="#ff0000">This product will be in stock on %s.</font>');
define('TEXT_ALSO_PURCHASED_PRODUCTS', 'Customers who bought this product also purchased');
define('TEXT_PRODUCT_OPTIONS', 'Available Options:');
define('TEXT_CLICK_TO_ENLARGE', 'Click to enlarge');
?>

Share this post


Link to post
Share on other sites

No, I meant the code that goes into the product_info.php file in the root. See the Install_Catalog.txt file for how to do that.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites

This contirb (header tags) is one of ony two contribs that I absolutely could not get to work and I just gave up.

 

My product_info was the same, I even thought it was something I did, so I went through it again (3 times) and ever time the same. If an answer is found to this persons problem, please post it in detail here so that I may try once again.


My Contributions

 

Henry Smith

Share this post


Link to post
Share on other sites

If the instructions are followed correctly, you can see if Header Tags is working after only a few minor changes, as detailed in the Install_Catalog.txt file. i suspect that what most people do is skip over the step where it says to test it before proceeding and that is where they get into problems. So I suggest starting over and only do the steps in the Install_Catalog.txt file. If it fails at that point, there are only a few files involved and it should be very easy to check.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Thanks for your help, I did just take over the site so I wasnt sure what the problem could be. But I will check over that file to see if I can find the problem.

 

 

If the instructions are followed correctly, you can see if Header Tags is working after only a few minor changes, as detailed in the Install_Catalog.txt file. i suspect that what most people do is skip over the step where it says to test it before proceeding and that is where they get into problems. So I suggest starting over and only do the steps in the Install_Catalog.txt file. If it fails at that point, there are only a few files involved and it should be very easy to check.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×