Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

point2point

Merchant id is invalid?

8 posts in this topic

I'm setting up oscommerce to use authorize.net

 

I get the following message

 

The following errors have occurred.

(13) The merchant login ID or password is invalid or the account is inactive.

 

I checked with authorize.net's support and they claim the account is active and have verified the username is correct. I've also made sure there is no white spaces after the username or the transaction key. Anyone have any ideas? authorize.net said i should try the oscommerce forums since the account is definetely active and i don't see a Password field in the settings.

 

Thanks in advance. Oscommerce support forums = for the win

Share this post


Link to post
Share on other sites

There could be many reasons for that error. To start with - which Authorize Net module are you using - the default one that comes with osCommerce or the new AIM one (link below my name)?

 

You'll get that error, for instance, if you have a Test Account, or your Authorize Net account is set to Test mode and your module is set to connect to the Live address - or the other way about.

 

Vger

Share this post


Link to post
Share on other sites
There could be many reasons for that error. To start with - which Authorize Net module are you using - the default one that comes with osCommerce or the new AIM one (link below my name)?

 

You'll get that error, for instance, if you have a Test Account, or your Authorize Net account is set to Test mode and your module is set to connect to the Live address - or the other way about.

 

Vger

 

Okay, i took your advice and logged in and made sure my authorize.net account was not in test mode. I'm using the default authorize.net module. I was curious on what exactly my authorize.net id is. Is it a number or actual username like Mywebsite01? I've tried it both ways but i'm still getting the error, any ideas?

Share this post


Link to post
Share on other sites

The Merchant Login ID is your User Name to login to your Authorize Net account.

 

Vger

Share this post


Link to post
Share on other sites
The Merchant Login ID is your User Name to login to your Authorize Net account.

 

Vger

 

Okay i've got that updated but i'm still getting this error. I have no clue on what the next troubleshooting step would be on this. Thought i could just plug this info in and it'd be golden. Could you give me a link to the updated authorize.net module?

 

Authorize.net says the account is active and ready to go so maybe that will fix it?

Share this post


Link to post
Share on other sites
Okay i've got that updated but i'm still getting this error. I have no clue on what the next troubleshooting step would be on this. Thought i could just plug this info in and it'd be golden. Could you give me a link to the updated authorize.net module?

 

Authorize.net says the account is active and ready to go so maybe that will fix it?

 

Does anyone have any idea on this issue? Authorize.net has verified my settings 3x times now and say that the issue is within oscommerce. Can anyone give me a next step in troubleshooting?

Share this post


Link to post
Share on other sites

I had this error as well but figured it out, thought I would pass it on for others.

 

The confusion has to do with the two options, Transaction Server (Live or Test) and Transaction Mode (Live or Test).

 

From the Authorize.net developer site:

 

If you are posting your transaction requests to the gateway URLs https://test.authorize.net/gateway/transact.dll or https://certification.authorize.net/gateway/transact.dll and you are using an account given to you by an Authorize.Net Reseller or from Authorize.Net Sales, you may encounter this error. The gateway URLs mentioned above only work with specific test accounts, available upon request by completing the form at http://developer.authorize.net/testaccount/

 

Try posting your transaction request to https://secure.authorize.net/gateway/transact.dll instead. If you need to submit a test transaction, you may do so by setting the field x_test_request to "TRUE". You may then remove x_test_request or set it to "FALSE" when you have completed your testing.

Share this post


Link to post
Share on other sites