Jump to content
Sign in to follow this  
Vger

[CONTRIBUTION] Authorize Net AIM module

Recommended Posts

I keep getting this error no matter what I change..

 

/store/checkout_payment.php?error_message=This+transaction+has+been+declined - Your+credit+card+could+not+be+authorized+for+this+reason.+Please+correct+any+inf

ormation+and+try+again+or+contact+us+for+further+assistance

 

.the transactions are listed in the Authnet unsettled transactions screen and all say "general error".

 

Any ideas?

 

Yep. Getting that error as well. WTF?

Share this post


Link to post
Share on other sites
Yep. Getting that error as well. WTF?

 

Think I'm hosed as well. Been running for 2 years, no problems, just updated to the 24 Oct 2008 download, but no luck...

 

error_message=%20-%20Your+credit+card+could+not+be+authorized+for+this+reason.+Please+correct+any+i

nformation+and+try+again+or+contact+us+for+further+assistance.&osCsid=fobfu1akjno9i5p0bmlf3mfs40

Share this post


Link to post
Share on other sites
Think I'm hosed as well. Been running for 2 years, no problems, just updated to the 24 Oct 2008 download, but no luck...

 

error_message=%20-%20Your+credit+card+could+not+be+authorized+for+this+reason.+Please+correct+any+i

nformation+and+try+again+or+contact+us+for+further+assistance.&osCsid=fobfu1akjno9i5p0bmlf3mfs40

 

Which version were you using before you upgraded to this one? My client wants to switch from Paypal to Authorize.Net and I want to make sure we use a reliable contribution so we don't lose sales.

Thanks in advance.

Share this post


Link to post
Share on other sites

I've had exactly the same problem but have finally solved it. The main problem I found was that my authorize.net's Direct Response wasn't setup to match what is required by osCommerce (either the build in authorize.net module or the new one)

 

This posts explains what was needed:

http://forums.oscommerce.com/index.php?sho...t&p=1304632

 

 

I ended up using the build in module because you enter the credit card information on the confirmation page (resulting in fewer abandoned carts because someone just forgot to confirm), though I did take a few things from the new module.

 

-Tim

Share this post


Link to post
Share on other sites

 

Hey Tim.

 

I've read your post a few times over the past couple of days and went to the link you provided and followed what was to be done there to no avail. Still getting the error, even in test mode.

 

I got my provider to turn cURL on so that's no longer an issue. Still no go.

 

I'm going to talk to the gateway people tomorrow and see if everything is ok there or not. Testing SHOULD work, right?

 

What would be great for those of us that are frustrated is to have some sort of code or explanation by the module for the reason why the credit card could not be authorized.

Share this post


Link to post
Share on other sites

Hello,

 

I hope that someone can help. I installed AIM onto a oscommerce site and when I run a credit card through I receive an error that says:

 

There has been an error processing your credit card

 

Please try again and if problems persist, please try another payment method.

 

 

I have read through many forums and can not figure why it wont process. I switched over to SIM and it works fine.

 

I have confirmed that cUrl is compiled.

User Login and Transaction key is correct

SSL is installed

The gateways are correct

 

 

I have used the contribute that Vger made and receive the same error. Its like my site isnt talking with auth net. Any tips on what to check here? Thanks for the help!

Share this post


Link to post
Share on other sites
Hello,

 

I hope that someone can help. I installed AIM onto a oscommerce site and when I run a credit card through I receive an error that says:

 

There has been an error processing your credit card

 

Please try again and if problems persist, please try another payment method.

 

 

I have read through many forums and can not figure why it wont process. I switched over to SIM and it works fine.

 

I have confirmed that cUrl is compiled.

User Login and Transaction key is correct

SSL is installed

The gateways are correct

 

 

I have used the contribute that Vger made and receive the same error. Its like my site isnt talking with auth net. Any tips on what to check here? Thanks for the help!

Live or test mode?

Share this post


Link to post
Share on other sites

I received this notice from Authorize.net - does anyone know if the AIM module need to be updated or enhanced to SSL3.0?

 

Dear Authorize.Net Developer:

 

During the week of March 16 - 20, 2009, Authorize.Net will be deprecating all legacy support for the SSL 2.0 protocol. Changes have recently been made to the Payment Card Industry Data Security Standard (PCI DSS) which have made the use of SSL 2.0 a PCI DSS violation.

 

Due to this change, it is critical that you update any applications or integrations that may be using the SSL 2.0 protocol to support the more current SSL 3.0/TLS 1.0 protocols. Failure to upgrade your applications or integrations may result in a lost ability to successfully process transactions via the Authorize.Net Payment Gateway.

 

If you have merchants who are currently using SSL 2.0 to connect to the Authorize.Net Payment Gateway, you must contact them immediately and arrange to update their integrations to the SSL 3.0/TLS 1.0 protocols.

 

For more information on the limitations of SSL 2.0 and the advantages of SSL 3.0/TLS 1.0, we recommend reviewing the white paper Analysis of the SSL 3.0 Protocol.

 

If you have any questions, please contact developer@authorize.net.

Share this post


Link to post
Share on other sites

Does anyone know how to pass the manufacturer name and model number along to authorize with the product name?

 

Right now, the description of products that get passed along looks like this: productname1 + productname2

 

What I would like it something like: manufacturer1-productname1(model number) + manufacturer2-productname2(model number)

 

does anyone know how to change this or know what file and place I should be looking for?

Share this post


Link to post
Share on other sites

I am using the newest AIM module (authorizenet_cc_aim.php Feb 19, 2009) available in the contributions. Except for the one line cURL update for SSL 3.0, the AIM module is the same as the one that came with the 2.2 RC2a installation package.

 

The site/AIM module have been up and running for 5 weeks without any problems, or so it seemed. I had a customer contact me a couple of weeks ago to tell me that he had tried multiple credit cards and attempts and every time he confirmed the order he was redirected to the checkout_payment page with the default error message "There has been an error processing your credit card - Please try again and if problems persist, please try another payment method." I did an exhaustive search and did all the troubleshooting I could think of but could not find the reason why this was happening.

 

Last week I had another customer contact me with the same problem and when he told me the dollar amount of the order I realized that the problem was tied to large orders. To troubleshoot, I did an order for 200 of one product to get the dollar amount and quantity up on the order and it went through fine so I realized it was the number of line items on the order. The “magic” number is 30. Customers can only place orders for up to 30 different products (unlimited quantities) per order. Anytime there is over 30 line items on an order they are redirected to the payment page/default error message. It doesn’t really apply but, in the configuration settings, “Product Quantities” is set to 0 (unlimited).

 

Nothing is transmitted to Authorize.net so the error is part of the pre-check done by the cart. I have looked in the Admin configuration settings, the code, the database tables, and the support forums and still cannot find any reason why this is happening.

 

Does anyone know of any reason why orders with over 30 different items in them would not be able to be processed using the AIM module/Authorize.net?

 

Thanks in advance for any help on this.

Share this post


Link to post
Share on other sites

I'm at my wits end here. :(

 

I have the same error as many people: "- Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance."

 

Does ANYONE have any new ideas on how to fix this??? I have literally been through every single page of this thread and tried every single solution and none of them are working for me.

 

I have verified all of my server/osc/auth.net settings over and over and over and they are all correct based on the requirements for this module.

 

If anyone can provide any new solution, I would be grateful.

Share this post


Link to post
Share on other sites

WOW. Okay, I have been working on this ALL DAY LONG.

 

I have FINALLY fixed the problem.

 

Others might know this but I obviously did not. When you make sure cURL is working, it probably by default will not be working with SSL. Apparently, you have to specify that you want cURL complied with PHP - AND working with SSL.

 

Once I had that fixed, it all works perfectly. Now, don't ask me how to actually make the fix, I don't know. My husband has his own server and once I told him that I saw another post that mentioned making this change, he was like "oh, yah ok" and went and fixed it. So, just ask your hosting provider to make sure cURL is working with SSL.

 

I hope this helps someone else!

Edited by mom2twins

Share this post


Link to post
Share on other sites
This is a new support thread created for a new and updated version of the AuthorizeNet AIM (Advanced Integration Method) module, released under GPL.

 

The module is located here:

 

http://www.oscommerce.com/community/contributions,4091

 

Vger

 

 

hello,

I am using the newest AIM module (authorizenet_cc_aim.php Feb 19, 2009)

I am having a hard time with my payment module It is Authorized.net.

It looks like there is none communication between the website and Authorized.net.

I can see the orders on the oscommerce_admin, but there is not record on Authorized.net.

Here are my module's settings:

 

Enable Authorize.net AIM Module

True

 

Login Username

GOOD (is it my authorized.net login or the API Login?) I try both

 

Transaction Key

GOOD

 

Transaction Mode

Live

 

Authorization Type

Authorize/Capture

 

Customer Notifications

False

 

Merchant Notifications

True

 

Request CVV Number

True

 

Sort order of display.

0

 

Payment Zone

 

 

Set Order Status

default

 

CURL Proxy URL

/usr/bin/curl

 

In the Authorized.net

My settings are:

 

Default Relay Response URL:

https://www.mywebsite.com/checkout_process.php

 

Direct Response Delimiter:

yes,

Default Field Separator: Comma

Field Encapsulation Character: double quotes

 

Transaction Version

3.1

 

 

Thank you! for any help. I am pulling my hair out.


Andrea

Share this post


Link to post
Share on other sites

I've spent the last eight hours going through every post in this thread, hoping to get a new install of this contribution to work. Sadly, the post above mine describes the same issue I'm having. I've tried a variety of different settings on Auth.net and in osC, to no avail. I see no indication that osC is communicating in any way with Authorize.net. I'm live on both ends, but I see no unsettled transactions. I don't get any errors, live or in test, aside from bad credit card numbers or expiration dates. The orders process as expected, with all email notifications going out from osC. But the "confirm" process is almost instantaneous, leading me to believe that there is zero communication between my site and Auth.net. cURL is compiled in PHP, and should work w/ SSL, per my host. SSL works as expected on my domain. configure.php has the correct URL and domain info.

 

My store was supposed to go live this weekend. Now I'm in a holding pattern and have no idea where to go next.

 

Enable Authorize.net AIM Module: True

Login Username: Set to API login

Transaction Key: Changed several times

Transaction Mode: Live

Authorization Type: Authorize/Capture

Customer Notifications: False

Merchant Notifications: True

Request CVV Number: True

Sort order of display.: 0

Payment Zone: United States

Set Order Status: default

CURL Proxy URL: none

 

My current Authorize.net settings (a variety of settings have been used):

 

Transaction Version: 3.1

Response/Receipt URLs: none

Default Relay Response: none

Direct Response:

Delimited Response: no

Default Field Separator: comma

Field Encapsulation Character: none

Edited by rdbstl

Share this post


Link to post
Share on other sites

My message can be disregarded. In my case, I apparently forgot to save changes made to checkout_process.php. I could have saved myself a ton of time had I checked this out sooner, but at least it's working...

Share this post


Link to post
Share on other sites

Has anyone converted orders_trustcommerce.php to work with Auhorize.net?

 

It allows shop owners to run transactions (preauth / postauth / refund) directly from the orders.php page in osC administration.

tc-example.gif

 

Regards,

Eric_K

Share this post


Link to post
Share on other sites

Ok... i am not real smart with this stuff - that being said - I installed the AIM module... ran some test transactions with authorize.net in test mode and the cart in test mode - working fine. So took it out of test mode on both and put in the specified test cc numbers that are supposed to decline - the don't... Get order processed... if I put in the 4222222222222 or a bad expiry it declines.

 

Additionally - none of the orders are showing up in the authorize.net reports... I followed all the instructions, and am very confused about whether this thing is working properly or not - it looks like it is - but when i check for transactions at authorize.net there is nothing there...

 

Any help greatly appreciated.

Share this post


Link to post
Share on other sites

Where do we change the Payment Method text on the invoice? It says: Authorize.net AIM. We want it to say: Credit Card because Authorize.net AIM means nothing to the customer. This contribution keeps the customer on our site so they have no idea who the card processor even is. No sense risking confusing them...

 

I thought it was in catalog\includes\languages\english\authorizenet_aim.php but evidently not. I changed it there and it didn't appear to affect anything on the invoice...


Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites
Where do we change the Payment Method text on the invoice? It says: Authorize.net AIM. We want it to say: Credit Card because Authorize.net AIM means nothing to the customer. This contribution keeps the customer on our site so they have no idea who the card processor even is. No sense risking confusing them...

 

I thought it was in catalog\includes\languages\english\authorizenet_aim.php but evidently not. I changed it there and it didn't appear to affect anything on the invoice...

 

Nevermind. Didn't realize it was storing that Payment Method in the orders table. Changing this in catalog\includes\languages\english\authorizenet_aim.php DOES in fact change it on any new invoices created since the change. A quick update of the orders table took care of the first few stragglers...

 

The only downside... It changes it on the Admin panel under the Payments module listing. So we changed our description to Credit Card Online so as to differentiate, as well as report on it. (We'll use a report to go back to Paypal and make them aware of how much money they lost in processing fees as a result of their sneaky strong-arm tactics in trying to get us to upgrade to their Website Payments Pro for $30 per month. Yes, they recently tightened their acceptance rules for payments made through the basic/free gateway which was resulting in a LOT of decline transactions. Of course this problem is remedied if we "upgrade to the Pro version for only $30 per month." Then we can choose our own security settings and make them more relaxed. Nevermind that their default security settings for the basic/free gateway are ridiculously strict now. They're getting too big for their own good, if you ask me. Think they can do whatever they want because they already have us "hooked". Little do they know how easy it is to get an Authorize.net account and add this contribution...)

 

Yes, that was an official somewhat-off-topic rant...


Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

Hello,

 

I have been digging around this Contribution Forum and I just can't seem to find where anybody may have had the same problem I am having.

 

I have installed the Authorize.net AIM as described. I enable it for testing and when I put in all the info, I get a

 

Expiry Date Entered is not valid

 

Can anybody assist me?

 

Thanks,

 

Troy

Share this post


Link to post
Share on other sites
Hello,

 

I have been digging around this Contribution Forum and I just can't seem to find where anybody may have had the same problem I am having.

 

I have installed the Authorize.net AIM as described. I enable it for testing and when I put in all the info, I get a

 

Expiry Date Entered is not valid

 

Can anybody assist me?

 

Thanks,

 

Troy

 

Expiration date has to be passed as four digits at all times. So January 2012 would be 0112. If you're leaving off the zero, that's your problem...


Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

Wow, thanks for the quick response!

 

I have drop downs for the Month and Year. I hit continue and on the confirmation page it shows up as you say. I hit the confirm order and then I get the error, and I am back at the CC Info page.

 

Thanks again,

 

Troy

Share this post


Link to post
Share on other sites

Hello again,

 

The CC Date works fine for the stock CC payment module. But with the Auth AIM I get the Expiry error. Does that help?

 

Thanks,

 

Troy

Share this post


Link to post
Share on other sites
Hello again,

 

The CC Date works fine for the stock CC payment module. But with the Auth AIM I get the Expiry error. Does that help?

 

Thanks,

 

Troy

 

I'm not really an expert on this module, as we had it working within 30 minutes of install, so we didn't have any real problems to run down. I am anal enough that I read through this support thread first though. Two suggestions I would have is to make sure your delimiters are set correctly and/or you might want to add error tracking code. If I'm thinking of the right mod (have been researching/implementing several lately), there was a user who posted some code for this quite a few pages back.

Edited by kru

Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×