Jump to content
Sign in to follow this  
Vger

[CONTRIBUTION] Authorize Net AIM module

Recommended Posts

So I found two posts that deal with this issue, but it dates back to 2004 (the old AIM module)...

 

http://forums.oscommerce.com/index.php?sho...l=x_reason_code

http://forums.oscommerce.com/index.php?sho...l=x_reason_code

 

Can the author (Vger?) please provide an update to the changes needed to display the reason code?

 

Thanks in advance!

 

Don't know if this will help you, but I dumped out the contents of the response from Authorize.Net. In the file includes->modules->authorizenet_cc_aim.php there is this code:

 

if ($regs[0] == '1') {

 

if (tep_not_null(MODULE_PAYMENT_AUTHORIZENET_CC_AIM_MD5_HASH)) {

 

if (strtoupper($regs[37]) != strtoupper(md5(MODULE_PAYMENT_AUTHORIZENET_CC_AIM_MD5_HASH . MODULE_PAYMENT_AUTHORIZENET_CC_AIM_LOGIN_ID . $regs[6] . $this->format_raw($order->info['total'])))) {

 

$error = 'general';

 

}

 

}

 

} else {

 

switch ($regs[2]) {

 

case '7':

 

$error = 'invalid_expiration_date';

 

break;

 

 

 

case '8':

 

$error = 'expired';

 

break;

 

 

 

case '6':

 

case '17':

 

case '28':

 

$error = 'declined';

 

break;

 

 

 

case '78':

 

$error = 'cvc';

 

break;

 

 

 

default: if ($regs[0] == '1') {

 

if (tep_not_null(MODULE_PAYMENT_AUTHORIZENET_CC_AIM_MD5_HASH)) {

 

if (strtoupper($regs[37]) != strtoupper(md5(MODULE_PAYMENT_AUTHORIZENET_CC_AIM_MD5_HASH . MODULE_PAYMENT_AUTHORIZENET_CC_AIM_LOGIN_ID . $regs[6] . $this->format_raw($order->info['total'])))) {

 

$error = 'general';

 

}

 

}

 

} else {

 

switch ($regs[2]) {

 

case '7':

 

$error = 'invalid_expiration_date';

 

break;

 

 

 

case '8':

 

$error = 'expired';

 

break;

 

 

 

case '6':

 

case '17':

 

case '28':

 

$error = 'declined';

 

break;

 

 

 

case '78':

 

$error = 'cvc';

 

break;

 

 

 

default:

 

$error = 'general';

 

break;

 

}

 

}

 

$error = 'general';

 

break;

 

}

 

}

 

$regs[0] is not '1' and the value of $regs[2] is '33'. There is also a message in the returned array stating "Credit card number must be provided".

 

In the function before_process(), an array is built containing this information:

'x_card_num' => substr($HTTP_POST_VARS['cc_number_nh-dns'], 0, 22),

 

'x_exp_date' => $HTTP_POST_VARS['cc_expires_month'] . $HTTP_POST_VARS['cc_expires_year'],

 

'x_card_code' => substr($HTTP_POST_VARS['cc_cvc_nh-dns'], 0, 4));

 

and a post string is built based upon the data in this array.

 

Dumping out the array, I don't see any values related to the credit card (each of these three items are blank). Dumping out the data in $HTTP_POST_VARS shows these three array items to be blank.

 

I've looked in checkout_confirmation.php and checkout_process.php and cannot determine where these array items get set. Maybe someone with better troublehsooting/programmings skills can figure this out.

Share this post


Link to post
Share on other sites
This is a new support thread created for a new and updated version of the AuthorizeNet AIM (Advanced Integration Method) module, released under GPL.

 

The module is located here:

 

http://www.oscommerce.com/community/contributions,4091

 

Vger

 

Hi,

I installed the module and it looks fine, but when i test it and enter the test card information, it tried to process and then gets stuck at checkout_process.php and displays blank page.

What can be the problem?

 

thank you

Share this post


Link to post
Share on other sites
This is a new support thread created for a new and updated version of the AuthorizeNet AIM (Advanced Integration Method) module, released under GPL.

 

The module is located here:

 

http://www.oscommerce.com/community/contributions,4091

 

Vger

 

Hi, I have I think all of the Authorize modules and I can not get any of them to work. It seems that the website is not connecting to authourize.net properly when using (AIM), I get a cretit card error, or no notice at all.

 

I can get to the credit card page of Authorize.net using the (SIM) and then it returns to the payment page saying the credit card can not be processed after Authorize.net accepted the payment. Authorize.net authorizes and accepted the transaction and then sends out e-mails, but no order in admin or does osc send any e-mails.

 

I believe if I fix just one of these, I will then be able to use either of the Authorize.net modules. Please help me someone.

Share this post


Link to post
Share on other sites
Tried everything in this whole thread - I get this error

https://3cgraphics.com/store/checkout_payme...4cc302332e752e0

 

it doesn't appear that there is an error as nothing is there for why the auth fails. Also no failed transactions (no declined) in the auth.net admin panel/reports.

 

text in red bar - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance.

 

I can authorize a transaction on the virtual terminal so my account is good and card is good - SSL works - very discouraged that I can't even begin to figure this out even with all the help in the thread - ZERO progress in 4+ hours - help??

 

THANKS!!!

3 weeks = zero progress

Share this post


Link to post
Share on other sites
Just want to say that this is a great module. Installed and worked fine the very first time.

 

Keep up the good work!

 

Jeremy

 

Glad someone is happy

Share this post


Link to post
Share on other sites

Downloaded the module. It is missing the file catalog/includes/modules/payment/authorizenet_aim.php. Where is that? Also I have installed and made all the required changes, am in test mode and put credit card info in the checkout page. Once I click submit the page comes back with a "Please select a payment method for your order" at the top of my page. I have installed, uninstalled and reinstalled several times. Any help would be appreciated.

 

Thanks, amy

Share this post


Link to post
Share on other sites
Downloaded the module. It is missing the file catalog/includes/modules/payment/authorizenet_aim.php. Where is that?

 

Thanks, amy

Anyone have an answer for Amy...and me? The file description says it is a complete package and all of the other new files listed in the install guide are there.

 

Bob

Share this post


Link to post
Share on other sites
Just want to say that this is a great module. Installed and worked fine the very first time.

 

Keep up the good work!

 

Jeremy

 

Jeremy,

can you tell us which version of the module did you install?

 

Thank you

Share this post


Link to post
Share on other sites
Jeremy,

can you tell us which version of the module did you install?

 

Thank you

 

Jeremy - I went ahead and used one from an earlier version and it seemed to work fine. I can't believe that no one else noticed it was missing! Now the orders are going through but no items are showing on authorize.net. All emails are sent and everything else seems to work fine. Thanks. Amy

Share this post


Link to post
Share on other sites
I went ahead and used one from an earlier version and it seemed to work fine. I can't believe that no one else noticed it was missing! Now the orders are going through but no items are showing on authorize.net. All emails are sent and everything else seems to work fine. Thanks. Amy
Amy, which version is it that worked for you?

Share this post


Link to post
Share on other sites
ok here's the latest...

 

My client tested this with her visa and works great.

 

She also tested with amex and gets the same error as I do with my mastercard.

 

I just got a later version of the cc_validation.php file and changed it over and now mastercard is working.

 

Hi Melinda,

 

I have been following the board and your previous posting and it looks like I would need to update my cc_validation.php file as well. Can you please let me know where I can find a newer cc_validation.php file? I look under the contribution without success.

 

Kindest regards,

 

Dominique Leroux

Share this post


Link to post
Share on other sites
I sent a message to emailmaomao to update (missing file) contribution...

 

That file is still missing from the install package... It won't work without it...

 

 

Any ideas or feedback from the contributor would be greatly appreciated!

 

Thanks!

 

--Jeff

Share this post


Link to post
Share on other sites
That file is still missing from the install package... It won't work without it...

 

 

Any ideas or feedback from the contributor would be greatly appreciated!

 

Thanks!

 

--Jeff

 

waiting for file...

Share this post


Link to post
Share on other sites
waiting for file...

 

 

Can anybody send me the latest file thats missing in this package please? This is ridiculous

Share this post


Link to post
Share on other sites

Request for help from Vger needed!

 

I'm using Vger's authorizenet_aim.php contribution. Works flawlessly except I'm having 1 problem. When I have CVV entry required via my gateway, it will decline any Amex card because they use a 4-digit CVV. visa and mastercard go through no problem (3 digit CVV). Help! I've checked the php file and see the portions that define CVVs, and it looks like everything is fine. But whenever Amex customers try to check out, they get the generic 'your credit card could not be authorized' message.

 

:(

 

Any ideas?

 

 

if (MODULE_PAYMENT_AUTHORIZENET_AIM_USE_CVV == 'True') {

$js .= ' if (cc_cvv == "" || cc_cvv.length < "3" || cc_cvv.length > "4") {' . "\n".

' error_message = error_message + "' . MODULE_PAYMENT_AUTHORIZENET_AIM_TEXT_JS_CC_CVV . '";' . "\n" .

' error = 1;' . "\n" .

' }' . "\n" .

' }' . "\n";

Share this post


Link to post
Share on other sites

I just downloaded the newest version and was getting the error "The merchant login ID or password is invalid or the account is inactive." I looked at the main module code (/inc/mods/payment/authorizenet_aim.php) and at line 301, there's an if/else statement that determines whether you're in test or live mode and sets the URL. However, it looks like they're reversed - it says if test then url = secure, else url = test. I flipped them to what seems more intuitive, and it now works perfectly.

Share this post


Link to post
Share on other sites

From Authorize.net help

Question/Topic: AMEX Card Code Processing

Answer/Article

American Express Merchants are not set up with the ability to process Card Codes (what American Express calls a Card Identification Number or CID) by default. The following information is from American Express's Mail Order/Phone Order/Internet Procedures brochure.

 

Your merchant account must be certified to verify the CID number. To inquire more about the program, send an e-mail to es.fraud.prevention@aexp.com.

 

Original Source:

https://www209.americanexpress.com/merchant...roch_032305.pdf

https://www209.americanexpress.com/merchant...entionBrochures

 

The following is a list of possible CVV2/CID response codes and their corresponding meanings. Each code is unique; no code will ever overlap in meaning:

M - Match, the CVV2 code entered matched that of the credit card.

N - No Match indicates the code entered is incorrect.

P - Not processed means that the code was not validated.

S - Should be on card but not so indicated means that the customer left that field blank.

U - Issuer not certified means that the card issuing bank does not participate in the CVV2 program or hasn't provided the key so that the code can be validated.

 

If your account is not supported by Amex to use the CVV/CID program you will need to uncheck options "P" and "U" for Amex transactions to process correctly.

This will be done in the Card Code Settings of the Merchant interface:

 

1. Login into https://account.authorize.net

2. Click on Account.

3. Select the 'Card Code Verification' link.

4. Uncheck options ‘‘P’ and 'U' from this page, then click submit.

 

If you are not sure if your Amex merchant account is set up to support CID processing you will need to contact American Express at es.fraud.prevention@aexp.com to see if this was established on your Merchant account.

 

 

Hope this helps

 

- George

 

Request for help from Vger needed!

 

I'm using Vger's authorizenet_aim.php contribution. Works flawlessly except I'm having 1 problem. When I have CVV entry required via my gateway, it will decline any Amex card because they use a 4-digit CVV. visa and mastercard go through no problem (3 digit CVV). Help! I've checked the php file and see the portions that define CVVs, and it looks like everything is fine. But whenever Amex customers try to check out, they get the generic 'your credit card could not be authorized' message.

 

:(

 

Any ideas?

 

 

if (MODULE_PAYMENT_AUTHORIZENET_AIM_USE_CVV == 'True') {

$js .= ' if (cc_cvv == "" || cc_cvv.length < "3" || cc_cvv.length > "4") {' . "\n".

' error_message = error_message + "' . MODULE_PAYMENT_AUTHORIZENET_AIM_TEXT_JS_CC_CVV . '";' . "\n" .

' error = 1;' . "\n" .

' }' . "\n" .

' }' . "\n";

Share this post


Link to post
Share on other sites
From Authorize.net help

Question/Topic: AMEX Card Code Processing

Answer/Article

American Express Merchants are not set up with the ability to process Card Codes (what American Express calls a Card Identification Number or CID) by default. The following information is from American Express's Mail Order/Phone Order/Internet Procedures brochure.

 

Your merchant account must be certified to verify the CID number. To inquire more about the program, send an e-mail to es.fraud.prevention@aexp.com.

 

Original Source:

https://www209.americanexpress.com/merchant...roch_032305.pdf

https://www209.americanexpress.com/merchant...entionBrochures

 

The following is a list of possible CVV2/CID response codes and their corresponding meanings. Each code is unique; no code will ever overlap in meaning:

M - Match, the CVV2 code entered matched that of the credit card.

N - No Match indicates the code entered is incorrect.

P - Not processed means that the code was not validated.

S - Should be on card but not so indicated means that the customer left that field blank.

U - Issuer not certified means that the card issuing bank does not participate in the CVV2 program or hasn't provided the key so that the code can be validated.

 

If your account is not supported by Amex to use the CVV/CID program you will need to uncheck options "P" and "U" for Amex transactions to process correctly.

This will be done in the Card Code Settings of the Merchant interface:

 

1. Login into https://account.authorize.net

2. Click on Account.

3. Select the 'Card Code Verification' link.

4. Uncheck options ‘‘P’ and 'U' from this page, then click submit.

 

If you are not sure if your Amex merchant account is set up to support CID processing you will need to contact American Express at es.fraud.prevention@aexp.com to see if this was established on your Merchant account.

 

 

Hope this helps

 

- George

 

 

Wow - thank you for this! This is probably exactly what the problem is, I had no idea. I'm going to contact Amex and see if this can get resolved. Again, thank you for your help. :lol:

Share this post


Link to post
Share on other sites
Wow - thank you for this! This is probably exactly what the problem is, I had no idea. I'm going to contact Amex and see if this can get resolved. Again, thank you for your help. :lol:

 

I sent an email and got a generic reply back. Now i gotta call them I guess!

 

 

For questions about fraud prevention solutions or training materials, please

visit our website at www.americanexpress.com/fraudinfo.

 

You can also contact your American Express account manager or call Merchant

Services at 800-528-5200. Thank you.

 

 

American Express made the following annotations on Wed Jun 18 2008 12:13:28

------------------------------------------------------------------------------

"This message and any attachments are solely for the intended recipient and may contain confidential or privileged information. If you are not the intended recipient, any disclosure, copying, use, or distribution of the information included in this message and any attachments is prohibited. If you have received this communication in error, please notify us by reply e-mail and immediately and permanently delete this message and any attachments. Thank you."

 

American Express a ajouté le commentaire suivant le Wed Jun 18 2008 12:13:28

 

Ce courrier et toute pièce jointe qu'il contient sont réservés au seul destinataire indiqué et peuvent renfermer des renseignements confidentiels et privilégiés. Si vous n'êtes pas le destinataire prévu, toute divulgation, duplication, utilisation ou distribution du courrier ou de toute pièce jointe est interdite. Si vous avez reçu cette communication par erreur, veuillez nous en aviser par courrier et détruire immédiatement le courrier et les pièces jointes. Merci.

******************************************************************************

-------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

First, thanks Vger for the contribution.

 

 

Transactions are working and we are making sales with this module. My only problem was that in test it was returning the cc's last 4 + auth code. Now that I've moved it into production I only get the cc expiry date. The transactions are being logged properly except for that. Also the email we get from authorize.net has the auth codes and whatnot, so we are using this in production.

 

 

What could have gone wrong?

 

My thoughts:

 

There seems to be nothing in the response for the authorize_aim.php module. I think this is something with checkout_process.php as that looks like the file that should be receiving and logging this information.

 

-mevdev

Share this post


Link to post
Share on other sites

After installing this contribution I can't seem to get it to display. It shows up in payment modules in Admin and I can configure the settings, but it will not display on checkout_payment.php. The original authorizenet module shows up and works but this AIM module does not even show up.

 

I have tried enabling other payment modules and they all show up just fine.

 

Any idea what the problem might be?

Share this post


Link to post
Share on other sites
After installing this contribution I can't seem to get it to display. It shows up in payment modules in Admin and I can configure the settings, but it will not display on checkout_payment.php. The original authorizenet module shows up and works but this AIM module does not even show up.

 

I have tried enabling other payment modules and they all show up just fine.

 

Any idea what the problem might be?

 

 

I got it working by adding authorizenet_aim.php; to the MODULE_PAYMENT_INSTALLED configuration table. Every time I make a change with any of the payment modules the settings disappears. Any idea how I can stop authorizenet_aim.php; from being deleted from the MODULE_PAYMENT_INSTALLED configuration table?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×