Jump to content
Sign in to follow this  
iainsanderson

easy populate help needed

Recommended Posts

Hi All,

 

I am new to osc and to easy populate. I need to use ep because I have alot of products and entering them by hand will take years.

 

I have downloaded ep and it is on my live server.

 

This may take sometime as I have a few problems, the first being how to build an import file ? I just need an example of one so that I can then add my products.

 

when I try to download a text file, Download .txt file with TAB delimited to edit ( Model / Price / Quantity )

 

I get this message.

 

1146 - Table 'ebdbase.TABLE_PRODUCTS_GROUPS' doesn't exist

 

SELECT customers_group_price, customers_group_id FROM TABLE_PRODUCTS_GROUPS WHERE products_id = 212 ORDER BY customers_group_id

 

[TEP STOP]

 

I am not sure what is happening, please help

 

Thanks for all help in advance.

 

 

Iain

Edited by iainsanderson

Share this post


Link to post
Share on other sites

It means either that table is missing from your database or you don't have TABLE_PRODUCTS_GROUPS defined in the includes/database.php file. Since that is a standard table in oscommerce, I'm guessing the define was deleted in the file. You should compare your file with the one from the oscommerce package.

 

Jack

Share this post


Link to post
Share on other sites
It means either that table is missing from your database or you don't have TABLE_PRODUCTS_GROUPS defined in the includes/database.php file. Since that is a standard table in oscommerce, I'm guessing the define was deleted in the file. You should compare your file with the one from the oscommerce package.

 

Jack

 

 

Ok, thank you for your help, I have now defined the table in databases.php and also built the table in phpmyadmin.

 

 

I can now download ok, when Itry to upload the same file I am getting the following:

 

Warning: move_uploaded_file(/home/iainsand/public_html/catalog/EP_TEMP_DIR/1010.xls): failed to open stream: No such file or directory in /home/iainsand/public_html/catalog/admin/includes/functions/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/php5pMc8G' to '/home/iainsand/public_html/catalog/EP_TEMP_DIR/1010.xls' in /home/iainsand/public_html/catalog/admin/includes/functions/easypopulate_functions.php on line 32

 

 

File uploaded.

Temporary filename: /tmp/php5pMc8G

User filename: 1010.xls

SIZE_EP466

 

Warning: file(/home/iainsand/public_html/catalog/EP_TEMP_DIR1010.xls): failed to open stream: No such file or directory in /home/iainsand/public_html/catalog/admin/easypopulate.php on line 620

 

Warning: Invalid argument supplied for foreach() in /home/iainsand/public_html/catalog/admin/easypopulate.php on line 642

 

Cheers

 

Iain

Share this post


Link to post
Share on other sites
Ok, thank you for your help, I have now defined the table in databases.php and also built the table in phpmyadmin.

I can now download ok, when Itry to upload the same file I am getting the following:

 

Warning: move_uploaded_file(/home/iainsand/public_html/catalog/EP_TEMP_DIR/1010.xls): failed to open stream: No such file or directory in /home/iainsand/public_html/catalog/admin/includes/functions/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/php5pMc8G' to '/home/iainsand/public_html/catalog/EP_TEMP_DIR/1010.xls' in /home/iainsand/public_html/catalog/admin/includes/functions/easypopulate_functions.php on line 32

File uploaded.

Temporary filename: /tmp/php5pMc8G

User filename: 1010.xls

SIZE_EP466

 

Warning: file(/home/iainsand/public_html/catalog/EP_TEMP_DIR1010.xls): failed to open stream: No such file or directory in /home/iainsand/public_html/catalog/admin/easypopulate.php on line 620

 

Warning: Invalid argument supplied for foreach() in /home/iainsand/public_html/catalog/admin/easypopulate.php on line 642

 

Cheers

 

Iain

 

Double-check your permissions on the /tmp directory and verify that all users have full access (chmod 777).

Share this post


Link to post
Share on other sites
Double-check your permissions on the /tmp directory and verify that all users have full access (chmod 777).

 

 

I have checked and I hadn't set them. I have now set them, but I am still getting the same problem

Share this post


Link to post
Share on other sites
I have checked and I hadn't set them. I have now set them, but I am still getting the same problem

 

 

I am not sure and being a newbie to osc, I am a bit hesitant in saying this. I am using 2.78-MS2 and I have been having alot of trouble uploading files, as you can see from the above threads.

 

Everywhere I have looked it says maek sure the $tempdir setting are correct. Well I say.....I have looked everywhere for this line of code in my easypopulate.php file and it is no where to be seen, I am I missing something or what ?

 

I read a document written by one of the forum users Daddyslipdisk and he said that the line of code should be just below the version information, well to my amazement its not....

 

Please please please, can someone set me straight on this. Other than the above its a great mod.

Share this post


Link to post
Share on other sites

When you see capital letters in a failure, it means that item is not defined. I'm not sure where EP_TEMP_DIR is coming from. It is not in my EP archive but maybe you are using a later version. In any case, you have to define that. Search the EP suport thread. If it is due to your version, there is probably a fix for it there.

 

Jack

Share this post


Link to post
Share on other sites
When you see capital letters in a failure, it means that item is not defined. I'm not sure where EP_TEMP_DIR is coming from. It is not in my EP archive but maybe you are using a later version. In any case, you have to define that. Search the EP suport thread. If it is due to your version, there is probably a fix for it there.

 

Jack

 

 

Hi Jack,

 

Thanks for helping, I was using version 2.79, which did not work for me, I then downgraded to 2.62 which now works fine dfor what I want it. The EP TEMP DIR was the problem, you are correct, I don't think as you say it was defined anywhere.

 

Anyway many thanks for your help.

 

Iain

Share this post


Link to post
Share on other sites
It means either that table is missing from your database or you don't have TABLE_PRODUCTS_GROUPS defined in the includes/database.php file. Since that is a standard table in oscommerce, I'm guessing the define was deleted in the file. You should compare your file with the one from the oscommerce package.

 

Jack

Hi,

 

i have the same problem

 

so i need to create table PRODUCTS_GOUPS and i need to change the includes/database.php

 

my questions:

 

1. how do i create that table?

- simply run a query CREATE_TABLE products_groups ??

2. which file do you mean?

- do you mean ..../admin/includes/database_tables.php or .... /includes/database_tables.php ?

 

tia Joep

 

Ps. you write: 'Since that is a standard table in oscommerce'

i'm using osCommerce 2.2 Milestone 2 Update 051113 ??

Share this post


Link to post
Share on other sites

Yu shouldn't have to create it since it is standard. It must have been deleted. You need to check your backups to see what is missing.

 

Jack

Share this post


Link to post
Share on other sites

No, I'm mistaken. I did a quick check before of a few files that were handy and it is in those so I jumped to the wrong conclusion. I just checked the basic sql file and it is not in there. So that is added by some contribution. You will need to find which one and go from there.

 

Jack

Share this post


Link to post
Share on other sites

Ok, thanks for your help.

 

I do not really need that table to get EP running, it's just that i now have a error link in my admin, i do not like that ;)

 

Joep

Share this post


Link to post
Share on other sites

There is something in the code that needs it though. You should find out what that is so it can be fixed to avoid problems later on. Just search the files for products_groups.

 

Jacl

Share this post


Link to post
Share on other sites

That table is needed for the 'separate price per customer-module' in the easypopulate.php.

There is no simple 'comment out section'. (to me that is)

 

I do not mind installing that module, allthough i do not need it, but the thing is, it's manual is over 70 pages with modifications, a bit lengthy.

 

I also found out that there are froogle problems, therefore i need to go back to a backup and try an early version of EP.

 

thanks for your time, Joep

Share this post


Link to post
Share on other sites
When you see capital letters in a failure, it means that item is not defined. I'm not sure where EP_TEMP_DIR is coming from. It is not in my EP archive but maybe you are using a later version. In any case, you have to define that. Search the EP suport thread. If it is due to your version, there is probably a fix for it there.

 

Jack

 

Jack, I have the same problem as iainsanderson. He seems to have solved it by downloading an older version. I would like to avoid that. Since I am not very experienced with databases, I'm a bit confused with the "not defined" piece. I've opened the database_table.php file and see all the table names defined - do I just need to add "EP_TEMP_DIR" into that list?

 

Also - when I downloaded the copy of the database within the EasyPopulate admin interface, I open it to find the same results as fenyullow. I get this: v_products_modelEP_DELIMITERv_products_imageEP_DELIMITERv_products_name_1EP_DELI

MITERv_products_description_1EP_DELIMITERv_products_url_1EP_DELIMITERv_products_

priceEP_DELIMITERv_products_weightEP_DELIMITERv_date_availEP_DELIMITERv_date_add

edEP_DELIMITERv_products_quantityEP_DELIMITERv_manufacturers_nameEP_DELIMITERv_t

ax_class_titleEP_DELIMITERv_statusEP_DELIMITEEP_DELIMITEREOREOR

 

followed by the rest of the data...

 

What I did was remove all the capital lettered columns and then added my data into the correct column. Tried to upload it and got the same error as iainsanderson:

 

Warning: move_uploaded_file(/web/sites/impulse/buttonbling.com/catalog/EP_TEMP_DIR/template3.csv): failed to open stream: No such file or directory in /web/sites/impulse/buttonbling.com/catalog/admin/includes/functions/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpGfOggN' to '/web/sites/impulse/buttonbling.com/catalog/EP_TEMP_DIR/template3.csv' in /web/sites/impulse/buttonbling.com/catalog/admin/includes/functions/easypopulate_functions.php on line 32

 

FILE_UPLOAD_EP

TEMPORARY_FILENAME_EP/tmp/phpGfOggN

USER_FILENAME_EPtemplate3.csv

SIZE_EP19956

 

Warning: file(/web/sites/impulse/buttonbling.com/catalog/EP_TEMP_DIRtemplate3.csv): failed to open stream: No such file or directory in /web/sites/impulse/buttonbling.com/catalog/admin/easypopulate.php on line 620

 

Warning: Invalid argument supplied for foreach() in /web/sites/impulse/buttonbling.com/catalog/admin/easypopulate.php on line 642

 

Can you point me in the right direction please?

Thank you!

Share this post


Link to post
Share on other sites
Jack, I have the same problem as iainsanderson. He seems to have solved it by downloading an older version. I would like to avoid that. Since I am not very experienced with databases, I'm a bit confused with the "not defined" piece. I've opened the database_table.php file and see all the table names defined - do I just need to add "EP_TEMP_DIR" into that list?

 

Also - when I downloaded the copy of the database within the EasyPopulate admin interface, I open it to find the same results as fenyullow. I get this: v_products_modelEP_DELIMITERv_products_imageEP_DELIMITERv_products_name_1EP_DELI

MITERv_products_description_1EP_DELIMITERv_products_url_1EP_DELIMITERv_products_

priceEP_DELIMITERv_products_weightEP_DELIMITERv_date_availEP_DELIMITERv_date_add

edEP_DELIMITERv_products_quantityEP_DELIMITERv_manufacturers_nameEP_DELIMITERv_t

ax_class_titleEP_DELIMITERv_statusEP_DELIMITEEP_DELIMITEREOREOR

 

followed by the rest of the data...

 

What I did was remove all the capital lettered columns and then added my data into the correct column. Tried to upload it and got the same error as iainsanderson:

 

Warning: move_uploaded_file(/web/sites/impulse/buttonbling.com/catalog/EP_TEMP_DIR/template3.csv): failed to open stream: No such file or directory in /web/sites/impulse/buttonbling.com/catalog/admin/includes/functions/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpGfOggN' to '/web/sites/impulse/buttonbling.com/catalog/EP_TEMP_DIR/template3.csv' in /web/sites/impulse/buttonbling.com/catalog/admin/includes/functions/easypopulate_functions.php on line 32

 

FILE_UPLOAD_EP

TEMPORARY_FILENAME_EP/tmp/phpGfOggN

USER_FILENAME_EPtemplate3.csv

SIZE_EP19956

 

Warning: file(/web/sites/impulse/buttonbling.com/catalog/EP_TEMP_DIRtemplate3.csv): failed to open stream: No such file or directory in /web/sites/impulse/buttonbling.com/catalog/admin/easypopulate.php on line 620

 

Warning: Invalid argument supplied for foreach() in /web/sites/impulse/buttonbling.com/catalog/admin/easypopulate.php on line 642

 

Can you point me in the right direction please?

Thank you!

 

Read 1readmefirst document in the download package instead of "so called" manual, it has more steps.

Share this post


Link to post
Share on other sites
Read 1readmefirst document in the download package instead of "so called" manual, it has more steps.

 

 

I really hate to say this but I've given up. I am going to use my existing database and php pages with another shopping cart solution. Maybe I will try osCommerce again for another client - but I just got too frustrated with this import tool and I wasn't about to re-enter my products. I probably just don't understand the technology well enough, which will hopefully improve with time.

 

Thank you for the help you guys provided.

Shelly

Share this post


Link to post
Share on other sites
Care to elaborate? :huh:

find in easypopulate.php:

if (isset($filelayout['v_customer_price_1'])){
					$sql2 = "SELECT
									customers_group_price,
									customers_group_id
							FROM
									".TABLE_PRODUCTS_GROUPS."
							WHERE
							products_id = " . $row['v_products_id'] . "
							ORDER BY
							customers_group_id"
						   ;
					$result2 = tep_db_query($sql2);
					$ll = 1;
					$row2 =  tep_db_fetch_array($result2);
					while( $row2 ){
							$row['v_customer_group_id_' . $ll]		 = $row2['customers_group_id'];
							$row['v_customer_price_' . $ll]		 = $row2['customers_group_price'];
							$row2 = tep_db_fetch_array($result2);
							$ll++;
					}
			}
			if ($dltype == 'froogle'){
					// For froogle, we check the specials prices for any applicable specials, and use that price
					// by grabbing the specials id descending, we always get the most recently added special price
					// I'm checking status because I think you can turn off specials
					$sql2 = "SELECT
									specials_new_products_price
							FROM
									".TABLE_SPECIALS."
							WHERE
							products_id = " . $row['v_products_id'] . " and
							status = 1 and
							expires_date < CURRENT_TIMESTAMP
							ORDER BY
									specials_id DESC"
						   ;
					$result2 = tep_db_query($sql2);
					$ll = 1;
					$row2 =  tep_db_fetch_array($result2);
					if( $row2 ){
							// reset the products price to our special price if there is one for this product
							$row['v_products_price']		 = $row2['specials_new_products_price'];
					} 
			}

 

put these lines between /* */.

 

it works for me

Share this post


Link to post
Share on other sites
so i did

 

any luck?

 

It didn't work for me, qouting out that section that is ... my problem is similar though not quite the same as the poster above, ie the database of products file is uploadable, and goes up without a hitch, but none of the products are there. It's rather odd! :)

 

This is the actual error I get

 

File uploaded.

Temporary filename: /tmp/phpNxeu89

User filename: Full-EP2006Apr04-1907.txt

SIZE_EP211947

Share this post


Link to post
Share on other sites
It didn't work for me, qouting out that section that is ... my problem is similar though not quite the same as the poster above, ie the database of products file is uploadable, and goes up without a hitch, but none of the products are there. It's rather odd! :)

 

This is the actual error I get

 

File uploaded.

Temporary filename: /tmp/phpNxeu89

User filename: Full-EP2006Apr04-1907.txt

SIZE_EP211947

 

 

Umm - What size is the file?

 

EP has problems with files >500k or 300 records. You probably want to split them up before uploading.

 

Just a thought from a newbie.

 

BTW - Check out this thread for other problems :

 

http://forums.oscommerce.com/index.php?sho...=162244&st=3680

Edited by akheir

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×