Jump to content
Nimmit

AJAX Attribute Manager support

Recommended Posts

27 minutes ago, cinolas said:

@raiwa Thanks! I searched and searched but had not found anything about that incompatibility. I will look into the new version.

The first report was here:

see also the following posts.


The update with the setting mentioned was here:

 

Share this post


Link to post
Share on other sites

First many thanks @raiwa for the great addon modul and the support!

I have a general Question:
Lets say we have 2 attributes (A1 & A2) with 3 different values (AxO1 ... AxO3) for each attribute(Ax). In this case the product will have 6 different prices (A1O1_A2O1 ... A1O3_A2O3).
Shouldn't it be 9 different prices(not 2*3 but 3**2)?

Maybe a practical example: Lets say we sell screws in different size(M4 to M10) and material (steel and aluminum). Now the pricedifference between M4 and M6 is not equal for the 2 different materials.

I hope that I could express my problem clearly.

Is there any addon which implements such a price/attribut/model?

I would like to code this, but dont like to reinvent the wheel ;)

Share this post


Link to post
Share on other sites

Hello @philpla,

As far as I know this is not available yet. But I can be wrong.

Anyway this is not related to AJAX Attributes Manager. I would suggest you to post in the general support forum to see if someone else knows something about.

Edited by raiwa

Share this post


Link to post
Share on other sites
vor 1 Minute schrieb raiwa:

Hello @philpla,

As far as I know this is not available yet. But I can be wrong.

Anyway this is not related to AJAX Attributes Manager. I would suggest you to post in the general support forum to see if someone else knows something about.

Hello @raiwa

thanks for your very fast reply. I will forward my question. I asked at this "place" cause I was most likely to suspect a clue here due to the thematic proximity.

Maybe some will show up with an idea.

Anyway thanks again for maintaining this addon!

Share this post


Link to post
Share on other sites

Hi;

I just installed this beautiful addon on Phoenix Can you please help me edit this small piece of code for the option addon More Product weight..

 

The product Info.php has changed a lot in Phoenix so I am not able to change the code below-

Code in Phoenix latest version 1.0.5.0 is-

 $product_info_query = tep_db_query("select p.*, pd.* from products p, products_description pd where p.products_status = '1' and p.products_id = '" . (int)$_GET['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");

Code that needs to be adding the weight part is-

 $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.products_weight, p.manufacturers_id, p.products_gtin, p.ship_status from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$_GET['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");

Please can you help me do it...

Thank you in advance..

It will be deeply appreciated..

Regds./

radhavallabh

 

Share this post


Link to post
Share on other sites
40 minutes ago, radhavallabh said:

The product Info.php has changed a lot in Phoenix so I am not able to change the code below-

You don't have to.  That query will already return everything in the products table, including products_weight.  Just ignore the instruction to modify that query and proceed. 


Always back up before making changes.

Share this post


Link to post
Share on other sites
3 minutes ago, ecartz said:

You don't have to.  That query will already return everything in the products table, including products_weight.  Just ignore the instruction to modify that query and proceed. 

Thank you so much!!!

Share this post


Link to post
Share on other sites

Hi I just upgraded to 1.0.5.1 Phoenix..

I get below errors

Undefined offset: 27 in C:\xampp\htdocs\xxx\admin\attributeManager\classes\attributeManager.class.php on line 234

Undefined offset: 495 in C:\xampp\htdocs\xxx\admin\attributeManager\classes\attributeManager.class.php on line 237

Help will be deeply appreciated

Thank you in advance;

Regds./

radhavallabh

Share this post


Link to post
Share on other sites

Hi;

I am running 1.0.5.6 version Phoenix

I am facing a issue after installing this the Remove product on shopping cart has stopped working; It simply refreshes without removing the product dear. Whereas update product works fine.

Products without the attribute also delete and update easily.

I use it with the MPW function feature. Can you help me fix it please.

Regds./

radhavallabh

Share this post


Link to post
Share on other sites
52 minutes ago, radhavallabh said:

Hi;

I am running 1.0.5.6 version Phoenix

I am facing a issue after installing this the Remove product on shopping cart has stopped working; It simply refreshes without removing the product dear. Whereas update product works fine.

Products without the attribute also delete and update easily.

I use it with the MPW function feature. Can you help me fix it please.

Regds./

radhavallabh

This is unrelated to AJAX Attribute manager. Please post in the apropriate thread.

Share this post


Link to post
Share on other sites

Hello Rainer,

Just upgraded PHOENIX to 1.0.6.O and the Ajax Attribute Manager tab disappeared when going to editing the product. I am wondering if it is related to the other tabs having a font awesome icon next to each of them. I am not sure how that could be added to AAM to see if that would make it show. Any idea?

Share this post


Link to post
Share on other sites
4 minutes ago, raiwa said:

When I'll have a look to update it. It's on the list.

Thank you Rainer, hard to live without it!

Share this post


Link to post
Share on other sites

Uploade new version:

AJAX Attribute Manager Phoenix 3.2.0

Changes Version 3.2.0.:

+ updated for Phoenix 1.0.5.9+ (jquery update and bootstrapped admin/categories.php)

Tested with Phoenix 1.0.7.3

NOTE: Ajax Attributes Manager Table has not been updated yet to bootstrap table, but it is full functional.

Full Package
Update instructions included

Share this post


Link to post
Share on other sites
On 6/19/2020 at 1:25 PM, raiwa said:

Uploade new version:

AJAX Attribute Manager Phoenix 3.2.0

Changes Version 3.2.0.:

+ updated for Phoenix 1.0.5.9+ (jquery update and bootstrapped admin/categories.php)

Tested with Phoenix 1.0.7.3

NOTE: Ajax Attributes Manager Table has not been updated yet to bootstrap table, but it is full functional.

Full Package
Update instructions included

Hello Rainer,

Just installed it on PHOENIX 1.0.7.3 but when clicking the attributes manager tab nothing happens. Rechecked that all the hooks were added and all the attribute manager files.

Share this post


Link to post
Share on other sites

Just checked in a different Phoenix 1.0.7.3 teststore and it works for me.

Is your store a vanilla installation or is it updated from previous versions and/or has other apps/addons installed?

Please try on a new clean unmodified Phoenix 1.0.7.3 store.

Share this post


Link to post
Share on other sites
3 hours ago, raiwa said:

Just checked in a different Phoenix 1.0.7.3 teststore and it works for me.

Is your store a vanilla installation or is it updated from previous versions and/or has other apps/addons installed?

Please try on a new clean unmodified Phoenix 1.0.7.3 store.

Hi Rainer, did set up a new test site (vanilla) and it does work there.

My 2 other sites are live sites both with Header Tags SEO, Ultimate SEO URLs, Images as attributes (did set that to true in Attribute Manager), Order Editor, Burt's support code hooks, 2 languages so I can not figure out what could make the tab not work. Guess I will have to gradually add everything into the test site to see what could block… long night ahead.

Share this post


Link to post
Share on other sites

 

On 6/19/2020 at 4:25 AM, raiwa said:

NOTE: Ajax Attributes Manager Table has not been updated yet to bootstrap table, but it is full functional.

 

I found that the attribute manager content was displaying on all tabs, although the table itself was fine.

To perform a quick fix for functionality, I had to edit /attributeManager/includes/attributeManagerPlaceHolder.inc.php

and change

echo '<div id="section_attribute_manager" style="padding: 10px;">';

to

echo '<div class="tab-pane fade" id="section_attribute_manager" role="tabpanel">';

Dave

Share this post


Link to post
Share on other sites
48 minutes ago, grumplestiltskin said:

 

I found that the attribute manager content was displaying on all tabs, although the table itself was fine.

To perform a quick fix for functionality, I had to edit /attributeManager/includes/attributeManagerPlaceHolder.inc.php

and change


echo '<div id="section_attribute_manager" style="padding: 10px;">';

to


echo '<div class="tab-pane fade" id="section_attribute_manager" role="tabpanel">';

Dave

THis is how the included file already looks like in AJAX-AttributeManager-V3.2.0.._CE_Phoenix.

You probably missed to upload and replace the file or you are using an older version.

Share this post


Link to post
Share on other sites
On 6/21/2020 at 11:24 PM, raiwa said:

THis is how the included file already looks like in AJAX-AttributeManager-V3.2.0.._CE_Phoenix.

You probably missed to upload and replace the file or you are using an older version.

O good! I was on the right track. You are right though - most likely missed it completely after diff'ing against all my silly mods :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×