Jump to content
Latest News: (loading..)
Nimmit

AJAX Attribute Manager support

Recommended Posts

Hi there,

 

I've just installed AttributeManager-V2.8.9 and it's got some sort of error.

 

When I go onto the editing page for a product, the manager shows up almost fine, as in the screen shot but it has a message underneith it.

 

The following is the message/error it's showing:

 

1054 - Unknown column 'products_options.products_options_track_stock' in 'where clause'

 

select products_name, products_options_name as _option, products_attributes.options_id as _option_id, products_options_values_name as _value, products_attributes.options_values_id as _value_id from products_description, products_attributes, products_options, products_options_values where products_attributes.products_id = products_description.products_id and products_attributes.products_id = '128' and products_attributes.options_id = products_options.products_options_id and products_attributes.options_values_id = products_options_values.products_options_values_id and products_description.language_id = 1 and products_options_values.language_id = 1 and products_options.products_options_track_stock = 1 and products_options.language_id = 1 order by products_attributes.options_id, products_attributes.options_values_id

 

[TEP STOP]

 

It seems to also prevent me from adding any attributes/options to the product using the AttributeManager.

 

Does anyone know what I need to do to fix this problem?

 

Any help would be extremely appreciated!

Edited by absolutebeginner

Share this post


Link to post
Share on other sites

Hi there,

 

I've just installed AttributeManager-V2.8.9 and it's got some sort of error.

 

When I go onto the editing page for a product, the manager shows up almost fine, as in the screen shot but it has a message underneith it.

 

The following is the message/error it's showing:

 

1054 - Unknown column 'products_options.products_options_track_stock' in 'where clause'

 

select products_name, products_options_name as _option, products_attributes.options_id as _option_id, products_options_values_name as _value, products_attributes.options_values_id as _value_id from products_description, products_attributes, products_options, products_options_values where products_attributes.products_id = products_description.products_id and products_attributes.products_id = '128' and products_attributes.options_id = products_options.products_options_id and products_attributes.options_values_id = products_options_values.products_options_values_id and products_description.language_id = 1 and products_options_values.language_id = 1 and products_options.products_options_track_stock = 1 and products_options.language_id = 1 order by products_attributes.options_id, products_attributes.options_values_id

 

[TEP STOP]

 

It seems to also prevent me from adding any attributes/options to the product using the AttributeManager.

 

Does anyone know what I need to do to fix this problem?

 

Any help would be extremely appreciated!

 

Do you have QTPro installed? I think this is a field from that contrib.

Share this post


Link to post
Share on other sites

If you don't have QT Pro (you definitely don't), simply do instructions in that post.

 

Jenica,

 

you don't need to install QT Pro. In the latest version this plugin is tutned on by default. So, simple disable it by do following:

 

find catalog\admin\attributeManager\classes\attributeManagerConfig.class.php and edit line 65 "AM_USE_QT_PRO", set it to "false".

 

You mean this right?

 

>>>>>

The code shows as :-

 

$this->add('AM_USE_QT_PRO', true);

 

>>>>>

Should I change to :-

 

$this->add('false', true);

 

>>>>>

Or :-

 

$this->add('false');

 

 

?

 

As the name suggests, I'm an absolute beginner!

 

Thanks

Edited by absolutebeginner

Share this post


Link to post
Share on other sites

You mean this right?

 

As the name suggests, I'm an absolute beginner!

 

Thanks

We all were beginners some time... :thumbsup:

 

Change this line

$this->add('AM_USE_QT_PRO', true);

to this:

$this->add('AM_USE_QT_PRO', false);

 

In this code AM_USE_QT_PRO is the variable you should never change. But the value of this variable may be change according to your needs. You should disable QT Pro functionality by now, so set the variable value to FALSE.

Share this post


Link to post
Share on other sites

We all were beginners some time... :thumbsup:

 

Change this line

$this->add('AM_USE_QT_PRO', true);

to this:

$this->add('AM_USE_QT_PRO', false);

 

In this code AM_USE_QT_PRO is the variable you should never change. But the value of this variable may be change according to your needs. You should disable QT Pro functionality by now, so set the variable value to FALSE.

 

Thanks so much! Perfect now.

Share this post


Link to post
Share on other sites

hello!

It seems that I can't use this contrib. I am using 3 browsers: IE 8, Opera 10 and Mozilla 3.6.2.

The problem is that it does nothing. Nothing is showing below the price.

I tryed to delete the .htaccess file but with no luck. I used a lot of versions of this contributions and none worked.

I've had some errors in the language file (<? converted to <?php and <br /> converted to <br>) but beside this nothing is showing

Only when I try to add a new product I get this message: "Save Product before adding options"

So, there is a solution to this problem?

 

Thank you!

Share this post


Link to post
Share on other sites

I found where the problem was.

I am using a Slashdot menu (this one) for column_left.

If I erase the <?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> it works just fine.

Any idea why this is happening?

I found that the problem is with the "gliding" script:

 

	<script type="text/javascript">
// <![CDATA[
var myMenu;
window.onload = function() {
	myMenu = new SDMenu("my_menu");
	myMenu.init();
};
// ]]>
</script>

If I erase ONLY this code, the AJAX Attribute contribution works fine, but I can't use my menu (it can't glide)

Share this post


Link to post
Share on other sites

Sorry for very short answer. I can't post this time. Find window.onload function in AJAX AM contrib and mix code from window.onload of your menu and window.onload of AJAX AM contrib in one function. Hope this can help. I see this isshue carefully later.

Edited by RusNN

Share this post


Link to post
Share on other sites

Hi again,

 

Been working successfully with this addon now for while, since RusNN helped me fix the small problem I was having with it not showing up.

 

It's been working great, a really good contribution! Makes it so much quicker and easier to add options to products!

 

I am having one minor problem/defect however.

 

When I add multiple options to a product, only the first option added keeps itself in the order I set it to on the Attribute Manager control panel.

 

For example, say I set 3 options for a product, like so;

 

Color:

Red

Green

Purple

 

Size:

Small

Medium

Large

 

Second color:

No Second Color

Grey

Green

Blue

 

.. And then I update that info to the website. The first option (Color) will stay in exactly the order I want it to. But the other two options will mix up in a random order, like so;

 

Color:

Red

Green

Purple

 

Size:

Medium

Small

Large

 

Second color:

Blue

Grey

No Second Color

Green

 

Does anybody know how this can be controlled? So that they all stay in the order I set them to in the Attribute Manager.

Edited by absolutebeginner

Share this post


Link to post
Share on other sites
Does anybody know how this can be controlled? So that they all stay in the order I set them to in the Attribute Manager.

If I understand correctly, see my post 988 in this thread. Possibly that is your solution. Ask, if you have questions.

Share this post


Link to post
Share on other sites

i have problem sorting Attribute value alphabetical

 

help plz

Mode

Please, read my post just above yours and go through the link in it. All your answers there.

Share this post


Link to post
Share on other sites

Does anyone know if there's a way to add on/off buttons to attribute options? I want to be able to shut an option off if it's temporarily out of stock. I don't need the full functionality of QTPRo. Plus I tried installing it but couldn't get it to work with all the other mods I have installed.. SPCC, PAPs, etc... I don't keep track of stock in OSC because many of my products are drop-shipped or special ordered. I would just like to remove it from the drop-down list temporarily without deleting it completely.

 

Thanks in advance to anyone who takes the time to respond... and thanks for this great contribution. It's saved me so much time!

 

Leslie

Share this post


Link to post
Share on other sites

I'm not exactly shure if it is, but I never saw plugin like you described. Seems not to difficult to do such functionality yourself. One field in database, couple of modified querries on client side, some coding on admin to allow to manipulate with on/off switch.

Share this post


Link to post
Share on other sites

Hi,

 

1.

I have installed the excellent Ajax Attribute Manager 2.8.9. Unfortunately, I wrote two similar options, Size, by mistake and now I cannot find a way to delete one of them. I don’t see any delete button or menu where I can delete. How do I do?

 

 

2.

I have also problems with that the values don’t show in the right numerical order on the catalog page although they are in the right order on the admin page. I know that there have been several questions about this, but as I’m an absolute beginner I ask for as a simple answer as to Winnie-the-Pooh bear, if possible.

 

bofri

Share this post


Link to post
Share on other sites

Hi,

 

1.

I have installed the excellent Ajax Attribute Manager 2.8.9. Unfortunately, I wrote two similar options, Size, by mistake and now I cannot find a way to delete one of them. I don’t see any delete button or menu where I can delete. How do I do?

 

 

2.

I have also problems with that the values don’t show in the right numerical order on the catalog page although they are in the right order on the admin page. I know that there have been several questions about this, but as I’m an absolute beginner I ask for as a simple answer as to Winnie-the-Pooh bear, if possible.

 

bofri

1. You may delete them through standart osC Product Attribute page.

 

2. I'am afraid I can't tell this better. It is very simple, just look to the code and try to understand. In the old instruction for Ajax AM this is described also, but you just to do only client side.

Share this post


Link to post
Share on other sites

Guys, I need implement weight in this addon... someone have this implemented? Or know how to do this?

 

Thank you!

I implemented contribution More Product Weight v1.0 to AJAX AM since version 2.8.7. It deals with individual attributes weight, but not with products weight. Product's weight remain unchanged and goes as default.

To switch on the support for MPW find in attributeManagerConfig.class.php

$this->add('AM_USE_MPW', false);

and replace with

$this->add('AM_USE_MPW', true);

Share this post


Link to post
Share on other sites

hello!

It seems that I can't use this contrib. I am using 3 browsers: IE 8, Opera 10 and Mozilla 3.6.2.

The problem is that it does nothing. Nothing is showing below the price.

I tryed to delete the .htaccess file but with no luck. I used a lot of versions of this contributions and none worked.

I've had some errors in the language file (<? converted to <?php and <br /> converted to <br>) but beside this nothing is showing

Only when I try to add a new product I get this message: "Save Product before adding options"

So, there is a solution to this problem?

 

Thank you!

 

 

I have the same problem.

 

Anyone can help us ?

 

Thanks a lot.

Share this post


Link to post
Share on other sites

Difficult to say whats wrong. Only general words, such as check her or there. Need to see closely.

Does other AJAX and javascript site work on your hosting? Are the path settings OK? Try on other computers, browsers, operating systems.

Share this post


Link to post
Share on other sites

Nobody mentioned anywhere that attributes will be set After saving the product. Personally I thought that attributes will be set even when I create a new product.

 

This is the Info bubble says, first to save than set attributes. But it's the same procedure like the standard one from OSC. And in this case this addon doesn't help anyone with nothing. If you can't set attributes when you create a new product it's useless.

 

The question is: does this addon work when you first create a product or only for modifying the products ?

 

I hope I'm wrong.

 

Thanks a lot and looking forward to your reply.

 

PS: Regarding other systems and browsers, it does the same thing everywhere, I tested it with all known browsers, and javascript it's working, in fact everything it's working.

Edited by bogdansbg

Share this post


Link to post
Share on other sites

This addon can only edit existing product. The reason is simple - linking attributes to undefined product is impossible. The linking uses internal database identifiers of attributes, options and first of all, of a product which you link to. No product means no product ID, so linking is impossible.

The internal mechanism of osC allows you to create product (should read as "create new product ID") only after clicking button "Confirm" (sorry, I don't remember actual name of it in english). After you click this, the new product record with new product ID saved in database and you redirected to product listing.

This is why AJAX AM can't work with newly product - there are no product, before you not save it. Adding attributes to product through this contrib is always editing product. So like a standart osC.

Edited by RusNN

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×