Jump to content
Nimmit

AJAX Attribute Manager support

Recommended Posts

I really need some help here maybe some one has had the same issue as I and resolved it. I have the contrib installed and seems to work but don't. When I try to edit a product to add like a size it will not add the option. When I click to add it does nothing.

 

Few questions:

 

1. What is the browser you use Name + Version.

2. Did you get any javascript errors.

3. Version and modification level of the shop.

4. Version of the AJAX AM you are trying to use.

 

Without such information it is impossible even to think about where the bug can be.


If you are happy with my OSC contribution changes feel free to hire me.

Share this post


Link to post
Share on other sites

I install the 2.8.2 version on my site, and it works. but the page comes out with the error message

 

Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /var/www/vhosts/lifecorners.com/httpdocs/cart/admin/includes/functions/sessions.php on line 123

 

my osc version is v2.2 RC2a and php 5.0.4 (Zend: 2.0.4-dev)

I have follow the instruction to install the script 3 times, but still comes out with the same error. can someone help

thank you

ken

Share this post


Link to post
Share on other sites
Few questions:

 

1. What is the browser you use Name + Version.

2. Did you get any javascript errors.

3. Version and modification level of the shop.

4. Version of the AJAX AM you are trying to use.

 

Without such information it is impossible even to think about where the bug can be.

 

firefox 2.0.0.14

osCommerce 2.2-MS2

AJAX-AttributeManager-V2.8.3

 

no errors at all it just does nothing, I can add sizes now but not colors??? I have actually tried all my browsers Netscape, IE v7 and firefox the all respond the same.

Share this post


Link to post
Share on other sites
I install the 2.8.2 version on my site, and it works. but the page comes out with the error message

 

Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /var/www/vhosts/lifecorners.com/httpdocs/cart/admin/includes/functions/sessions.php on line 123

 

my osc version is v2.2 RC2a and php 5.0.4 (Zend: 2.0.4-dev)

I have follow the instruction to install the script 3 times, but still comes out with the same error. can someone help

thank you

ken

 

Please read the previous page(s) ... search lines in red. I'm sure you will find a solution.

 

 

firefox 2.0.0.14

osCommerce 2.2-MS2

AJAX-AttributeManager-V2.8.3

 

no errors at all it just does nothing, I can add sizes now but not colors??? I have actually tried all my browsers Netscape, IE v7 and firefox the all respond the same.

 

V2.8.3 is created by another coder so I do not guarantee that it is bug free. Try V2.8.2 :rolleyes:

About the errors ... in Firefox ... Tools->Error Console ;)


If you are happy with my OSC contribution changes feel free to hire me.

Share this post


Link to post
Share on other sites

I loaded v2.8.2 up this morning and it works a little better at least it functions. I still cant update "color", so I added one call "option" and am using that for colors. Weird it wont let me use one but I can use the other two without problems. I have option and size working so its working well enough to function now.

 

Thanks for your help and keep up the great work

 

Please read the previous page(s) ... search lines in red. I'm sure you will find a solution.

 

 

 

 

V2.8.3 is created by another coder so I do not guarantee that it is bug free. Try V2.8.2 :rolleyes:

About the errors ... in Firefox ... Tools->Error Console ;)

Share this post


Link to post
Share on other sites

Hi,

I'm a new in the oscommerce and in programming at all.

I have os2.2 installed, and trying to install AJAX contribution.

After changing categories.php can't get into categories/products, I receive just blank page, no error messages, nothing.

Help :(

Share this post


Link to post
Share on other sites

Maybe you have php errors turned off.

 

Check everything again ... check the 123 bug in sessions ... try to remove the .htaccess in the attrib manager's folder.

 

Good Luck :rolleyes:

 

Hi,

I'm a new in the oscommerce and in programming at all.

I have os2.2 installed, and trying to install AJAX contribution.

After changing categories.php can't get into categories/products, I receive just blank page, no error messages, nothing.

Help :(


If you are happy with my OSC contribution changes feel free to hire me.

Share this post


Link to post
Share on other sites

good call, check the .htaccess every time I have ever received a black page its been an issue the that file.

 

These programmers here are so smart at this stuff, I am not being sarcastic thats the truth...

Share this post


Link to post
Share on other sites

Option Type & Attribute Weight Contributions

 

Hi there,

 

i wondered if anyone had successfully integrated either of these contributions with the Ajax Attribute Manager? And if so would you be willing to share any tips code?

 

Thanks

 

Dave

Share this post


Link to post
Share on other sites
Maybe you have php errors turned off.

 

Check everything again ... check the 123 bug in sessions ... try to remove the .htaccess in the attrib manager's folder.

 

Good Luck :rolleyes:

 

Thank you TomaszBG, it works! :lol:

after turning on php errors found the files in the wrong folder :blush:

Share this post


Link to post
Share on other sites
Option Type & Attribute Weight Contributions

 

Hi there,

 

i wondered if anyone had successfully integrated either of these contributions with the Ajax Attribute Manager? And if so would you be willing to share any tips code?

 

Thanks

 

Dave

 

I too am looking for this. I Have all 3 contributions but there is no variable for the weight or price. I have managed to add the extra box for weight but have no idea how to make them dynamic and save multiple weights or multiple prices. Ideas anyone. More importantly what part of the current code gives the variable option and value.

Share this post


Link to post
Share on other sites

I just want to say that this was the fastest and easiest contribution to install! You guys who developed this are the best!

A big thank you, it makes the attributes editing so easy.

 

Intergrated well with my 50 or so other contributions without any hiccups.....

 

Thanks again.

Share this post


Link to post
Share on other sites
1052 - Column 'products_options_sort_order' in order clause is ambiguous

select * from products_attributes as pa INNER JOIN products_options po ON pa.options_id=po.products_options_id where products_id = '1065' AND language_id=1 order by products_options_sort_order

 

... now appears on the edit page.

 

Fun.

 

I saw that someone had a similar problem but I couldn't see any solution that works for me (I did try). Seems to be an issue with 2.8.2

 

Cheers

 

 

Hi naiadomare. How did you resolve that issue?

I installed version AJAX-AttributeManager-V2.8.2 and get the same problem when setting "$this->add('AM_USE_SORT_ORDER' , true);"

 

I would like your help please :rolleyes:

 

 

About 2.8.x version:

 

Do not enable SORT ORDER ... if you already use it plese stay with 2.7.x.

 

Adding new options/values may not be compatible with some non EN languages.

 

About 123 error please read previous page.

 

 

Hello TomaszBG

 

Is there some way to turn sort order on and get the contribution working?

I really need it lol :blush:

Share this post


Link to post
Share on other sites
...

 

Hello TomaszBG

 

Is there some way to turn sort order on and get the contribution working?

I really need it lol :blush:

 

You have PM ;)


If you are happy with my OSC contribution changes feel free to hire me.

Share this post


Link to post
Share on other sites

hello, I am in the process of enhancing my shop and need some advice.

 

I think I am going to use Ajax Attribute manager.

 

Today I have an addon "Image_Manager" which has given me a nice way of adding new products.

This addon, however can not handle options as images. And I am not sure if its the right way to go

by using the contrib "Options as Images". I have searched the net extensively and found another

Ajax application: http://www.webextremecustomiser.com/index....p;products_id=1

 

This application makes it possible to have options as images in thumb nails. Clicking on a thumb nail will

"swap" the large image with that of the thumb nail, plus... on hoovering, show an even larger image as

defined through the stylesheet.

The crucial thing is that this image swapper was not designed for OScommerce but a descendent...

But, AJAX is AJAX... so I beleive that it could be used?

 

Any suggestions?...

 

Sara

Share this post


Link to post
Share on other sites

Hi guys, I'm trying to get this running on my store, any chance you might be able to point me in the right direction with this error?

 

1054 - Unknown column 'language_id' in 'where clause'

 

select * from products_options where language_id='1' order by products_options_name

 

[TEP STOP]

 

 

Any help appreciated,

Cheers

Edited by Melinda Odom
other cart promotion

Share this post


Link to post
Share on other sites

Hi,

 

I updated this contribution on my stores and the price doesn't show on the shopping cart page or throughout the checkout.

 

Big Brother Personalized Hat

- Colors Of Product Khaki

- Gift Wrap Option Yes Gift Wrapping

- Gift Wrap Style Baby Boy

 

The gift wrap option yes gift wrapping should show the additional $4 charge but does not, however, the attribute price is added to the product's base price.

 

Can you tell me where to look for this?

 

Thank you!

Share this post


Link to post
Share on other sites
Hi,

 

I updated this contribution on my stores and the price doesn't show on the shopping cart page or throughout the checkout.

 

Big Brother Personalized Hat

- Colors Of Product Khaki

- Gift Wrap Option Yes Gift Wrapping

- Gift Wrap Style Baby Boy

 

The gift wrap option yes gift wrapping should show the additional $4 charge but does not, however, the attribute price is added to the product's base price.

 

Can you tell me where to look for this?

 

Thank you!

 

When you are asking ... always share information like:

OSC version ?

AM Version ?

Are there any other attributes contributions installed?

:rolleyes:

 

For now:

1. Probably your issue is not conneced in any way with AM (for sure if you use 2.8.0-2.8.3).

2. There may be another contributions that are not compatible with AM.

3. Hidden DB errors ... somewhere.

;)


If you are happy with my OSC contribution changes feel free to hire me.

Share this post


Link to post
Share on other sites
When you are asking ... always share information like:

OSC version ?

AM Version ?

Are there any other attributes contributions installed?

:rolleyes:

 

For now:

1. Probably your issue is not conneced in any way with AM (for sure if you use 2.8.0-2.8.3).

2. There may be another contributions that are not compatible with AM.

3. Hidden DB errors ... somewhere.

;)

 

Hi,

 

I have tried versions 2.6, 2.8.2, and 2.8.3 on my test site with no other contributions and still the same results.

 

Am using rc2.2a

 

Only the plus or minus attribute price does not show on the attribute listing on the shopping cart page and throughout the checkout and not on the email received either.

:rolleyes:

Edited by Melinda Odom
edit

Share this post


Link to post
Share on other sites
Hi,

 

I have tried versions 2.6, 2.8.2, and 2.8.3 on my test site with no other contributions and still the same results.

 

Am using rc2.2a

 

Only the plus or minus attribute price does not show on the attribute listing on the shopping cart page and throughout the checkout and not on the email received either.

:rolleyes:

 

What about the standard "AM" in the admin. Does it show everything correctly.


If you are happy with my OSC contribution changes feel free to hire me.

Share this post


Link to post
Share on other sites

Hi,

 

I have not made any changes to the attributeManager.php. It is the same as the download.

 

Can you tell me what to look for?

 

I did a completely fresh install using attribute manager 2.8.2.

 

This is the product which clearly shows the attribute prices:

http://www.designhosting.us/rc2/catalog/pr...3/products_id/8

 

If you put that product in the cart it does not show the price of the attribute.

 

Am on centos5 with mysql5 and php5.

 

Thanks!

Edited by Melinda Odom

Share this post


Link to post
Share on other sites
Hi,

 

I have not made any changes to the attributeManager.php. It is the same as the download.

 

Can you tell me what to look for?

 

I did a completely fresh install using attribute manager 2.8.2.

 

This is the product which clearly shows the attribute prices:

http://www.designhosting.us/rc2/catalog/pr...3/products_id/8

 

If you put that product in the cart it does not show the price of the attribute.

 

Am on centos5 with mysql5 and php5.

 

Thanks!

 

It is normal that OSC does not show attribute prices outsite "product page" ... here is a demo of fresh clear OSC ... it works the same way :rolleyes:


If you are happy with my OSC contribution changes feel free to hire me.

Share this post


Link to post
Share on other sites

Hi,

 

Before all the updates it use to show the price also but not now so I guess this is normal now for rc2.2a.

 

It would really be nice to have the price show up especially on the email the store owner gets.

 

Thanks again!

Edited by Melinda Odom

Share this post


Link to post
Share on other sites

array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /admin/includes/functions/sessions.php on line 123

 

Just putting this fix in an easy place to find all associated fixes. I'm not the author of these, just the (re)publisher.

 

open file catalog/admin/includes/functions/sessions.php

 

line 123 find:

return array_key_exists($variable, $_SESSION);

 

and replace with:

return isset($_SESSION[$variable]);

 

Once I did that, I started getting the warning:

Session not registered - You cant access this page directly

 

To fix that, open catalog/admin/attributeManager/attributeManager.php

go to line 56:

stopDirectAccess::checkAuthorisation(AM_SESSION_VALID_INCLUDE);

and comment it out.

 

That brings the attribute manager onto the product page in admin. For what it's worth

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×