Jump to content
Nimmit

AJAX Attribute Manager support

Recommended Posts

I can't seem to get this contribution to show up... I completely replaced the attribute manager folder and made the changes to categories.php but when I go to the product attributes in the admin it looks the same. Any ideas?

 

Sorry just found it. In the categories/product section.

Share this post


Link to post
Share on other sites

Sorry to post yet again...

 

I just got done installing QT pro, I'm not getting any error messages; but, when I click on the QT pro stock button it shows me the option to change the quantity for the main product but not for any of the attributes. I have deleted and re-entered attributes to no avail. Not sure if this is a conflict with this program... but desperately trying to fix this little bug. Please if anyone has any ideas let me know. Thanks!

Share this post


Link to post
Share on other sites

I'm so sorry for so many posts. I'm just chomping at the bit....

 

I just got the quantities to update for individual attributes... I wish I knew how but am not sure. I don't think my ftp program was saving correctly. ARgh

 

The only problem I'm having now are the two available options...

Share this post


Link to post
Share on other sites

I have added this contribution to my site and am getting this error when I add an attribute from the attribute page and when I add an error from the add product page it doesnt do anything at alll.

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values ('', '2', '0', '0', '', '+', '0')

 

[TEP STOP]

 

Any ideas?

Share this post


Link to post
Share on other sites

I recently installed the contrib on my relatively fresh osc 2.2, but it simply doesn't work.

I checked all installation steps again, but didn't find the mistake.

 

Ich also checked javascript activation.

 

In my admin-section nothing changed at all...

 

Any ideas how to fix this?

Need any additional information?

Share this post


Link to post
Share on other sites

I just downloaded the sort order option to this contribution and I get the sort order option in the admin side and label them 1 through whatever but when going to view the product in the store, they are still ordered alphabetically.

Share this post


Link to post
Share on other sites

There's a bug when adding new Options or Values. For instance, if I put in the value

C&H
into the New Option input field,
C
is what gets entered into the database.

Looks like the values are not being url-encoded.

 

To fix this, open /admin/attributeManager/javascript/attributeManager.js

 

around line 240, inside: function getAllPromptTextValues() {

 

find line:

returnArray.push(allValues[i].id+':'+getElement(allValues[i].id).value);

 

replace with:

returnArray.push(allValues[i].id+':'+encodeURIComponent(getElement(allValues[i].id).value));

Share this post


Link to post
Share on other sites

Good morning everyone,

 

i recently made a fresh install and tried again to install AJAX AM.

It still doesn't work.

I checked all steps of installing again, but I can't find what I did wrong.

 

Perhaps I made a mistake when editing categories.php???

 

Any ideas what typically goes wrong when editing???

Im new to all this, so if I made something wrong, I can't see it myself...

Would be nice if someone could check the installing documentation, if there are steps, i could have understand the wrong way...

Share this post


Link to post
Share on other sites

In my ecommerce i sell contact lenses.

And it has a peculiar structure, for example:

 

Option Name Option Value

 

Power right eye 0.00

-0.25

-0.50

... (until)

-10.00

 

Power left eye 0.00

-0.25

-0.50

... (until)

-10.00

 

 

I have many options values, and that is always repeated twice.

Before this contribution I enter these values only one time, now I have to double values.

 

options.gif

 

In this image the curve base left eye (LE) not appear

Share this post


Link to post
Share on other sites

I've been using this attribute manager for a long time now, and LOVE it! I was wondering if anyone has any advice on adding the ability to add a blank text input box option to a product.


What? Yeah, I can do that.

Share this post


Link to post
Share on other sites

Hey

Newbie here. Using OSC2.2 MS2 with BuySafe module on PHP5.0.5 Apache 1.3.37

 

Have installed AJAX Attribute Manager 2.7(1) and all seems to go well UNTIL I

try to load a new item & below the Price box, I get the following error :

 

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

Needless to say, there are no attribute management options.

 

Much help would be most appreciated, please.

Share this post


Link to post
Share on other sites
In my ecommerce i sell contact lenses.

And it has a peculiar structure, for example:

 

Option Name Option Value

 

Power right eye 0.00

-0.25

-0.50

... (until)

-10.00

 

Power left eye 0.00

-0.25

-0.50

... (until)

-10.00

I have many options values, and that is always repeated twice.

Before this contribution I enter these values only one time, now I have to double values.

 

options.gif

 

In this image the curve base left eye (LE) not appear

 

 

I am having this same problem. I have looked though the forum, but have not found a solution. Anyone?

 

Rad

Edited by radtrace

Share this post


Link to post
Share on other sites
I am having this same problem. I have looked though the forum, but have not found a solution. Anyone?

 

Rad

 

I truley do like this contribution, and it would be awsome if I could find this problem and fix it. EVERY attribute I place in the cart is doubled. I don't know enough about ajax and MySQL to hunt down the problem. I seems to be inserting every call to the DB 2 times, I just can't figure out where the calls are that are making it do it. ANY HELP would be nice right now. It's the last thing holding up the release of the store.

 

Rad

Share this post


Link to post
Share on other sites

For anybody having problems with the sort order and double entries try this:

As dumb as it may sound and tedious..

 

Go.........super......slow.....after.......each......add/checkmark.....

 

 

I dont know why, but this worked for me. After showing them doubled and out of order, I went and deleted all the attributes to that product..and then one by one entered in the options (size, color, etc). Wait about 5 seconds after each one.

 

Then for sort order, do the same after adding it...wait about 5 seconds.

 

Not saying this will work for everybody, but it worked over here...which is oh so strange :blink:

Share this post


Link to post
Share on other sites
I just downloaded the sort order option to this contribution and I get the sort order option in the admin side and label them 1 through whatever but when going to view the product in the store, they are still ordered alphabetically.

 

Anyone have any ideas on this problem at all??

Share this post


Link to post
Share on other sites
For anybody having problems with the sort order and double entries try this:

As dumb as it may sound and tedious..

 

Go.........super......slow.....after.......each......add/checkmark.....

I dont know why, but this worked for me. After showing them doubled and out of order, I went and deleted all the attributes to that product..and then one by one entered in the options (size, color, etc). Wait about 5 seconds after each one.

 

Then for sort order, do the same after adding it...wait about 5 seconds.

 

Not saying this will work for everybody, but it worked over here...which is oh so strange :blink:

 

No Joy on the slo...o...o...o...w input. Still getting double database entries. like the eyeglasses above:

 

color: green

green

red

red

blue

blue

doesn't seem to matter how I input I still get two of every option :'( any other ideas anyone?

 

Rad

Share this post


Link to post
Share on other sites

For everyone seeing double, have you checked your data base to see if, perhaps in error, the queries were run twice?

 

jon

Edited by jonquil

It's all just ones and zeros....

Share this post


Link to post
Share on other sites

I am having this exact same problem. Double entries for attributes added to a product. AND...

 

say I add a size to a product and then go to add a second size, the choice of size is removed from the first column.

Share this post


Link to post
Share on other sites

I am having problems with the sort order aspect of this contribution. Every time I change the sort order of the product attributes it only changes in the admin and not the actual product page. The template shows correct in the ajax attribute manager but that is it.

 

in the file admin/attributeManager/classes/attributeManagerConfig.class.php the directions say:

 

Change the column name to whatever your sort column is called on each of your database tables

 

$this->add('AM_FIELD_OPTION_SORT_ORDER','products_options_sort_order'); // Sort column on Products_options table

$this->add('AM_FIELD_OPTION_VALUE_SORT_ORDER','products_options_sort_order'); // Sort column on product_attributes table

 

I used the contribution "Product Attrib Sort v1.2a" located at http://www.oscommerce.com/community/contributions,1822

Im a little confused about what column name to change. The sql file in the sort order contribution adds the column

"attribute_sort" to product attributes table. Is this what I change the above to?

 

If not what is the correct edit of this file. Any help will be greatly appreciated.

Share this post


Link to post
Share on other sites
I am having problems with the sort order aspect of this contribution. Every time I change the sort order of the product attributes it only changes in the admin and not the actual product page. The template shows correct in the ajax attribute manager but that is it.

 

in the file admin/attributeManager/classes/attributeManagerConfig.class.php the directions say:

 

Change the column name to whatever your sort column is called on each of your database tables

 

$this->add('AM_FIELD_OPTION_SORT_ORDER','products_options_sort_order'); // Sort column on Products_options table

$this->add('AM_FIELD_OPTION_VALUE_SORT_ORDER','products_options_sort_order'); // Sort column on product_attributes table

 

I used the contribution "Product Attrib Sort v1.2a" located at http://www.oscommerce.com/community/contributions,1822

Im a little confused about what column name to change. The sql file in the sort order contribution adds the column

"attribute_sort" to product attributes table. Is this what I change the above to?

 

If not what is the correct edit of this file. Any help will be greatly appreciated.

 

Hi John and osc lovers,

 

This is also the problem i am working with at the moment.

I hope someone will help this out!

 

Greetings from a rainy Holland

Share this post


Link to post
Share on other sites
I truley do like this contribution, and it would be awsome if I could find this problem and fix it. EVERY attribute I place in the cart is doubled. I don't know enough about ajax and MySQL to hunt down the problem. I seems to be inserting every call to the DB 2 times, I just can't figure out where the calls are that are making it do it. ANY HELP would be nice right now. It's the last thing holding up the release of the store.

 

Rad

I think the solution will be this site.

Really?

http://www.lenscareonline.com/purevisi0n-t...27449369d2b4265

Please help me.

Share this post


Link to post
Share on other sites
Hi John and osc lovers,

 

This is also the problem i am working with at the moment.

I hope someone will help this out!

 

Greetings from a rainy Holland

 

Maybe someone will help us solve the problem.

 

GReetings

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×