Jump to content
Nimmit

AJAX Attribute Manager support

Recommended Posts

are all of you adding this contribution to stores with existing product attributes? im very interested in adding it to my store, but want to make sure its fine to add it to a store with lots of products and attributes already.

I added to a store with existing products (albeit only 45 or 50), and it worked fine. As other people mentioned, version 2.1 seems to work for those who have different prices for different attributes. It really does make the whole process a lot easier, and works for new and existing products/attributes.

Share this post


Link to post
Share on other sites

install instructions state:

 

Find (Around line 346 on a fresh ms2)

onload="SetFocus();"

 

Replace With

onload="goOnLoad();"

 

in admin/categories these is no code that even resembles onload="SetFocus();"

 

my ajax attributes manager doesnt open when i edit any item - any tips?


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Disregard the above post - it was a long day - i have found it.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

My installation experience.

 

I downloaded attrib_sort_v1.2 (29th of March 2005). WHY: It seemed like an easy integration.

 

Following the instructions should result in a fully functional sort atribute which can be seen under product attributes. However, I've made a few minor tweaks.

 

1. I've added the following to my sql database:

ALTER TABLE products_attributes ADD COLUMN products_options_sort_order INT UNSIGNED NOT NULL DEFAULT '0';

ALTER TABLE products_options ADD COLUMN products_options_sort_order INT UNSIGNED NOT NULL DEFAULT '0';

 

2. Anywhere 'attribute_sort' is referenced from the contribution above needs to be replaced with 'products_options_sort_order'.

 

Now for AJAX attribute manager. 2.3c did not work for me as the attributes that were being displayed were 1 character long. (As referenced in prior posts.) Therefore, I installed 2.3b without QT Pro fix. Follow the instruction and then finish off by enabling the sort order option.

 

Problems I've encountered so far:

1. Blank attributes. (Very few. Only 1 so far.)

2. There was one product that would not accept an attribute sort order number. It would get set back to zero. However, I was able to fix it via the first contribution.

 

Hope this helps someone. This is a great concept and does make assigning attributes to your products a bit more tolerable. Hope I haven't missed anything. :D

Share this post


Link to post
Share on other sites

Hello,

 

I tried to installed latest version (2.3b). It got me some problems:

I cannot save the prices for the attribute. They always equals 0.

 

Then I just replace 2.3b with 2.1 version and it works for me.

 

 

Also I have the question about the attribute qty. Is it real to add the quantity field for each attribute value?

 

Thanks,

Igor.

Share this post


Link to post
Share on other sites
I downloaded attrib_sort_v1.2 (29th of March 2005). WHY: It seemed like an easy integration.

I was thinking of adding this contribution as I have used it before:

Product Attributes Sort Order v1.0 by Forrest Miller

 

Does anyone know the difference between the contributions mentioned?

 

Thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I was thinking of adding this contribution as I have used it before:

Product Attributes Sort Order v1.0 by Forrest Miller

 

Does anyone know the difference between the contributions mentioned?

 

Thanks

 

The one you've mentioned does not have anything to do with sorting the attributes based on some index value. It sorts by price and then by the order it was entered. This is the order the author was interested in.

Share this post


Link to post
Share on other sites
The one you've mentioned does not have anything to do with sorting the attributes based on some index value. It sorts by price and then by the order it was entered. This is the order the author was interested in.

I don't understand, please clarify.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

I want to add this contribution to a store: MORE PRODUCT WEIGHT

 

Basically if this or any other contribution alters the admin/products_attributes.php page then how is easy is it to make the same adjustments in the ajax attribute manager?

 

I did see the instructions in the footer of the install file but I didn't manage to make it work. Has anyone managed to get the attribute manager to show all the extra or new fields they have created in the admin/pruducts_attrbutes.php page?

 

Thanks for any tips.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
Hi there,

 

I've been reading a lot about this contrib and I'm going to install v2.3c Beta, but I have a question regarding the instructions. Specifically, the bit about configuring with an attribute sorting contibution....I've found several Attribute sorting contribs...which one should I use? In other words, in the instructions it says...

 

Can anyone tell which Sort Order Plugin these instructions refer to?

 

I just want to make sure that I can sort the attribute values the way they should appear, e.g. Small, Medium, Large.....

 

Thanks,

 

Adam

 

 

Yes. I too need more clarification on this. The attributes are all in the opposite order of what I put them in unless I do all backwards. Please someone clarify this last set of instructions. I would like to use the sort order plug-in. :-"

Share this post


Link to post
Share on other sites

About the Price & Prefix bug :

 

Although I’m a C#/Delphi programmer i think i found it !

 

If you look in the attributeManager.js around line #83 there’s an amUpdate function.

 

Maybe when they added support for sorting they never looked at this function very well.

 

When I change the line :

 

amSendRequest('amAction=update&option_id='+optionId+'&option_value_id='+optionValueId+'&price='+getDropDownValue('price_'+optionValueId)+'&prefix='+getDropDownValue('prefix_'+optionValueId)+'&sortOrder='+getDropDownValue('sortOrder_'+optionValueId),'',false);

 

 

And change this in the following :

amSendRequest('amAction=update&option_id='+optionId+'&option_value_id='+optionValueId+'&price='+getDropDownValue('price_'+optionValueId)+'&prefix='+getDropDownValue('prefix_'+optionValueId)+'&sortOrder=0','',false);

 

By replacing this code it will work, but I think the code has to check if sorting is enabled !

 

You will see that saving the price will work again…

 

just look at :

getDropDownValue('sortOrder…………..

This is not working, and I think because in my installation I don’t have sorting enabled yet.

is this function using some kind of getElementByName/id ?, and then trying to refer it, without checking this is null or not ?, is this happening ?

 

 

Maybe the designer can tell anything how to solve this the correct way ?

 

Carlo Coertjens

Netherlands

 

btw great contribution !

Edited by CarloC

Share this post


Link to post
Share on other sites

Hi there. Great Attribution.

 

I've installed version 1.5 long time ago and it worked great. Today I've upgraded to version 2.3b, by deleting and replacing the AttributeManager folder.

 

But i have a major problem. I found other people in this thread who had the same problem, but I couldn't find the solution anywhere. And it drives me nut!

 

Please help.

 

After installed (Upgraded) to version 2.3b, I'm getting this error:

 

"Session not registered - You cant access this page directly"

 

I run the script on an external server with php5 and apache server.

Share this post


Link to post
Share on other sites

Help needed.

 

I installed version 2.3b and everything seems to work fine besides the fact that when you click the arrow to add the attribute to the list for the item it does nothing.

I can the Option and the Value, but when I click the arrow icon to add, it does nothing.

 

I have installed on another shop and it worked fine straight away. But this time it doesn't and it is a fresh install of the latest version of osCommerce with no other addons.

 

Can someone help, please.

Share this post


Link to post
Share on other sites

I use firefox, and 2.3c. which it displays but does not work, with the many problems documented earlier in this topic.

 

I used a firefox add-in called JSview to see what was happening and this part

 

<!-- osc@kangaroopartners.com - AJAX Attribute Manager  -->
<tr>
<td colspan="2"><?php require_once( 'attributeManager/includes/attributeManagerPlaceHolder.inc.php' )?></td>
</tr>
<!-- osc@kangaroopartners.com - AJAX Attribute Manager end -->

 

didnt output anything within the html source.. Im not any good at ajax/javascript but can anyone with any knowledge. give me some ideas on if this is correct?

Share this post


Link to post
Share on other sites

Hello and congratulation for this very best contribution !! :thumbsup:

 

 

 

 

I search to add support "ADD WEIGHT" to Attribut AJAX ?

 

 

How to make to add “ADD WEIGHT”? it would be enough to take as a starting point “attribut order” but I cannot what add like code.

 

 

Thx for your help ! :thumbsup:

Share this post


Link to post
Share on other sites
Help needed.

 

I installed version 2.3b and everything seems to work fine besides the fact that when you click the arrow to add the attribute to the list for the item it does nothing.

I can the Option and the Value, but when I click the arrow icon to add, it does nothing.

 

I have installed on another shop and it worked fine straight away. But this time it doesn't and it is a fresh install of the latest version of osCommerce with no other addons.

 

Can someone help, please.

This is exactly what I am experiencing with 2.3b. I first tried to install v2.3c but that displayed the options using only the first letter (as mentioned previously in this thread). I then tried to copy over my admin/attributeManager folder with 2.3b but that didn't help. It was exactly the same as before so I thought something might have gone wrong. I did a full uninstall of this contrib and tried to install 2.3b again as a few people confirmed that they had it working ok. I really just need this contrib for the templates system and I was thinking about installing attributes sets plus but this is ajaxy and I'm a sucker for it.

 

Please, someone, come to our rescue.. this one is beyond me.

Share this post


Link to post
Share on other sites
This is exactly what I am experiencing with 2.3b. I first tried to install v2.3c but that displayed the options using only the first letter (as mentioned previously in this thread). I then tried to copy over my admin/attributeManager folder with 2.3b but that didn't help. It was exactly the same as before so I thought something might have gone wrong. I did a full uninstall of this contrib and tried to install 2.3b again as a few people confirmed that they had it working ok. I really just need this contrib for the templates system and I was thinking about installing attributes sets plus but this is ajaxy and I'm a sucker for it.

 

Please, someone, come to our rescue.. this one is beyond me.

I have now tried:

 

v2.1 beta

v2.3 beta

v2.3b - beta

v2.3c - beta

v2.3b - beta (BUGFIX)

 

None of these are working for me. I have no idea what is wrong.

Share this post


Link to post
Share on other sites
Hello and congratulation for this very best contribution !! :thumbsup: I search to add support "ADD WEIGHT" to Attribut AJAX ?

I have fiddle with this contribution to add weight too by using this contribution: MORE WEIGHT ....... but I can't get it to work alongside the Ajax Attribute Manager.

 

If anyone can see any easy way to add more fields to the Ajax Attrbiutes Manager please give a pointer here - thanks.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites
I have fiddle with this contribution to add weight too by using this contribution: MORE WEIGHT ....... but I can't get it to work alongside the Ajax Attribute Manager.

 

If anyone can see any easy way to add more fields to the Ajax Attrbiutes Manager please give a pointer here - thanks.

 

 

I manage to use “add weight” but it is necessary that I rename “product_options_sort_order” to “option_value_weight” and it's work ! but then how to make to use both? (add_weight + attribut_sort) Nimmit and Phocea, an idea?

Share this post


Link to post
Share on other sites

Has anyone gotten this contribution to work with the Admin Access Level Accounts 2.0? I just installed that and it requires all files in the admin side of the site to be added to a permissions folder to show properly. I've been playing around with it all day but I can't for the life of me get it to work.

 

Any ideas?

Share this post


Link to post
Share on other sites

Hi

Has anyone set the attribute prices to include tax when entering the amount?

At the present time I have to calculate the attribute prices.

A solution is to remove the tax in products_info, but I need the tax to be specified in orders so that wont work.

Share this post


Link to post
Share on other sites

Hi,

Does any one faced the following problem or know how to solve it?

Please refer to the screen shot

 

pic-1.gif

 

The characters should be in Cyrillic

 

Alex

Edited by alex_rus

Share this post


Link to post
Share on other sites
Has anyone gotten this contribution to work with the Admin Access Level Accounts 2.0? I just installed that and it requires all files in the admin side of the site to be added to a permissions folder to show properly. I've been playing around with it all day but I can't for the life of me get it to work.

 

Any ideas?

 

Run in phpMyadmin the following:

 

INSERT INTO `admin_files` VALUES ('', 'attributeManager.php', 0, 3, '1');

 

change last '1' to what ever group you need, or write '1,2,3' to allow access to groups 1, 2 and 3

 

P.S. \this is written in manual :thumbsup:

 

Alex

Share this post


Link to post
Share on other sites
Hi,

Does any one faced the following problem or know how to solve it?

Please refer to the screen shot

 

pic-1.gif

 

The characters should be in Cyrillic

 

Alex

 

Issue solved - just change in attributeManager.php

header('Content-type: text/html; charset=ISO-8859-1');

 

to what coding you need

 

Alex

Share this post


Link to post
Share on other sites

First - I am very novice to OS Commerce. Sorry.

 

I installed the AJAX Manager as instructed. It shows up on a product detail page - but it is not displaying the size values fully. This site sells designer flip-flops. Example:

 

Womens sizes should be:

 

US 4/5

US 6/7

etc.

 

They display like this:

 

U

U

etc.

 

 

One of the other Womens sizes should be:

 

8

9

10

etc.

 

They display like this:

 

8

9

1

etc.

 

The second example indicates (to me) that the attributes are only displaying ONE character (first) from the size table. Is this a simple fix?

 

Then - once that is fixed, do I need to save a "template" do describe this set?

 

Example:

Womens Classic Flops

and another for

Womens Wedge Flops

 

Thanks in advance,

 

Keith

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×