Jump to content
Sign in to follow this  
perfectpassion

Protx Direct v2.22

Recommended Posts

fair enough, the problem that way is that if it turns out to be fraudulent after payment has been taken the card merchant will charge them a "chargeback" (often around ?25) on top of them losing the money for the order!

 

Oh well their problem not yours!! :-)

 

Tom

Share this post


Link to post
Share on other sites

Tom,

 

As i dispatch my goods immediately i have my authorization type set as "PAYMENT". Is this correct.

 

I us the Third Man as re-assurance.

 

As for fraud I have had lots of trasactions through now and its been fine, touch wood!

 

While I am here how do I add American Express to the drop down list, so this is also accepted in the payment page?

Share this post


Link to post
Share on other sites

That sounds fine - good to hear it's working ok.

 

To enable american express - go into your admin area then Modules -> Payment -> Protx Direct -> Edit

 

Then find AMEX and change to TRUE.

 

Tom

Share this post


Link to post
Share on other sites

I've just uploaded v2.4.

 

A few small changes for those that want them:

 

- Added blank default for start and expiry dates in case not on card and to prompt customer to complete fields

 

- Start & expiry dates listed as numbers (as on cards) instead of textual dates

 

- Added friendly and more informative error message text for AVS / CV2 failures

 

Tom

Share this post


Link to post
Share on other sites

The following is copied from the protx form thread for information:

 

Which bank do you use? Streamline have a Security Declaration you need to sign and agree to which says you ned to physical have your own server with you having the only access to it etc... All of which can't be done with 1and1.

 

Each system administrator should have an individual account and quality passwords should be used and changed regularly and a full audit trail of system administrator actions should be maintained and regularly reviewed.

 

I use LloydsTSB Cardnet - the requirements to have your own server and security procedures etc only apply if you store any card details (under the PCI regulations set by the industry) so I don't understand why Streamline are stating this for all accounts

 

 

 

Well on the Protx site it says that you will have to undergo a PCI audit these days to use the direct method. Frankly that scares me! I am considering using Protx Form so I hope any problems get solved.

 

I have contacted protx and this is their reply:

Dear Tom,

 

Thank you for your email.

 

If you are not storing any credit card information then you will not need to undergo a PCI audit, but if you are storing some of these details then your bank may require you to meet certain PCI standards. You therefore need to clarify with your merchant bank whether or not you are required to take a PCI audit.

 

Further information on the PCI audit and what it entails can be found by following this link: http://www.protx.com/aboutus/04_pci.asp.

 

We recommend that if you are using VSP Direct, you do not store any of the card details once they have been entered on the payment page.

 

Kind Regards

 

Protx.

 

As it stands the stores the last 4 digits of the CC in the DB only so shouldn't be a concern for PCI checks - this is part of the osC checkout_process that stores these not the payment module itself although it is the payment module that passes it to osC to store so can be modified to some extent. To this extent PCI regulations should not affect your choice between protx form and protx direct.

 

Tom

 

 

(posted in the protx direct thread for reference)

Share this post


Link to post
Share on other sites

If you do store cc details then they have to be encrypted, but luckily there is a contribution that does this.

 

Vger

Share this post


Link to post
Share on other sites

Great contribution... All works great in test mode... just waiting for my protx account to go live....

 

Thanx again for a great contribution

Share this post


Link to post
Share on other sites

Hi,

 

I'm going through the process of switching from Protx Forms to Direct - is there anything in particular I need to do / get Protx to do?

 

Also, I have installed and configured an SSL cert fine for the server, and amended config.php so that ENABLE_SSL is true, but the checkout process is not using https:// at all - am I missing something here?

 

Thanks a lot, once this is up and running the site will look much more professional I reckon.

 

Also, Villa or Blues?

Share this post


Link to post
Share on other sites

If you purchased a template for your website then it's likely that the 'Dreamweaver Kiddie' who wrote it hardcoded all the links to http.

 

Vger

Hi,

 

I'm going through the process of switching from Protx Forms to Direct - is there anything in particular I need to do / get Protx to do?

 

Also, I have installed and configured an SSL cert fine for the server, and amended config.php so that ENABLE_SSL is true, but the checkout process is not using https:// at all - am I missing something here?

 

Thanks a lot, once this is up and running the site will look much more professional I reckon.

 

Also, Villa or Blues?

Share this post


Link to post
Share on other sites
If you purchased a template for your website then it's likely that the 'Dreamweaver Kiddie' who wrote it hardcoded all the links to http.

 

Vger

 

Nope, this was done from scratch, although it does use STS template system.

 

In theory, should that one change in /includes/configure.php make SSL checkout work?

 

Thanks...

Share this post


Link to post
Share on other sites
No, you also need to input the https addresses.

 

Vger

 

Thanks, I've got that sorted.

 

Sorry to bombard you (all) but, although I seem to have got this working, I have one more question.

 

When you use the Protx Form method, the seller gets an email from Protx to say that payment has been taken. This is in addition to the email from osCommerce containing the order details. Does the seller still get this email when using Protx Direct?

 

Thanks for all the help...

Share this post


Link to post
Share on other sites

No. protx doesn't send emails to either the vendor or the customer when using the direct method - the point with the direct method is that it is all supposed to be handled by the vendors system - in this case osCommerce.

 

Tom

Share this post


Link to post
Share on other sites
No. protx doesn't send emails to either the vendor or the customer when using the direct method - the point with the direct method is that it is all supposed to be handled by the vendors system - in this case osCommerce.

 

Tom

 

Thanks for all the help, it's up and running great. As a thank you, name the charity of your choice and I'll make a donation.

Share this post


Link to post
Share on other sites

Hi, having a problem... orders below ?1000 work fine, over ?1000 and the user gets an error saying "The amount is non-numeric"

 

anyone know why the customer would be getting that error?

 

thanx in advance

 

regards

Share this post


Link to post
Share on other sites

Is the customer sticking a comma into the sum, as in:

 

1,000

 

Vger

Share this post


Link to post
Share on other sites

Thanx for the reply...

 

No i have tried that myself... its deffinately to do with a comma in the 1,000 though as i have checked with protx...

 

I have removed it from admin panel and currencies, where else the comma be?

 

thanx

Share this post


Link to post
Share on other sites

In catalog/includes/modules/payment/protx_direct.php:

 

Find (line 310)

Amount => number_format($HTTP_POST_VARS['ord_total'], 2),

 

and replace with

Amount => number_format($HTTP_POST_VARS['ord_total'], 2,'.',''),

 

It was formatting any number over 1000 with the comma.

 

I'll add this to an update for the future.

 

Tom

Edited by perfectpassion

Share this post


Link to post
Share on other sites

Ah Tom, I'm back with more issues....

 

One of the sites I run is having a right problem with getting some customer details mixed up at order time.

 

Anyway, as a result I'm doing a total update to the latest full code drop as well as payment modules.

 

I'm it's up and running again and I've installed the latest version of the ProTX module, but am getting card errors...

 

1. When in test mode, I get the following error when I go to confirm order.

"- Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance." with no error before the -

 

 

2. So I've done a Server IP Test just to get the info out of the system...

 

"VPSProtocol=2.22&TxType=PAYMENT&Vendor=cmpstore&VendorTxCode=3008079345910657&
Amount=16.58&Currency=GBP&Description=Order+Number%3A+4754&CardHolder=Stewart+Gilray&
CardNumber=4929000000006&StartDate=0305&ExpiryDate=0309&IssueNumber=&CV2=123&
CardType=VISA&CustomerEMail=XXXXXX.com&ContactNumber=01943+850299&
BillingAddress=XXXXXXXX&BillingPostCode=XXXXX&DeliveryAddress=XXXXX&DeliveryPostCode=XXXXX&
CAVV=&XID=&ECI=&ClientIPAddress=192.168.0.3&
Basket=2%3ATAPFS+-+Live+in+Liverpool+-+PAL%3A1%3A15%3A0.00%3A15.00%3A15.00%3AShipping%3A1%3A1.58%3A----%3A1.58%3A1.58&3DSecureStatus="

 

I remember I had this problem before, but for the life of me I can't remember how to fix it...

Edited by Stewart Gilray

Share this post


Link to post
Share on other sites

Please can you help me get things running smoothly?

 

I've got this contribution running on OS2.2, with SSL enabled. I have Curl enabled through PHP. When I do a Server IP Test, I've checked that the IP that comes up in the post is correct on my Protx account. Then when I do a Test, I get the error message "Couldn\'t create a transaction (VRTXInvalidIPAddress". Please can somebody help? I've looked through this topic but couldn't find a solution. I've tried adding the extra Curl related lines in includes/modules/payment/protx_direct.php. I'm also emailing my host to see if there's a shared IP address I need to add.

 

Thanks in advance,

Tatty

Share this post


Link to post
Share on other sites

Hi Tatty,

 

If you do a test transaction with the Server IP test mode on then PM me the details I'll look through (I wouldn't post the details here as there are some sensitive details).

 

Tom

Share this post


Link to post
Share on other sites
Hi Tatty,

 

If you do a test transaction with the Server IP test mode on then PM me the details I'll look through (I wouldn't post the details here as there are some sensitive details).

 

Tom

 

Hi Tom,

 

Thanks for your really kind offer. I've managed to get it working now (phew!) and thought someone else might find this useful: the reason it wouldn't work is because Protx wouldn't accept my Preauth transactions. They only want real time transactions. So in admin I set Authorization Type to PAYMENT and now all is well.

 

Thanks again Tom,

Tatty

Share this post


Link to post
Share on other sites

Hi,

 

I am having problems with protx direct.

 

I can make a transaction, and refund the transaction in the testing environment - as required from protx direct. However whenever I make a transaction successfully, it doesn't show up in oscommerce or send me to the checkout_success.php page. It instead throws me back to the credit card page, with no message.. In the address bar though, there appears to be an error message hiding there:

 

https://www.directbikes.uk.com/checkout_pay...9f23e93111eac5b

 

Please help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×