Jump to content
Sign in to follow this  
perfectpassion

Protx Direct v2.22

Recommended Posts

I'm trying to get this working but I'm struggling ...

 

Apparently v2.23 of protx is the only version now available in the simulator and so this contrib won't work as is (I want to try it out before signing up for a Protx account). I tried the obvious of changing

var $protocol = '2.23';

 

but it now fails with the error:

 

MALFORMED - If the BillingPostCode is supplied, you must provide all non optional Billing details.

 

 

I've tried adding BillingFirstNames and BillingSurname to the section below but still no luck. Anybody got it working on 2.23 - or got any ideas on what needs to be done? Any help greatly appreciated

 

 $submit_data = array(
     'VPSProtocol' => $this->protocol,
     'TxType' => MODULE_PAYMENT_PROTX_DIRECT_AUTHORIZATION_TYPE, // Transaction Type
     'Vendor' => MODULE_PAYMENT_PROTX_DIRECT_VENDOR_NAME, // Vendor Login ID
     'VendorTxCode' => $VendorTxCode,  // Unique Transaction ID
     'Amount' => $this->format_raw($order->info['total']),
     'Currency' => $order->info['currency'],
     'Description' => $order_description,
     'CardHolder' => substr($_POST['protx_direct_cc_owner'],0,50),
     'CardNumber' => $_POST['protx_direct_cc_number_nh-dns'],
     'StartDate' => (tep_not_null($_POST['protx_direct_cc_start_month']) ? $_POST['protx_direct_cc_start_month'] . $_POST['protx_direct_cc_start_year'] : ''),
     'ExpiryDate' => $_POST['protx_direct_cc_expires_month'] . $_POST['protx_direct_cc_expires_year'],
     'IssueNumber' => (tep_not_null($_POST['protx_direct_cc_issue']) ? $_POST['protx_direct_cc_issue'] : ''),
     'CV2' => $_POST['protx_direct_cc_cvv_nh-dns'],
     'CardType' => $_POST['protx_direct_cc_type'],
  'BillingFirstNames' => substr($order->customer['firstname']),
 	  'BillingSurname' => substr($order->customer['surname']),
     'BillingAddress' => substr($billing_add,0,200),
     'BillingPostCode' => substr($order->billing['postcode'],0,10),
     'DeliveryAddress' => substr($delivery_add,0,200),
     'DeliveryPostCode' => substr($order->delivery['postcode'],0,200),
     'CustomerName' => substr($order->customer['firstname'].' '.$order->customer['lastname'],0,100),
     'ContactNumber' => substr($order->customer['telephone'],0,20),
     'CustomerEMail' => substr($order->customer['email_address'],0,255),
     'ClientIPAddress' => tep_get_ip_address(),
     'Basket' => $basketlist,
     'AccountType' => MODULE_PAYMENT_PROTX_DIRECT_MERCHANT_ACCOUNT,
     'Apply3DSecure' => $use_3D_Secure
   );

Share this post


Link to post
Share on other sites

You are correct - the Simulator only supports protocol v2.23 - this module is currentl v2.22 which will work indefinately against the test and live servers but not the simulator.

 

I will be update the code as soon as I get time between paid work.

Share this post


Link to post
Share on other sites

Hi all,

 

I successfully installed this contribution yesterday, and all tests have worked with Protx in terms of accepting card payments and refunds, but I have a couple of queries.

 

When I am logged into the site, and add something to my cart, and then click Checkout, I get the message "Note: Your "Visitors Cart" contents will be merged with your "Members Cart" contents once you have logged on. [More Info] and have to re-log in again. It wasn't doing this until I activated the Protx module. I do currently have the catalog folder (standard and secure areas), password protected until the site is finally ready to go live, so I am hoping this is the reason.

 

Secondly, if I click CVV Number (More Info), I get the animated gif, but nothing happens - the site just hangs. Looking at the jpegs supplied with the contribution, I should see a pop-up graphic showing where the CVV number is. Is this a known problem?

 

Jonathan

Edited by JonathanR

Share this post


Link to post
Share on other sites

I can't think of any reason why the protx module would cause the login session to be lost.

 

Regarding the CVV popup - where does the link point to (rt click-properties) - if it looks like FILENAME_POPUP_CVV then you need to add the line from the install script to /includes/filenames.php

Share this post


Link to post
Share on other sites

I get this error when trying to place an order using Protx Direct 2.22 with 3D-Secure enabled:

 

Not Found

 

The requested URL /shop/protx_process.php/action/iframe/termurl/http://myurl.org.uk/shop/protx_process.php/action/3Dreturn/protx_id/8 was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at myurl.org.uk Port 80

 

Obviously, I've replaced 'myurl' instead of the domain name.

 

If I turn 3D-Secure off then the payments go through fine - 3D-Secure is enabled in my Protx control panel and I have the IP address of the server added into the Protx account.

 

Someone might have a really simple solution to this which would save me spending hours trying to figure it out - I have no programming abilities - installing/configuring the shopping cart and protx direct module is just about the extent of my abilities.

Share this post


Link to post
Share on other sites

I'm trying to upgrade from v4.3 to v4.4. (And hopefully from there to v5!)

 

I thought it probably wouldn't be necessary to uninstall the module in admin then reinstall it after upgrading as there are just changes to pages. But am I wrong here?

 

I've currently upgraded all pages except for catalog>protx_process.php.

 

There have been three different errors when I've tried to upgrade this one:

1 - to do with sql, something about '-catalog'

2 - there was an extra '}' in checkout_process (which I removed and now works fine, but it wasn't a problem before)

3 - 4020 : Information received from an Invalid IP address. The value was... my web host's IP (which isn't listed in Protx Admin, but is this to do with me not uninstalling and reinstalling?)

 

Just a bit nervous of going further at this point!

Share this post


Link to post
Share on other sites

You don't need to upgrade through the versions - you can jump straight in with v5!

 

1 - to do with sql, something about '-catalog'
- could you please be more specific about the error
3 - 4020 : Information received from an Invalid IP address. The value was... my web host's IP (which isn't listed in Protx Admin, but is this to do with me not uninstalling and reinstalling?)
this is not related to the installation - simply add the IP to the protx admin area.

Share this post


Link to post
Share on other sites

Thanks Tom. I'm sticking at 4.4 for now, I've got it working and lots of transactions have gone through fine.

 

I've just had one small issue this morning where the same order number has been allocated to two different orders in protx admin, although in oscommerce admin they've got different order numbers. Is there anything I should do about this?

 

Thanks!

Tatty

Share this post


Link to post
Share on other sites

Unfortunately that's a flaw with oscommerce itself and may happen from time to time if you have a busy site - it won't cause any harm but just be aware of it when reconciling your transactions

Share this post


Link to post
Share on other sites

Thanks Tom, that's good to know.

 

Is there any advice you can give on cutting down on our Failed transactions? Usually these have CV2, PC and ADDRESS marked as "not provided" in Protx admin, and the reason given for failure is "Transaction failed Protx validation. Either an INVALID or MALFORMED response was returned."

 

Is this just customers not filling stuff in properly, or is there something I can do?

 

Thanks,

Tatty

Share this post


Link to post
Share on other sites

Hi Tom,

I've just seen a couple of emails today about "ProTX" becoming "SagePay" are you rebranding and making any chances to your contrib for this?!

 

IE are there any URL changes too?!

Share this post


Link to post
Share on other sites

There are URL changes which they have today released and will take effect on 21st April.

 

I'm trying to find out from them if the old urls will continue to work past this date and also if we can use the new urls before that date (for live services). Once I have that info I'll release an update to the module.

 

I'm in the process of updating the module from v2.22 to v2.23 - part of the update includes the possibilty of including the paypal via Protx integration - is anyone interesed in this?

Share this post


Link to post
Share on other sites

v5.1 Uploaded

 

This supports the v2.23 protocol and new SagePay URLs. This version does not yet support the PayPal integration.

 

Please note that this module will not yet work in live mode until Protx launch the new SagePay URLs on Tues 21st April - it does however work successfully in Simulator and Test modes.

 

Version 5.0c should continue to work after the switch over as Protx are putting in URL redirects however you may have to change the "Disable cURL SSL check" to true in your osC admin settings to prevent SSL cert error messages.

 

I'm afraid we'll have to watch this space and see what happens - I think we all have experience of how badly upgrades and system changes tend to go at the Protx end :-(

Share this post


Link to post
Share on other sites

Hi PerfectPassion

 

With regard to the new contribution - when Protx make the change to Sagepay, will the previous versions of your Protx add-ons still work?

Edited by Jan Zonjee

Debbie Harrison

 

Share this post


Link to post
Share on other sites

In theory the existing modules should continue to work as Protx are enabling URL redirects rfom old to new (though I don't know how long they will be in place for).

 

However we can't test this until switch over day unfortunately.

Share this post


Link to post
Share on other sites

It is due for Tuesday 21st April (tomorrow) - Protx believe in giving customers plenty of notice - the email from them only arrived 4 days ago!

Share this post


Link to post
Share on other sites

It did come about by surprise didn't it...

 

Tom, do you think you'll be doing any updates when the switch goes live, IE is it worth getting this version, or wait just in case?

Share this post


Link to post
Share on other sites

Personally I'm not updating my live store yet but will be watching transactions carefully on the day and then perform the update in a few days i things seem ok however if it grinds to ahalt I've got the new module ready - its simply a case of overwriting the existing file with the new (assuming you are currently using a v5 version of the module)

Share this post


Link to post
Share on other sites

I installed at the end of July 2008. I have no idea if thats version 5 or what?

Edited by dvharrison

Debbie Harrison

 

Share this post


Link to post
Share on other sites

v5 was released in october so it's likely it will be v4.4 instead - upgrading from v4.4 to v5 requires a little bit more work than just dropping the files in but the instructions are included and quite straightforward.

Share this post


Link to post
Share on other sites

the most stupid move i have ever seen. when the brand name protx after all these years is about to be known increasingly by many both consumers & traders it now all a sudden decides to abandon it and change it to who knows "sagepay". even in next week's internet world held in London, they still use the brand name protx and "sagepy" is no where to be seen.

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hi Gemrock

 

I shall definitely look out for that next week as I am going to the same event.

 

Also just took a look at Protx's website and at the moment it justs mentions they are part of Sage UK but thats it.

Edited by dvharrison

Debbie Harrison

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×