Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
Guest

Protx Direct v2.22

Recommended Posts

Quantrum - what you have copied is correct - that is what should appear when it is set to "Server IP Test". What you need to do is add the IP shown (REMOTE_HOST) to the Protx admin areas. This needs doing 3 times - once each for the Simulator, test and live accounts. Then change the settings in your osC admin to "Simulator" or "test" and then try a few transactions.

 

So I need to take the IP address from the Remote_host tag on the page full of text, and place it on the protx admin area where it says Valid IP Addresses or is it somewhere else ?

 

sorry I know this makes me sound so dumb, i feel it...and thanks for the help Tom

Share this post


Link to post
Share on other sites
Guest

yes thats it - but it needs doing for each of the 3 servers

 

Tom

Share this post


Link to post
Share on other sites
yes thats it - but it needs doing for each of the 3 servers

 

Tom

 

the actual IP only shows up when I try it via serveriptest...the others all seem to produce random errors saying there's a problem with the mysql table.

Share this post


Link to post
Share on other sites

Right I've been on the phone to protx about it all and everythings sorted now its just going live with it...i've made the alterations it tells me to do...but i cant figure out whats next, looking online at the protx help stuff doesnt provide any answers in the slightest.

 

Would anybody be able to give me like a step by step on turning the cart live what I have to do in the admin section please.

 

Thanks

 

Mark

Share this post


Link to post
Share on other sites
Guest

You need to place some test orders with the protx module set to "Test server", then contact Protx and ask to "Go Live" - once live you can set the module to "production" and that's it!

 

Tom

Share this post


Link to post
Share on other sites

I've done the test orders and everything then they said set it to golive and then run a couple of test transactions.

 

so do i have to set it to production, run a couple tests off my own cards and refund them to myself, then put it up online....its confussing me so much

Share this post


Link to post
Share on other sites
Guest

if it works fine in test, it *should* work fine live but you absolutely right to try some real cards (in Production mode) to make sure it works. If you place the order then VOID the transaction in your admin you will avoid having to pay the merchant fees on the transactions (you can only void if it has not been settled - this happens overnight).

 

Tom

Share this post


Link to post
Share on other sites

TEST SERVER :

Request URL=https://ukvpstest.protx.com/vspgateway/service/vspdirect-register.vsp
Data string sent=VPSProtocol=2.22&TxType=PAYMENT&Vendor=ELECTROR&VendorTxCode=58-41659590605760574255700186200881&Amount=39.94&Currency=GBP&Description=Order+Number%3A+58&CardHolder=awais+tahir&CardNumber=5404000000000001&StartDate=0607&ExpiryDate=0409&IssueNumber=&CV2=123&CardType=MC&BillingAddress=london%2C%0D%0Alondon%2C%0D%0ALondon.%2C%0D%0AUnited+Kingdom&BillingPostCode=e1+2lj&DeliveryAddress=london%2C%0D%0Alondon%2C%0D%0ALondon.%2C%0D%0AUnited+Kingdom&DeliveryPostCode=e1+2lj&CustomerName=awais+tahir&ContactNumber=079&CustomerEMail=admin%40dastylex.com&ClientIPAddress=86.27.69.254&Basket=2%3ACanon+Filter+UV+absorbing+72+mm%3A1%3A25.00%3A4.38%3A29.38%3A29.38%3AShipping%3A1%3A10.56%3A----%3A10.56%3A10.56&AccountType=E&Apply3DSecure=0
Protx response=VPSProtocol=2.22
Status=3DAUTH
StatusDetail=2007 : Please redirect your customer to the ACSURL, passing the MD and PaReq.
3DSecureStatus=OK
MD=2011955582003193058
ACSURL=https://ukvpstest.protx.com/mpitools/accesscontroler?action=pareq
PAReq=eJxlUl1vgjAUfd+vILwuoS0fAuZa49RkLmMy5qJ77KAZJAJaYMP9+rUI02Vv95yennvvaWHa5n
vtk4sqK4uJTgysT+kNbFLB+eKFx43gFAJeVeyDa1ky0U1MiO84jmdibBHfwo6nUwhnET9S6H2otDEIoAF
KAxGnrKgpsPh4t3qijo1tawSoh5BzsVr0rIOtkUlcTxqcaShYzunycTnfROsomEUbY74OAHU0xGVT1OJE
PVP6DQAasadpXR/GCG23W+P/ZSUAdBksbFRVScM2S+ioZrtTuvHfvtPglkXP7667wA+7/e7rdQJIKSBhNacyBJcQE2uEjC08xhhQxwPL1STU8n1bbnkGcFA9Ztcn1wzIsAUv4mGVAQFvD2XBpcIE9
FtDwquYhqKsWy0IV7KvwoAue8zvVdxxLRMkKumuUmaZDAj72O7cFACktKh/RNQ/t6z+fIMfit+yFg==
Response array=Array
(
[VPSProtocol] => 2.22
[Status] => 3DAUTH
[StatusDetail] => 2007 : Please redirect your customer to the ACSURL, passing the MD and PaReq.
[3DSecureStatus] => OK
[MD] => 2011955582003193058
[ACSURL] => https://ukvpstest.protx.com/mpitools/accesscontroler?action=pareq
[PAReq] => eJxlUl1vgjAUfd+vILwuoS0fAuZa49RkLmMy5qJ77KAZJAJaYMP9+rUI02Vv95yennvvaWHa5nvtk4sq
K4uJTgysT+kNbFLB+eKFx43gFAJeVeyDa1ky0U1MiO84jmdibBHfwo6nUwhnET9S6H2otDEIoAFKAxGnr
KgpsPh4t3qijo1tawSoh5BzsVr0rIOtkUlcTxqcaShYzunycTnfROsomEUbY74OAHU0xGVT1OJEPVP6DQ
AasadpXR/GCG23W+P/ZSUAdBksbFRVScM2S+ioZrtTuvHfvtPglkXP7667wA+7/e7rdQJIKSBhNacyBJcQE2uEjC08xhhQxwPL1STU8n1bbnkGcFA9Ztcn1wzIsAUv4mGVAQFvD2XBpcIE9
FtDwquYhqKsWy0IV7KvwoAue8zvVdxxLRMkKumuUmaZDAj72O7cFACktKh/RNQ/t6z+fIMfit+yFg==
)

curl_error=

 

hi TOM, i was the one with godaddy hosting issue.. and after that my protx was working just fine .. but today i have started having this problem as described above!

this problem came out of no where! all the transactions were going thru yesterday.. but today it is giving out errors in test mode as well as live mode!

i cant reinstall the shop as brownowl did.. wht should i do?

i really need the solution as soon as possible..

i tried removing the godaddy curl thing but it didn't helped me either!

thanx

Edited by nahi_sonu

outside links are not allowed in signatures

Share this post


Link to post
Share on other sites
Guest

could you elaborate on what the problem you are experiencing is?

 

The debug you provided is the normal response for a 3D-Secure card prior to redirection to the bank - there are no errors there.

 

Tom

Share this post


Link to post
Share on other sites

now i tried again with test server and i am getting this debug status..

 

Request URL=https://ukvpstest.protx.com/vspgateway/service/vspdirect-register.vsp
Data string sent=VPSProtocol=2.22&TxType=PAYMENT&Vendor=ELECTROR&VendorTxCode=58-71996221985718705342561298969179&Amount=51.69&Currency=GBP&Description=Order+Number%3A+58&CardHolder=awais+tahir&CardNumber=4929000000006&StartDate=0107&ExpiryDate=0409&IssueNumber=&CV2=123&CardType=VISA&BillingAddress=london%2C%0D%0Alondon%2C%0D%0ALondon.%2C%0D%0AUnited+Kingdom&BillingPostCode=e1+2lj&DeliveryAddress=london%2C%0D%0Alondon%2C%0D%0ALondon.%2C%0D%0AUnited+Kingdom&DeliveryPostCode=e1+2lj&CustomerName=awais+tahir&ContactNumber=079&CustomerEMail=admin%40dastylex.com&ClientIPAddress=86.27.69.254&Basket=2%3ACanon+Filter+UV+absorbing+72+mm%3A1%3A25.00%3A4.38%3A29.38%3A29.38%3AShipping%3A1%3A10.56%3A----%3A10.56%3A10.56&AccountType=E&Apply3DSecure=2
Protx response=VPSProtocol=2.22
Status=OK
StatusDetail=0000 : The Authorisation was Successful.
VPSTxId={076E4AF9-4346-BC60-D374-D89B2B7910CA}
SecurityKey=4YCML0KICZ
TxAuthNo=3629646
AVSCV2=SECURITY CODE MATCH ONLY
AddressResult=NOTMATCHED
PostCodeResult=NOTMATCHED
CV2Result=MATCHED
3DSecureStatus=NOTCHECKED
Response array=Array
(
[VPSProtocol] => 2.22
[Status] => OK
[StatusDetail] => 0000 : The Authorisation was Successful.
[VPSTxId] => {076E4AF9-4346-BC60-D374-D89B2B7910CA}
[SecurityKey] => 4YCML0KICZ
[TxAuthNo] => 3629646
[AVSCV2] => SECURITY CODE MATCH ONLY
[AddressResult] => NOTMATCHED
[PostCodeResult] => NOTMATCHED
[CV2Result] => MATCHED
[3DSecureStatus] => NOTCHECKED
)

curl_error=

on protx admin panel transaction is showing as successfull.. but on site.. it is still showing in my basket.

wht should i do?


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites
Guest

again the debug is completely normal.

 

What is the actual problem you are experiencing? You say it still shows in your basket but what happens when you place the order - does it go the the success page, doe sit go back the the payment page, is the screen blank etc etc etc - you need to say what the problem is.

 

You also say that everything was fine until today - what changed? - something must have changed with your site or server.

 

Tom

Share this post


Link to post
Share on other sites

i disabled the debug mode to see what exactly the last page is showing.. and without debug mode.. it is showing me one more error...

 

2013 - Lost connection to MySQL server during query

update protx_direct set customer_id = '16', order_id = '58', vendortxcode = '58-26014950238986207653069109617730', txtype = 'PAYMENT', value = '39.94', vpstxid = '{7FA424BF-68ED-493A-99E2-5D2B4FCC5F14}', status = 'OK', statusdetail = '0000 : The Authorisation was Successful.', txauthno = '3629683', securitykey = 'PCRD9ZAURM', avscv2 = 'SECURITY CODE MATCH ONLY', address_result = 'NOTMATCHED', postcode_result = 'NOTMATCHED', CV2_result = 'MATCHED', 3DSecureStatus = 'NOTCHECKED', CAVV = '', txtime = '2007-11-20 05:27:51' where id = '0'

[TEP STOP]


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites

but the transaction on protx is successfull .. i can see the user, product purchased, address and everything on protx server! but on my site.. it is just showing the error above.. and the product is still in the basket!


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites
Guest

the above is not an error - it is the debug dump - it is only displayed if you turn it to true in your site admin (under payment modules) - you must have done that inadvertently if you weren't try to get the to display. Your basket will not empty if debug is set to true.

 

Turn it to false and your "problem" will be fixed.

 

Tom

Share this post


Link to post
Share on other sites

yeah i guess that worked out! thanks alot mate!

hey tom.. are you on yahoo messenger? can we talk there for few min? please?


outside links are not allowed in signatures

Share this post


Link to post
Share on other sites

I have installed this and am using the Test server. When ever I get to the final page I get:

 

Credit Card Error!

 

Any suggestions as to what I need to do to fix this?

 

Thanks

Share this post


Link to post
Share on other sites
I have installed this and am using the Test server. When ever I get to the final page I get:

 

Credit Card Error!

 

Any suggestions as to what I need to do to fix this?

 

Thanks

 

I got this sorted - wrong IP address.

 

I have two remaining questions - 1 is where can I get the missing 3Dsec_help.php file from to go into includes/languages/english/modules/payment

 

The other is this:

 

I have received this information from PROTX:

 

You MUST NOT process MOTO (telephone) orders via an e-commerse website. Telephone orders need to be processed as MOTO transactions, which means either developing your own admin area to submit details to protx flagged as "AccountType=M", or you need to be processing them via the VSP Terminal as provided by Protx in your VSP Admin Area.

 

I thought that if I took a telephone order I could create a customer and place an order on their behalf on the website - it seems not - how do other people process telephone orders?

 

Thanks

Share this post


Link to post
Share on other sites
Guest

The 3Dsec_help.php file is in the v4.4 .zip file - one in the /catalog and one in /catalog/includes/languages/english (they are the same name but different files).

 

Regarding MOTO - it is the merchant banks that set this rule (different risk levels with online vs mail order / telephone) apparently you should have 2 separate merchant IDs for each as the banks may charge diffrent fees etc. There is also the issue of 3D-Secure - it is compulsory for Maestro online transactions (optiona of other cards) but is not used at all for MOTO so that will be the main problem for processing orders in the way that you say.

 

Tom

Share this post


Link to post
Share on other sites
The 3Dsec_help.php file is in the v4.4 .zip file - one in the /catalog and one in /catalog/includes/languages/english (they are the same name but different files).

 

Regarding MOTO - it is the merchant banks that set this rule (different risk levels with online vs mail order / telephone) apparently you should have 2 separate merchant IDs for each as the banks may charge diffrent fees etc. There is also the issue of 3D-Secure - it is compulsory for Maestro online transactions (optiona of other cards) but is not used at all for MOTO so that will be the main problem for processing orders in the way that you say.

 

Tom

Tom

 

Many thanks for your reply. This is a fantastic contribution by the way.

 

I have been told I can process telephone orders over the web for protx so long as I flag these orders with "AccountType=M", do you have any idea how I can do this? How do other people take telephone orders?

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites

You need to have your Protx account set up for MOTO (Mail Order - Telephone Order), and then you can log in to your Protx Terminal and take orders over the phone.

 

Vger

Share this post


Link to post
Share on other sites
You need to have your Protx account set up for MOTO (Mail Order - Telephone Order), and then you can log in to your Protx Terminal and take orders over the phone.

 

Vger

 

But how do I take these products out of my shop - I know I can take orders via the VSP Terminal, but this doesn't let me remove the stock form my shop or let the customers track there order etc? The VSP Terminal just lets you make the payment, there's no integration with the shop so I'm really confused about how I process these orders and have a track of them in my oscommerce shop - or can I just not do that?

 

If I'm understanding it correctly I need to do the following:

 

Check with my merchant bank if they are able to accept telephone orders or ask if a need a new separate merchant number.

 

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites
Guest
But how do I take these products out of my shop - I know I can take orders via the VSP Terminal, but this doesn't let me remove the stock form my shop or let the customers track there order etc? The VSP Terminal just lets you make the payment, there's no integration with the shop so I'm really confused about how I process these orders and have a track of them in my oscommerce shop - or can I just not do that?

 

If I'm understanding it correctly I need to do the following:

 

Check with my merchant bank if they are able to accept telephone orders or ask if a need a new separate merchant number.

Thanks

 

Lotti

 

When we get a phone order we just create an invoice in excel and send the item that way. We then reduce the stock from the site.

 

Have a problem of my own:

 

A couple of customers have phoned up and told us that they get a fatal error during the Protx Process. The order still goes through fine. Anyone had the same problems, if so how do you fix it.

Share this post


Link to post
Share on other sites
Guest

Urgent help needed, with regards to the above post after hitting confirm checkout it is showing:

 

Warning: main(includes/languages/english/checkout_success.php) [function.main]: failed to open stream: No such file or directory in /home/deviltro/public_html/checkout_success.php on line 50

 

Warning: main(includes/languages/english/checkout_success.php) [function.main]: failed to open stream: No such file or directory in /home/deviltro/public_html/checkout_success.php on line 50

 

Warning: main(includes/languages/english/checkout_success.php) [function.main]: failed to open stream: No such file or directory in /home/deviltro/public_html/checkout_success.php on line 50

 

Fatal error: main() [function.require]: Failed opening required 'includes/languages/english/checkout_success.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/deviltro/public_html/checkout_success.php on line 50

 

The payment goes through fine, but shows the above

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×