Jump to content
Sign in to follow this  
perfectpassion

Protx Direct v2.22

Recommended Posts

There's no way at the moment to tell what is happening with particular sites - not until Protx get things sorted out at their end.

 

If you still have problems when Protx is fully working then post back.

 

You can go to the Protx Support Forums for feedback on the current state of play.

 

Vger

 

 

Many thanks Vger

 

I kind of guessed that this would be the case ... but thought I'd ask just in case.

 

If I had hair I'd be pulling it out.

 

JK

Share this post


Link to post
Share on other sites
This is just poor on the part of Protx. They've screwed up a few times recently, and now they've done it again.

 

There's no excuse for a big operator like them not testing out the new system thoroughly before switching it Live. And obviously they didn't test it thoroughly or else it would be working now.

 

Vger

 

 

Couldn't agree more .. can you imagine the amount of money that's being lost by internet shops that JUST use PROTX!!!

 

Thank god I still have PayPal and Google checkout!!! Haven't lost a sale ... yet <touches wood>

 

Oh well it gave me a chance to upgrade to the latest version and change to the new URLs.

 

Just have to hope it works when PROTX goes live again LOL.

Edited by Babygurgles

Share this post


Link to post
Share on other sites
Couldn't agree more .. can you imagine the amount of money that's being lost by internet shops that JUST use PROTX!!!

 

Thank god I still have PayPal and Google checkout!!! Haven't lost a sale ... yet <touches wood>

 

Oh well it gave me a chance to upgrade to the latest version and change to the new URLs.

 

Just have to hope it works when PROTX goes live again LOL.

 

 

 

are the new URL's part of v4.3 ?

 

or is there something else I need to change etc

 

jk

Share this post


Link to post
Share on other sites
are the new URL's part of v4.3 ?

 

or is there something else I need to change etc

 

jk

 

PROTX requires new URLs which are not present in v4.3 (which uses the old URLs)

 

However it is not a problem as PROTX will be redirecting old URLs to new.

 

Tom will update the package to the new URLs as and when.

Edited by Babygurgles

Share this post


Link to post
Share on other sites
However it is not a problem as PROTX will be redirecting old URLs to new

 

Unfortunately the redirects are one of the many things not working.

 

Vger

Share this post


Link to post
Share on other sites
Unfortunately the redirects are one of the many things not working.

 

Vger

 

 

Oh lol!

Share this post


Link to post
Share on other sites
The new URLs are not in 4.3

 

PROTX requires new URLs which are not present in v4.3 (which uses the old URLs)

 

However it is not a problem as PROTX will be redirecting old URLs to new.

 

Tom will update the package to the new URLs as and when.

 

 

cool .... my brain is fudge just now ... the a slightest thing is anxiety inducing.

I've lost a couple of thousand today already plus the possibility of repeat business from those customers.

 

I may have to resort to sedatives

 

JK

Share this post


Link to post
Share on other sites
I may have to resort to sedatives

 

Resort to Pay Pal instead - until Protx get things sorted out.

 

Vger

Share this post


Link to post
Share on other sites

Protx just went live.

 

I tried it but got ...

 

Transaction Timed Out at Authorisation Stage.

 

Anyone else testing?

Share this post


Link to post
Share on other sites

Is it just me, or is everyone else ending up on the first page of threads when they come to the forum, instead of on the last page they viewed?

 

Vger

Share this post


Link to post
Share on other sites

Just put a transaction through myself but the authorisation took an age. I thought it was going to time out again!

Share this post


Link to post
Share on other sites
Is it just me, or is everyone else ending up on the first page of threads when they come to the forum, instead of on the last page they viewed?

 

Vger

 

 

Yup .. annoying isn't it.

Share this post


Link to post
Share on other sites

Ok

 

Just taken my first successful PROTX order of today (that wasn't me).

 

Seems to be working but I'll keep my eye on it.

Share this post


Link to post
Share on other sites

I have just got my 1st transaction through after the Protx "All is well" announcement. Between then and now I kept getting a technical error reported, and have just found the following error meesage in the Protx table for all transactions:

 

3021 : The Basket format is invalid. The value was 3:Medium and Large Paw Tag:1:9.48:0.00:9.48:9.48:

 

 

I have ust changed the PROTX module config so that the shopping cart details are not being passed across, and now my live account is functioning again.

Edited by allrightpet

Share this post


Link to post
Share on other sites

I've undone all my v4.3 integration efforts and am now back with v3.1

 

all seems to be working ok

 

I think I'll wait till protx have their house in order before I try to upgrade to v4.3

 

jk

Share this post


Link to post
Share on other sites

As it seems its my day for posting crap in this thread, here's another :D

 

Adding a daft little timer clock to v4.3 (timer.gif attached to this post)

 

FIND in catalog>protx_process.php

 

<center>Your payment is being processed<p>Please wait a few seconds.</p></center>

 

Replace with ..

 

		  <center>Your payment is being processed<p>Please wait a few seconds.</p></center><p />
	  <div align="center">' . tep_image(DIR_WS_IMAGES . 'timer.gif', 'Checkout timer', '50px', '50px') . '</div>

 

Upload timer.gif to catalog>images

 

Done!

 

Vger/perfectpassion You are welcome to use this daft little extra if you so wish. (or just make a better one for me to use :P)

Share this post


Link to post
Share on other sites

Anybody else getting the invalid basket error. I turned the 'send shopping cart' off and it's working OK at the moment. Has anyone managed to come up with a fix so this can be turned back on? :-"

Share this post


Link to post
Share on other sites

Hello all... after reading through some of this thread I was wondering if v4.3 is the best version to go for - what do ytou all think?

 

THanks

 

Andy

Share this post


Link to post
Share on other sites
Hello all... after reading through some of this thread I was wondering if v4.3 is the best version to go for - what do ytou all think?

 

THanks

 

Andy

 

In my opinion there is no downside whatsoever to using the latest version v4.3.

 

Or putting it the other way around I see no benefit in using the older versions.

Share this post


Link to post
Share on other sites
Anybody else getting the invalid basket error. I turned the 'send shopping cart' off and it's working OK at the moment. Has anyone managed to come up with a fix so this can be turned back on? :-"

 

Exact same problem and same temporary solution. Is there a fix?

Share this post


Link to post
Share on other sites

What a day! Even made the BBC (http://news.bbc.co.uk/1/hi/business/6925991.stm.

 

It seems to be working at the moment - lets hope it stays stable - I have noticed that some transaction are slow to process. Whilst tresting these and staring at the screen waiting I had exactly the same idea as you Babygurgles - you've saved me having to put a graphic together to include in the next update (I'm going to leave it a little while just to make sure that the new Protx system has settled down first!).

 

Some people get the invalid basket error if the shipping is free - for now easiest to turn off the send basket - it is fixed in the upcoming version.

 

Tom

Share this post


Link to post
Share on other sites

Better version of the timer graphic

 

I must have too much time on my hands :D

Edited by Babygurgles

Share this post


Link to post
Share on other sites

Now had two orders where payment has been taken but the order hasn't been confirmed in oscommerce so there is no order. As I've had to turn "send basket contents" off, this is a real problem! Any idea? Thanks John

Share this post


Link to post
Share on other sites

I think that Protx are still having some timeout issues - if you look back a page or two in this thread there's an addition you can make to increase the timeout delay - that may help

 

Tom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×