Jump to content
Sign in to follow this  
r2006

uk postal rates contrib

Recommended Posts

I've installed the uk postal rates contribution, but although UK Royal Mail Standard Rates and UK Royal Mail Recorded Delivery modules show up in admin / modules / shipping I can't seem to make them active for some reason, even though they show up as being enabled (i.e. their value is 1 in the Enable Zones Method box)

 

no doubt I've missed something - any help appreciated. thanks.

Share this post


Link to post
Share on other sites

being active where? during checkout? If so check the shipping zones for these modules. Set the shipping zone of each one to "none" and retry.

Share this post


Link to post
Share on other sites

Hi,

 

I have installed exactly the same contribution and have the same problem.

 

When the 'Enable Zones Method' is set to '1' in Admin, you get 'This is currently the only shipping method available to use on this order.' at the checkout, but without any choice or cost being shown.

 

 

When the 'Enable Zones Method' is set to '0' in Admin, you get no shipping method at all.

 

Usually when you intstall a shipping method in the shipping module, you get a '0' appear in the sort order column. I don't get this when installing this.

 

Any suggestions why it is not working?

 

Thanks. Paul.

Share this post


Link to post
Share on other sites

When you installed did you overrided the zones.php file? Because as I understand all you need todo, is to add the values from the speadsheet to the zones of the osc. Now the osc files of this contribution are from 2002. If you did override them and you're using ms2.2 it explains the problem. You could restore from backup and then just implement the prices from the spreadsheet.

 

This is the contrib I am refering to:

http://www.oscommerce.com/community/contributions,272

Share this post


Link to post
Share on other sites
When you installed did you overrided the zones.php file? Because as I understand all you need todo, is to add the values from the speadsheet to the zones of the osc. Now the osc files of this contribution are from 2002. If you did override them and you're using ms2.2 it explains the problem. You could restore from backup and then just implement the prices from the spreadsheet.

 

This is the contrib I am refering to:

http://www.oscommerce.com/community/contributions,272

 

I had the same problem as above when I had it set as below

 

Zone 1 Countries

UK

 

But I then added GB as below and it now come up as an option when a customer wants to checkout.

 

Zone 1 Countries

UK,GB

 

But I have changed all the shipping rates so that I can set products in a certain catergory to a set weight and it will give then free delivery for up to 10 of the items which seem to work fine but when other products are put in the cart (None free delivery items) with the correct weights in it doesnt seem to be able to add it up right. The weight is correct but the prive in comes out on the cart doesnt match the price for the weight.

 

Here are the rates

 

1:0.00,60:0.30,100:0.46,150:0.64,200:0.79,250:0.94,300:1.07,350:1.21,400:1.40,45

0:1.59,500:1.78,600:2.15,700:2.52,750:2.71,800:2.90,900:3.27,1000:3.64

 

So any thing up to 1g is free, this is were I have set the cards at 0.1 so once they get to 10 it will add on the ?0.30 charge which seems to work.

 

But I have just done a test for the rest of the delivery and set one item at a 1g so I should be able to add 60 of then before it jumps up to the next delivery cost but for some reason it jumps to ?0.80 when I get to 40 and the weight is correct on the cart just is doesnt match the postage prices in admin. I have taken every thing of like % increase for large packages and there is handling fee and no tare weight but it still does it.

 

Hope someone can help and hope the GB helped you guys.

Share this post


Link to post
Share on other sites

I have a similiar problem, i managed to get the standard postal rates to work for uk and other selected countries, but i can't get the other method to work, it has no sort order in the listing in admin?

 

So what i did was to change the flat rate to "Special Delivery" so it pops up in the checkout as an additional postage option but i cant make it go away when international customers check out? Any idea's im totally lost...

 

Seems as if theres no easy and simple postage charging mods? or have i missed it as ive been through loads of them!!

 

Thanks in advance.

Paul..

Edited by boxmodz

Share this post


Link to post
Share on other sites

you can make it go away if you set the shipping zone for your Special Deliver module to be one that covers only UK.

Share this post


Link to post
Share on other sites

well, i tried that by setting it to european countries and setting zones_to_geo_zones zone_id to 1 and geo_zone_id to 1, also changed uk to geo_zone_id to 1 but its dissapeared.

 

If i change from european countries to none, it comes back??

 

Have i missed something or read too much into it.. :)

 

Paul..

Share this post


Link to post
Share on other sites

should be something with the module's code. Shipping modules should have a drop-down list to select the shipping zone (those zones are configured from the tax zones-details) and you shouldn't touch the dbase ids of the sql tables.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×