Jump to content

Recommended Posts

Thanks. I did not have the separation. But it looks like a maximum of 3 locations is allowed, is this correct? In changing the locations, I'm not sure why, but even after refreshing cache, an old marker location shows. It also looks like a maximum of 5 marker labels can be entered. I would like to show customer city locations, which could number 100 or greater. Is there a limitation on this?

There's no intentional limit but I had set the size for the location field to be 64 characters and that is what is limiting it. The label field is set to 20, which will also be too small for what you want to do. So you will need to edit the easymap table in the database and change those two fields to a higher number. You may also need to increase the maximum size of the form field in admin fro them so it allows you to enter longer strings. I'll make a note to change those in the next version.

Share this post


Link to post
Share on other sites

Thanks, Jack.

It looks like for getting the widest world view, zoom level 1 or 2 is probably best.

By making a period (.) as the marker label, all the marker locations look similar, and if I'm not mistaken, zoom is relative to Greenwich, so the more I zoom, the less I will see of west coast U.S., Europe and so on.

Is there a way for me to add a caption (for the city), when the mouse hovers over a particular marker? My marker locations only contain city and province / state / country without streets.

Share this post


Link to post
Share on other sites

Hi jack,

 

I want to integrate easy map on contact us page.

How can this be done ?

 

soeb


Thanks and Regards

 

Soeb Shaikh

Share this post


Link to post
Share on other sites

You would need to merge the code in the locate-us.php file once the contribution is installed.

Share this post


Link to post
Share on other sites

Hi Jack

 

Installed EasyMap 3.1 on my OSc 2.3.3 with no probls on catalog side but admin looks bit wrong, seems it still using some old 2.2 RC... code. See scheenshoot.

 

Also found in admin/easymap.php - TEXT_VERSION_CHECK_UPDATES, TEXT_MISSING_VERSION_CHECKER are not definded in language file and (visit the support thread) linked to Daily Specials.

 

http://www.trade24h.co.uk/screen.jpg

Edited by leveera

Share this post


Link to post
Share on other sites

I can't be sure but your image seems to show Easy Map in the Tools section. If that is the case, then you made a mistake since it has its own section.

 

For the missing definitions, you need to upload the Version Checker files. Just unzip it and upload the files in the admin directory to your admin directory.

 

Thanks for mentioning the wrong link. I will correct that.

Share this post


Link to post
Share on other sites

Hi Jack,

 

Thanks for reply

 

Sorry forgot to mention I moved easymap to Tools section, not mistake but just to avoid extra folder. Anyway the bug is same whenever easymap in own folder or under Tools menu.

 

Looks like

icons: {
'header': 'ui-icon-plus',
'headerSelected': 'ui-icon-minus'
}

 

are in wrong place on admin easymap page and it only like this in IE8

 

Also, admin/include/functions/easymap.php is empty file in last package

Edited by leveera

Share this post


Link to post
Share on other sites

I tested it in IE, FF and Chrome and it displays fine for me. And I compared the files in my test shop to be sure they are the same as the last release, which they are. So the display problem is either due to something in your admin or a mistake in the installation. As for the function file, thanks for mentioning that but isn't used so it should be empty.

Share this post


Link to post
Share on other sites

'ok, sorted.

 

Rendering prob in admin/easymap.php because my IE8 don't like

<style type="text/css"> .....</style>

where it is.

 

Simply deleted css block and replaced styles to available in default stylesheet.

Happy now )))

Edited by leveera

Share this post


Link to post
Share on other sites

Hi Jack,

Thanks for another great contribution.

 

4) In includes/languages/english/modules/boxes/bm_information.php

(and any language file you use), before the last ?>

 

ADD:

 

define('MODULE_BOXES_INFORMATION_BOX_EASYMAP', 'Locate Us');

 

That didn't work for me. Should be

 

define('MODULE_BOXES_INFORMATION_EASYMAP', 'Locate Us');

Share this post


Link to post
Share on other sites

Or maybe better to change this step and keep things written in the same way.

 

3) In includes/modules/boxes/bm_information.php

 

REPLACE

 

' <a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . MODULE_BOXES_INFORMATION_BOX_CONTACT . '</a>'

 

with

 

' <a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . MODULE_BOXES_INFORMATION_BOX_CONTACT . '</a><br>' .

' <a href="' . tep_href_link(FILENAME_EASYMAP) . '">' . MODULE_BOXES_INFORMATION_BOX_EASYMAP . '</a>'

Share this post


Link to post
Share on other sites

Ok i know I'm asking a lot of questions, I have figured them all out besides I can not see my map on my site..where should it be located for me to view?

Share this post


Link to post
Share on other sites

ok i see my map i had to add the information box but its showing the "LOCATE US" as 'MODULE_BOXES_INFORMATION_BOX_EASYMAP'

 

I have checked my files and everything is right

Share this post


Link to post
Share on other sites

Seeing text in capital letters usually means a definition is missing. In this case, it is in the languages file included with this addon so it seems you didn't upload everything.

Share this post


Link to post
Share on other sites

yay that fixed it! Now I should just be able to add all my locations and my customers can do a search?

Edited by partrade12

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×