Jump to content
Sign in to follow this  
Rigadin

[contribution] STS PLUS v4

Recommended Posts

If the infobox goes into a left or right column, then it has nothing to do with the content template. When you use a content template for your product_info.php page, another template is used for header, columns and footer (use the debug mode to see the path to this 'outside' template) and probably your infobox is missing on this one.

 

If the place of your infobox is under the content, then do like this (in the 'outside' template):

$content

$relatedbox

 

so $content will be replaced by the content template and $relatedbox by your infobox.

 

- Rigadin

 

Thanks! I see what you are saying, however when I go into debug mode using ?sts_debug=debug

I dont know which file is the right "outside" template to do what you said with $content / $relatedbox..(I see a lot of diff ones...

 

I see things like

STS_VERSION=[4.0.7]

OSC_VERSION=[osCommerce 2.2-MS2]

STS_TEMPLATE=[includes/sts_templates/test/sts_template.html]

STS_MODULE=[sts_product_info]

STS_INC_MODULES=[general.php - sts_user_code.php - product_info.php - ]--------------------------------------------------------------------------------

$sts->template['footer2applicationbottom']--------------------------------------------------------------------------------<!-- footer_eof //-->

<br>

</body>

</html>

--------------------------------------------------------------------------------

$sts->template['applicationtop2header']--------------------------------------------------------------------------------<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html dir="LTR" lang="en">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<title>osCommerce</title>

<base href="http://localhost/catalog/">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

<script language="javascript"><!--

function popupWindow(url) {

window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res

izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le

ft=150')

}

//--></script>

</head>

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

<!-- header //-->

--------------------------------------------------------------------------------

$sts->template['bestsellersbox_only']--------------------------------------------------------------------------------

<!-- start bestsellersbox_only //-->

 

<!-- end bestsellersbox_only //-->

--------------------------------------------------------------------------------

$sts->template['columnright2footer']--------------------------------------------------------------------------------<!-- right_navigation_eof //-->

</table></td>

</tr>

</table>

<!-- body_eof //-->

 

<!-- footer //-->

--------------------------------------------------------------------------------

$sts->template['header2columnleft']--------------------------------------------------------------------------------<!-- header_eof //-->

 

<!-- body //-->

<table border="0" width="100%" cellspacing="3" cellpadding="3">

<tr>

<td width="125" valign="top"><table border="0" width="125" cellspacing="0" cellpadding="2">

<!-- left_navigation //-->

--------------------------------------------------------------------------------

$sts->template['specialfriendbox']--------------------------------------------------------------------------------

<!-- start specialbox //-->

 

<!-- end specialbox //-->

--------------------------------------------------------------------------------

$sts->template['urlmyaccountlogo']--------------------------------------------------------------------------------http://localhost/catalog/account.php?osCsid=27546c452f68aaa54916ac6af1dc2ba0--------------------------------------------------------------------------------

$sts->template['urlcheckoutlogo']--------------------------------------------------------------------------------http://localhost/catalog/checkout_shipping.php?osCsid=27546c452f68aaa54916ac6af1dc2ba0

 

 

 

on the top and stuff like this on the bottom

$sts->template['maninfobox']--------------------------------------------------------------------------------

<!-- start maninfobox //-->

 

<!-- end maninfobox //-->

 

I feel extermely ignorant to this, and being that this is my first time at attempting this ...I feel bad that I have to waste your time with it...but im pretty lost...thanks again

 

It works when i turn off the content template...If i just use the default and index templates and set the product_info.php to false then the variable relatedbox is replaced correctly on the product page..but it is when i turn on the product info.php and use it as the content template that it no longer works......I assumed it would work similar to the alsopurchased box...

 

so i just took the code from the "related products contrib" file and created a related_products.php file with 1..I put that in the includes/modules ..............then

2. I defined ('FILENAME_RELATED_PRODUCTS', 'related_products.php'); on the filenames.php ......then

3. I define('TEXT_RELATED_PRODUCTS', 'Optional related products'); in the languages/english/product_info.php.............then

4. I put require(DIR_WS_BOXES . 'related_products.php');

$sts->restart_capture ('relatedbox', 'box'); // Get the related products on the includes/modules/sts_inc/sts_column_left.php....

 

so you were right that i put it in the sts_column_left...I just cant figure out where to put that info now....would I just put that same line above (step 4) in whatever template is being used for the content one and leave everything else the same? (and then the relatedbox call would work?)

 

Thanks so much!

Share this post


Link to post
Share on other sites

So if I understand correctly, the relatedbox goes under the content, like the also purchased box.

Based on that, I see 2 choices:

1) place $relatedbox on your content template.

2) As $relatedbox is already created in sts_column_left, make it available in content template by placing

$template_pinfo['relatedbox']= $sts->template['relatedbox'];

inside the file includes/modules/sts_inc/product_info.php


STS PLUS, a variation of STS, is now available.

ACA 2.0 is also out!

Share this post


Link to post
Share on other sites
So if I understand correctly, the relatedbox goes under the content, like the also purchased box.

Based on that, I see 2 choices:

1) place $relatedbox on your content template.

2) As $relatedbox is already created in sts_column_left, make it available in content template by placing

$template_pinfo['relatedbox']= $sts->template['relatedbox'];

inside the file includes/modules/sts_inc/product_info.php

 

Sorry i forgot to put in the previous post that I do already have this in the bottom of the sts_inc/product_info.php at the bottom of the document (seen below_)

 

$sts->stop_capture ('alsopurchased'); // Get the result to the main array

$template_pinfo['alsopurchased']= $sts->template['alsopurchased']; // Put it in the product info

 

$sts->stop_capture ('relatedbox'); // Get the result to the main array

$template_pinfo['relatedbox']= $sts->template['relatedbox']; // Put it in the product info

 

so you can see i basically just took the also purchased box above it and did the same thing (assuming that would work haha) .....and as i said the result is that the realtedbox works as a function when content template is turned off, but not when it is turned on...Im wondering if there is a special definition file somewhere else for the content template that i havent put the info in for...should it work where i have put it at the bottom of the sts_inc/product_info.php ??? thanks again

Share this post


Link to post
Share on other sites

Try to place whatever text in you variable:

 

$template_pinfo['relatedbox'] = 'Hello World'

and check is it coming or not on the page. Is there any logic inside the code of the box that could prevent it from displaying? Run in debug mode and check for the content of the 'relatedbox' variable, is it empty or not?


STS PLUS, a variation of STS, is now available.

ACA 2.0 is also out!

Share this post


Link to post
Share on other sites

I've installed the STS 4.0.7 Plus for the first time but I can't get the main content to show up. In the admin side I have the following:

Files for normal template

sts_user_code.php;sts_column_left.php;sts_column_right.php

 

 

All the boxes show up normally, but no content anywhere. If I click on the My Account link for example there's only empty space where there should be content. Does anyone has any idea what's happening here?

Share this post


Link to post
Share on other sites

Hello,

great nice work! I installed it and it works :)

 

I want to customize the design and i did not figure out how to change the width of the colums?

 

When I edit this line in application_top.php

define('BOX_WIDTH', 125);

Nothing happens until I change in the "normal" mode and the boxes are in that width I want to.

 

Even when I edit the sts_template.html nothing changes.

 

Please help me!

Share this post


Link to post
Share on other sites

Ok, I got it. I used the debug mode and it showed me that I was editing and uploading a wrong file all the time.

 

@those who are new to this contribution:

Read the manual and use the debug mode for more information!

 

So long

Share this post


Link to post
Share on other sites

Found the problem but can't remove the message above, column_right.php was evil and corrupt, but is now fixed. I've mad a Contrib Installer file for STS 4.07 Plus if someone is interested.

 

Hopefully it's soon possible to template the boxes too.. Thanks for the great contrib.

Share this post


Link to post
Share on other sites

Hi,

 

I've installed STS PLUS (i think!) and installed via the admin panel etc etc. I thought that I could change the test template and save, then refresh the website and the changes would be made. I tried deleting a box $catmenu but it still shows. What am i doing wrong. i've looked through all the manuals and the threads but am still unclear why this isn't working - i thought that is the idea? Also in the test template $numrequests is there but doesn't show on my website, have I installed incorrectly?

 

Please help

 

Becki

Share this post


Link to post
Share on other sites

Terve Tero,

 

You should have only sts_user_code.php in the parameter 'files for normal template'. The files sts_column_left.php and sts_column_right are already called respectively in includes/column_left.php and includes/column_right.php. If you add them in 'files for normal template', the code for the infoboxes will be processed twice and the main content will disappear or be strange.

 

You can skin your infoboxes with this contribution: http://www.oscommerce.com/community/contributions,1680

or wait a while that STS can do it (it's in dev).

 

To all of you who change the default template and do not see the result in your store: leave only sts_template.html in your template folder, remove the other templates. You can add them later when you are more familiar with STS PLUS.


STS PLUS, a variation of STS, is now available.

ACA 2.0 is also out!

Share this post


Link to post
Share on other sites
To all of you who change the default template and do not see the result in your store: leave only sts_template.html in your template folder, remove the other templates. You can add them later when you are more familiar with STS PLUS.

 

Ha!!! That solved my problem. Thanks!

 

Been playing around with STS PLUS with a new install of osCommerce as a total newbie for 3 days. Looks like this contribution will make my life a whole lot easier.

 

To help the other newbies with this, I suggest that your comment about leaving only the sts_template.html in the template folder be included in the beginning of the user documentation.

 

Here is another suggestion. Have the contribution install only the sts_template.html in the sts_templates/test folder, and the full set on another folder such sts_templates/full. This would eliminate a lot of confusion and still provide your full set of template files.

 

Thanks again for a great contribution.

Share this post


Link to post
Share on other sites

Can anyone help... I have installed the contribution and my store performs as expected until I go to the admin area and attempt to switch on/use the contrib.

I get this when I navigate to the Modules area in admin

Parse error: parse error, unexpected T_BREAK in /home/cellworl/public_html/admin/modules.php on line 25

I have the dropdown admin menu and I can see the STS option but clicking any module; shipping, payments sts gives the same error

 

ANy ideas? I have double checked my install and all seems fine...

Line 25 of the admin/modules.php is the break; here:

require('includes/application_top.php');

$set = (isset($HTTP_GET_VARS['set']) ? $HTTP_GET_VARS['set'] : '');

 

if (tep_not_null($set)) {

switch ($set) {

// START STS PLUS 4.0

case 'sts':

$module_type = 'sts';

$module_directory = DIR_FS_CATALOG_MODULES . 'sts/';

$module_key = 'MODULE_STS_INSTALLED';

define('HEADING_TITLE', HEADING_TITLE_MODULES_STS);

break;

// END STS PLUS 4.0

case 'shipping':

Edited by ianraba

Share this post


Link to post
Share on other sites
To all of you who change the default template and do not see the result in your store: leave only sts_template.html in your template folder, remove the other templates. You can add them later when you are more familiar with STS PLUS.

 

Rigadin,

 

I created a new folder in my sts_templates folder called "test2".

 

When I use the following URL to view my template in this new folder, I don't see any of the infoboxes skins:

 

http://www.soundsgoodpro.com/eshop/index.p..._template=test2

 

Do you have any idea what could be going wrong?

 

I want to take advantage of the administrator template view without disturbing my "live" site.

 

Thanks,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

First of all I have to say I love the simplicity of STS Plus. I am running into an issue. I would like to use the "Your Recent History" contribution. In theory, the Your Recent History contribution will show the recent products viewed by the website user at the bottom of each page.... however it's not working w/ the STS Plus contribution.

 

Has anyone had any luck, or can anyone tell me why it wouldn't be showing up?

 

For the record... I have the cache turned off in the admin.

 

I've included the modified file changes here but not the two new pages that are part of the contribution

 

1) add the class into the classes directory

2) add the module into the modules directory


3) in application_top.php after this code :

// include shopping cart class
 require(DIR_WS_CLASSES . 'shopping_cart.php');

add this code :

// include viewed products class
 require(DIR_WS_CLASSES . 'viewed_products.php');

3A) in application_top.php after this code:

// include the language translations
 require(DIR_WS_LANGUAGES . $language . '.php');

add this code :

// VIEWED PRODUCTS
if (!$spider_flag) {
 if (!tep_session_is_registered('viewed')) {
tep_session_register('viewed');
$viewed = new viewed_products(10);
 }
 if (isset($_GET['action'])) {
if ($_GET['action'] == 'viewed_remove') {
  $viewed->reset();
} elseif ($_GET['action'] == 'viewed_switch') {
	if ($viewed->on) { 
	  $viewed->on = false;
	} else { 
		$viewed->on = true;
	}
}
 }
}

4) in application_bottom.php just before this code :

tep_session_close();


add this code :

// ADD VIEWED PRODUCT
if (
	(!$spider_flag)
and (tep_session_is_registered('viewed'))
and (isset($_GET['products_id'])) 
and ($_GET['action'] != 'viewed_remove')
and ($_SESSION['viewed']->on)
  ) {
 $_SESSION['viewed']->add_viewed($_GET['products_id']);
}

// ADD SEARCH
if (
	(!$spider_flag)
and (tep_session_is_registered('viewed'))
and (stristr(basename($PHP_SELF),'advanced_search_result'))
and ($_GET['keywords'] != '')
and ($_GET['action'] != 'viewed_remove')
and ($_SESSION['viewed']->on)
  ) {
 $_SESSION['viewed']->add_search(trim(strtolower($_GET['keywords'])));
}


5)  Add to your language file :

define('BOX_HEADING_VIEWED_ITEMS', 'Your Recent History');
define('TEXT_RESET_VIEWED_ITEMS', 'Erase My Recent History');
define('TEXT_VIEWED_NOT_AGAIN', 'Do not show me again');
define('TEXT_HIST_ALSO_PURCHASED_PRODUCTS', 'Customers who bought products in Your Recent History also purchased our...');
define('TEXT_DO_YOU_REMEMBER','Do you remember this one?');
define('TEXT_HIST_EXPL1',' Your Recent History records the last ');
define('TEXT_HIST_EXPL2',' products and searches you have viewed for your convenience.<br><br>This information is not stored and erased when you leave our site.');


~Phoenixx ~

"Great Spirits Have Always Encountered Violent Opposition from Mediocre Minds."

Share this post


Link to post
Share on other sites

hello,everybody.

 

i am a fresh man. i just install MS2.2, and stsplus, it works well.

i want to change the logo which always display 'osc' now, how can i do this?

 

thank you

Share this post


Link to post
Share on other sites

Hi,

 

I have the STS Plus contributions working now and it is good!

 

I want to put a navigation bar horizontally across the top of the page. I have played around with dreamweaver and added a navigation bar with roll over images to the html template, this seems to work!

 

Can anyone recommend doing this or not doing it (maybe I should be using $url I?ve read about).

 

Are there any foreseeable problems using the html code (dreamweaver method) to do this?

 

Oh and I read in the manual that I should be using ultimate url's rather than relative ones. I am running with a local install at the moment and the navigation bar only seems to work when i use relative url's. This will mean i don't have to change all the links when i upload as well - is this a problem and should i definitely be using full url's?

 

 

Thank you for your advice.

 

Becki

Share this post


Link to post
Share on other sites

hello forum,

 

I am a newbie so please bare with me while I try to explain what I would like to accomplish

with this great contribute please as well as I am asking for some simple guideance to begin

with this if I may.

 

I have installed the OSC on my main domain name so therefore will it matter that my OSC is

in my main root when I then go to install the STSPlus v4 version? I ask this becuase the steps keep saying in the catolog files and I dont seem to have a catolog file and I read somewhere in this forum that if you

have installed the OSC in your main root then you dont have a catolog file?

and if what I said above is so then how should I install it so that when visitors come to my

main site and pull up my domain name then my html pages for the store as well as the store itself will

show please?

 

I also wanted to mention that I installed the OSC thru my hosting cpanel thru the Fantasico version will this

make a difference or no?

 

Next question:

 

I have installed or should say I edited out my OSC on these following files:

privacy policy

conditions

 

I also did all this below to the OSC that is installed on my site at the moment:

 

I edited out the main page where the text showes up at first when you install the OSC

I also changed my LOGO heading as well as the background colors and the footer colors and the

header colors thru the css page.

I also added a new box thru the contributes here to add my adsense banner on the right and left

columes and I added the steps to show that box as well in the 2 columes pages as well as where it said

to add a new box to make that adsense box show.

 

SO what I need to know now please before I go for installing the STSPlus contibute is will any of the above

work that I have done so far get altered out or messed up with this new install and if so how can I avoid it

before it happens. I really would like to use this contribute to alter the boxes ( mean to move them around a bit) and to be then able to add my HTML coding as I belong to alot of affiliate programs and see this

contribute as I am understanding it to work to be able to allow me to add those extra codings as they are

mainly with HTML as there listings etc, please if any of this is not going to work for what and how I wanted

to set up my store can anyone here be so kind as to point me in the right path before I take the wrong

path so to speak, I at first was going to install the STS latest version but after reading both threads thought this version here out of the 2 would work easyer for the newbie such as myself to get it to work.

Thanks to everyone who can offer me the advice and guidance I need to move forward with this project

 

starz

Share this post


Link to post
Share on other sites

Hi guys

 

I have installed STS Plus v4.07 and it has been working great!

 

I now want to try and move my site from the catalog directory to the root. My images on my site are all broken, even though I (think I) have made the relevant changes in the configure files. In admin, the STS module seems to be uninstalled, even though it is still showing on the site. Basically, can anyone tell me if there are STS files I need to edit? Or whether I have just messed up my configure files?

 

Thanks

Share this post


Link to post
Share on other sites
Hi guys

 

I have installed STS Plus v4.07 and it has been working great!

 

I now want to try and move my site from the catalog directory to the root. My images on my site are all broken, even though I (think I) have made the relevant changes in the configure files. In admin, the STS module seems to be uninstalled, even though it is still showing on the site. Basically, can anyone tell me if there are STS files I need to edit? Or whether I have just messed up my configure files?

 

Thanks

You can easily use the following javascript to perform a redirect from your root directory to your store directory:

 

<html>

<head>

<title>Easy Redirect</title>

</head>

<body>

You will be redirected to

http://www.yourstoredirectory.com.

<script language="JavaScript">

self.location = URL;

</script>

</body>

</html>

or you could also use a META TAG as in the following example:

<meta HTTP-EQUIV="REFRESH" content="0; url=http://www.yourdomain.com/index.html">This Meta Tag redirect code will redirect your visitors to another web page instantly. The content="0; may be changed to the number of seconds you want the browser to wait before redirecting. This code comes in handy if you change your web address and need to redirect your visitors to the new page.
I would recommend you put your store back in it's original folder and use one of the above examples. I do believe there is a contribution that would also solve your problem but can't remember which one it is. Do a search on google using the following search code:

 

"redirect" site:forums.oscommerce.com
By the way, this is a much better way to search these forums than the search features at the top of the forum page. ;)

 

Good Luck,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I have installed the OSC on my main domain name so therefore will it matter that my OSC is

in my main root when I then go to install the STSPlus v4 version? I ask this becuase the steps keep saying in the catolog files and I dont seem to have a catolog file and I read somewhere in this forum that if you

have installed the OSC in your main root then you dont have a catolog file?

and if what I said above is so then how should I install it so that when visitors come to my

main site and pull up my domain name then my html pages for the store as well as the store itself will

show please?

Your root directory has become your "catalog", just copy anything to your root that was asked to copy to your "catalog". I will admit, I have not tried this but I am very familiar with the STS and I don't see any problem for you.

 

I also wanted to mention that I installed the OSC thru my hosting cpanel thru the Fantasico version will this

make a difference or no?

No problem at all...this is exactly how I installed my copy.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
hello,everybody.

 

i am a fresh man. i just install MS2.2, and stsplus, it works well.

i want to change the logo which always display 'osc' now, how can i do this?

 

thank you

 

The "easiest" way to do this is to upload an image of the same name (oscommerce.gif) to your store's image folder. This will replace the default logo with your own logo.

 

Good luck, Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I want to put a navigation bar horizontally across the top of the page. I have played around with dreamweaver and added a navigation bar with roll over images to the html template, this seems to work!

 

Can anyone recommend doing this or not doing it (maybe I should be using $url I've read about).

Becki, I have designed my own graphic navigational bar at the top of my site to intergrate nicely with the rest of my site just as you have mentioned. I have not ran into any issues using this method. I prefer this method because it makes my site stand out from the rest as well as giving me the control over my navigation.

 

Good luck,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Your root directory has become your "catalog", just copy anything to your root that was asked to copy to your "catalog". I will admit, I have not tried this but I am very familiar with the STS and I don't see any problem for you.

 

No problem at all...this is exactly how I installed my copy.

 

 

 

Hello Bkellum,

 

thank you very much for taking the time out to reply back to me on these questions I really appreciate it

if I may can I ask another few questions of you since you have more experience then me in the STS

install issue please?

 

(1) Where it says to upload the then files of the STS right can I instead simply install the PHP pages themselves

into the right files and just copy over them say for example the STS says copy these files into the catolog/includes directory: And not in the /admin/ section?

application_top.php

header.php

column_left.php

column_right.php

footer.php

application_bottom.php

sts_start_capture.php

sts_stop_capture.php

sts_restart_capture.php

sts_display_output.php

sts_user_code.php

sts_template.html

 

but for me then since mine is on the root already i would just add these files to the includes file itself? I ask this becuase there are a few folders with this install and each has there own files in them but if I already am on the root then would I be safer to just install the individual php pages them selves or would this not work that way to read the code correctly?

 

Also I am taking it that each file gets there own name etc but all my files show like this when I first log into

 

my tools section:/home/thesuper/public_html, and in this file it shows the admin folder opened and a bunch of files in there so again would my "catalog" /includes be this first Includes folder I am seeing? As this is what I see when I hit that includes folder: /home/thesuper/public_html/includes

Just want to make sure I am doing this all the correct way first try is all.

 

I also wanted to ask since I made the minor adjustements to my site example of color, add the yahoo box,

and altered out my colume files right and left files, would I be better off to use the advance mode to install those extra files or should I try to just install these files and then go back and alter the things I changed before this install?

 

Also I really need to ask how does one make a backup of there site to say to there computer in case I need to recall those original files back please? I have done the backups for the site but always checked off the first box not the 2nd is that the difference then? Again forgive me if I should new:) but to this side of things I really am new:)

 

I do so appreciate you taking the time out to guide me the right way with this install, and by the way would it make much of a difference on weather I am using the STS-2_00 or the STSPlus 4.07 version or do they both work the same way? as I saw 2 different types in the contribute section and once again I would much rather ask ahead of time if it makes a difference which one I use or which is easyer to follow along with ahead of time.

thanks once again and I hope to here back from you soon on this as I was afraid to go forward with this until i could get some guidance from here on how to install it all.

 

starz

Share this post


Link to post
Share on other sites
...since mine is on the root already i would just add these files to the includes file itself? I ask this becuase there are a few folders with this install and each has there own files in them but if I already am on the root then would I be safer to just install the individual php pages them selves or would this not work that way to read the code correctly?

 

Starz, in your particular install, you would only need to copy the "includes" folder and all of it's subfolders and files into your root directory. (I'm talking about the includes folder from the "Upload" folder that came with the STS Plus 4.07 contribution) By doing this, you will overwrite any existing files with the "same name" that already exists in your default includes folder on your root directory but your other existing files will remain intact.

To try and make this easier for you to understand, let's take a look at what an oscommerce store directory would look like if it were installed in the "catalog" folder:

 

Catalog

 

Admin

Download

Images

Include

Pub

"all_additional_files".php

 

You would upload the STS files in the "Include" folder that you see above. However; in your case the "Catalog" folder is actually your root directory.

 

As far as the modifications that you made, I would get the STS going as you can easily redo your modifications. Besides, you may not care about doing those modifications once you see how easy it is to use regular HTML to edit your shop.

 

Hope this helps.

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Starz, in your particular install, you would only need to copy the "includes" folder and all of it's subfolders and files into your root directory. (I'm talking about the includes folder from the "Upload" folder that came with the STS Plus 4.07 contribution)
One more thing...this gets a lot of people confused....

 

You will also have to copy the "clean_osc" folder and all of it's files as well into the same named folders on your root folder. For example: "Admin" to your "Admin" folder, "Includes" to your "Includes" folder.

 

You actually onle need the files within each folder. Do not add and additional "Admin" folder inside your current "Admin" folder, just add the files.

 

Good luck,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×