Jump to content
Sign in to follow this  
Rigadin

[contribution] STS PLUS v4

Recommended Posts

I have installed STS and it is awesome.....

 

I have 2 questions...

 

1) how do I customize what shows for content? here is an image of how I want it to look

layout.jpg

 

2) I have inserted an image into my page and I want to link that image to a particular category in my store how do I do that?

 

Thanks in advance...

-J :thumbsup:

Share this post


Link to post
Share on other sites
I have installed STS and it is awesome.....

 

I have 2 questions...

 

1) how do I customize what shows for content? here is an image of how I want it to look

 

 

2) I have inserted an image into my page and I want to link that image to a particular category in my store how do I do that?

 

Thanks in advance...

-J :thumbsup:

 

 

Did you ever get any feedback on this?

I am trying to do the same with the products overview page.

 

Let me know how you are getting on..


Espen Falkenhaug

Share this post


Link to post
Share on other sites

The $content part of the template comes from the php script, for example index.php . If you want to change its design, you have to edit index.php or any included file (like includes/modules/product_listing.php). There are some contributions to change the design of the product listing.

 

The only exception for now is product_info.php, for which you can create a content template and place elements where you want.

 

If you feel so, you can also create/modify the sts modules to create content templates for other pages.

 

You can create links to categories using the placeholder $urlcat_CategoryID where CategoryID must be replaced by the ID of the target category.

 

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

I have looked everywhere and can not find anything/else regarding this issue.

 

I'm currently running STS plus v4.0.7 and have recently installed Print Order receipt v1.4. While it looks as if everything is working correctly - the problem occurs when a customer/user clicks on the "PRINT INVOICE" button the window that pops-up is rendered by the STS template system but doesn't show the content of the invoice.... in other words the invoice pop-up is completely blank except for the header and footer of the main website.

 

Does anyone know what needs to be done to make the data show in the invoice pop-up?

 

Zoe

Share this post


Link to post
Share on other sites

Nevermind I got it to work by adding the left and right column code from a functioning STS page.

 

Zoe

Share this post


Link to post
Share on other sites

Hi,

 

I'm new to all this and I'm not a coder so please bear this in mind, but I beleive I have installed it okay.

 

The problem is when I go to Modules/STS Modules/ and I try to edit Default to say Use templates? = Yes, it changes while editing but as soon as i click update it reverts back to saying false.

 

Any ideas.

 

Plus it there a dummy's guide to using STS as I haven't a clue what I'm doing here. I have modded computer games and made basic html websites in Dreamweaver but this is unknown territory for me.

Share this post


Link to post
Share on other sites

The problem as described in the above post seems to affect the whole Modules section of the Admin area.....values can longer be changed.

 

Other sections of the admin area seem unaffected.

Share this post


Link to post
Share on other sites
The problem as described in the above post seems to affect the whole Modules section of the Admin area.....values can longer be changed.

 

Other sections of the admin area seem unaffected.

You are missing some of the files needed. Most likely some files failed or were corrupted during the FTP upload. You can try uploading again and everything should be fine. However, to answer your other post regarding a help guide, I suggest upgrading to STSv4.2 and follow the User Manual that is provided. :thumbsup:

 

Good Luck!


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
The problem as described in the above post seems to affect the whole Modules section of the Admin area.....values can longer be changed.

 

Other sections of the admin area seem unaffected.

 

 

Mark - New install this will fix your problem I think. Had the same issue

 

http://forums.oscommerce.com/index.php?s=&...st&p=923577

 

Laurie

Share this post


Link to post
Share on other sites

Thanks guys, I'll start from scratch again.

 

Install:

 

oscommerce-2.2ms2-060817

register_globals_v1.5

STS v4.2 with Header Tags Controller 2.5.9

Infobox Templates for use with STSv4.2

 

Cross fingers and all other bits that will cross and pray it works this time :blink:

Share this post


Link to post
Share on other sites
You are missing some of the files needed. Most likely some files failed or were corrupted during the FTP upload. You can try uploading again and everything should be fine. However, to answer your other post regarding a help guide, I suggest upgrading to STSv4.2 and follow the User Manual that is provided. :thumbsup:

 

Good Luck!

 

 

I've upgraded to STSv4.2 and re-installed (many times) and got a few bugs iron out with Vger's help.

 

The values now change but I still can't see any change to the template.

 

I've installed all three modules, uploaded a new template "marks_template01.html" to the sts_templates/test folder and pointed to that file in the STS Modules admin default section as the Default Template File.

 

What have I done wrong as it's not working? :blink:

Share this post


Link to post
Share on other sites

Hello.

 

I have the same problem like Rugman:

 

The problem is when I go to Modules/STS Modules/ and I try to edit Default to say Use templates? = Yes, it changes while editing but as soon as i click update it reverts back to saying false.

 

I can´t get the default setting started.

I tried reinstalls and also update from STS Plus to higher versions.

 

Can anyone help?

Thanks alot!!!

Share this post


Link to post
Share on other sites
Hello.

 

I have the same problem like Rugman:

 

The problem is when I go to Modules/STS Modules/ and I try to edit Default to say Use templates? = Yes, it changes while editing but as soon as i click update it reverts back to saying false.

 

I can´t get the default setting started.

I tried reinstalls and also update from STS Plus to higher versions.

 

Can anyone help?

Thanks alot!!!

You need to install the "osc 060817 STS Module Patch" listed on the STS download page.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I installed a clean OScommerce MS2 with this contrib, I also added googlesitemap generator but that did not change any of the files you had...

My only problem is that when I am in the admin panel I am getting warnings on the following pages:

Page control says:

Permissions settings for the /catalog/includes/header_tags.php file appear to be incorrect

Permissions settings for the /catalog/includes/languages/english/header_tags.php file appear to be incorrect

 

Both of these are set to 777, I have also tried 755 but warnings still appear.

Also get this warning on text control:

Permissions settings for the /catalog/includes/languages/english/header_tags.php file appear to be incorrect

 

Any suggestions on what I may have done wrong?

Thanks for the help.

Pattie

Share this post


Link to post
Share on other sites

Thank mand, great contribution.

I am testing it out for first time.

I have created new fresh site with no change at all.

uploaded the latest version onto this new fresh site.

But its not showing up in Modeules section.

 

i have checked file permissions of

 

/#####/.com/catalog/includes/modules/sts

 

and its 755

 

i cant figure why catalog see this module.

 

Any idea?

 

thanks

Share this post


Link to post
Share on other sites

Hi, I am trying to customise my first oscommerce shop, i have previosuly used oscommerce but left it in its basic state, I have installed STS templates and I am impressed, howeevr one thing I would liketo do is make the seach box different, All I want is the box that the site vierer woudl type into and the magnyfing glass icon, I dont want the tect or the box around it, is there nayway I can do this

 

I pressumed that when i use the $searchbox# command, it just pulls in the seach.php but I cant find anyhting in there that makes the box and text appear....

just noticed that what I want to achieve is very similar to the serach this topic box, just the white box (maybe the words search here) withint the box and then the icon instead of the search topic command

Can anyone help?

 

Cheers

Edited by dapex

Share this post


Link to post
Share on other sites

hello.i use Login Box with members name.i dont' know how to add new boxes or template variables..what is the code i should add to sts_user_code.php to display this contribution?

 

thanks a lot !

Share this post


Link to post
Share on other sites
hello.i use Login Box with members name.i dont' know how to add new boxes or template variables..what is the code i should add to sts_user_code.php to display this contribution?

 

thanks a lot !

Open your sts_user_code.php file and you will notice a section of instructions that are commented out (so that the PHP is not parsed) regarding how to add custom infoboxes into your sts templates. It will instruct you on how to use the "start capture/end capture" routine.

 

Also, I would strongly suggest upgrading to STSv4.4 if you are still using STS Plus.

 

I hope this has helped,

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I have been searching for a way to customize certain outputs of my site, such as the produce listings.

Wondering if STS is the answer or maybe with the inclusion of another contribution.

 

What I am after is to have two types of product listings to display;

One similar to this - http://handeshobbies.com/Paint_Testors_Enamels_1.html#Top with no "More Info" and no "Large Image".

The other page to display something like this - http://handeshobbies.com/index_Test2.html with either; Large Image, Add to Cart, or More Info buttons added.

 

On my actual osC work in progress site, I utilized the Big Image and Dynamenu(?).

I would like to further customize the site with possibly Easypopulate and Graphical Borders contribs.

Test site - http://handeshobbies.com/catalog/

 

Thanks for looking and any help would be greatly appreciated.

 

Jim


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

thanks bill kellum for answer my first ques.and i have another ques

i install osc from a templatemonster package,i install STS4.4 and set to use STS,i can see sts_template.html as my index page but STS doesn't work,i see also all variable $

what is this problem?maybe STS works with new fresh and lastest osc version?

Share this post


Link to post
Share on other sites
I have been searching for a way to customize certain outputs of my site, such as the produce listings.

Wondering if STS is the answer or maybe with the inclusion of another contribution.

 

What I am after is to have two types of product listings to display;

One similar to this - http://handeshobbies.com/Paint_Testors_Enamels_1.html#Top with no "More Info" and no "Large Image".

The other page to display something like this - http://handeshobbies.com/index_Test2.html with either; Large Image, Add to Cart, or More Info buttons added.

 

On my actual osC work in progress site, I utilized the Big Image and Dynamenu(?).

I would like to further customize the site with possibly Easypopulate and Graphical Borders contribs.

Test site - http://handeshobbies.com/catalog/

 

Thanks for looking and any help would be greatly appreciated.

 

Jim

Jim, STSv4.4 would allow you to make a product (content) template to add, delete or move around the different objects assiciated with the product page such as the ones you mentioned above. STS templates the product_info.php file.

If you need to change the way the product_listing.php file displays, you will need a contribution such as "Featured Products" or something similiar. Currently, STS does not template the product_listing.php file. It can be done with the addition of another STS module for that particular script.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
thanks bill kellum for answer my first ques.and i have another ques

i install osc from a templatemonster package,i install STS4.4 and set to use STS,i can see sts_template.html as my index page but STS doesn't work,i see also all variable $

what is this problem?maybe STS works with new fresh and lastest osc version?

How to make STS tags work in your custom templates:

 

As far as the required code, you only need the following in EACH of your template pages to make STS work on those pages:

 

1. <?php DEFINE ('STS_END_CHAR', '#'); ?>

2. <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

3. <html $htmlparams>

4. <head>

5.<meta http-equiv="Content-Language" content="en-us">

6. <!--$headcontent-->

7. <link rel="stylesheet" type="text/css" href="stylesheet.css">

8. </head>

  • Line 1 above defines the stop character "#" (can be anything you want such as "$") that will parse the PHP faster. If you use this line, be sure to add the stop character to each one of your tags in that template. For example; "$content" becomes "$content#". See the STS User Manual for more details.
  • Line 2 will be different depending upon what type of HTML validation you are using. Look up page validation on Google for more information regarding this.
  • Line 3 is REQUIRED as is. See STS documentation for more details.
  • Line 6 is REQUIRED as is. See STS documentation for more details.
  • Line 7 will vary depending upon your css stylesheet and its file path. If your stylesheet is not in the root of your store catalog, then specify its location here.

Play around with what works and doesn't but the above will get your custom templates to work with STS tags.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Jim, STSv4.4 would allow you to make a product (content) template to add, delete or move around the different objects assiciated with the product page such as the ones you mentioned above. STS templates the product_info.php file.

If you need to change the way the product_listing.php file displays, you will need a contribution such as "Featured Products" or something similiar. Currently, STS does not template the product_listing.php file. It can be done with the addition of another STS module for that particular script.

 

Thank you Bill :thumbsup:

 

I will give it a try and take a look at the other STS modules.

 

I truely appreciate the response and help!

 

Jim


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites
How to make STS tags work in your custom templates:

 

As far as the required code, you only need the following in EACH of your template pages to make STS work on those pages:

 

1. <?php DEFINE ('STS_END_CHAR', '#'); ?>

2. <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

3. <html $htmlparams>

4. <head>

5.<meta http-equiv="Content-Language" content="en-us">

6. <!--$headcontent-->

7. <link rel="stylesheet" type="text/css" href="stylesheet.css">

8. </head>

  • Line 1 above defines the stop character "#" (can be anything you want such as "$") that will parse the PHP faster. If you use this line, be sure to add the stop character to each one of your tags in that template. For example; "$content" becomes "$content#". See the STS User Manual for more details.
  • Line 2 will be different depending upon what type of HTML validation you are using. Look up page validation on Google for more information regarding this.
  • Line 3 is REQUIRED as is. See STS documentation for more details.
  • Line 6 is REQUIRED as is. See STS documentation for more details.
  • Line 7 will vary depending upon your css stylesheet and its file path. If your stylesheet is not in the root of your store catalog, then specify its location here.

Play around with what works and doesn't but the above will get your custom templates to work with STS tags.

 

thanks for your instruction,i followed your help and it's ok ^^.but there's many variable $ doesn't work when i put them in index page, $content works,$searchbox not works,i only see $ in index,

what is this problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×