Jump to content
Sign in to follow this  
Rigadin

[contribution] STS PLUS v4

Recommended Posts

Hi I just installed STS4.0.3 working fine so far, now 2 questions:

 

1. Where do I save the files for just the index layout and the products layout after activating the modules for the different layouts? I can just read about .php files for the index and products and nothing about where to put the html files...

 

2. I will eventually install Header Tags Controller but I saw that other people had a hard time to do so, but mainly because they used the STSPlus version and I have STS4. Sorry for this stupid question, but is it easier to add HTC to STS4 or is it the same pain as for STSPlus? If there is a procedure for HTC + STS4 and/or could you point me there?

 

Thanks so much in advance!

 

If you have installed STS as opposed to STS Plus you may be better posting in the STS forum:

 

http://forums.oscommerce.com/index.php?showtopic=204381

 

As for HTC, I've got the latest version of STS Plus installed and didn't have any problems - just have to follow the STS instructions and not the standard ones.

Share this post


Link to post
Share on other sites
I don't know how (maybe my fault?) but 2 modules were buggy. I just placed an update on the contribution page.

 

Note: if you use only index.php.html and not any template for some specific category (like index.php_1.html), you do not need to install (in admin) the module for index.php pages, the default module is enough and faster.

 

- Rigadin

 

Hi,

I have installed it local with Wamp. It works fine. But when i tried it on the server it ingores my template. I have only installed default. I only want one simply template, but it wont work.

http://www.smitty.opweb.nl/catalog

 

Help

Share this post


Link to post
Share on other sites

Hi,

I am trying to add a background image to the whole website using STS, but it seems not that simple to add a background image. Even a normal image I can't add, and changing colour of the text doesn't work. Is it ment to be simple like HTML/CSS?

Share this post


Link to post
Share on other sites
Hi, I'm trying to create a template for one of my category pages.

 

I have read the documentation on this but still a little confused.

 

I have named the file index.php_21.html and saved it to includes/sts_templates/test

 

Do I then need to set the index template to include this file from the admin?

 

I tried this but get errors on tha catalog:

 

Warning: main(includes/modules/sts_inc/index.php_21.html): failed to open stream: No such file or directory in /homepages/4/d71/htdocs/catalog/includes/modules/sts_inc/sts_display_output.php on line 21

 

Warning: main(): Failed opening 'includes/modules/sts_inc/index.php_21.html' for inclusion (include_path='.:/usr/local/lib/php') in /homepages/4/d71/htdocs/catalog/includes/modules/sts_inc/sts_display_output.php on line 21

 

so I guess this must be wrong thing to do as it's looking for my file in sts_inc

 

so how do I do it? I am using headertags if that's of relevance.

 

Thanks,

Natalie

 

Hi,

 

The only thing needed to use index templates is to enable the index module in admin. When the module is enabled, it will find itself what template to use. In your case, when viewing category ID21, index.php_21.html will be used.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
Hi,

I am trying to add a background image to the whole website using STS, but it seems not that simple to add a background image. Even a normal image I can't add, and changing colour of the text doesn't work. Is it ment to be simple like HTML/CSS?

It sounds like your are experiencing a url image link problem.

 

Either way, Edit your CSS page to set the background color to an image like so:

background-image: url('YOURIMAGE.jpg')

This should do the trick, Bill Kellum[/code]


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello, I've just started using STS, and I've found it to be a great template system, but I'm having a weird problem. On any given page (except specific product pages) the middle area, where "what's new for May" or a list of manufacturer products should be, is blank.

What's weird is everything shows up fine if I turn STS off.

Any ideas?

Thanks!

Ty

Share this post


Link to post
Share on other sites
To put a link behind an image, first build the variable in sts_user_code.php. Example:

 

$sts->template['urlmylogo'] = tep_href_link(FILENAME_MYFILENAME, '', 'SSL');

 

The corresponding placeholder to use on your template is $urlmylogo and it links to the "myfilename" page.

 

On your template, place the image and create a link using $urlmylogo as destination.

 

Thank for this.

 

Sorry for the delay (was making the template) .. please tell me what i am doing wrong. As a test i just linked the $checkout to an image.

 

This is how it is in my html template:

 

<div id="id029-mod2-28">

<a href="$checkout"><img src="images/029-mod2_27.gif" alt="" width="780" height="432" border="0"></a> </div>

 

This is what is in the sts_user_code.php:

 

$sts->stop_capture('catmenu');

$sts->template['checkout'] = tep_href_link(FILENAME_shopping_cart.php, '', 'SSL');

 

When i click on the image it just says:

 

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

 

If you think this is a server error, please contact the webmaster.

 

What am i doing wrong please?

 

Thanks again

Share this post


Link to post
Share on other sites

The infoboxes clutter up when using sts and i would like to put a <br> between them. If i do that for each box there are huge gaps between them when so boxes don't appear. I don't want a template for each page so i guess i have to edit column right.php. This is my feeble attempt:

require(DIR_WS_BOXES . 'shopping_cart.php')

print '<br>';

require.....

you get the idea right. please can you put the proper way to edit column right.php

or am i going about this the wrong way and should edit shooping_cart.php

Nick


Menou and unome

Share this post


Link to post
Share on other sites

i have a problem wheni create new templates even a blank one it still has the oscommerce logon breadcrumbs and the myaccoutn logo and text, cart logo and text and check put logo and text how do i get rid of it

Share this post


Link to post
Share on other sites

Hey guys...

 

I have managed to install STS 4 with the product extra fields contribution. They both work but I have a simple problem at displaying more than one extra field at the product page using STS.

 

I pasted this code which is the product extra fields code:

// START: Extra Fields Contribution v2.0b
$extra_fields_query = tep_db_query("SELECT pef.products_extra_fields_status as status, pef.products_extra_fields_name as name, ptf.products_extra_fields_value as value FROM ". TABLE_PRODUCTS_EXTRA_FIELDS ." pef LEFT JOIN  ". TABLE_PRODUCTS_TO_PRODUCTS_EXTRA_FIELDS ." ptf ON ptf.products_extra_fields_id=pef.products_extra_fields_id WHERE ptf.products_id=".$HTTP_GET_VARS['products_id']." and ptf.products_extra_fields_value<>'' and (pef.languages_id='0' or pef.languages_id='".$languages_id."') ORDER BY products_extra_fields_order");
$counter = tep_db_num_rows($extra_fields_query);
if($counter > 0){
while($extra_fields = tep_db_fetch_array($extra_fields_query)) {
if(!$extra_fields['status'])  // show only enabled extra field
	continue;
	$template['product_extra_field_name'] = '<b>'.$extra_fields['name'].': </b>';
	$template['product_extra_field_value'] = $extra_fields['value'].'<br>';
}
} else {
$template['product_extra_field_name'] = '';
$template['product_extra_field_value'] = '';
}	
// END: Extra Fields Contribution

 

into sts_product_info.php file and it does display the extra fields but it shows only the last field and not all...

 

For example: Say I have a DVD, that I need to display extra fields with the following order:

 

1. Year

2. Duration of the movie

3. Director

4. Actors

5. Subtitles

 

The page only shows the last field which is Subtitles, even though all other fields are filled properly. Anyone knows a solution?

 

Thanks in advance


There's a diference between living & BEING ALIVE!

Share this post


Link to post
Share on other sites

Hi I have just intalled this module and i am customising the index page (www.hotta.co.uk/catalogue )

 

i am doing this ok, but i cant see some other pages that need customising.. for example if you go to

 

http://hotta.co.uk/catalogue/shopping_cart.php you just see the default shopping cart page.

 

 

i am not sure where to find the template for this page? please help

Share this post


Link to post
Share on other sites

I can't seem to get productid or productsid to display in my template, as well as specialfriendbox.

 

I have product_info.php.html in my main template directory and product_info.php.html in my content directory. All other variables are parsed and display without problems.

 

What am I missing?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi there,

 

I wonder if anyone can help me.

 

I have just installed STS 4 and is not showing in the admnistration page.

 

Any suggestions?

 

Many thanks in advance.

 

Regards

Share this post


Link to post
Share on other sites
Hi there,

 

I wonder if anyone can help me.

 

I have just installed STS 4 and is not showing in the admnistration page.

 

Any suggestions?

 

Many thanks in advance.

 

Regards

Please ignore the previous post, I have managed to sort it out now

Share this post


Link to post
Share on other sites

Hi all,

 

I have installed STS4 and when I set 'Use templates' to 'TRUE' the site doesn't load at all.

 

The error message I get is:

 

STS4 was designed to work with OSC version [osCommerce 2.2-MS2]. This is version [PROJECT_VERSION].

 

And my osCommerce version is 2.2-MS2.

 

Can you help me please?

 

Thanks

Share this post


Link to post
Share on other sites

Please ignore this post (AGAIN!!!) Sorry :)

 

The define('PROJECT_VERSION', 'osCommerce 2.2-MS2'); tag was commented.

 

Cheers

 

Hi all,

 

I have installed STS4 and when I set 'Use templates' to 'TRUE' the site doesn't load at all.

 

The error message I get is:

 

STS4 was designed to work with OSC version [osCommerce 2.2-MS2]. This is version [PROJECT_VERSION].

 

And my osCommerce version is 2.2-MS2.

 

Can you help me please?

 

Thanks

Share this post


Link to post
Share on other sites

Hi all,

 

I have installed this contribution using the upload/catalog files within the package as I have a few other contributions. Pretty much everything works with this contribution except i have found that when the prices display, rather than a ? sign in front of the price, it has a J for example J1.99 rather than ?1.99.

 

When I disable this contribution, everything is fine but when I use my modified template with the $content tag and enable the contribution, the currency symbols all change. Any Ideas?

 

Lee

Share this post


Link to post
Share on other sites
Hi all,

 

I have installed this contribution using the upload/catalog files within the package as I have a few other contributions. Pretty much everything works with this contribution except i have found that when the prices display, rather than a ? sign in front of the price, it has a J for example J1.99 rather than ?1.99.

 

When I disable this contribution, everything is fine but when I use my modified template with the $content tag and enable the contribution, the currency symbols all change. Any Ideas?

 

Lee

 

Forget that last post, I found the solution. Instead of entering ? in the currency symbol left in the admin section, i entered £ and this sorts it out.

Share this post


Link to post
Share on other sites

Hi,

 

Has anyone got 'cdynamic meta tags v1.4' contribution working with sts-plus installed, files are appearing in the cache but i don't think it is actually working, i can't see anything in the source code

 

Any hints, one question is do i need to change pages i want meta tags on other than catalog/index.php and catalog/product_info.php - do i have to make the changes to some sts files aswell - if so wich ones please?

 

Thankyou for any help :)

 

Becki

Share this post


Link to post
Share on other sites

Hi,

I have used the previous version of STS (v3), but this one which I have installed few days ago is amazing. The best thing about it, is that it is very fast, plus other new excellent features. :thumbsup:

However, I have a question which I couldn't find it in this forum.

Is there anyway we could merge some checkout pages in order to reduce the number of clicks during check out? for example, merge the shipping and payment page? or any other combination?

I have a heavily modified website so, I don't to use another contribution which are available for merging the pages. If this could be done by STS trick that would me awesome.

 

Any suggestion will be grateful.

 

Thanks


Regards,

Share this post


Link to post
Share on other sites

HI,

 

Has anyone got STS PLUS 4.0.7 working with cdynamics meta tagsV1.4, they both work independently but not together. I tried the help in the meta tags support but no luck.

 

Any help please!

 

Becki

Share this post


Link to post
Share on other sites
Hi,

I have used the previous version of STS (v3), but this one which I have installed few days ago is amazing. The best thing about it, is that it is very fast, plus other new excellent features. :thumbsup:

However, I have a question which I couldn't find it in this forum.

Is there anyway we could merge some checkout pages in order to reduce the number of clicks during check out? for example, merge the shipping and payment page? or any other combination?

I have a heavily modified website so, I don't to use another contribution which are available for merging the pages. If this could be done by STS trick that would me awesome.

 

Any suggestion will be grateful.

 

Thanks

 

Sorry but this is not an STS feature. Each page of the checkout procedure has its own functionalities and STS only move the graphical elements around the page.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Hello STS users!

 

 

 

STS v4.1 has been updated to STS v4.2. :D

 

 

 

STS v4.2 is a User-Friendly Version of the Simple Template System (STS).

 

 

Version 4.2 is the easiest template system to date for the osCommerce solution. STS has recently been ranked 5th among contribution downloads for osCommerce, passing BTS (Basic Template System).

 

The Simple Template System (STS) has seen a lot of great changes over the years, changes for the better and has drawn a huge fan base. I hope that this version will continue that trend as well as bring in the novice who may have considered previous STS versions ?too taunting?. :'( :blink: :huh:

 

This update includes the "Footer? patch, as well as the "Product info module v1.0.6" and ?Index module v1.0.3? updates, integrated into one seamless install. We can all thank Chris (Rigadin2) for these fine updates! I have only taken these updates and bundled them into one seamless install package, along with easy to understand documentation and additional templates for your convenience.

 

With the author's blessing, STS v4.2 is an official release of the Simple Template System.

 

Why this new version 4.2?

STS 4.1 has seen three major changes and a few bug fixes since its release back in April 2006. Without this update, in order to install a stable STS v4.1, new users would have to download four different files as well as make some additional changes to a few of the PHP files in their store. With version 4.2, installation is as simple as downloading this complete package and following the instructions toward one seamless installation. Instructions for manual installation are still available for those who have a heavily modified store.

 

If you have kept up with all of the fixes mentioned in the support forum (this forum) as well as the patches and new modules uploaded onto the contribution site, then you already have version 4.2, without the updated documentation and additional templates of course.

 

Main advantages of this version:

-Integrated all bug fixes and updates to this fine contribution into one seamless package.

-Updated the install text as well as the contribution?s documentation to make the installation and use of STS 4 more user-friendly.

-Added a new ?blank? template with all of the required code for ease of use to create your own STS v4.2 templates from scratch.

-Added install instructions for the ?Infobox Templates for STS? contribution as an STS4.2 add-on.

 

 

STS 4.2, differences with STS 4.1:

-Updated ?includes/modules/sts/sts_index.php? (Rigadin2, May 8, 2006, Index module v1.0.3 for STS4)

-Updated ?includes/sts/sts_product_info.php (Rigadin2, June 5, 2006, Product info module v1.0.6)

-Updated ?includes/footer.php? (Rigadin2, July 25, 2006 ?Footer Patch?)

-Updated ?sts_templates? folder from both the ?clean_osc? and ?upload? folders (cleaned up discrepancies and remains from STS PLUS)

-Bug fix: ?index.php_0.html? template for main page will now work as designed.

-Added: A new module parameter to set in admin.

You now have the choice to set STS to look for templates of parent categories.

-Bug fix: The ?sts_product_info.php? module does not call the function sts_strip_content_tags anymore when using a content template, because there is nothing to take away from your content template.

 

 

You can download it here:

 

http://www.oscommerce.com/community/contributions,1524

 

 

 

The support forum will continue to be located at the STSv4 forum that can be found here:

 

http://forums.osCommerce.com/index.php?showtopic=204381

 

 

 

Enjoy,

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello STS users!

***NOTICE***

Attention STS Plus 4.07 Users Who Wish to Upgrade to STSv4.2:

The "Installation Text" has been updated on August 12, 2006 to correct an error regarding the upgrade path for those upgrading from STS Plus 4.07 to STSv4.2.

 

**THIS ONLY AFFECTS STS PLUS 4.07 UPGRADERS. **

I have setup a special download page just for the documentation updates.

 

You can download the updated documentation here:

 

http://soundsgoodpro.com/stsv4_2.htm

 

 

 

The full package download for STSv4.2 is also available. (Of course, it is still available on the osCommerce download page)

 

:-

 

Sorry for the inconvenience. - Bill Kellum

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×