Jump to content
Sign in to follow this  
Rigadin

[contribution] STS PLUS v4

Recommended Posts

These are on every single page except for the main admin page. What could I have done wrong?

 

// START STS PLUS 4.0 $sts->restart_capture ('applicationtop2header'); // END STS PLUS 4.0

// START STS PLUS 4.0 $sts->restart_capture ('header'); // END STS PLUS 4.0

 

Fatal error: Call to a member function on a non-object

 

in /home/public_html/wosestore/admin/includes/application_bottom.php on line 21

 

 

Also, I really do not understand how to edit my product_info.php

 

I need help bad!

Share this post


Link to post
Share on other sites
I need help bad!
LB, Tell us about your install...Was this on a clean OsCommerce? Do you have any other contributions installed? Was your store functioning correctly before you installed STS Plus? Did you upload both folders from the STS Plus contribution (contents of "UPLOAD" and "Clean_osc")?

 

After the install, did you configure your store from the admin side?

 

Configuration

Go to admin panel - modules, you should see a new link in the left column: STS.

Click on it and a list of modules appears. Those modules are in catalog/includes/modules/sts.

3 modules are delivered with the contribution v4.0.5:

 

1) Default:
This is the main module, it must be installed in order to use STS PLUS v4. Parameters are:

- Use Simple Template System: 'True' to use STS PLUS, 'False' to use stock osc.

 

Give us some of the above and we may be able to help you out.

 

Thanks,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I'm on the same page as Hunabku. I can't find this module and am at a loss. I had installed Header Tags before this contribution so I'm not sure if that is a problem. I did read this in the instructions:

 

"By default the file sts_user_code is included, but if you don't use any placeholder defined inside this file, just remove it from the list. In the other hand, if you add a contribution which add some new placeholders, like the famous header tags controller, then you only need to add the file in the list. The files must be separated by semicolons."

 

But I'm really not sure what that means. I'm sure there's probably an easy answer out there. Can anyone post a link or some instructions? Thanks.

 

 

Aloha Rigadin,

 

Much kudos for your helpful posts and most excellent STS plus. As far as....

I see no reference on the HTC contribution page for the module you speak of. I have spent hours (searched forum, etc) and still can't get the the page title of my index.php to change. I have held off on installing the admin part of HTC since with the catalog part installed the page title is still "osCommerce"

 

Any ideas?

Share this post


Link to post
Share on other sites
Yes, I did a clean. I uploaded both folders. I configed everything also.
Check your installation again. it seems you are missing a file or placed it in the wrong folder.

 

Go to this link for more detailed information regarding installation: Post #202

 

Let me know if this helps,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Check your installation again. it seems you are missing a file or placed it in the wrong folder.

 

Go to this link for more detailed information regarding installation: Post #202

 

Let me know if this helps,

 

Bill Kellum

I fixed that, but now every single url in the admin cp looks like this

 

http://www.wordofsouth.comdir_ws_admincategories.php/?selected_box=catalog&osCAdminID=0928e6380b68d5e4836a7150c6843a30

 

http://www.wordofsouth.com/wosestore/admin/HTTP_CATALOG_SERVERDIR_WS_CATALOG?osCAdminID=2c9184f03df17ae06755a08a6b8d9b01

Share this post


Link to post
Share on other sites

thatsright ,

check your configure.php file in admin. There should be defined all paths like

HTTP_CATALOG_SERVER

DIR_WS_CATALOG

....

 

For example , define('HTTP_CATALOG_SERVER', 'http://localhost'); (for my locahost) or

define('HTTP_CATALOG_SERVER', 'http://www.yourdomain.com'); for you.

 

 

Thanks,

Igor.

Share this post


Link to post
Share on other sites

Could someone help me. I have added sts plus V4.05 (i think) but when I tried to use one of the test files I only get the php names shoing and not their items.

 

My Webpage

Share this post


Link to post
Share on other sites

Hello... I need help urgently!

 

I'm ready to post my website to directories but can't because of one small.. or big thing! I need titles, keywords and description meta tags on my oscommerce pages. However... I'm using sts plus and installed (partially) the header tag contribution and have now found that the header contribution doesn't work if your using sts plus!

 

Does anyone know how to set keyword, descriptions and title meta tags on the oscommerce pages?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Could someone help me. I have added sts plus V4.05 (i think) but when I tried to use one of the test files I only get the php names shoing and not their items.

 

My Webpage

I'm not sure why the "#" symbol is showing after each of your placeholders but I would start by removing the "#" at the end of $content and then see if it makes a positive change for you.

 

Also, make sure you have configured STS in the Admin panel under Modules. Set the template to be true.

 

Hope this helps you out....let us know.

 

Thanks,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hello... I need help urgently!

 

I'm ready to post my website to directories but can't because of one small.. or big thing! I need titles, keywords and description meta tags on my oscommerce pages. However... I'm using sts plus and installed (partially) the header tag contribution and have now found that the header contribution doesn't work if your using sts plus!

 

Does anyone know how to set keyword, descriptions and title meta tags on the oscommerce pages?

 

Thanks in advance.

Nadia,

 

This subject has been discussed in detail in previous posts but I'll try to give you a quick synopsis:

 

You need at least the 2.4.7 Header Tag Controller and pay close attention to the installation instructions. Here is some particulars that you need to pay close attention to:

 

MODIFICATIONS TO FILES: (not all shops begin in the catalog directory so adjust to your site)

 

Add to /catalog/includes/application_top.php at the end of

the file right before the last ?>

 

// BOF: WebMakers.com Added: Header Tags Controller v2.4.7

require(DIR_WS_FUNCTIONS . 'header_tags.php');

// Clean out HTML comments from ALT tags etc.

require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

// EOF: WebMakers.com Added: Header Tags Controller v2.4.7

 

NOTE: if already using FREE-CALL FOR PRICE Add-on you do not need

to add the clean_html_comments.php to application_top as you should

already have it there.

 

NOTE for STS Users: The above also applies to STS shops but does not

always work for some reason. If your STS shop fails, in your sts_output.php file,

 

FIND

require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

require(DIR_WS_FUNCTIONS . 'header_tags.php');

CHANGE TO

require_once(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

require_once(DIR_WS_FUNCTIONS . 'header_tags.php');

 

================================================================================

======================

CHANGES TO ALL FILES:

 

Changes in all files in /catalog containing: <title><?php echo TITLE; ?></title>

This applies to most of the files in your root directory (the same location where your

index.php file is located).

 

Modify a line in all files ( approximately 35 files ) where there is a <TITLE> tag:

These files are located in your root directory. A search for

<title><?php echo TITLE; ?></title>

will locate all the files needing a change.

 

NOTE: The <TITLE> tag is different in popup_image.php and is not handled by Header Tags Controller.

 

In each file of /catalog/ you will need to make the following modification:

 

Replace the existing two lines in all files that you want to use the Header Tags Controller:

 

Old Lines:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

New Lines:

 

<?php

// BOF: WebMakers.com Changed: Header Tag Controller v2.4.7

// Replaced by header_tags.php

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

// EOF: WebMakers.com Changed: Header Tag Controller v2.4.7

?>

 

NOTE: Rather than remove the original line, I used this block of code that uses the standard TITLE if the header_tags.php file does not exist.

 

Hope this helps you out.

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Natalie,

 

STS Plus 4.07 should work fine with your store files being in the root. You will not need to modify the default settings of STS in order for this to work...should be "business as usual".

 

As for the redirect, yes and no. Search engines today are a lot smarter than just a few years ago. I mentioned the "meta redirect" earlier, but I don't think that would be a good idea considering how search engines have adapted to how most xxx sites use, or should I say, abuse the use of meta redirects. Javascript redirects and those implemented by your web administrator work best with search engine spiders. You may want to look into doing a redirect using a line of code in your .htacess file. Look here for more details on this:

All in all, if you are concerned with not being ranked or skipped by the search engine spiders, I would leave your store where it's at in the root directory. Just keep it in mind in future modifications to your shop that "catalog" means your root folder.

 

Don't take this the wrong way, but most people who have to use redirects is usually because of poor planning or some kind of mistake. Taking the time to plan out your site before jumping in head first will usually prevent the need from ever having to use a redirect. Whew....wish someone would have mentioned this to me a long time ago..... :lol:

 

Good luck,

 

Bill Kellum

 

Hi Bill,

 

Thanks for all your previous advice... I have tried once again to move to the root (I have other domains using the same web space so redirects are difficult).

I 'removed' STS Plus through the admin prior to moving the site as I had problems last time. Now, the site is working fine, but I can't 'install' STS from admin. I thought perhaps it was referencing the wrong module but I can't see where this would be.

If I move it back STS works fine without any problems! Very Strange!

Just wondering if you have any other suggestions? Or if there is anyone else reading who has the same problem?

 

Thanks,

Natalie

Share this post


Link to post
Share on other sites

It seems it is all my modules so not an STS problem.. sorry to waste time. But if anyone does have any suggestions please let me know!

Share this post


Link to post
Share on other sites
Hi Bill,

 

Thanks for all your previous advice... I have tried once again to move to the root (I have other domains using the same web space so redirects are difficult).

I 'removed' STS Plus through the admin prior to moving the site as I had problems last time. Now, the site is working fine, but I can't 'install' STS from admin. I thought perhaps it was referencing the wrong module but I can't see where this would be.

If I move it back STS works fine without any problems! Very Strange!

Just wondering if you have any other suggestions? Or if there is anyone else reading who has the same problem?

 

Thanks,

Natalie

Natalie,

 

I know the install might be a little confusing so I will try to make it simple for you.

 

 

If you are going from a directory to the root, be sure you do the same for the STS installation.

 

For example:

 

 

 

Installation (for a store located in the ROOT directory

 

1.
Make a backup of your OsCommerce files.
(for this installation, I would suggest just making a folder on your computer called "oscommerce_backup" and copy ALL your oscommerce files and folders to this folder.)

2.
Copy STS files from the "UPLOAD" folder to your root directory
.
(Do not upload the actual folder called "upload" but rather the contents of this folder.) You will upload these files and folders to your store directory, for you it would be your root drive. You will not "add" the folder "catalog", but you will "add" it's contents. The files that you will include in the sts download "upload" folder are the following:

 

includes

>classes

>functions

>languages

>>english

>>>modules

>>>>sts

>modules

>>sts

>>sts_inc

>sts_templates

>>test

>>>content

 

So, for the above folders, insert them into the appropriate folders of the same name in your store. Since you already have a
, you would only put the contents of the "includes" folder there, not another folder within the folder. You may be overthinking this a bit. It's really pretty simple.
If you someone gave you an apple basket full of apples but you already had an apple basket, you would just dump or "upload" the addition apples into your exiting apple basket and throw away the new apple basket.

 

3.
Copy the files from the folder "clean_osc" over your root directory
.
(Don't be fooled by this step. This is an either/or statement. You must EITHER copy the files from the "clean_osc" folder into your root directory OR do the manual edits to each one of the pages on your own. You NEED these files in addition to the files in the Upload folder.

 

4.
If you have a modified shop, you can use a comparison program to update your shop with the files in the folder "Clean_osc", and forget the manual modifications
.
(Do this step only if you chose the "OR" option in the previous step. This step is included for those who have a lot of contributions already installed and would rather dig into the "nuts-an-bolts" of STS Plus on thier own to have more control over the installation. This is a good thing but if you don't need it, you can skip this step.

 

Installation (for a store in a directory such as "catalog" or "store" or "whatever name you wish")

 

1.
Make a backup of your OsCommerce files.
(for this installation, I would suggest just making a folder on your computer called "oscommerce_backup" and copy ALL your oscommerce files and folders to this folder.)

2.
Copy STS files from the "UPLOAD" folder to your store directory ("catalog" or "store" or "whatever you named this directory").
(Do not upload the actual folder called "upload" but rather the contents of this folder.) You will upload these files and folders to your store directory
("catalog" or "store" or "whatever you named this directory").
You will not "add" the folder "catalog", but you will "add" it's contents. The files that you will include in the sts download "upload" folder are the following:

 

 

includes

>classes

>functions

>languages

>>english

>>>modules

>>>>sts

>modules

>>sts

>>sts_inc

>sts_templates

>>test

>>>content

 

So, for the above folders, insert them into the appropriate folders of the same name in your store. Since you already have a
, you would only put the contents of the "includes" folder there, not another folder within the folder. You may be overthinking this a bit. It's really pretty simple.
If you someone gave you an apple basket full of apples but you already had an apple basket, you would just dump or "upload" the additional apples into your exiting apple basket and throw away the new apple basket.

 

3.
Copy the files from the folder "clean_osc" over your store directory ("catalog" or "store" or "whatever you named this directory").
(Don't be fooled by this step. This is an either/or statement. You must EITHER copy the files from the "clean_osc" folder into your
store directory ("catalog" or "store" or "whatever you named this directory").
OR do the manual edits to each one of the pages on your own. You NEED these files in addition to the files in the Upload folder.

 

4.
If you have a modified shop, you can use a comparison program to update your shop with the files in the folder "clean_osc", and forget the manual modifications listed in the contributions install text.

 

Check the above to make sure you reinstalled your STS files in the appropriate folders and you should be set to go.

 

Good luck,

 

Bill Kellum

 

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Nadia,

 

This subject has been discussed in detail in previous posts but I'll try to give you a quick synopsis:

 

You need at least the 2.4.7 Header Tag Controller and pay close attention to the installation instructions. Here is some particulars that you need to pay close attention to:

Hope this helps you out.

 

Bill Kellum

Hi Bill,

 

thanks for the response. I have read posts about this topic, and they have lead me to believe that it's not possible to have meta tags using the header tag controller!... unless I've missed out some posts!

 

I'm using Header Tag Controller 2.5.6.

 

I paid close attention to the doc you showed me. But I must admit that I can't find the file sts_output.php... as wasn't this file in sts version 3?... and it's not in sts plus?

 

"I got upto the stage in Install_Catalog.txt where it says...

The catalog section should now be installed and working! However, if the admin section

has not been installed, some page headings may be missing. This is just temporary and, in

fact, shows that the installation is working so far. :)"

 

And when I went to my webpage and loaded up the catalog index page, the title is what I set it... not what was set by the Header Tag Controller, i.e. when I disable sts Header Tag Controller works.

 

i apologise if I'm repeate quesions that have been answered over and over again! Maybe you could be so kind as to point me in the right direction where these posts are... I'll re-search for these posts to see if I can find the answers. But the truth is... I've followed the instructions, and am confused as to where sts_output.php is.

 

Thanks,

Nadia.

Share this post


Link to post
Share on other sites
Hi Bill,

 

thanks for the response. I have read posts about this topic, and they have lead me to believe that it's not possible to have meta tags using the header tag controller!... unless I've missed out some posts!

 

I'm using Header Tag Controller 2.5.6.

 

I paid close attention to the doc you showed me. But I must admit that I can't find the file sts_output.php... as wasn't this file in sts version 3?... and it's not in sts plus?

 

"I got upto the stage in Install_Catalog.txt where it says...

The catalog section should now be installed and working! However, if the admin section

has not been installed, some page headings may be missing. This is just temporary and, in

fact, shows that the installation is working so far. :) "

 

And when I went to my webpage and loaded up the catalog index page, the title is what I set it... not what was set by the Header Tag Controller, i.e. when I disable sts Header Tag Controller works.

 

i apologise if I'm repeate quesions that have been answered over and over again! Maybe you could be so kind as to point me in the right direction where these posts are... I'll re-search for these posts to see if I can find the answers. But the truth is... I've followed the instructions, and am confused as to where sts_output.php is.

 

Thanks,

Nadia.

Nadia,

 

I don't use the Header Tag contribution but I have read where Rigadin made reference that STS PLUS and the Header Tag contribution would work together as long as the file that I mentioned earlier was followed.

 

Even though I do not use Header Tag, I will research this for you and let you know ASAP. Keep your fingers crossed. :-)

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
thatsright ,

check your configure.php file in admin. There should be defined all paths like

HTTP_CATALOG_SERVER

DIR_WS_CATALOG

....

 

For example , define('HTTP_CATALOG_SERVER', 'http://localhost'); (for my locahost) or

define('HTTP_CATALOG_SERVER', 'http://www.yourdomain.com'); for you.

Thanks,

Igor.

 

I did that and well, I am still having that problem.

Share this post


Link to post
Share on other sites

To Natalie:

If the problem is with all modules, and it worked before you moved your store to the root, then the problem is is the configure.php file in the admin/includes folder. Check that the paths are correct there.

 

To Shedmore:

No you were not annoying me :)

 

To HTC users:

I understand that some of you are having trouble installing HTC with STS PLUS as somebody has removed the module from HTC contribution page! It is now available on the STS PLUS contribution page. Follow these instructions and it should work very fast:

 

- Follow HTC instructions for the installation, but:

  • Do not modify the files in catalog folder
  • There is nothing to modify in sts_display_output.php (sts_output.php has never existed btw). These instructions are for STS v2/v3 and not for STS PLUS.

- From the STS PLUS contribution page, download the STS PLUS module I posted today and follow the install instructions (=copy 1 file and configure the STS PLUS modules in admin to use this file).

- On your template, be sure that you have the placeholder <!--$headcontent--> in the header (for example right after the <head>.

 

Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

thanks.

 

It was the template being set to false, when I thought I has set it to true :blush: :blush:

 

many thanks

 

I'm not sure why the "#" symbol is showing after each of your placeholders but I would start by removing the "#" at the end of $content and then see if it makes a positive change for you.

 

Also, make sure you have configured STS in the Admin panel under Modules. Set the template to be true.

 

Hope this helps you out....let us know.

 

Thanks,

 

Bill Kellum

Share this post


Link to post
Share on other sites
To HTC users:

I understand that some of you are having trouble installing HTC with STS PLUS as somebody has removed the module from HTC contribution page! It is now available on the STS PLUS contribution page. Follow these instructions and it should work very fast:

 

- Follow HTC instructions for the installation, but:

  • Do not modify the files in catalog folder
     
  • There is nothing to modify in sts_display_output.php (sts_output.php has never existed btw). These instructions are for STS v2/v3 and not for STS PLUS.

- From the STS PLUS contribution page, download the STS PLUS module I posted today and follow the install instructions (=copy 1 file and configure the STS PLUS modules in admin to use this file).

- On your template, be sure that you have the placeholder <!--$headcontent--> in the header (for example right after the <head>.

 

Rigadin

hello

 

HTC module do not work for me.

I have installed STS plus and after it i installed HTC i do not edit my /catalog content only index.php like is stated on HTC installation instructions. After it i added HTC module made everything by instruction and i got such error after it. :( please help me someone to result this sutaution.

 

Fatal error: Cannot redeclare tep_get_header_tag_products_title() (previously declared in /home/admin/shop/html/includes/functions/header_tags.php:8) in /home/admin/shop/html/includes/functions/header_tags.php on line 8

Share this post


Link to post
Share on other sites

Try again with an unmodified index.php, otherwise the same file is called from index.php and also from STS PLUS => some functions will be declared twice and give this error.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
Try again with an unmodified index.php, otherwise the same file is called from index.php and also from STS PLUS => some functions will be declared twice and give this error.

 

- Rigadin

i do not added <title> modification. all other modification was added.

 

so you all modifications clear and leave 100 % not changed index.php file ?

Share this post


Link to post
Share on other sites

if you mean that. so i uploaded clean index.php in my catalog but error was the same. Can you offer something ?

Share this post


Link to post
Share on other sites

Hi

 

COOLMENUS and STS PLUS problem

 

I have STS plus installed on a new installation of OSC, all works fine, a great contribution but then i tried to unstall coolmenus. i followed the intructions according to the install file exactly but nothing seems to happen with my category menu, basically it looks the same as it did before.

 

Is coolmenus compatable with STS PLUS?

 

thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×