Jump to content
Sign in to follow this  
Rigadin

[contribution] STS PLUS v4

Recommended Posts

...

Why we cannot start capture at the end of application_top and finish it at the begin of column_left ? Then find all code between <head> </head> and display it . In this case all js will work.

What do you think about this idea?

 

Thanks,

Igor.

 

P.S. Sorry for my english. Let me know if you don't understand anything.

 

In fact this is already the case: js found in header is captured and will be displayed on your pages if you have put the <!--$headcontent--> placeholder in the header of your template. The external js file is interesting if you want to add new js: no need to modify all php files in catalog but only the template(s).


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

I need some installation help please. I installed the STS Plus 4.0.07 on a clean and working OSC. I followed the instructions and uploaded the upload/catalog folder. Then i went to the admin and went to modules as per the instructions in the word file. There is no STS link to be found anywhere.

So then i also installed the clean_osc/catalog but still no STS link in the modules part of the admin. Am i missing something? I checked and all the folders and files seemd to be uploaded. Is there anything else i have to do?

 

Which folder should i upload? The upload folder or the clean_osc or both? Please help me out it?s so frustrating to be stuck. The shop worked as usual after i did the installation, no difference at all. There wher just no STS link in the admin modules part. My configure PHP is set to 444, should it be set to 777?

Share this post


Link to post
Share on other sites
I just read a few posts back that both the upload and clean_osc catalog should be uploaded. I did that already but i still don?t see the STS link in admin modules section.
Be sure you did not upload the "Upload" folder, just it's contents.

 

Let me know if that was your problem,

 

Bill Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I get this error

 

Fatal error: Call to a member function on a non-object in /home/lbwos/public_html/wosestore/admin/includes/application_bottom.php on line 21

Share this post


Link to post
Share on other sites
Does form_check.js.php work for you at create_account.php page ?

 

Thanks,

Igor.

 

Yes it works for me. Check the html source of your create_account.php page, is there any javascript in header?

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
Be sure you did not upload the "Upload" folder, just it's contents.

 

Let me know if that was your problem,

 

Bill Kellum

 

 

No that is not the problem. I kept the correct catalog structure.

Share this post


Link to post
Share on other sites

A new question if i may. First of all thanks for a great contribution, i understand how to use most of it right away.

 

There is one thing that i can?t figure out though. How do i create a template for the index.php in the english folder? I want to put a picture on that page. If i create a new index.php.html it will affect the inex.php in the catalog folder and not the one in the english folder? I want to place a picture only in the /english/index.php. Can that be done with a template? I have no idea how to place a picture with PHP.

Share this post


Link to post
Share on other sites

Hello...Im back, I was just curious (i cant seem to run debug mode in the category/subcategory "content" listing page)

 

Anyway....I am trying to remove the categories txt link below the category images in the content area (that are there by default) becuase with the images i am using (the names are in the images) it is reduntant and bad looking, I cant figure out where to go or what to delete to do this though...and as always, any help would be greatly appreciated ..thanks again

Share this post


Link to post
Share on other sites

@shedmore:

 

Is it an option to remove the name, and make it a space?

Then you dont see the text link i think...

Or change the link color in the stylesheet.txt to you background

Share this post


Link to post
Share on other sites

The part of code that put image and text is located in index.php, around line 100:

	while ($categories = tep_db_fetch_array($categories_query)) {
  $rows++;
  $cPath_new = tep_get_path($categories['categories_id']);
  $width = (int)(100 / MAX_DISPLAY_CATEGORIES_PER_ROW) . '%';
  echo '				<td align="center" class="smallText" width="' . $width . '" valign="top"><a href="' . tep_href_link(FILENAME_DEFAULT, $cPath_new) . '">' . tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT) . '<br>' . $categories['categories_name'] . '</a></td>' . "\n";
  if ((($rows / MAX_DISPLAY_CATEGORIES_PER_ROW) == floor($rows / MAX_DISPLAY_CATEGORIES_PER_ROW)) && ($rows != $number_of_categories)) {
	echo '			  </tr>' . "\n";
	echo '			  <tr>' . "\n";
  }
}

 

Remove this from the code.

. '<br>' . $categories['categories_name']

and that's should work.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites

Thanks for the help guys, unfortunately

 

The part of code that put image and text is located in index.php, around line 100:

CODEwhile ($categories = tep_db_fetch_array($categories_query)) {

$rows++;

$cPath_new = tep_get_path($categories['categories_id']);

$width = (int)(100 / MAX_DISPLAY_CATEGORIES_PER_ROW) . '%';

echo ' <td align="center" class="smallText" width="' . $width . '" valign="top"><a href="' . tep_href_link(FILENAME_DEFAULT, $cPath_new) . '">' . tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT) . '<br>' . $categories['categories_name'] . '</a></td>' . "\n";

if ((($rows / MAX_DISPLAY_CATEGORIES_PER_ROW) == floor($rows / MAX_DISPLAY_CATEGORIES_PER_ROW)) && ($rows != $number_of_categories)) {

echo ' </tr>' . "\n";

echo ' <tr>' . "\n";

}

}

 

Remove this from the code.

. '<br>' . $categories['categories_name']

and that's should work.

 

- Rigadin

 

did not remove the txt link below the images, I should point out (which im sorry I didnt before) that these images and categories are actually subcategory folders, the main categories dont have images, just the subs, so im wondering if the above recommendation is for main cats, and not sub cats, if that is the case what should I do instead.....and again .....thanks so much

Share this post


Link to post
Share on other sites

and thanks for that suggestion ViPeRII ...a space would work fine instead of txt, but I dont know where I am going to put that in the code that is the problem...and the second option of changing the css...is not viable because it will change the other links around the site to be invisible as well...one trick i thought of was to maybe put a class over it that would be a 0% txt size and see if the crushes the txt size, but before doing that I wanted to see if anyone knew how to actually remove the subcat txt links from the code...thanks again

Share this post


Link to post
Share on other sites

All the solutions proposed implies that you know where is the code that displays the categories name, so when you find this place, best is to remove it. And one remark about displaying 0px text or "white on white" text: search engines can think that this is some kind of spam!

 

Anyway, I tried the solution I proposed few posts ago and it works! So try again, you probably made something wrong.

 

- Rigadin


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
All the solutions proposed implies that you know where is the code that displays the categories name, so when you find this place, best is to remove it. And one remark about displaying 0px text or "white on white" text: search engines can think that this is some kind of spam!

 

Anyway, I tried the solution I proposed few posts ago and it works! So try again, you probably made something wrong.

 

- Rigadin

 

 

My reply to this is:

You are absolutely right Rigadin!

But i didn't know the other way, so i made a sugestion ;-)

 

 

By the way, (i think it's been asked for a few times...)

 

Could the be some code to disable the new product for box in the middle of the screen, just like the infoboxes?

Share this post


Link to post
Share on other sites

To remove the new products box from index.php, search for FILENAME_NEW_PRODUCTS.

To remove the upcoming products box in index.php, search for FILENAME_UPCOMING_PRODUCTS.


STS v4.5 SP5 is out, and check the STS Power Pack contribution too!

New thumbnailer using phpThumb: oscThumb. Works great.

Share this post


Link to post
Share on other sites
To remove the new products box from index.php, search for FILENAME_NEW_PRODUCTS.

To remove the upcoming products box in index.php, search for FILENAME_UPCOMING_PRODUCTS.

 

 

I know that one, but that removes it from all pages.

I have a 5 catagory deep menu. I want to show this box in the first 2 layers, but after the 3th,

i want to disable it.

 

So that cant be done in your option i think.

 

Thats why i'm asking for a option en maybe a new version of sts plus? ;-)

Share this post


Link to post
Share on other sites

These are on every single page except for the main admin page. What could I have done wrong?

 

// START STS PLUS 4.0 $sts->restart_capture ('applicationtop2header'); // END STS PLUS 4.0

 

 

// START STS PLUS 4.0 $sts->restart_capture ('header'); // END STS PLUS 4.0

 

Fatal error: Call to a member function on a non-object

 

in /home/public_html/wosestore/admin/includes/application_bottom.php on line 21

 

 

 

 

 

Also, I really do not understand how to edit my product_info.php

Share this post


Link to post
Share on other sites

Aloha Rigadin,

 

Much kudos for your helpful posts and most excellent STS plus. As far as....

 

- To have Header Tags working with STS PLUS, you need to install a module. You can get the module from the same page as the Header Tags contribution.

- Rigadin

 

I see no reference on the HTC contribution page for the module you speak of. I have spent hours (searched forum, etc) and still can't get the the page title of my index.php to change. I have held off on installing the admin part of HTC since with the catalog part installed the page title is still "osCommerce"

 

Any ideas?

Share this post


Link to post
Share on other sites

Rigadin,

 

I've searched this thread to try to find anything regarding replacing the link for the "Click to enlarge" text under the product image to redirect it to a different webpage.

 

I want to make the link from "Click to enlarge" go directly to the "products webpage" url that is entered when the product is listed. This is the same link that is created for the text "For more information, please visit this products webpage" reference.

 

I am so close at doing this but keep falling short.

 

I want to continue using the small .gif file for my products image, but I want to redirect the "Click to enlarge" textlink to the product's webpage where I have created a nifty image slideshow. I have already changed the "Click to enlarge" text to "Additional Views" but have been unsuccessful at getting the link to work.

 

I use STS PLUS v4.07 and I noticed you have a $imagelarge placeholder available. I am only using the default template and index.php.html template. Do I need to use the content template and change the link in the $imagelarge tag to make this work?

 

Any ideas?

 

Thanks,

 

Bill Kellum

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

thanks for you help rigadin2, I wasn?t trying to annoy you ...(which it seems like I did with your response) I have added a bunch of modifications to the site, and sometimes I get lost in all of them (especially at 2 in the morning), I erased the right code but on the wrong line... (Should have searched further down in my index) It did indeed work...but I just wanted to say thanks for the help again...and sorry if I frustrated you....

Share this post


Link to post
Share on other sites
Rigadin,

 

I've searched this thread to try to find anything regarding replacing the link for the "Click to enlarge" text under the product image to redirect it to a different webpage.

 

I want to make the link from "Click to enlarge" go directly to the "products webpage" url that is entered when the product is listed. This is the same link that is created for the text "For more information, please visit this products webpage" reference.

 

I am so close at doing this but keep falling short.

 

I want to continue using the small .gif file for my products image, but I want to redirect the "Click to enlarge" textlink to the product's webpage where I have created a nifty image slideshow. I have already changed the "Click to enlarge" text to "Additional Views" but have been unsuccessful at getting the link to work.

 

I use STS PLUS v4.07 and I noticed you have a $imagelarge placeholder available. I am only using the default template and index.php.html template. Do I need to use the content template and change the link in the $imagelarge tag to make this work?

 

Any ideas?

 

Thanks,

 

Bill Kellum

OK, After hours of trying to get this to work by hard coding PHP, I gave up and easily made the changes that I wanted to do above using a "content template". I "simply" love the "Simple Template System Plus"!!!!icon12.gif

 

You can see an example of what I did with the product url and the image by going here:http://hatoverheels.com/eshop/product_info...&products_id=48

 

Click on the "Additional Views" text link under the image and see how I made use of the link without the Javascript popup window. :thumbsup:

 

-Billy Kellum


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×