Jump to content
Sign in to follow this  
vivaxone

Administration Access Level Accounts 2.0 need help

Recommended Posts

Hi :)

 

 

I have installed this Contribution (Admin Access 2.2a) with ALL the patches. Now - I have the following problems:

 

 

1. When I click on 'TOOLS' - I get the following Error message:

 

 

Not Found

The requested URL /shop/admin/FILENAME_FORBIDEN was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Apache/1.3.37 Server at www.5280gourmet.com Port 80

 

2. When I go into 'REPORTS' - 'Products Viewed' or 'Products Purchased' and click on one of the things listed in these submenus - I get the same Error message!

 

 

3. When I click on the Administration link on the top right hand corner (next to 'Support Site' and 'Online Catalog') - it gives me a very blue (hard to see) screen with ALL the links to all the things in a top level ADMIN access (when clicking on one of those links - they end up going to the Error above but I still don't think that everything should be listed in here). And - is there a way to change the color scheme so it would be easier to see?

 

4. I was reading through all the posts in this thread and I wonder about the security... what exactly do you recommend I do to make this secure? (in laymen's terms please)

 

 

Thank you for all your great replies,

 

Jan :blink:

Edited by romantix

Share this post


Link to post
Share on other sites

Hi :blink:

 

I still have the problems above but now I have a new problem as well - as mentioned above - I have installed this Contribution (Admin Access 2.2a) with ALL the patches.

 

 

Now - I have a problem logging into the Admin area. It initially let me get in, I changed my password and setup access for another person. Then, when the other person tried to login - they couldn't. It would just give them (and from that time on - give me also) a popup asking for a user ID and password but would never accept the correct information. After 3 tries - it times out and says:

 

 

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Apache/1.3.37 Server at www.5280gourmet.com Port 80 I have somehow managed to get in through Firefox but it keeps doing that (to me) in IE and also to the other person who is trying to login from a different computer on both IE and Firefox. The problem really is that it just presents the pop-up login box instead of the on the page login window which has the link to send the password if forgotten and so on...

 

 

 

Would anyone know what I can do? (I'm afraid I might never be able to login into the ADMIN again!

 

 

 

Thanks to all of you for your ideas,

 

 

 

Jan

Edited by romantix

Share this post


Link to post
Share on other sites
Hi, I have installed this great mod and it appears to work except that when the variables are parsed to add a new member, I get an internal server error. My server logs aren't giving any clues, so if anyone could point me in the right direction, I would be grateful!

 

Thanks in advance!

 

 

Did you get an answer to this? I am having the same problem!

Share this post


Link to post
Share on other sites

Hi,

 

I've added the Admin Access Level Accounts 2.2a into my loaded store, with quite a few other modules installed, including MULTI VENDORS MVS 1.1 and also Ultimate SEO URLs.

 

These mods work well as designed, from what I can see so far. It was a little difficult to get both the MVS and Admin Access Levels to work. Had to move a few files around and do a bit of hacking here and there to get the Vendors left side menus to show up correctly.

 

Anyway, here is the issue:

 

How can I let Vendors login with the Admin Access into a group that lets them see/edit ONLY their own products, identified with their own Vendor IDs in the database?

 

We want our drop-ship vendors to be able to maintain their own inventory in the store, and not be able to mess with other vendors' products.

 

Another question, interestingly -- how can we establish the MVS/Admin-Levels setup so that they CANNOT change our categories? Only be able to add/modify/delete products?

 

Any ideas out there?

 

Thanks a bunch!

Share this post


Link to post
Share on other sites

Hello,

 

How can I force left navigation boxes refer to some files via SSL connection? For example, I need to have the following files under SSL connection in customers box:

// '<a href="' . tep_href_link(FILENAME_CREATE_ACCOUNT, '', 'SSL') . '" class="menuBoxContentLink">' . BOX_MANUAL_ORDER_CREATE_ACCOUNT . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_CREATE_ACCOUNT, '', 'SSL') . '" class="menuBoxContentLink">' . BOX_MANUAL_ORDER_CREATE_POACCOUNT . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_CREATE_ORDER, '', 'SSL') . '" class="menuBoxContentLink">' . BOX_MANUAL_ORDER_CREATE_ORDER . '</a>');

 

tep_admin_files_boxes(FILENAME_CREATE_ACCOUNT, BOX_MANUAL_ORDER_CREATE_ACCOUNT) .

tep_admin_files_boxes(FILENAME_CREATE_POACCOUNT, BOX_MANUAL_ORDER_CREATE_POACCOUNT) .

tep_admin_files_boxes(FILENAME_CREATE_ORDER, BOX_MANUAL_ORDER_CREATE_ORDER);

Any help would be appreciated.

Share this post


Link to post
Share on other sites

Is there anyone can make an update of this contribution to can manage the user with manufacture? When a user is added to some categories and 1 or more manufactures, he can only do every thing on the products of those manufactures in those categories . With that feature, we can share our shop to many and many manufactures, so they can update theirs products by themself.

 

And who had fix this bug ?

I use the Categorie Admin (Extension for Administration Access Level Account ) with Patches of Oliswiss , Administration Access Level Account 2.2a.

I found that, if one user who can view product (only create new, not edit, not copy, not delete), he can set the Status of all products! If someone "go to crazy", he can kill my shop!

 

And, beside that, can we have the log files of every accounts ? With that file I can know my user had did what things in my shop !


Paint for VietNamese :

Share this post


Link to post
Share on other sites

hi!

what a great contribution this is!!!

 

I seem to have only one, minor "problem"... very minor but would be great if i could get a solution somehow.

 

Case is i have 1 superadmin , 1 productadmin , 1 customerrelationadmin

first two levels work as expected but with the thrid, when i login all goes wel lbut it shows the message:

Please contact your Web Administrator to request

more access or if you found any problem.

 

Left column shows links fine that "belong" to this admin level.

 

the only way to solve it to allow this adminlevel to enter the catalog:products and categories..

but i would like this adminlevel to only be able to be for customerrelations. If they want to check product/categories they can do it on the frontend.

 

Is there something i missed? or ...?

 

Thanks!

Share this post


Link to post
Share on other sites
How can I let Vendors login with the Admin Access into a group that lets them see/edit ONLY their own products, identified with their own Vendor IDs in the database?

 

I have the same requirement (as does Le Quoc Hung, I notice)

 

Tom, have you or anybody found a contribution that handles 'Admin Access into a group'?

or ... anyone working on such a solution at the moment?

 

 

ah-ha ... maybe this will work ... just found it:

"Listing Products Instructions in admin for vendors"

http://www.oscommerce.com/community/contri.../search,vendors

 

 

Thanks

Puddle

Edited by puddle

Share this post


Link to post
Share on other sites
I have the same requirement (as does Le Quoc Hung, I notice)

 

Tom, have you or anybody found a contribution that handles 'Admin Access into a group'?

or ... anyone working on such a solution at the moment?

ah-ha ... maybe this will work ... just found it:

"Listing Products Instructions in admin for vendors"

http://www.oscommerce.com/community/contri.../search,vendors

Thanks

Puddle

 

I just install that contribution but i see that it is only instructions how to manage catalog. There is no function with the feature that i need for the vendors (this vendor can edit or add .. the products of another vendors).


Paint for VietNamese :

Share this post


Link to post
Share on other sites

Has anybody got the Supertracker contrib working with admin access? The supertracker.php page is not keeping my osCAdminID so I get redirected to a login page every time I try to look at a report... Any ideas?

Share this post


Link to post
Share on other sites
Has anybody got the Supertracker contrib working with admin access? The supertracker.php page is not keeping my osCAdminID so I get redirected to a login page every time I try to look at a report... Any ideas?

 

I fixed it by editing the following code in catalog/admin/supertracker.php after line 125 :

Replace:

<option value=""><?php echo TABLE_TEXT_MENU_TEXTE; ?></option>

<option value="supertracker.php?report=refer"><?php echo TEXT_TOP_REFERRERS; ?></option>

<option value="supertracker.php?report=success_refer"><?php echo TEXT_TOP_SALES;?></option>

<option value="supertracker.php?special=geo"><?php echo TEXT_VISITORS;?></option>								

<option value="supertracker.php?special=keywords"><?php echo TEXT_SEARCH_KEYWORDS;?></option>

<option value="supertracker.php?special=keywords_last24"><?php echo TEXT_SEARCH_KEYWORDS_24;?></option>			
<option value="supertracker.php?special=keywords_last72"><?php echo TEXT_SEARCH_KEYWORDS_3;?></option>			
<option value="supertracker.php?special=keywords_lastweek"><?php echo TEXT_SEARCH_KEYWORDS_7;?></option>		<option value="supertracker.php?special=keywords_lastmonth"><?php echo TEXT_SEARCH_KEYWORDS_30;?></option>		<option value="supertracker.php?report=exit"><?php echo TEXT_TOP_EXIT_PAGES;?></option>

<option value="supertracker.php?report=exit_added"><?php echo TEXT_TOP_EXIT_PAGES_NO_SALE;?></option>

<option value="supertracker.php?report=ave_clicks"><?php echo TEXT_AVERAGE_CLICKS;?></option>						<option value="supertracker.php?report=ave_time"><?php echo TEXT_AVERAGE_TIME_SPENT;?></option>					<option value="supertracker.php?special=prod_coverage"><?php echo TEXT_PRODUCTS_VIEWED_REPORT;?></option>	 <!-- modifed by azer//-->	

<option value="supertracker.php?special=last_ten"><?php echo TEXT_LAST_TEN_VISITORS;?></option>

<?php if (SUPERTRACKER_USE_PPC) {?>						

<option value="supertracker.php?special=ppc_summary"><?php echo TEXT_PPC_REFERRAL;?></option>

 

With This:

 

	
<div class="supertracker_text">	
<?php echo TABLE_TEXT_MENU_DESC_TEXTE; ?> <form name="report_select"><select name="report_selector" onchange="page_redirect(this)">							
<option value=""><?php echo TABLE_TEXT_MENU_TEXTE; ?></option>
<?php //Begin compatibility with Admin Level Access
?>
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&report=refer' ?>"><?php echo TEXT_TOP_REFERRERS; ?></option>
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&report=success_refer' ?>">
<?php echo TEXT_TOP_SALES;?></option>
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=geo' ?>"><?php echo TEXT_VISITORS;?></option>								
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=keywords' ?>"><?php echo TEXT_SEARCH_KEYWORDS;?></option>							
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=keywords_last24' ?>"><?php echo TEXT_SEARCH_KEYWORDS_24;?></option>										
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=keywords_last72' ?>"><?php echo TEXT_SEARCH_KEYWORDS_3;?></option>										
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=keywords_lastweek' ?>"><?php echo TEXT_SEARCH_KEYWORDS_7;?></option>										
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=keywords_lastmonth' ?>"><?php echo TEXT_SEARCH_KEYWORDS_30;?></option>													
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&report=exit' ?>"><?php echo TEXT_TOP_EXIT_PAGES;?></option>
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&report=exit_added' ?>"><?php echo TEXT_TOP_EXIT_PAGES_NO_SALE;?></option>
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&report=ave_clicks' ?>"><?php echo TEXT_AVERAGE_CLICKS;?></option>								
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&report=ave_time' ?>"><?php echo TEXT_AVERAGE_TIME_SPENT;?></option>
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=prod_coverage' ?>"><?php echo TEXT_PRODUCTS_VIEWED_REPORT;?></option>	 <!-- modifed by azer//-->	
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=last_ten' ?>"><?php echo TEXT_LAST_TEN_VISITORS;?></option>
<?php if (SUPERTRACKER_USE_PPC) {?>													
<option value="<?php echo $PHP_SELF . '?osCAdminID=' . $osCAdminID . '&special=ppc_summary' ?>"><?php echo TEXT_PPC_REFERRAL;?></option>
<?php //End compatibility with Admin Level Access
?>

Share this post


Link to post
Share on other sites

I install Admin Access version 2.2 and extension.

 

when I double click in my administrative system with admin access on my admin name, I recieve this error Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in */includes/functions/database.php on line 107

 

Any insight provided would be greatly appreciated.

Share this post


Link to post
Share on other sites
I install Admin Access version 2.2 and extension.

 

when I double click in my administrative system with admin access on my admin name, I recieve this error Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in */includes/functions/database.php on line 107

 

Any insight provided would be greatly appreciated.

 

I find the answer

 

http://forums.oscommerce.com/index.php?s=&...st&p=923496

Share this post


Link to post
Share on other sites

I have a problem with the way the Administration Access Level Accounts 2.0 works. I created a category for my site admin's. I set the group to have full access to the categories.php file & set certain Category Access restrictions, but for the users that have full Category Access they can't see anything that isn't in a category. Like if I add a product to the top level of the catalog they can't view the item. If you were to just click on the Catalog link you would by default be taken to this: admin/categories.php?selected_box=catalog. On that page you have the option to create a new category or new product, but it only shows new category. This is where my admin's can't view or add new products.

 

-Jason

Share this post


Link to post
Share on other sites

I still unable to get this to work. Any help?

 

Also in the login.php file for this contribution this line is wrong.

 

Currently this is the code around Line 43

 

tep_session_register('login_first_name');

 

It should be this blow...the session name was wrong.

 

tep_session_register('login_firstname');

 

I found this when I was writing some custom functions & wasn't able to print their first name out.

Share this post


Link to post
Share on other sites

I've installed this contrib and it works great...no problems....only thing is i also have Batch printer center installed and it doesn't show up on my menus anymore. I have the following lines:

 

english.php

define('BOX_TOOLS_BATCH_CENTER', 'Batch Print Center');

 

filenames.php

define('FILENAME_BATCH_PRINT', 'batch_print.php');

 

and in customers.php

$contents[] = array('text'  => tep_admin_files_boxes(FILENAME_CUSTOMERS, BOX_CUSTOMERS_CUSTOMERS) .
tep_admin_files_boxes(FILENAME_ORDERS, BOX_CUSTOMERS_ORDERS) .
tep_admin_files_boxes(FILENAME_BATCH_PRINT, BOX_TOOLS_BATCH_CENTER));

 

I also have the line in tools.php but it doesnt show up there either.

 

Anyone have any idea how to fix this?

Share this post


Link to post
Share on other sites
I've installed this contrib and it works great...no problems....only thing is i also have Batch printer center installed and it doesn't show up on my menus anymore. I have the following lines:

 

english.php

define('BOX_TOOLS_BATCH_CENTER', 'Batch Print Center');

 

filenames.php

define('FILENAME_BATCH_PRINT', 'batch_print.php');

 

and in customers.php

$contents[] = array('text'  => tep_admin_files_boxes(FILENAME_CUSTOMERS, BOX_CUSTOMERS_CUSTOMERS) .
tep_admin_files_boxes(FILENAME_ORDERS, BOX_CUSTOMERS_ORDERS) .
tep_admin_files_boxes(FILENAME_BATCH_PRINT, BOX_TOOLS_BATCH_CENTER));

 

I also have the line in tools.php but it doesnt show up there either.

 

Anyone have any idea how to fix this?

 

That looks right. Is the batch_print.php active in Admin > Administrator > File Access under Customers?

 

Iggy


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites
Ok I'm an idiot. I didn't add the file access in the admin section. I failed to fully understand the feature....lol It's working now.

 

It's nice when it's easy (and I've done that a few times myself) :lol:

 

Iggy


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites

hello,

 

i installed the contribution. but now the search function for example on customer- or productsite is not working. everytime i run a search, i'm landing on the login-page...

 

can anyone help?

thanks in advance

Share this post


Link to post
Share on other sites
Hi Irina...

 

I fixed the Problems and added the files to the contribution

(www.oscommerce.com/community/contributions,1359)

 

I hope you can use it, too...

 

Kind regards,

Thomas

 

Hi All, Ive had this problem for days now and still cannot solve it. I have messed with the code so much now I dont know what I have done. Everything works apart from I am getting this problem when logged in as any other user apart from admin and viewing the catalog pages:

 

1065 - Query was empty

 

 

 

[TEP STOP]

 

I have tried using your code Thomas but it just isnt going away. Is there are direct files I can upload?

 

Best Regards

Jim

Share this post


Link to post
Share on other sites

hello

 

I' would like to know the solution to the change password problem (registar globals = off).

i CANT CHANGE THE PASSWORD OF A MEMBER

 

Please help

 

TKS IN ADVANCE

Share this post


Link to post
Share on other sites

Hi folks!

I have installed the Access with Level account (v. 2.2a) very carefully, but now the server answer with the error message "Error 404-the page cannot be found" if i try to access the admin/index.php page

I have also uploaded the original admin/index.php page from back-up (without contrib additions) but this do not fix the problem!!

Any idea out there?

Please help me... i need to go on line March 1, 2007

 

Thanks in advance.

 

Enzo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×