Jump to content

Archived

This topic is now archived and is closed to further replies.

itelectr

images won't upload

Recommended Posts

Hi all

having problems uploading images when creating a new product.

this was working but for some reason it is now no longer working.

all attributes in the images folder are set to 777.

Not sure what has happend but i cant install any new products because of this.

 

 

some of the errors i get are:

 

Warning: move_uploaded_file(): open_basedir restriction in effect. File(/home/itelectr/public_html/catalog/images/nopic.gif) is not within the allowed path(s): (/home/itelectr/:/usr/lib/php:/usr/local/lib/php:/tmp) in /backup/itelectr/public_html/catalog/admin/includes/classes/upload.php on line 94

 

Error: File upload not saved.

 

i have installed a new catalog on the same server and still same problem,

any ideas?

Share this post


Link to post
Share on other sites

sounds like your host may have changed something, have you checked with them?


Installed Contributions: CCGV, Close Popup, Dynamic Meta Tags, Easy Populate, Froogle Data Feeder, Google Position, Infobox Header Entire Row, Live Support for OSC, PayPal Seal with CC images, Report_m Sales, Shop by Price Revised, SQL Updater, Who's Online Enhancement, Footer, GNA EP Assistant and still going.

Share this post


Link to post
Share on other sites
I think the best thing is that i change hosting

 

It looks as though they have switched to running PHP in Safe Mode with the 'file upload' feature disabled in php.ini

 

You can check this for yourself in your osC admin panel --> Tools --> Server Info, and do a browser page search for 'file upload', and you should see if it is enabled or not.

 

If it is not enabled then you will need to move - as you need this feature to run osCommerce.

 

Vger

Share this post


Link to post
Share on other sites

×