Jump to content

Archived

This topic is now archived and is closed to further replies.

iosysuk

SAFE MODE RESTRICTIONS

Recommended Posts

My site has suddenly started displaying SAFE MODE errors on the main catalog site and also the Admin site.

 

I've checked the files for whitespaces, as per the KB article, and they are correct.

 

Catalog site (http://www.peterborough-phantoms.com/catalog) shows ...

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid/gid is 10043/10001 is not allowed to access owned by uid/gid 0/0 in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/includes/functions/sessions.php on line 118

 

Warning: Cannot modify header information - headers already sent by (output started at /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/includes/functions/sessions.php:118) in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/includes/functions/general.php on line 1174

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/includes/functions/sessions.php:118) in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/includes/functions/sessions.php:118) in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/includes/functions/sessions.php on line 67

 

Admin site (http://www.peterborough-phantoms.com/catalog/admin) shows ...

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid/gid is 10043/10001 is not allowed to access owned by uid/gid 0/0 in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/admin/includes/functions/sessions.php on line 110

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/admin/includes/functions/sessions.php:110) in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/admin/includes/functions/sessions.php:110) in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/admin/includes/functions/sessions.php on line 67

 

Warning: Cannot modify header information - headers already sent by (output started at /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/admin/includes/functions/sessions.php:110) in /usr/local/psa/home/vhosts/peterborough-phantoms.com/httpdocs/catalog/admin/includes/functions/general.php on line 104

 

I've also checked the post-installation tasks to ensure security is correct on the files ...

1. Rename the catalog/install folder or delete it.

2. Reset the permissions on catalog/includes/configure.php to 644 (if you are still getting the warning message at the top of the page after setting this configure.php files to 644 then set the catalog/includes/configure.php file to 444 which is read only - this happens on some servers that have been updated for security reasons).

3. Set the permissions on catalog/images directory to 777

4. Set the permissions on admin/images/graphs directory to 777

5. Create the directory admin/backups and set the permissions to 777 (this is the folder to store the database backup of your store in the "Tools" section of the store admin).

 

Any ideas as this is doing my business no good !!!

 

Ian

Share this post


Link to post
Share on other sites
Your hosting company probably turned safe mode on. Read through this, you should be able to solve your problem.

 

http://forums.oscommerce.com/index.php?showtopic=181312

 

MY ISP has turned on SAFE MODE without warning.

 

They told me to got Admin and change the SESSIONS entry as per te thread you mention.

 

UNFORTUNATELY, the Admin pages are alo failing for me.

Does anyone know which entry in which file needs changing (or is it in the Database) ?

 

ian

Share this post


Link to post
Share on other sites

Ok, calmed down now, and after trawlng what seemed like half the internet i've found a fix.

 

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

 

 

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

 

UPDATE configuration SET configuration_value = 'tmp' WHERE configuration_key='SESSION_WRITE_DIRECTORY'

 

Click GO

 

Et Voila !

Ian

Share this post


Link to post
Share on other sites
MY ISP has turned on SAFE MODE without warning.

 

They told me to got Admin and change the SESSIONS entry as per te thread you mention.

 

UNFORTUNATELY, the Admin pages are alo failing for me.

Does anyone know which entry in which file needs changing (or is it in the Database) ?

 

ian

Usually people have been able to access enough of admin to make the change. It is stored in the database though.

 

It's in the configuration table, line 136, configuration_value.


Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Share this post


Link to post
Share on other sites

wow, Im so glad I found this page... more to the point the last two posts!

 

I had problems after transferring from offline editting in xampp.

 

Many Thanks

Share this post


Link to post
Share on other sites
Ok, calmed down now, and after trawlng what seemed like half the internet i've found a fix.

 

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

Click GO

 

Et Voila !

Ian

 

i love you!!! i have been trawling for hours... thanks for the solution!

Share this post


Link to post
Share on other sites

I was getting a similar thing on my shop, this has fixed it but I still get the same error when accessing my admin pages, I assume theres another absolute path somewhere?

Share this post


Link to post
Share on other sites
Ok, calmed down now, and after trawlng what seemed like half the internet i've found a fix.

 

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

Click GO

 

Et Voila !

Ian

 

thx m8. i am fixed my same problem. its really valuable info. its must be sticky..thx a million again

Share this post


Link to post
Share on other sites
Your hosting company probably turned safe mode on. Read through this, you should be able to solve your problem.

 

http://forums.oscommerce.com/index.php?showtopic=181312

 

 

I am getting similar error messages but nothing about Safe Mode (and I know its not on) I have already taken off the slash in front of tmp in the Session Store section in the Admin, but still errors

Share this post


Link to post
Share on other sites
Ok, calmed down now, and after trawlng what seemed like half the internet i've found a fix.

 

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

Click GO

 

Et Voila !

Ian

 

iosysuk for president, clean simple and working solution.. Sticky on this one ?..

Share this post


Link to post
Share on other sites
Ok, calmed down now, and after trawlng what seemed like half the internet i've found a fix.

 

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

Click GO

 

Et Voila !

Ian

 

 

thank you very much,,,,u r the best.

Share this post


Link to post
Share on other sites

Hi,

 

despite everything have been done and "safe mode" issue have been solve.

my page still giving these error (see below), and i was unable to go into my admin account.

Is it something to do with the "ini_get()" command at line13 in catalog/includes/functions/sessions.php file??

 

Anyone can help?

 

 

Warning: ini_get() has been disabled for security reasons in /data/members/free/tripod/uk/l/e/i/leiso/htdocs/catalog/includes/functions/sessions.php on line 13

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /data/members/free/tripod/uk/l/e/i/leiso/htdocs/catalog/includes/functions/sessions.php:13) in /data/members/free/tripod/uk/l/e/i/leiso/htdocs/catalog/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /data/members/free/tripod/uk/l/e/i/leiso/htdocs/catalog/includes/functions/sessions.php:13) in /data/members/free/tripod/uk/l/e/i/leiso/htdocs/catalog/includes/functions/sessions.php on line 102

 

my page at : http://members.lycos.co.uk/leiso/catalog/

 

Thanks and Regards,

leiso

Share this post


Link to post
Share on other sites
Hi,

 

despite everything have been done and "safe mode" issue have been solve.

my page still giving these error (see below), and i was unable to go into my admin account.

Is it something to do with the "ini_get()" command at line13 in catalog/includes/functions/sessions.php file??

 

Anyone can help?

my page at : http://members.lycos.co.uk/leiso/catalog/

 

Thanks and Regards,

leiso

 

you ll have to edit your database

Share this post


Link to post
Share on other sites
you ll have to edit your database

 

edit database..?

 

Do you mean edit the "SESSION_WRITE_DIRECTORY" setting to something like:

tmp (without slash) or

../tmp (create a 'tmp' folder in ../catalog/)

Tried those.. but having the same problem!

 

Even tried edit command ini_get() to @ini_get() as recommended in some website, but its only mask the error warning without really solve the problem..

 

Any others way out??

 

Thanks,

leiso

Share this post


Link to post
Share on other sites

Hi,

 

I get the error :

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /hermes/bosweb/web013/b139/sl.foumanco/public_html/eshop/includes/configure.php:33) in /hermes/bosweb/web013/b139/sl.foumanco/public_html/eshop/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /hermes/bosweb/web013/b139/sl.foumanco/public_html/eshop/includes/configure.php:33) in /hermes/bosweb/web013/b139/sl.foumanco/public_html/eshop/includes/functions/sessions.php on line 102

 

I changed the SESSION_WRITE_DIRECTORY parameter to tmp but the issue still exists.

Should we create tmp under the catalog folder?

I appreciate urgent replies.

 

Thanks

Share this post


Link to post
Share on other sites
Ok, calmed down now, and after trawlng what seemed like half the internet i've found a fix.

 

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

 

 

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

 

 

 

Click GO

 

Et Voila !

Ian

 

Thanks Ian. It worked for me too.

Share this post


Link to post
Share on other sites
Ok, calmed down now, and after trawlng what seemed like half the internet i've found a fix.

 

Cause : Previous bug in PHP fixed in latest version (Chances are your ISP has updated to the new version)

 

 

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

 

 

 

Click GO

 

Et Voila !

Ian

 

I did the change to tmp

 

but I can still not access the admin panel, I get the error:

 

Fatal error: Cannot re-assign $this in /catalog/admin/includes/classes/upload.php on line 31

 

Does anyone know what to do about this?

Share this post


Link to post
Share on other sites

×