Jump to content
Latest News: (loading..)
surfalot

[Contribution] More_pics_6 v1.1 For osC 2.2 MS2

Recommended Posts

It will work with MS2 with some hand patching of the files (RC2a makes changes to some files, so you can't just overwrite.) STS is supposed to work, but I haven't tried it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I'm thinking about upgrading to the newest version of more pics v2.x but I have a question about the thumbnailed images, are they just the large images shown smaller or does the contribution actually make new thumbnail images of your large images and only load the large image when you hover over the thumbnail on the product page?

This is important because if you have multiple large images it may take awhile for some browsers to load the page unless it is being loaded after the fact with some sort of ajax.

 

Can anyone tell me if this just resizes the large images for thumbnails on the products page or if it actually creates thumbnails?

 

Also does anyone know does the Extra Images contrib http://addons.oscommerce.com/info/1289 do this with thumbnails or just resizing?


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

The image box uses the full-size images. This is done so that the images load instantly on mouseover/click. I recommend that the box be placed at the bottom of the page so that loading does not detract from the rest of the page. This has worked well on the sites I've used it on. I've seen it used this way on other sites as well.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks for the prompt reply.

 

Two last questions. We're currently using a combo of big/small images and an older more pics 6. For instance each image has a small image (category) medium image (product page) and large image 1 2 3 4 5 7 (more pics 6 popup product page).

 

1) Can we set this new version 2.x to show medium images on the product pages (with thumbnails below) and the large images in a popup?

 

2) Could this contrib be integrated somehow with an ajax loader for the other images so it loads them on demand instead of with the rest of the page for faster page loading times? Here is an example of a script I was thinking about trying to use: http://www.dhtmlgoodies.com/scripts/ajax-d...ic-content.html


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

1. Oops, I misread this. It should be possible, but would require some changes to the code.

 

2. It should be possible. An automatic thumbnail generator would also be useful. I've thought about this, but I haven't had time to experiment. Please let us know if you do work on this.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I am new to the forum, so hello and thank you for all your effective contributions first of all. I use the More Pics 2.0.x contribution by kymation and I would like to use the latest Easy Populate contribution by surfalot to reference/populate the pi.image_filenames from the PRODUCTS_IMAGES table.

 

I have not come across an answer to this one but it is just what I and quite possibly others that have installed More Pics 2.0.x need.

 

Is their an update out there or anyone who has successfully got these two effective contributions to work with the more images version 2 adjustment? There is no guidance in the More Pics file package.

Share this post


Link to post
Share on other sites

Hi all,

 

I started working with oscommerce the other day and tried to setup more_pics. So far everything went smooth. Used Beyond Compare to edit the files since I have already ultimate seo url running. Now, the issue that appears is that I dont see any pictures when I am on the product detail. I did run the install.php and it said that x pictures were updated. However, also in the admin panel I only see 8 menu points when I go to MorePics. According the the how_to_use file there should be a couple more. You can go to shop.utzonoperahouse.com to enter the shop. There you also can see that not more but actually less pics are shown. Thanks for any help already.

Regards,

 

cs

 

osc_mp_problem.gif

Share this post


Link to post
Share on other sites

I installed version 1.4.3 and I have STS 4.5.8 installed. I followed all the instructions for installing the addon and the instructions for integrating with STS 4.2. The problem I have now, is that if I have a product that does not have an image, on the product_info.php page, where the image would be, it shows $mopics_output$. If the product has images, it shows fine. how can I get the product info page to show the NO IMAGE image if there is no product image? It does display the NO IMAGE image on the listing page.

 

Thanks

Share this post


Link to post
Share on other sites
Hi all,

 

I started working with oscommerce the other day and tried to setup more_pics. So far everything went smooth. Used Beyond Compare to edit the files since I have already ultimate seo url running. Now, the issue that appears is that I dont see any pictures when I am on the product detail. I did run the install.php and it said that x pictures were updated. However, also in the admin panel I only see 8 menu points when I go to MorePics. According the the how_to_use file there should be a couple more. You can go to shop.utzonoperahouse.com to enter the shop. There you also can see that not more but actually less pics are shown. Thanks for any help already.

Regards,

 

cs

 

[...]

 

Alright, got this pretty much sorted out. Reinstalled all and started with that addon to install. However, there is still one option not working. The popup. If I click on zoom for example it justs opens the same page.

http://www.utzonoperahouse.com/OSC/product...8morepics

Anyone got any ideas?

Edited by KeyserSöze

Share this post


Link to post
Share on other sites

This is the expected behavior if you have the Image Box enabled. Set your Admin > More Pics > Use CSS Format and Use CSS Images Instead of Popup to false and the popup will work as expected.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
This is the expected behavior if you have the Image Box enabled. Set your Admin > More Pics > Use CSS Format and Use CSS Images Instead of Popup to false and the popup will work as expected.

 

Regards

Jim

 

Thanks a lot Jim. One issue less.

 

Regards,

cs

Share this post


Link to post
Share on other sites
I installed version 1.4.3 and I have STS 4.5.8 installed. I followed all the instructions for installing the addon and the instructions for integrating with STS 4.2. The problem I have now, is that if I have a product that does not have an image, on the product_info.php page, where the image would be, it shows $mopics_output$. If the product has images, it shows fine. how can I get the product info page to show the NO IMAGE image if there is no product image? It does display the NO IMAGE image on the listing page.

 

Thanks

Can anyone answer this please??

Share this post


Link to post
Share on other sites

Hello,

 

I installed this nice feature, except the usage of admin setting ´show all images on product info page´is to me unclear.

 

Changing this setting doesn´t seem to make any difference. I aiming at setting the extra picture available after pressing `zoom´ and not directly.

 

I hope you can help me understand this.

 

Tkx,

Harry

Share this post


Link to post
Share on other sites

Hi All,

 

I installed this contribution and everything works fine...except for the specials page...where the pictures are not displayed.... Do you know how to fix this??

 

Thanks

Share this post


Link to post
Share on other sites

It's likely that you missed an edit to catalog/specials.php. There are two locations that need changes; both are marked with More Pics.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi,

 

Before i start changing all my details (have a templated shop so manual update galore) All I want is a large image displayed in a seperate column on product_info, no pop ups

Would this be the right contrib to install or is there an easier way?

Share this post


Link to post
Share on other sites

Do you mean an additional image, or just the one that's already there in a different size? If you want just one additional image, More Pice version 1.4.3 would be more than adequate, and is probably the simplest mod that will do the job.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

If you just need the one image, you don't need More Pics, or anything else for that matter. Just load your images at the size that you want and replace the SMALL_IMAGE_WIDTH and SMALL_IMAGE_HEIGHT in the image function with '' (two single quotes.) You can also get rid of the link to the popup page.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That bleeding simple.. I really need to get myself a php book.. I will try this out tomorrow! Its 1:30am here and i want to watch Ep 6 of lie to me..

 

like this

 

<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . 
$product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, '') . '</a>'; ?>

 

hmmm think i can remove the target=blank thing.

Share this post


Link to post
Share on other sites

All that you actually need is

<?php echo tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name']); ?>

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi...

 

I've installed More pics 2.0.5 today.

I followed all insturction. When I go to admin -> configuration, I can't find out More Pic as your screen shot.

Because I'm starting with an unmodified copy of osCommerce 2.2RC2a, I've just uploaded all of the files in the Catalog.

Please help me ....

Share this post


Link to post
Share on other sites

Did you run the database.sql?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×