Jump to content
surfalot

[Contribution] More_pics_6 v1.1 For osC 2.2 MS2

Recommended Posts

een trying to work this out for the past 3 days. :'(

 

I recently installed (first) "more pics V1.3b" and since I got errors I then installed "more pics V1.2c". Both versions gave me the same outcome.

 

The issues are as follows...

 

1. MYSQL gave me this error:

Error

SQL query:

ALTER TABLE `products` ADD `products_subimage1` VARCHAR( 64 ) AFTER `products_image` ;

MySQL said: Documentation
#1060 - Duplicate column name 'products_subimage1' 

 

2. The Catalog page shows the thumbnail image, but when I click on it I go to product_info.php page with the product desription, no image appering here. But when I click the "review button" on the bottom, I get the thumbnail image and the "click to enlarge" button which opens the popup window with the arrows and images. :'(

 

3. In the admin area there is a "More Pics" tab, but no pics displayed.

 

4. The "remove image" function in admin, product update doesnt work.

 

 

Please,please,please....I need your help. :'(

1. looks like it's already installed.

2. I'm guessing you didn't merge the changes correctly. Look that over a little more with a good comparison tool.

3. If you are refering to the Admin -> Confirguration -> More Pic, then those are settings, no pics are displayed there.

4. Has worked fine for me in all installations. Again, check your merge. It may be related to file permissions. If the file was uploaded by FTP, your web page may not have permissions to delete it. Depends on how your host is configured.

Share this post


Link to post
Share on other sites
Hey Guys

 

Has anyone used the morepics contribution with SPPC, i have used, and the thumbnails no longer show up on the product_info.php page.

 

However, when i click the main image, i can still scroll to the next image

 

Has anyone experienced this?

 

Thanks

 

Tarek

RACESPEC

recheck how you merged the files. you must have something out of place.

Share this post


Link to post
Share on other sites
Could you help me please?

 

I don't know what I've done wrong. :huh:

 

I have STS installed and now MorePics as well. I do get all the pictures on the product info page BUT it doesn't matter which image I click at I still get the first one in the pop-up window!! WHY?? And why doesn't the "back and next" buttons show?

 

Do any of you have a clue what I may have done wrong?

 

Take a look and you'll see what I mean. Just click any image at the page

 

http://rcmaffian.se/oscommerce_st/catalog/...;products_id=23

 

Please anyone??

 

Best reards

Jessica :blink:

looks like your product_info.php page has the correct links.

 

Must be you didn't get the code merged correctly in the image_popup.php file correct.

 

I also see at the top of the code for the popup, there is

<html $htmlparams}>

that's not correct either.

Share this post


Link to post
Share on other sites
looks like your product_info.php page has the correct links.

 

Must be you didn't get the code merged correctly in the image_popup.php file correct.

 

I also see at the top of the code for the popup, there is

<?php
/*
 $Id: popup_image.php,v MoPics 6 2003/06/05 23:26:23 Exp $

 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2003 osCommerce

 Released under the GNU General Public License
 Updated by John Wood - www.z-is.net
*/

 require('includes/application_top.php');

 $navigation->remove_current_page();

 $products_query = tep_db_query("select pd.products_name, p.products_image from " . TABLE_PRODUCTS . " p left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and pd.language_id = '" . (int)$languages_id . "'");
 $products = tep_db_fetch_array($products_query);
// BOF: More Pics 6
$PID = $HTTP_GET_VARS['pID'];
$invis = $HTTP_GET_VARS['invis'];
$result = mysql_query("select * from " . TABLE_PRODUCTS . " where products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");
// EOF: More Pics 6
?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo $products['products_name']; ?></title>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<script language="javascript"><!--
var i=0;
function resize() {
<?php // BOF: More Pics 6 ?>
 if (document.layers) i=40;
 if (document.images[0]) window.resizeTo(document.images[0].width +30, document.images[0].height+160-i);
<?php // EOF: More Pics 6 ?>
 self.focus();
}
//--></script>
<?php // BOF: More Pics 6 ?>
<meta http-equiv="Page-Enter" content="blendTrans(Duration=0.5)">
<meta http-equiv="Page-Exit" content="blendTrans(Duration=0.5)">
<?php // EOF: More Pics 6 ?>
</head>
<body onload="resize();">
<?php // BOF: More Pics 6 ?>
<table border="0" cellpadding="0" cellspacing="0" align="center">
     <?php // Lets find the last available image !
$image = tep_db_fetch_array($result);
if ($image['products_subimage6'] != ''){       
$last = '6';
}elseif ($image['products_subimage5'] != ''){
$last = '5';
}elseif ($image['products_subimage4'] != ''){
$last = '4';
}elseif ($image['products_subimage3'] != ''){       
$last = '3';
}elseif ($image['products_subimage2'] != ''){       
$last = '2';
}elseif ($image['products_subimage1'] != ''){       
$last = '1';
}elseif ($image['products_image'] != ''){       
$last = '0';
}
$next = $invis + '1';
$back = $invis - '1';
?>
<?php
if (($invis == '0') || ($invis == '')){
$insert = $image['products_image'];
} else  {
$insert = $image['products_subimage' . $invis. ''];
}
/* 
//
// for use if you want to define a maximum width and height for the large popup images.
//
$max_width=0;
$max_height=0;
$img = DIR_WS_IMAGES . $insert;
list($width, $height, $type, $attr) = getimagesize($img);
if ($max_width!=0 && $max_width<$width && $max_height!=0 && $max_height<$height) {
 if (($max_width-$width)>($max_height-$height)) {
   $width = $max_width;
   $height = 0;
 } else {
   $width = 0;
   $height = $max_height;
 }
} elseif ($max_width!=0 && $max_width<$width) {
 $width = $max_width;
 $height = 0;
} elseif ($max_height!=0 && $max_height<$height) {
 $width = 0;
 $height = $max_height;
}
echo '<tr><td align="center"><img src="' . $img . '"' . (($width!=0)?' width="'.$width.'"':'') . (($height!=0)?' height="'.$height.'"':'') . '></td>';
*/
//
// to use the above code, you must remove the next two lines.
//
$img = DIR_WS_IMAGES . $insert;
echo '<tr><td align="center"><img src="' . $img . '"></td>';
?>        </tr>
<tr>
   <td height="0" align="center"></td></tr>
<tr>
   <td height="20" align="center">
<?php
if (($back != '-1') || ($next <= $last)) {
 echo '<hr color="#666666" size="3">';
}
if ($back != '-1'){
echo '<a href="'.tep_href_link('popup_image.php','pID='.$PID.'&invis='.$back).'">' . tep_image(DIR_WS_IMAGES.'left.gif', 'previous', '', '', 'border="0"') . '</a>  ';
}
if ($next <= $last){
echo '<a href="'.tep_href_link('popup_image.php','pID='.$PID.'&invis='. $next).'">' . tep_image(DIR_WS_IMAGES.'right.gif', 'next', '', '', 'border="0"') . '</a>';
}
echo '</td></tr>';
?>
</table>
<?php // EOF: More Pics 6 ?>
</body>
</html>
<?php require('includes/application_bottom.php'); ?>


Jessica Fuchs

Share this post


Link to post
Share on other sites
looks like your product_info.php page has the correct links.

 

Must be you didn't get the code merged correctly in the image_popup.php file correct.

 

I also see at the top of the code for the popup, there is

<html $htmlparams}>

that's not correct either.

 

 

The $htmlparams is gone now I think. :) But it didn't help. :(

 

Is there anything wrong with my image_popup code?

 

Thank you!!

 

I love the contribution!!!! Really hope I (you) can get it to work at my site.

 

Best regards

Jessica


Jessica Fuchs

Share this post


Link to post
Share on other sites

Hi Surfalot,

 

Thanks for the response, I guess you responded at the same time I posted a Thank You note. :)

 

 

Wanted to know if your contribution will work with "lightbox" contribution, and if so, which one?

 

 

 

Many Thanks,

 

Liza

Share this post


Link to post
Share on other sites
The $htmlparams is gone now I think. :) But it didn't help. :(

 

Is there anything wrong with my image_popup code?

 

Thank you!!

 

I love the contribution!!!! Really hope I (you) can get it to work at my site.

 

Best regards

Jessica

 

what is being displayed is not in the code you posted for the popup page. It appears that the STS you have installed is using a template for the popup image page. So thing in that page code in being executed. You'll need to do some work with the STS popup image template page and integrate the More Pics popup page code.

Edited by surfalot

Share this post


Link to post
Share on other sites
Hi Surfalot,

 

Thanks for the response, I guess you responded at the same time I posted a Thank You note. :)

 

Wanted to know if your contribution will work with "lightbox" contribution, and if so, which one?

 

Many Thanks,

 

Liza

 

Some have, look through this topic for clues.

Share this post


Link to post
Share on other sites
what is being displayed is not in the code you posted for the popup page. It appears that the STS you have installed is using a template for the popup image page. So thing in that page code in being executed. You'll need to do some work with the STS popup image template page and integrate the More Pics popup page code.

 

 

THANK YOU!!!!!!!!!! :thumbsup:

 

I deleted the STS-popup file and NOW IT'S WORKING!!! :lol:

 

YOU'RE THE BEST!!!! :thumbsup:

 

Thank you once again for all your help!!

 

Best regards

Jessica


Jessica Fuchs

Share this post


Link to post
Share on other sites

I wonder if you "surfalot" would like to help me with one more thing? :blush:

 

I would like to add our logo in the popup-window. At the bottom... to the left of the "next/back" buttons.

Could you tell me WHERE in the code I'm suppose to add the image?

 

Can I write like this?

 

<p align="left">

<img border="0" src="images/rclogoliten.gif">

 

I'm sorry to bather you again. But at least... I'm learning, so hopefully I will be able to do this by my self some day ;)

 

Regards

Jessica

 

 

This is my popup-image.php file..

<?php
/*
 $Id: popup_image.php,v MoPics 6 2003/06/05 23:26:23 Exp $

 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2003 osCommerce

 Released under the GNU General Public License
 Updated by John Wood - www.z-is.net
*/

 require('includes/application_top.php');

 $navigation->remove_current_page();

 $products_query = tep_db_query("select pd.products_name, p.products_image from " . TABLE_PRODUCTS . " p left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and pd.language_id = '" . (int)$languages_id . "'");
 $products = tep_db_fetch_array($products_query);
// BOF: More Pics 6
$PID = $HTTP_GET_VARS['pID'];
$invis = $HTTP_GET_VARS['invis'];
$result = mysql_query("select * from " . TABLE_PRODUCTS . " where products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");
// EOF: More Pics 6
?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo $products['products_name']; ?></title>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<script language="javascript"><!--
var i=0;
function resize() {
<?php // BOF: More Pics 6 ?>
 if (document.layers) i=40;
 if (document.images[0]) window.resizeTo(document.images[0].width +30, document.images[0].height+160-i);
<?php // EOF: More Pics 6 ?>
 self.focus();
}
//--></script>
<?php // BOF: More Pics 6 ?>
<meta http-equiv="Page-Enter" content="blendTrans(Duration=0.5)">
<meta http-equiv="Page-Exit" content="blendTrans(Duration=0.5)">
<?php // EOF: More Pics 6 ?>
</head>
<body onload="resize();">
<?php // BOF: More Pics 6 ?>
<table border="0" cellpadding="0" cellspacing="0" align="center">
     <?php // Lets find the last available image !
$image = tep_db_fetch_array($result);
if ($image['products_subimage6'] != ''){       
$last = '6';
}elseif ($image['products_subimage5'] != ''){
$last = '5';
}elseif ($image['products_subimage4'] != ''){
$last = '4';
}elseif ($image['products_subimage3'] != ''){       
$last = '3';
}elseif ($image['products_subimage2'] != ''){       
$last = '2';
}elseif ($image['products_subimage1'] != ''){       
$last = '1';
}elseif ($image['products_image'] != ''){       
$last = '0';
}
$next = $invis + '1';
$back = $invis - '1';
?>
<?php
if (($invis == '0') || ($invis == '')){
$insert = $image['products_image'];
} else  {
$insert = $image['products_subimage' . $invis. ''];
}
/* 
//
// for use if you want to define a maximum width and height for the large popup images.
//
$max_width=0;
$max_height=0;
$img = DIR_WS_IMAGES . $insert;
list($width, $height, $type, $attr) = getimagesize($img);
if ($max_width!=0 && $max_width<$width && $max_height!=0 && $max_height<$height) {
 if (($max_width-$width)>($max_height-$height)) {
   $width = $max_width;
   $height = 0;
 } else {
   $width = 0;
   $height = $max_height;
 }
} elseif ($max_width!=0 && $max_width<$width) {
 $width = $max_width;
 $height = 0;
} elseif ($max_height!=0 && $max_height<$height) {
 $width = 0;
 $height = $max_height;
}
echo '<tr><td align="center"><img src="' . $img . '"' . (($width!=0)?' width="'.$width.'"':'') . (($height!=0)?' height="'.$height.'"':'') . '></td>';
*/
//
// to use the above code, you must remove the next two lines.
//
$img = DIR_WS_IMAGES . $insert;
echo '<tr><td align="center"><img src="' . $img . '"></td>';
?>        </tr>
<tr>
   <td height="0" align="center"></td></tr>
<tr>
   <td height="20" align="center">
<?php
if (($back != '-1') || ($next <= $last)) {
 echo '<hr color="#666666" size="3">';
}
if ($back != '-1'){
echo '<a href="'.tep_href_link('popup_image.php','pID='.$PID.'&invis='.$back).'">' . tep_image(DIR_WS_IMAGES.'left.gif', 'previous', '', '', 'border="0"') . '</a>  ';
}
if ($next <= $last){
echo '<a href="'.tep_href_link('popup_image.php','pID='.$PID.'&invis='. $next).'">' . tep_image(DIR_WS_IMAGES.'right.gif', 'next', '', '', 'border="0"') . '</a>';
}
echo '</td></tr>';
?>
</table>
<?php // EOF: More Pics 6 ?>
</body>
</html>
<?php require('includes/application_bottom.php'); ?>


Jessica Fuchs

Share this post


Link to post
Share on other sites
recheck how you merged the files. you must have something out of place.

 

I am using SPPC with more pics, has anyone done that before. I've rechecked everything and seems fine by me

 

Does anyone have code for their product_info.php page that has more pics and SPPC built in

 

Thanks

 

Tarek

RACESPEC

Share this post


Link to post
Share on other sites

ok all. I have been scouring this thread and have read all 37 pages to make sure that I am not re-asking a question. I am really bummed out about this. I have added the contrib: more categories : http://www.oscommerce.com/community/contri...+category+boxes

 

and I would love to have this more pics contrib work. I meticulously updated all the code for this contrib to work - but when I loaded my main page - it stops loading right when the category box would show. This leads me to believe that the problem lies in the combination of my more category boxes contrib and this contrib.

 

Also, as this contrib has many changes to the categories.php and the more category boxes contrib, I think uses the morecategories.php to create its effect - there is some problem here.

 

Please can somone assist me.

 

I would like to continue to use the more cateogry boxes contrib- as I have configured my page how I want it accordingly - but how can I use this contrib as well.

 

I hope this doesn't sound convaluted. Perhaps someone more proficient can check how the more category boxes contrib affects what I am trying to do.

 

Thanks in advance

Your help is much appreciated.

 

Jonathan

Share this post


Link to post
Share on other sites
I wonder if you "surfalot" would like to help me with one more thing? :blush:

 

I would like to add our logo in the popup-window. At the bottom... to the left of the "next/back" buttons.

Could you tell me WHERE in the code I'm suppose to add the image?

 

Can I write like this?

 

<p align="left">

<img border="0" src="images/rclogoliten.gif">

 

I'm sorry to bather you again. But at least... I'm learning, so hopefully I will be able to do this by my self some day ;)

 

Regards

Jessica

 

 

This is my popup-image.php file..

<?php
/*
 $Id: popup_image.php,v MoPics 6 2003/06/05 23:26:23 Exp $

 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2003 osCommerce

 Released under the GNU General Public License
 Updated by John Wood - www.z-is.net
*/

 require('includes/application_top.php');

 $navigation->remove_current_page();

 $products_query = tep_db_query("select pd.products_name, p.products_image from " . TABLE_PRODUCTS . " p left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and pd.language_id = '" . (int)$languages_id . "'");
 $products = tep_db_fetch_array($products_query);
// BOF: More Pics 6
$PID = $HTTP_GET_VARS['pID'];
$invis = $HTTP_GET_VARS['invis'];
$result = mysql_query("select * from " . TABLE_PRODUCTS . " where products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");
// EOF: More Pics 6
?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo $products['products_name']; ?></title>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<script language="javascript"></script>
<?php // BOF: More Pics 6 ?>
<meta http-equiv="Page-Enter" content="blendTrans(Duration=0.5)">
<meta http-equiv="Page-Exit" content="blendTrans(Duration=0.5)">
<?php // EOF: More Pics 6 ?>
</head>
<body onload="resize();">
<?php // BOF: More Pics 6 ?>
<table border="0" cellpadding="0" cellspacing="0" align="center">
     <?php // Lets find the last available image !
$image = tep_db_fetch_array($result);
if ($image['products_subimage6'] != ''){       
$last = '6';
}elseif ($image['products_subimage5'] != ''){
$last = '5';
}elseif ($image['products_subimage4'] != ''){
$last = '4';
}elseif ($image['products_subimage3'] != ''){       
$last = '3';
}elseif ($image['products_subimage2'] != ''){       
$last = '2';
}elseif ($image['products_subimage1'] != ''){       
$last = '1';
}elseif ($image['products_image'] != ''){       
$last = '0';
}
$next = $invis + '1';
$back = $invis - '1';
?>
<?php
if (($invis == '0') || ($invis == '')){
$insert = $image['products_image'];
} else  {
$insert = $image['products_subimage' . $invis. ''];
}
/* 
//
// for use if you want to define a maximum width and height for the large popup images.
//
$max_width=0;
$max_height=0;
$img = DIR_WS_IMAGES . $insert;
list($width, $height, $type, $attr) = getimagesize($img);
if ($max_width!=0 && $max_width<$width && $max_height!=0 && $max_height<$height) {
 if (($max_width-$width)>($max_height-$height)) {
   $width = $max_width;
   $height = 0;
 } else {
   $width = 0;
   $height = $max_height;
 }
} elseif ($max_width!=0 && $max_width<$width) {
 $width = $max_width;
 $height = 0;
} elseif ($max_height!=0 && $max_height<$height) {
 $width = 0;
 $height = $max_height;
}
echo '<tr><td align="center"><img src="' . $img . '"' . (($width!=0)?' width="'.$width.'"':'') . (($height!=0)?' height="'.$height.'"':'') . '></td>';
*/
//
// to use the above code, you must remove the next two lines.
//
$img = DIR_WS_IMAGES . $insert;
echo '<tr><td align="center"><img src="' . $img . '"></td>';
?>        </tr>
<tr>
   <td height="0" align="center"></td></tr>
<tr>
   <td height="20" align="center">
<?php
if (($back != '-1') || ($next <= $last)) {
 echo '<hr color="#666666" size="3">';
}
if ($back != '-1'){
echo '<a href="'.tep_href_link('popup_image.php','pID='.$PID.'&invis='.$back).'">' . tep_image(DIR_WS_IMAGES.'left.gif', 'previous', '', '', 'border="0"') . '</a>  ';
}
if ($next <= $last){
echo '<a href="'.tep_href_link('popup_image.php','pID='.$PID.'&invis='. $next).'">' . tep_image(DIR_WS_IMAGES.'right.gif', 'next', '', '', 'border="0"') . '</a>';
}
echo '</td></tr>';
?>
</table>
<?php // EOF: More Pics 6 ?>
</body>
</html>
<?php require('includes/application_bottom.php'); ?>

sure, add that just before the end body tag near the end of the file.

Share this post


Link to post
Share on other sites
sure, add that just before the end body tag near the end of the file.

 

 

:thumbsup:

 

THANK YOU SO MUCH!!!!!!!!!

 

Have a nice day! ;)

 

Best regards

Jessica


Jessica Fuchs

Share this post


Link to post
Share on other sites

Great contribution.

 

However I was wondering whether it is possible to have the additional images replace the main image in the main product window rather than popping up in a separate window? Is it?

 

Thanks

Share this post


Link to post
Share on other sites
Great contribution.

 

However I was wondering whether it is possible to have the additional images replace the main image in the main product window rather than popping up in a separate window? Is it?

 

Thanks

 

 

To clarify , I am using STS 4.x and I want to image to appear wher the $imagelarge usually does.

Share this post


Link to post
Share on other sites

Hi, Can somone tell me how you ad more pictures with this module? i used this other version called Dynamic MoPics before http://www.oscommerce.com/community/contri...ll/search,mopic and in that contribution you didn't have to do anything in admin to add pictures you just named your pictures like picture_1, picture_2, picture_3 and so on. This was so easy and fast. Does this contribution do it the same way or do you have to ad pictures through admin or something?

To ad pictures through admin or excel will not work for me, to much work when you have many thousand products. Someone might say it's not so much work with excel, but the problem is that different people work with ad products and pictures so it's so easy when the pictures always show if you just upload them. I hope you understand what i mean:)

Can someone also tell me what the big difference is between this two modules, like why i should use one over the other?

 

All help will be appreciated!

 

Thanks

Lars

Share this post


Link to post
Share on other sites
Hi, Can somone tell me how you ad more pictures with this module? i used this other version called Dynamic MoPics before http://www.oscommerce.com/community/contri...ll/search,mopic and in that contribution you didn't have to do anything in admin to add pictures you just named your pictures like picture_1, picture_2, picture_3 and so on. This was so easy and fast. Does this contribution do it the same way or do you have to ad pictures through admin or something?

To ad pictures through admin or excel will not work for me, to much work when you have many thousand products. Someone might say it's not so much work with excel, but the problem is that different people work with ad products and pictures so it's so easy when the pictures always show if you just upload them. I hope you understand what i mean:)

Can someone also tell me what the big difference is between this two modules, like why i should use one over the other?

 

All help will be appreciated!

 

Thanks

Lars

Stick with the one you know. Its the only images contrib I know that doesn't require defining each image in the database.

Share this post


Link to post
Share on other sites
To clarify , I am using STS 4.x and I want to image to appear wher the $imagelarge usually does.

 

Additional Images contribution has that feature, but has no instructions for integrating with STS. once you install STS, you really need to know it well to integrate other contributions.

Share this post


Link to post
Share on other sites

I have a decent knowledge of STS. However I don't really see STS as a luxury but an essential part of making a OsComerce site your own. Thanks though.

Share this post


Link to post
Share on other sites
I have a decent knowledge of STS. However I don't really see STS as a luxury but an essential part of making a OsComerce site your own. Thanks though.

essential, maybe if you don't know php well. the mods STS requires doubles the work necessary for adding contributions. I would prefer to make structural changes to the shop for the design so that ongoing maintenance and contribution addition is simplified. Little more time in the initial design, far less time, ongoing, without STS. ;)

Share this post


Link to post
Share on other sites
essential, maybe if you don't know php well. the mods STS requires doubles the work necessary for adding contributions. I would prefer to make structural changes to the shop for the design so that ongoing maintenance and contribution addition is simplified. Little more time in the initial design, far less time, ongoing, without STS. ;)

 

 

Eh?

Share this post


Link to post
Share on other sites

I'm not quite sure what I did. There's a "More Pics" option under configurations, but there's no additional images option for the products. I know you've said that we need to add lines 703-756 from the categories.php pages, but I don't know where to add it to. I've tried adding it to the bottom of my categories.php page and it still doesn't show up. thanks!

Share this post


Link to post
Share on other sites

nevermind,

I did additional images instead.

 

 

I'm not quite sure what I did. There's a "More Pics" option under configurations, but there's no additional images option for the products. I know you've said that we need to add lines 703-756 from the categories.php pages, but I don't know where to add it to. I've tried adding it to the bottom of my categories.php page and it still doesn't show up. thanks!

Share this post


Link to post
Share on other sites

Hi guys,

 

I have version 2 by matrix france installed along with the lightbox, All is working pretty well except my thumbnails looked pants

so decided to try and add the the thumbnail mod.

 

it seems to work ok except that it puts a black background on .GIF images which I would like to stop.

 

Also I have the star product mod installed and on the main page it all goes wrong look at http://www.get-wireless.co.uk/dev this is my test site.

 

The actual products work fine if you go down into them

 

I commented that line out in the html_output.php file but then get other errors.

 

Ca anyone suggest where to fix this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×