Jump to content

Archived

This topic is now archived and is closed to further replies.

fancave

How do you disable the Reviews feature?

Recommended Posts

I've searched the forum and not found a suitable answer.

 

I want to completely disable the Reviews feature and don't want anything about reviews to appear on the pages. I've set the maximum values of Reviews Displayed at 0 but now I'm getting "There are no product reviews" in the Review box.

 

Who can help me turn off this feature?

 

:)

Share this post


Link to post
Share on other sites

In includes/column_right.php

 

Find:

 

require(DIR_WS_BOXES . 'reviews.php');

 

Delete it or comment it out

 

// require(DIR_WS_BOXES . 'reviews.php');

 

Give me a minute or two and I'll find the other places references appear.


Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Share this post


Link to post
Share on other sites

Line 212: /catalog/product_info.php controls the button in the product page

 

<td class="main"><?php echo '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS) . '</a>'; ?></td>

 

Quick way to leave the line for future reference, comment out just before echo:

 

<td class="main"><?php // echo '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS) . '</a>'; ?></td>


Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Share this post


Link to post
Share on other sites
I've searched the forum and not found a suitable answer.

 

I want to completely disable the Reviews feature and don't want anything about reviews to appear on the pages. I've set the maximum values of Reviews Displayed at 0 but now I'm getting "There are no product reviews" in the Review box.

 

Who can help me turn off this feature?

 

:)

the easiest way is what alan said first, go into column_right.php(or column_left.php if you moved it there)

find this: require(DIR_WS_BOXES . 'reviews.php');

change to://require(DIR_WS_BOXES . 'reviews.php');

the 2 lines in the front will comment it out, and if you decide you want it again later then go back there and take the lines out.


"I must admit that I personally measure success in terms of the contributions an individual makes to her or his fellow human beings."

---Margaret Mead---

 

"The answer is never the answer. What's really interesting is the mystery. If you seek the mystery instead of the answer, you'll always be seeking. I've never seen anybody really find the answer -- they think they have, so they stop thinking. But the job is to seek mystery, evoke mystery, plant a garden in which strange plants grow and mysteries bloom. The need for mystery is greater than the need for an answer.

--Ken Kesey"

Share this post


Link to post
Share on other sites
the easiest way is what alan said first, go into column_right.php(or column_left.php if you moved it there)

find this: require(DIR_WS_BOXES . 'reviews.php');

change to://require(DIR_WS_BOXES . 'reviews.php');

the 2 lines in the front will comment it out, and if you decide you want it again later then go back there and take the lines out.

 

Hi!

 

He's right it's the easiest way, but please note that you have to do the second way too. So that customers will not have any way to post a review.

 

FYI from a newbie!

Share this post


Link to post
Share on other sites
Line 212: /catalog/product_info.php controls the button in the product page

 

<td class="main"><?php echo '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS) . '</a>'; ?></td>

 

Quick way to leave the line for future reference, comment out just before echo:

 

<td class="main"><?php // echo '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS) . '</a>'; ?></td>

 

 

what should i do i dont have the echo.... see below

 

<tr><td style="padding-left: 8px"><span class=ch7><?=$products_price?></span></td></tr>

<tr><td height=10></td></tr>

</table>

</td></tr>

<tr><td colspan=2 align=right><a href=<?=tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS)?></a><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_image_submit('button_in_cart.gif', IMAGE_BUTTON_BUY_NOW); ?></td></tr>

 

<tr><td height=36></td></tr>

<tr><td colspan=2 align=center>

<table cellspacing=0 cellpadding=0 width=457 align=center>

<tr><td class=ch8>

Share this post


Link to post
Share on other sites
Hi I don't have the 'echo' code bit either, did you get this sorted at all?

 

As a further note I also wanted to do this in my shop, with the possibility that I may want to revert back to using reviews at some point in the future. I have just created an white image file (gif) 1x1 pixel, and uploaded it to the includes/languages/images/buttons folder, replacing the current button_reviews.gif Simple :)

Share this post


Link to post
Share on other sites
<a href=<?=tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS)?></a>

 

replace with

<? // echo "<a href=".tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS)."</a>"; ?>

 

That should do it

Share this post


Link to post
Share on other sites

For some reason, google is indexing some of my product review pages and showing them in search results more frequently than the actual product info pages. Will the suggestions explained previously disable google from indexing review pages or is there another way of solving this indexing issue?

Share this post


Link to post
Share on other sites

If you have comment the lines google should not find the link and index the page , I recommend you to check that the references google do to your review pages are really not "operative", I mean they are not valid.

 

 

Some people has proposed to hide the link, but hide does not mean "deactivate" because it does not prevent anyone to access the reviews function using the link http://yourgoodhost/catalog/product_review...oducts_id=1xxxx (try it)

 

I’ve disable the reviews function renaming the .php files that make them work to .disable. You can delete the files but this way you can always recover them back.

So to disable the reviews rename the following files

product_reviews_info.php - to -> product_reviews_info.disable

product_reviews_write.php - to -> product_reviews_write.disable

reviews.php - to -> reviews.disable

product_reviews.php - to -> product_reviews.disable

 

Then any access to http://yourgoodhost/catalog/product_review...oducts_id=1xxxx will return a 404 page error , but since no links/buttons refer to the review this is a good behaviour.

Share this post


Link to post
Share on other sites

OH MY GOD SOMEBODY PLEASE HELP ME! I'm new to this sort of stuff and i have no idea where i went wrong! I was following the instructions on this topic to disable the reviews. i started with the

 

"the easiest way is what alan said first, go into column_right.php(or column_left.php if you moved it there)

find this: require(DIR_WS_BOXES . 'reviews.php');

change to://require(DIR_WS_BOXES . 'reviews.php');

the 2 lines in the front will comment it out, and if you decide you want it again later then go back there and take the lines out."

 

post and it worked fine. Then i moved onto the post that reads :

 

" <a href=<?=tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS)?></a>

 

 

replace with

CODE

<? // echo "<a href=".tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS)."</a>"; ?>

 

 

That should do it"

 

When i tried that the first time, it removed the review button, but it also removed the product photo. So i went back in and removed the //, but now the entire page wont load.

 

I have no idea what i did wrong because it seemed like i was just undoing the operation that i had just tried. Can somebody please advice me on what to do next in order to get this stuff back?

 

Thank you so much!

Share this post


Link to post
Share on other sites

I have already edited it out, but it might be successful for future ordering. How can I enable it so users can leave reviews for products only on items they have purchased? perhaps it would be done only through their my account area?

 

thank you

Share this post


Link to post
Share on other sites

Shana,

 

 

It looks like you are using a template...........change:

 

<tr><td colspan=2 align=right><a href=<?=tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS)?></a><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_image_submit('button_in_cart.gif', IMAGE_BUTTON_BUY_NOW); ?></td></tr>

 

to:

 

<tr><td colspan=2 align=right>  <!-- <a href=<?=tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS)?></a> --> <?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_image_submit('button_in_cart.gif', IMAGE_BUTTON_BUY_NOW); ?></td></tr>

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Im using a template and cant seem to figure out how to disable review feature:

 

my product info:

 

$button_text = '<a class="bg_button22" onMouseOut="this.id=\'bg_button22\';" onMouseOver="this.id=\'bg_button22\';" href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">'.tep_draw_list_top().IMAGE_BUTTON_REVIEWS.tep_draw_list_bottom().'</a>';

$button_img = '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.png', IMAGE_BUTTON_REVIEWS) . '</a>';

 

 

how to diable Reviews?

 

plz help!

 

THX in advance

Share this post


Link to post
Share on other sites

×