Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
tomjmul

Support thread for the Image Magic contribution

Recommended Posts

I just installed this contribution, but now I get no images shown.

 

I checked the thumnails/images, there wasnt anything here. The images are not being created.

 

What might cause this?

 

/jacob

Share this post


Link to post
Share on other sites

I'm suffering broken links for all images...WAIT...yes, I *do* have a /catalogs/thumbnails folder, and it is set to %777.

 

I took one of the broken links and pasted in the browser, and got:

 

Fatal error: Call to undefined function: fail() in /hsphere/local/home2/baalwww/testbed.cebu.us.com/catalog/imagemagic.php on line 25

 

So I went to imagemagic.php and looked at line 25. It is

 

$dbconn=@mysql_connect($server,$user,$password) or fail(10);

 

so i put an echo in for $server, $user and $dbname prior to this line but after the 3 lines

 

$server=DB_SERVER; # host name of server running MySQL

$user=DB_SERVER_USERNAME; # existing login username for mysql

$dbname=DB_DATABASE; # name of existing database to use

 

and refreshed the browser and get

 

DB_SERVERDB_SERVER_USERNAMEDB_DATABASE

Fatal error: Call to undefined function: fail() in /hsphere/local/home2/baalwww/testbed.cebu.us.com/catalog/imagemagic.php on line 28

 

so obviously something is very awry.

Share this post


Link to post
Share on other sites

Well done!!! It seems that you have the most excrutiatingly challenging part over you. You listening wulff and everybody else?

 

The debug info you gave shows that the three constants DB_SERVER, DB_SERVER_USERNAME, DB_DATABASE have not be defined.

 

I would be almost 99% certain then, that the problem lies with this line:

require('includes/configure.php');

 

1. Is imagemagic installed in your store root, and if so does that line point accurately to you configure.php file?

2. Are these constants defined in your configure.php file

 

You'll sort it out, don't worry.

 

Tom


OSC Image Magic

On-the-fly thumbnails, watermarks and image processing

Share this post


Link to post
Share on other sites
1. Is imagemagic installed in your store root, and if so does that line point accurately to you configure.php file?

2. Are these constants defined in your configure.php file

 

You'll sort it out, don't worry.

 

Tom

 

1. Yes, Yes, and

2. No

 

So now I guess, before I copy those lines from the admin config file into the catalog config file... i need to ask... catalog obviously is able to find the db, since when imagemagic is turned off the site works... so where is catalog getting the info, and why does imagemagic not get it from the same place?

Share this post


Link to post
Share on other sites
1. Yes, Yes, and

2. No

 

So now I guess, before I copy those lines from the admin config file into the catalog config file... i need to ask... catalog obviously is able to find the db, since when imagemagic is turned off the site works... so where is catalog getting the info, and why does imagemagic not get it from the same place?

 

 

You are right, osc IS getting them from somewhere.

Are you running osc locally with a /includes/local/configure.php file?

If not do a grep to find them

Edited by tomjmul

OSC Image Magic

On-the-fly thumbnails, watermarks and image processing

Share this post


Link to post
Share on other sites

Hey, you're quick...and right! Yes, and of course, when I look in it, there are those lines. This local thing has bitten me before...can I just put those lines in the catalog/configure.php file and delete the local, or do I need to do something else?

Share this post


Link to post
Share on other sites
Hey, you're quick...and right! Yes, and of course, when I look in it, there are those lines. This local thing has bitten me before...can I just put those lines in the catalog/configure.php file and delete the local, or do I need to do something else?

 

Yes, if you delete the local, osc will start to use the other one. But make sure the settings are the same in both


OSC Image Magic

On-the-fly thumbnails, watermarks and image processing

Share this post


Link to post
Share on other sites

Yahoo! That worked, and it looks great. Next question...the text watermarking is not showing up at all. Here are my settings:

 

Text Watermark in Pop-up Images Yes

Text Watermark in Product Information Thumbnails Yes

Text Watermark in Category Thumbnails No

Text Watermark in Heading Thumbnails No

Text Watermark in Small Thumbnails No

Watermark Text blah blah blah

Text Watermark Font Name arial.ttf

Text Watermark Size 14

Text Watermark Colour (HEX) aaaaaa

Text Watermark Transparency 20

Text Watermark Position Center

Text Watermark Margin 0

Text Watermark Angle 0

Share this post


Link to post
Share on other sites
Guest

hello there!

I have a very small question: is this Contrib supporting multiple images (lets say 6 images per Product?)

Thanks!

Share this post


Link to post
Share on other sites
Guest
hello there!

I have a very small question: is this Contrib supporting multiple images (lets say 6 images per Product?)

Thanks!

 

I have installed this Contrib and the Mo Pics 6 contrib, so yes, it will work with multiple images

 

Neil

Share this post


Link to post
Share on other sites

Hi,

 

I have installed the MOD but encounter a few errors..

When ever i upload the moded html_ouput.php page and turn I/M on my pictures seem to be broken. I have checked the URL and imagemagic php file is in there..

 

If i turn I/M off some of the images reappear but a few are still broken.

 

This is my code for html_output.php

 

<?php
/*
 $Id: html_output.php,v 1.56 2003/07/09 01:15:48 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

////
// The HTML href link wrapper function
 function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true) {
global $request_type, $session_started, $SID;

if (!tep_not_null($page)) {
  die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine the page link!<br><br>');
}

if ($connection == 'NONSSL') {
  $link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;
} elseif ($connection == 'SSL') {
  if (ENABLE_SSL == true) {
	$link = HTTPS_SERVER . DIR_WS_HTTPS_CATALOG;
  } else {
	$link = HTTP_SERVER . DIR_WS_HTTP_CATALOG;
  }
} else {
  die('</td></tr></table></td></tr></table><br><br><font color="#ff0000"><b>Error!</b></font><br><br><b>Unable to determine connection method on a link!<br><br>Known methods: NONSSL SSL</b><br><br>');
}

if (tep_not_null($parameters)) {
  $link .= $page . '?' . tep_output_string($parameters);
  $separator = '&';
} else {
  $link .= $page;
  $separator = '?';
}

while ( (substr($link, -1) == '&') || (substr($link, -1) == '?') ) $link = substr($link, 0, -1);

// Add the session ID when moving from different HTTP and HTTPS servers, or when SID is defined
if ( ($add_session_id == true) && ($session_started == true) && (SESSION_FORCE_COOKIE_USE == 'False') ) {
  if (tep_not_null($SID)) {
	$_sid = $SID;
  } elseif ( ( ($request_type == 'NONSSL') && ($connection == 'SSL') && (ENABLE_SSL == true) ) || ( ($request_type == 'SSL') && ($connection == 'NONSSL') ) ) {
	if (HTTP_COOKIE_DOMAIN != HTTPS_COOKIE_DOMAIN) {
	  $_sid = tep_session_name() . '=' . tep_session_id();
	}
  }
}

if ( (SEARCH_ENGINE_FRIENDLY_URLS == 'true') && ($search_engine_safe == true) ) {
  while (strstr($link, '&&')) $link = str_replace('&&', '&', $link);

  $link = str_replace('?', '/', $link);
  $link = str_replace('&', '/', $link);
  $link = str_replace('=', '/', $link);

  $separator = '?';
}

if (isset($_sid)) {
  $link .= $separator . $_sid;
}

return $link;
 }

////
// The HTML image wrapper function
// BOF Image Magic 
function tep_image($src, $alt = '', $width = '', $height = '', $params = '') {  
 global $product_info;

 //Allow for a new intermediate sized thumbnail size to be set 
 //without any changes having to be made to the product_info page itself. 
 //(see the lengths I go to to make your life easier :-)
 if (strstr($_SERVER['PHP_SELF'],"product_info.php")) {

	if (isset($product_info['products_image']) 
			   && $src == DIR_WS_IMAGES . $product_info['products_image']
			   && $product_info[products_id]==$_GET['products_id'])  {   //final check just to make sure that we don't interfere with other contribs
		$width = PRODUCT_INFO_IMAGE_WIDTH == 0?'':PRODUCT_INFO_IMAGE_WIDTH;
		$height = PRODUCT_INFO_IMAGE_HEIGHT == 0?'':PRODUCT_INFO_IMAGE_HEIGHT;
		$product_info_image=true;
		$page="prod_info"; 
	}
 }

 //Detect whether this is a pop-up image
 if (strstr($_SERVER['PHP_SELF'],"popup_image.php")) $page="popup";

 //do we apply the IE PNG alpha transparency fix?
 if  (strstr(strtolower($src),".png") && CFG_PNG_BUG=="True") $fix_png = true;

 //send the image for processing unless told otherwise
 $image = '<img src="' . $src . '"'; //set up the image tag just in case we don't want to process
 if (CFG_MASTER_SWITCH=="On") $calculate = true;
 else $calculate=false;

 // Don't calculate if the image is set to a "%" width
 if (strstr($width,'%') == true || strstr($height,'%') == true) $calculate = false; 

 // Dont calculate if a pixel image is being passed (hope you dont have pixels for sale)
 if (strstr($image, 'pixel')) $calculate = false;


 $image_size = @getimagesize($src);


 // Decide whether or not we want to process this image
 if (($width == '' && $height == '' && $page != 'popup' ) || ($width == $image_size[0] && $height == $image_size[0] && $page != 'popup')) {  
	if (CFG_PROCESS_GRAPHICS=="False") $calculate = false; //looks like this is a store graphic rather than product image
 }	

 // Is this image good to go?
 if (CONFIG_CALCULATE_IMAGE_SIZE && $calculate) { 

 if ($image_size) { 

  $ratio = $image_size[1] / $image_size[0];

  // Set the width and height to the proper ratio
  if (!$width && $height) { 
	$ratio = $height / $image_size[1]; 
	$width = intval($image_size[0] * $ratio); 
  } elseif ($width && !$height) { 
	$ratio = $width / $image_size[0]; 
	$height = intval($image_size[1] * $ratio); 
  } elseif (!$width && !$height && !$over_ride) { 
	$width = $image_size[0]; 
	$height = $image_size[1]; 
  } 

  //Encrypt the image filename if switched on
	if (CFG_ENCRYPT_FILENAMES == "True" && CFG_ENCRYPTION_KEY !="") {
		  $result = '';
		  $key=CFG_ENCRYPTION_KEY;
		  for($i=0; $i<strlen($src); $i++) {
			  $char = substr($src, $i, 1);
			  $keychar = substr($key, ($i % strlen($key))-1, 1);
			  $char = chr(ord($char)+ord($keychar));
			  $result.=$char;
		  }
		  $src=urlencode(base64_encode($result));
	}

   //Return the html
	$image = '<img src="imagemagic.php?img='.$src.'&w='.
	tep_output_string($width).'&h='.tep_output_string($height).'&page='.$page.'"';

} elseif (IMAGE_REQUIRED == 'false') { 
  return ''; 
} 
 }  

//If the size asked for is greater than the image itself, we check the configs to see if this is allowed and if not over-ride
 if ($width > $image_size[0] || $height > $image_size[1]) {
	if (CFG_ALLOW_LARGER  != 'True'){
		  $width=$image_size[0];
		  $height=$image_size[1];
		  $over_ride = true;
	}
 }
 // Add remaining image parameters if they exist
 if ($width) { 
$image .= ' width="' . tep_output_string($width) . '"'; 
 } 

 if ($height) { 
$image .= ' height="' . tep_output_string($height) . '"'; 
 }	 

 if (tep_not_null($params)) $image .= ' ' . $params;

 $image .= ' border="0" alt="' . tep_output_string($alt) . '"';

 if (tep_not_null($alt)) {
$image .= ' title="' . tep_output_string($alt) . '"';
 }

 if ($fix_png && CFG_MASTER_SWITCH=="On") {
	$image .= ' onload="fixPNG(this)"'; 
 }

 $image .= '>';   
 return $image; 
}
//EOF Image Magic


////
// The HTML form submit button wrapper function
// Outputs a button in the selected language
 function tep_image_submit($image, $alt = '', $parameters = '') {
global $language;

$image_submit = '<input type="image" src="' . tep_output_string(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image) . '" border="0" alt="' . tep_output_string($alt) . '"';

if (tep_not_null($alt)) $image_submit .= ' title=" ' . tep_output_string($alt) . ' "';

if (tep_not_null($parameters)) $image_submit .= ' ' . $parameters;

$image_submit .= '>';

return $image_submit;
 }

////
// Output a function button in the selected language
 function tep_image_button($image, $alt = '', $parameters = '') {
global $language;

return tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image, $alt, '', '', $parameters);
 }

////
// Output a separator either through whitespace, or with an image
 function tep_draw_separator($image = 'pixel_black.gif', $width = '100%', $height = '1') {
return tep_image(DIR_WS_IMAGES . $image, '', $width, $height);
 }

////
// Output a form
 function tep_draw_form($name, $action, $method = 'post', $parameters = '') {
$form = '<form name="' . tep_output_string($name) . '" action="' . tep_output_string($action) . '" method="' . tep_output_string($method) . '"';

if (tep_not_null($parameters)) $form .= ' ' . $parameters;

$form .= '>';

return $form;
 }

////
// Output a form input field
 function tep_draw_input_field($name, $value = '', $parameters = '', $type = 'text', $reinsert_value = true) {
$field = '<input type="' . tep_output_string($type) . '" name="' . tep_output_string($name) . '"';

if ( (isset($GLOBALS[$name])) && ($reinsert_value == true) ) {
  $field .= ' value="' . tep_output_string(stripslashes($GLOBALS[$name])) . '"';
} elseif (tep_not_null($value)) {
  $field .= ' value="' . tep_output_string($value) . '"';
}

if (tep_not_null($parameters)) $field .= ' ' . $parameters;

$field .= '>';

return $field;
 }

////
// Output a form password field
 function tep_draw_password_field($name, $value = '', $parameters = 'maxlength="40"') {
return tep_draw_input_field($name, $value, $parameters, 'password', false);
 }

////
// Output a selection field - alias function for tep_draw_checkbox_field() and tep_draw_radio_field()
 function tep_draw_selection_field($name, $type, $value = '', $checked = false, $parameters = '') {
$selection = '<input type="' . tep_output_string($type) . '" name="' . tep_output_string($name) . '"';

if (tep_not_null($value)) $selection .= ' value="' . tep_output_string($value) . '"';

if ( ($checked == true) || ( isset($GLOBALS[$name]) && is_string($GLOBALS[$name]) && ( ($GLOBALS[$name] == 'on') || (isset($value) && (stripslashes($GLOBALS[$name]) == $value)) ) ) ) {
  $selection .= ' CHECKED';
}

if (tep_not_null($parameters)) $selection .= ' ' . $parameters;

$selection .= '>';

return $selection;
 }

////
// Output a form checkbox field
 function tep_draw_checkbox_field($name, $value = '', $checked = false, $parameters = '') {
return tep_draw_selection_field($name, 'checkbox', $value, $checked, $parameters);
 }

////
// Output a form radio field
 function tep_draw_radio_field($name, $value = '', $checked = false, $parameters = '') {
return tep_draw_selection_field($name, 'radio', $value, $checked, $parameters);
 }

////
// Output a form textarea field
 function tep_draw_textarea_field($name, $wrap, $width, $height, $text = '', $parameters = '', $reinsert_value = true) {
$field = '<textarea name="' . tep_output_string($name) . '" wrap="' . tep_output_string($wrap) . '" cols="' . tep_output_string($width) . '" rows="' . tep_output_string($height) . '"';

if (tep_not_null($parameters)) $field .= ' ' . $parameters;

$field .= '>';

if ( (isset($GLOBALS[$name])) && ($reinsert_value == true) ) {
  $field .= stripslashes($GLOBALS[$name]);
} elseif (tep_not_null($text)) {
  $field .= $text;
}

$field .= '</textarea>';

return $field;
 }

////
// Output a form hidden field
 function tep_draw_hidden_field($name, $value = '', $parameters = '') {
$field = '<input type="hidden" name="' . tep_output_string($name) . '"';

if (tep_not_null($value)) {
  $field .= ' value="' . tep_output_string($value) . '"';
} elseif (isset($GLOBALS[$name])) {
  $field .= ' value="' . tep_output_string(stripslashes($GLOBALS[$name])) . '"';
}

if (tep_not_null($parameters)) $field .= ' ' . $parameters;

$field .= '>';

return $field;
 }

////
// Hide form elements
 function tep_hide_session_id() {
global $session_started, $SID;

if (($session_started == true) && tep_not_null($SID)) {
  return tep_draw_hidden_field(tep_session_name(), tep_session_id());
}
 }

////
// Output a form pull down menu
 function tep_draw_pull_down_menu($name, $values, $default = '', $parameters = '', $required = false) {
$field = '<select name="' . tep_output_string($name) . '"';

if (tep_not_null($parameters)) $field .= ' ' . $parameters;

$field .= '>';

if (empty($default) && isset($GLOBALS[$name])) $default = stripslashes($GLOBALS[$name]);

for ($i=0, $n=sizeof($values); $i<$n; $i++) {
  $field .= '<option value="' . tep_output_string($values[$i]['id']) . '"';
  if ($default == $values[$i]['id']) {
	$field .= ' SELECTED';
  }

  $field .= '>' . tep_output_string($values[$i]['text'], array('"' => '"', '\'' => ''', '<' => '<', '>' => '>')) . '</option>';
}
$field .= '</select>';

if ($required == true) $field .= TEXT_FIELD_REQUIRED;

return $field;
 }

////
// Creates a pull-down list of countries
 function tep_get_country_list($name, $selected = '', $parameters = '') {
$countries_array = array(array('id' => '', 'text' => PULL_DOWN_DEFAULT));
$countries = tep_get_countries();

for ($i=0, $n=sizeof($countries); $i<$n; $i++) {
  $countries_array[] = array('id' => $countries[$i]['countries_id'], 'text' => $countries[$i]['countries_name']);
}

return tep_draw_pull_down_menu($name, $countries_array, $selected, $parameters);
 }
?>

 

Thanks

Share this post


Link to post
Share on other sites

PLEASE READ

 

 

Neil,

 

Instead of uselessly posting a shit-load of code here, I think a better approach might be to actually read the readme and this forum.

 

I am not going to keep answering the same question over and over again. My time is worth more to me than that!

 

Why don't you try to help yourself first before asking others to?

 

The same goes for anyone else that just posts saying "it's not working", without providing what they, themselves have done to make it work. Almost every conceivable problem/solution is now in this thread.

 

Maybe someone else will give up their time for you, but if your post is ignored by me you'll know why.

 

Enough is enough!!

 

Tom

Edited by tomjmul

OSC Image Magic

On-the-fly thumbnails, watermarks and image processing

Share this post


Link to post
Share on other sites
Guest
PLEASE READ

Neil,

 

Instead of uselessly posting a shit-load of code here, I think a better approach might be to actually read the readme and this forum.

 

I am not going to keep answering the same question over and over again. My time is worth more to me than that!

 

Why don't you try to help yourself first before asking others to?

 

The same goes for anyone else that just posts saying "it's not working", without providing what they, themselves have done to make it work. Almost every conceivable problem/solution is now in this thread.

 

Maybe someone else will give up their time for you, but if your post is ignored by me you'll know why.

 

Enough is enough!!

 

Tom

 

I think you mean Mike :blink:

Share this post


Link to post
Share on other sites
I think you mean Mike :blink:

 

Yes I do indeed....sorry about that :blush:

 

The one helpful response in God knows how long, and this is how I treat you :D


OSC Image Magic

On-the-fly thumbnails, watermarks and image processing

Share this post


Link to post
Share on other sites

Tom,

 

I have searched this thread, the osC forums and all of the offical Imagemagick website but have not found a way to keep animated gif files animated.

 

Is there any update for this... either good/bad or indifferent?

 

Thanks in advance,

 

Nate

Share this post


Link to post
Share on other sites
Guest
Yes I do indeed....sorry about that :blush:

 

The one helpful response in God knows how long, and this is how I treat you :D

 

 

Don't sweat it. I've seen the amount of times you have replied with the same answer over and over again. It must have driven you mad!! :o

Share this post


Link to post
Share on other sites

Nate,

 

Here ya go.

 

In catalog/includes/functions/general.php add this function to the end ( but before the final ?> ):

 

function is_ani($filename)
{
   $filecontents=file_get_contents($filename);

   $str_loc=0;
   $count=0;
   while ($count < 2)
   {

		   $where1=strpos($filecontents,"\x00\x21\xF9\x04",$str_loc);
		   if ($where1 === FALSE)
		   {
				   break;
		   }
		   else
		   {
				   $str_loc=$where1+1;
				   $where2=strpos($filecontents,"\x00\x2C",$str_loc);
				   if ($where2 === FALSE)
				   {
						   break;
				   }
				   else
				   {
						   if ($where1+8 == $where2)
						   {
								   $count++;
						   }
						   $str_loc=$where2+1;
				   }
		   }
   }

   if ($count > 1)
   {
		   return(true);

   }
   else
   {
		   return(false);
   }
}

 

In /catalog/includes/functions/html_output.php find this bit of code:

 

  
// Is this image good to go?
if (CONFIG_CALCULATE_IMAGE_SIZE && $calculate) {

 

and just BEFORE it add this line:

if (is_ani($src)) calculate=false;

 

I will be including this in the next version.

Let me know how it works out for you.

 

Tom

 

 

P.S I think it is a massive oversight / downright laziness on the part of whoever runs this forum not to install the proper php formatting modules. That is why all the code posted looks like shit.

Edited by tomjmul

OSC Image Magic

On-the-fly thumbnails, watermarks and image processing

Share this post


Link to post
Share on other sites
Guest

When I installed the Contribution, I had the Cache issue, but I have just got it working now. I switched off PHP Safe Mode just to see if it would work, and it did!! I can now use the caching!

Share this post


Link to post
Share on other sites

Thanks Tom,

 

Seems to work perfect now.... Just had to change:

 

if (is_ani($src)) calculate=false;

 

to

 

if (is_ani($src)) $calculate=false;

 

 

Does this keep all animated gif files from being cached and resized into thumbs? It seems that all my images are loading a bit slower now (may just be me) but would it be this that is causing it? Or do they just need to be re cached and the thumbnails re-generated.

 

Thanks again!

 

Nate

 

PS: Did you get my PM about product listing?

Share this post


Link to post
Share on other sites

Intresting error i'm now getting now at the top of a number of pages...

 

Warning: file_get_contents(/teststore/icons2/error.gif): failed to open stream: No such file or directory in /home/ipodcar/public_html/teststore/includes/functions/general.php on line 2859

 

The more intresting part is that there infact a error.gif in that folder and the folder path is correct.... perhaps the most intresting part is that it that the error.gif is showing up without any problem.

Share this post


Link to post
Share on other sites

>_< I have now for 2 days look on all the code try all in admin section, but i can not get the watermaigc to the popup can you write how the admin can be so i work. ???

 

i have read the file and get to zero in image first. (in admin)

 

wish you will and it will be easy, you can get my url and the admin pass and login.

 

//Thanks for a nice work, and i hope i can get it to work

Share this post


Link to post
Share on other sites

I have read through all of the information on Image Magic and it looks like an awsome product. I had no problems durring the install but nothing has really changed. All of the setting are available in Admin but they don't seem to make any difference. The Mod is definetely on and all of the file changes have not generated any errors. The only thing I can thik of is that my directory structure is Shop\Images and not Catalog\Images. Could this be the problem? I'm using OSC 2.2-MS2 and the GD Image library is enabled and my website is http://www.benjamincufflinks.com.au/shop Thanks in advance for any assistance.

 

Scott


Scott Lawry

Share this post


Link to post
Share on other sites
I have read through all of the information on Image Magic and it looks like an awsome product. I had no problems durring the install but nothing has really changed. All of the setting are available in Admin but they don't seem to make any difference. The Mod is definetely on and all of the file changes have not generated any errors. The only thing I can thik of is that my directory structure is Shop\Images and not Catalog\Images. Could this be the problem? I'm using OSC 2.2-MS2 and the GD Image library is enabled and my website is http://www.benjamincufflinks.com.au/shop Thanks in advance for any assistance.

 

Scott

 

 

Sorry Guys don't respond to this querie as it turns out my hosting company moved my site onto another server last week and GD Image library is now not enabled. Grrrrrrrrr.

 

I will hopefully be able to sort this out once they finish the job they should have done last week.


Scott Lawry

Share this post


Link to post
Share on other sites

Will Someone Please Help Me ???

 

I Will Mean I Have Do All What The ReadMe File Will Have Me To Do, But I Can Not Get This To Work, Nothing Is Chances In The Popup. Please Help

 

The Url Is : http://The-Exterminator.dk/fido/

 

Wish You Will Have I Send Some File You Can See, Or Will Get My Admin Login And Pass Please Write It.

I Will So Much Have This To Work, So Please Help Me, I Have Try Now On 3 Days To Get It To Work.

 

I Can Not Get The "thumbnails" To Work, I Have Make A Directory In All Images Folders And Sub-Folders. And My PHP Is Set Up To :

 

GD Support: enabled

GD Version: bundled (2.0.28 compatible)

FreeType Support: enabled

FreeType Linkage: with freetype

FreeType Version: 2.1.9

T1Lib Support: enabled

GIF Read Support: enabled

GIF Create Support: enabled

JPG Support: enabled

PNG Support: enabled

WBMP Support: enabled

XBM Support: enabled

 

Please Help

Share this post


Link to post
Share on other sites

Hi Michael,

I had a look and see i/m working on all other pages except your popup page.

I think the reason may have to do with the fact that you have the seo switched on.

Try turning this off and let me know if it works now.

Regards creating images directories, you just need to create ONE. Under your stores root.

Tom


OSC Image Magic

On-the-fly thumbnails, watermarks and image processing

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×