Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

It's a bit crazy, isn't it?  :'( 

Sounds a bit weird indeed. I currently don't have this double tax problem, but maybe that's because the dutch paypal does not exist (I see the German does). There is a Dutch link, but it redirects and there seems to be nothing dutch about it after the redirect.

 

I think that instead of your changings this two changings must do it:

I assume you ment "on top of" or "in addition to" i.s.o. "instead of". But thanks for the update Frank, it will save me a headache if paypal decides to change the Dutch site in the same way. Edited by PandA.nl

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

Hopefully someone can point me in the right direction on this.

 

I have just installed this mod but when I hit Confirm Order in my shop i get directed to the Paypal screen but get the following error...

 

Please enter an amount greater than Zero

 

Your shopping cart is empty

 

Any ideas?

 

Our site isn't ssl but only uses Paypal for credit/debit card payments.

 

Have I not done something in the configuration to get this error?

 

In paypal it does say this in your IPN setup.......

 

Instant Payment Notification Preferences

--------------------------------------------------------------------------------

 

Instant Payment Notification (IPN)

Instant Payment Notification integrates PayPal payment notification and authentication with your website's back-end operations. Check this box to activate Instant Payment Notification, and enter the URL at which you will receive the payment notifications below. This URL should be a URL which you own and at which you receive HTML posts.

 

I haven't activated this because I am unsure about the URL i need to enter.

 

 

I have installed this mod because within the last couple of days we started to get a security popup from paypal stating that the certificate was out of date.

 

I hope someone can help me

 

Thanks in advance

 

Derek

Share this post


Link to post
Share on other sites

Ignore my above post, i have resolved my original problem and have gone back to the standard Paypal module.

 

Derek

Share this post


Link to post
Share on other sites
A few messages back I shared what I have entered.

 

The "Your PayPal Public Certificate ID:" is just a number that PayPal provides after you upload your Public Certificate to them.

 

I left the  Working Directory: and OpenSSL Location:  as is.

 

When I first started testing in paypal sandbox I visited their forum....about 3 weeks ago, and I saw a thread in there about someone said they were actually being charged....

NOW I dont see how that can happen....but

 

what you should do is generate CC numbers by going to add a CC and noting the random CC #s it generated for you...and just use that to test...like in scenario where someone doesnt have paypal account .......

Share this post


Link to post
Share on other sites

Hello guys! I was testing the contribution today around this time and I have some errors to report. I used to have no problem with the Order Status but today I got duplicated entries of the Pending status. The time log for the Pending status differ by around 10secs of each other. The worst has yet to come. After I updated the status to Processing, it will go back to Pending after a few seconds. Same thing. It will keep duplicating the Pending status.

 

I suspect that this error is coming from the PayPal Sandbox server. Can someone verify this?

 

Thank You

Edited by rezdwan

Share this post


Link to post
Share on other sites
Hello guys! I was testing the contribution today around this time and I have some errors to report. I used to have no problem with the Order Status but today I got duplicated entries of the Pending status. The time log for the Pending status differ by around 10secs of each other. The worst has yet to come. After I updated the status to Processing, it will go back to Pending after a few seconds. Same thing. It will keep duplicating the Pending status.

 

I suspect that this error is coming from the PayPal Sandbox server. Can someone verify this?

 

Thank You

I believe that the answer to my problem is here; Keep getting same IPN's. It is a link from the PayPalDev.org - An Independent Forum for PayPal Developers. Please check it out.

 

Thank You

Share this post


Link to post
Share on other sites

Here is a list of problems I have with Paypal IPN:

-For some reason I still get "Paypal IPN Invalid [Completed]"

-It won't forward their confirmed address to PayPal... how can I know it's not fraud?

-It CONFUSES ORDERS! I have 2 different customers names in one order, this has happened multiple times lately because of increased sales all happening at the same time.

-It hasn't been updating people's orders from "Preparing" to "Pending" - even after they successfully pay me.

 

Someone please help this time :(

JL

Edited by jlevi

Share this post


Link to post
Share on other sites

Hi thanks for this contribution, hopefully its going to stop a lot of problems.

 

I have one problem where I get no order email from my store if the customer does not return back to the checkout success page. Is there any way to fix this? Has this question already been answered 1000000 times already?

 

Also I have the IPN URL on my Paypal account set like below. Is this correct, it seems ok but i was a little unsure, I don?t see it mentioned in the documentation.

 

Instant Payment Notification (IPN) URL: http://www.mysite.com/ext/modules/payment/paypal_ipn/ipn.php

Share this post


Link to post
Share on other sites

I been having the same problems of the status not updating. I took an approach using the oscommerce admin section of "enhanced whos online" to watch the ipn try to communicate. I know it is paypal, because the address it is visiting is the ipn.php.

 

I notice that it is trying to communicate with my site, but the address is not right. I am using a shared SSL, so when my site is in secure mode the address is https://hostxx.ipowerweb/~username/ext/modu...pal_ipn/ipn.php

However, my normal site address is http://mywebsite.com

Paypal is doing somethig funny, it seems to be going to be mixing the addresses.

It is going to http://mywebsite.com/username/ext/modules/payment/paypal_ipn/ipn.php

 

Anyone know what coding would be responsible? what part of the coding automatically tells paypal what address to respond to? Any of the other people complaning about the status not updating, also using shared ssl?

Share this post


Link to post
Share on other sites
Here is a list of problems I have with Paypal IPN:

-For some reason I still get "Paypal IPN Invalid [Completed]"

-It won't forward their confirmed address to PayPal... how can I know it's not fraud?

-It CONFUSES ORDERS! I have 2 different customers names in one order, this has happened multiple times lately because of increased sales all happening at the same time.

-It hasn't been updating people's orders from "Preparing" to "Pending" - even after they successfully pay me.

 

Someone please help this time :(

JL

 

 

 

I have similar problems! :angry:

Share this post


Link to post
Share on other sites

Hi,

 

I am in the process of changing to this IPN module, and i am experiencing one slight problem. The main feature of the module does not appear to be working, i do not get a 'Preparing PayPal IPN' status order when the checkout confirmation screen is presented. at which point should this data be added to the DB (normal orders are added at checkout success?), as this mod doesnt modify any files i am a bit lost. I had the other Paypal IPN module working ok-ish, but this one looks more 'streamlined' so would really like to get it going.

 

All settings are pretty much default, i have 'deactivated' the IPN on my PayPal profile (removed the url used in the other IPN mod), all config settings are ok, no encryption etc. I also removed references and code from the other contribution (database entries and some code from checkout_success).

 

Here is the from data from checkout_confirmation , is there anything else i can look for (ie. when is the database updated with the 'Preparing' order details and status?):

 

<form name="checkout_confirmation" action="https://www.paypal.com/cgi-bin/webscr" method="post"><input type="hidden" name="cmd" value="_xclick"><input type="hidden" name="item_name" value="Console Plus"><input type="hidden" name="shipping" value="5.90"><input type="hidden" name="tax"><input type="hidden" name="business" value="sales@consoleplus.co.uk"><input type="hidden" name="amount" value="24.90"><input type="hidden" name="currency_code" value="GBP"><input type="hidden" name="invoice"><input type="hidden" name="custom" value="21819"><input type="hidden" name="no_shipping" value="1"><input type="hidden" name="no_note" value="1"><input type="hidden" name="notify_url" value="http://www.consoleplus.co.uk/ext/modules/payment/paypal_ipn/ipn.php"><input type="hidden" name="return" value="http://www.consoleplus.co.uk/checkout_process.php"><input type="hidden" name="cancel_return" value="http://www.consoleplus.co.uk/checkout_payment.php"><input type="hidden" name="bn" value="osCommerce PayPal IPN v1.0"><input type="image" src="includes/languages/english/images/buttons/button_confirm_order.gif" border="0" alt="Confirm Order" title=" Confirm Order "></form>

 

Any ideas greatly appreciated! :)

 

Cheers

 

Matt

Share this post


Link to post
Share on other sites

As a follow on from my last post, it appears there is something very wrong with my paypal setup here, i did a real test purchase and whilst the payment went ok i got a error from the 'debug' IPN email and also the order confirmation emails i recieive do not have any order numbers, and the order did not get update to the database at all (not under any status, no order was added to the DB at all, an email was sent (with all the details, but no order number):

 

Order Number:

Detailed Invoice: http://www.consoleplus.co.uk/account_histo...o.php?order_id=

Date Ordered: Tuesday, 01 February 2005

 

 

All other payment methods are working fine, it just seems to be a paypal issue.

 

I have de-activiated the IPN for now and am using the old 'basic' Paypal module (i'm ready to maually update some orders tommorow!) :)

Again, any help greatly appreciated.

 

Thanks Matt

Share this post


Link to post
Share on other sites
If you are not receiveing the paypal IPN updates then its a setting on your store somewhere...

 

Have you got the store password protected using htaccess?

Have you enabled the debug email?

 

 

Hey Sparky... i'm pretty much in the same boat. I don't think i have my password protected in the htaccess file, but how do i check?

 

Everything works perfect except I'm not getting a IPN. Basically this is working exactly like the regular paypal module osc comes with. BTW, i am not using encryption to pass stuff to pay pay.

 

My store is - http://www.neblinarecords.com/catalog/index.php if that helps at all.

 

Thanks in advance! :thumbsup:

Share this post


Link to post
Share on other sites

oh, BTW i do have my debug email set up but i haven't gotten anything.... just to be clear, i do recieve the email from the store stating there is an order.... just nothing from paypal.

Share this post


Link to post
Share on other sites

Hello guys,

 

I was wondering if anyone can help me with the undermentioned problem. I have set up osCommerce and I am using the osCommerce PayPal IPN. I have tested it using the Sandbox and everything seems fine except the status of the order.

 

When I click Edit on a order, the Status column showed Pending first then it will be Preparing [PayPal IPN]. Shouldn't it be the other way round? The Comments column seems fine with the remark PayPal IPN Verified [Completed] showed first.

 

Anyone else with the same problem? If it helps, here are the settings that I have used.

 

Shopping cart version: osCommerce 2.2 Milestone 2

Payment module version: osCommerce PayPal IPN 1.0 (Please note that I have tested the version 1.1 and getting the same problem as above.)

osCommerce PayPal IPN 1.0 settings:

Enable PayPal IPN Module

True

E-Mail Address

sales@domain.com

Transaction Currency

Only USD

Payment Zone

PayPal Zone

Set Preparing Order Status

Preparing [PayPal IPN]

Set PayPal Acknowledged Order Status

Pending

Gateway Server

Testing

Transaction Type

Per Item

Page Style

 

Debug E-Mail Address

 

Sort order of display.

0

Enable Encrypted Web Payments

False

Your Private Key

 

Your Public Certificate

 

PayPals Public Certificate

 

Your PayPal Public Certificate ID

 

Working Directory

 

OpenSSL Location

/usr/bin/openssl

 

Thank you

Edited by rezdwan

Share this post


Link to post
Share on other sites
you state the obvious, mibble ... I guess that's how you racked up so many posts

 

Inspecting the code, this appears to be a clash between Authorizenet Consolidated 1.7 and PayPal IPN.  The authorizenet mod to checkout_process.php has its own 'new order_total' embedded inline, before the standard code calls all the payment modules' before_process(), which in the case of PayPal IPN includes another 'new order_total' instance.

 

Can someone suggest a workaround?  [specifics, not generalities]

 

Fritz how did you fix the "hang" that occurs when the user clicks to go back to the merchants page from payPal when using the authorize.net 1.7 checkout_process.php file?


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites
When I click Edit on a order, the Status column showed Pending first then it will be Preparing [PayPal IPN]. Shouldn't it be the other way round? The Comments column seems fine with the remark PayPal IPN Verified [Completed] showed first.

 

Anyone else with the same problem?

Same here. Because everything else seems to work fine, I decided to let it be. But of course it does seem wrong to me too, not sure if it's a bug or a setting.

 

Is there anyone who does NOT have this problem? If so, could you post your settings?


Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites
Same here. Because everything else seems to work fine, I decided to let it be. But of course it does seem wrong to me too, not sure if it's a bug or a setting.

 

Is there anyone who does NOT have this problem? If so, could you post your settings?

Ahhh... It seems that I am not the only one with the problem. As PandA.nl had said, we can leave it be since everything looks fine but it's just not right. My other concern is when the customers sees this in their account. It can be confusing. Right?

Share this post


Link to post
Share on other sites

When a transaction is complete and the customer clicks the Return ro Mercahnt button, they are not being returned to my osC store. They are given an eror page.

 

When this happens, the url in the browser address bar is

 

http://checkout_process.php/?osCsid=long_number_here

 

It appears to me that this url should include the url to my web store.

 

In my PayPal account settings"Instant Payment Notification Preferences" on PayPal's web site, I have IPN "on" and I have entered

 

http://twowayradiodirectory.com/catalog/

 

as "the URL at which you will receive the payment notifications below"

 

What could be the problem?

 

I had this working at one time, then switched to the sandbox and had it working ok there. This began when I switched back to the live PayPal.


Rik Rasmussen

Share this post


Link to post
Share on other sites

I had not had the IPN set to "on" at PayPal for my earlier live or sandbox tests, I did try that as indicated above to see if it would make a difference. It did not. I have now unselected the IPN setting and removed the url at PayPal.

 

It is my understanding that when this module contacts PayPal, it activates the IPN and supplies the return url at that time.

 

So, I am stuck.


Rik Rasmussen

Share this post


Link to post
Share on other sites

I just went to the PayPal Developers forum and see that there is apparently a big problem with the PayPal IPN.

 

So, maybe the problem is not on my end.

 

Is anyone else here seeing IPN problems with PayPal?


Rik Rasmussen

Share this post


Link to post
Share on other sites
When I click Edit on a order, the Status column showed Pending first then it will be Preparing [PayPal IPN]. Shouldn't it be the other way round? The Comments column seems fine with the remark PayPal IPN Verified [Completed] showed first.

 

Anyone else with the same problem? If it helps, here are the settings that I have used.

 

Yeah, this is a bit of a pain, confusing for customers to be sure. Has to be a mix up somewhere in the code making it so the opposite selected status is processed. Anyone looked into this?

 

 

I just went to the PayPal Developers forum and see that there is apparently a big problem with the PayPal IPN.

 

So, maybe the problem is not on my end.

 

Is anyone else here seeing IPN problems with PayPal?

 

I've had two orders go through today with paypal, both show "PayPal IPN Verified [Completed]", but the status is not being changed to the status it should be and the customer is not notified that his payment processed like it did before. Very weird, just started happening.

Share this post


Link to post
Share on other sites

Oh, I meant to ask this in the previous post.

 

For sanity sake I thought it would be a good idea to show a step by step of what this mod is *supposed* to do, make it easier to see if there is a problem. I think knowing exactly WHAT happens and WHEN would help a lot of us fix any errors we are finding.

 

 

So basicly it works like this... (tell me if I miss anything or get it wrong)

 

1. on checkout_confirmation.php the order gets posted into the database with the "Preparing Order Status".

 

2. When the user goes to paypal and pays the ipn sets the comments of the the user's order status to "PayPal Acknowledged Order Status" and places a comment in the comment section to "PayPal IPN Verified [Completed]" (or [Denied]).

 

3. The user clicks the "continue" button on paypal returning to the site and THEN an email is sent to the user with the order details.

 

---------

 

Is this correct? Am I missing anything?

Share this post


Link to post
Share on other sites

That is also my understanding of the basic way it works.

 

Except that right now it isn't because of problems at PayPal.


Rik Rasmussen

Share this post


Link to post
Share on other sites
That is also my understanding of the basic way it works.

 

Except that right now it isn't because of problems at PayPal.

 

 

So if you get #2 (order status set to "PayPal Acknowledged Order Status" with the "PayPal IPN Verified [Completed]") BUT DON'T get the status set to the pending status with the user acknowledgement (email) that just means the user didn't hit the "continue" button but IPN is working... ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×