Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

Hi,

 

Sorry but Im having hard time searching through this thread..

 

I don't seem to get an confirmation e-mail, and everything works fine. I get paypal instant payment received e-mail, but I don't get Order Processed e-mail from my site..

 

Thank you.

Share this post


Link to post
Share on other sites
Hi,

 

Sorry but Im having hard time searching through this thread..

 

I don't seem to get an confirmation e-mail, and everything works fine. I get paypal instant payment received e-mail, but I don't get Order Processed e-mail from my site..

 

Thank you.

 

Join the club. I've been chasing this bug since January.

Share this post


Link to post
Share on other sites
I ran phpinfo() because actually I wasn't sure what they were using, however it's 4.3.11

GoDaddy.com is a pretty big webhost provider, so I haven't really considered the problem to be with their server, but if it is, it's not likely any changes will occur to accomodate me.

I'm curious though, what is it about a particular server's php version that would cause the Invalid Process error ?

 

Okay to give an update - via PM with Burnsey44, we might have found the problem ..

 

Currently the PayPal IPN is written to work with Register Globals ON .. if it's disabled on your server, you'll need to rewrite the code to make it compatible. Haven't done this myself yet though. For background on this, check out php.net with regards to superglobals and register globals. All tests for the contrib were done on a server with Register Gobals ON.

 

If anybody else is having issues with the PayPal IPN, please include in your post info on Register Globals status on your server - will help to understand your problem.

 

Terra

Edited by Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
I have a couple of questions.

 

Could someone please tell me what the major differences are between the PayPal IPN payment method (as implemented by this contrib) and PayPal Express Checkout (Direct Payments). In both you are directed to the Paypal website for payment and are returned to the merchant site afterwards.

 

Also, is it possible when directed to the paypal webiste, to arrive at the credit card entry screen rather than the paypal login screen? I.e. as it is implemented, you are taken to the paypal login screen. If you don't have an account you need to click on ''don't have a paypal account''? Is it possible to go straight to the page you arrive at when clicking on ''don't have a paypal account'' without having to go through the paypal login screen?

 

Basically, as PayPal will be the only payment method to begin with, I want to assume the buy does not have a PayPal account rather than the other way round.

 

Many thanks, in advance.

 

Jody

 

Jody - I've never used PayPal Express Checkout, so sorry can't comment on that.

 

Regarding the PayPal website - the PayPal IPN uses the PayPal standard integration which means you always arrive at the generic log in page. You don't have to open an account, but you will be prompted for it. There is no other way to integrate with PayPal and you cannot choose to arrive at the credit detail screen. That would actually be very confusing with customers who already have PayPal accounts and cause even more problems.

 

The only other way is Paypal Pro (or something like that) which is a paid service which you can integrate with your site ... not available in all countries and the costs seem quite high.

 

Personally if you are looking for a seamless integration, you might want to check out Protx. Reasonable prices, reliable and customers stay on your site. You do need a merchant account though.

 

all the best with your shop! Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
I don't seem to get an confirmation e-mail, and everything works fine. I get paypal instant payment received e-mail, but I don't get Order Processed e-mail from my site..

 

Do you have the PayPal IPN installed on your site (not the standard PayPal which come pre-installed, but the contrib from here: http://www.oscommerce.com/community/contributions,2679)

 

If yes, then you should see the orders stored in your admin even if the email fails. Basically, if customers do not return to your site, no email is sent but you do have a copy of the order in your admin section.

 

Please post back if that doesn't solve your query.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
Hi Terra - my bad, I cut the wrong code the first time... :-"

....

It could be that I don't have my PP account settings correct, but that's a whole other mess unto itself.

Terra - I have been having no end of problems trying to test PP IPN with the Sandbox... I'm continually getting Message 3005 errors. Not one single test transaction has gone through PP ever, even with several different test account configurations and two different PP Developer Center accounts. Paypal "support "has been *ahem* dismal in their efforts with only one "confirm your test account email address" reply. Well DUUUUHHHHH!

 

The orders are being stuck into the Orders database and I can see them as "Preparing [PayPal IPN]". However they do get stomped when I put another test transaction through, according to Harald's warning at the bottom of the readme. So at least I know it's working to this point!

 

Thinking perhaps I broke something when I modded the shipping costs I went back and restored an exact copy of the PP IPN 1.2a code. It's still not passing the shipping through, but everything else is being passed correctly.

 

The whole process is working right up until the "pay" page, after which it goes to the famous Message 3005. I'm wondering if you have a list of configuration settings that the business account profile should have set up.

 

My PayPal Account Settings:

- Canadian Business Account, Verified

- Not requested API access or signature

- Shipping Calculations: CAD$, no shipping values set up, transaction-based shipping override allowed

- Shipping Preference: default carrier Canada Post, no ship buttons selected

- Payment Receiving Preferences: Block US non-confirmed, block other currencies (non CAD$), block accidental, block Initiated payments, block eCheck

- IPN Preferences: On, url is http://www.domain.com/catalog/checkout_process.php

- Website Payment Preferences: Autoreturn On, return url http://www.domain.com/catalog/checkout_success.php, Payment Data Transfer On, Encrypted OFF, Contact phone Required

- Encrypted Payment Preferences: default, I don't/can't use it

- using a custom payment page

- Language Encoding: western European

 

My PP IPN Settings are:

 

Enable PayPal IPN Module: True

Move tax to total amount: True

E-Mail Address: set to my PayPal email address

Transaction Currency: Only CAD

Payment Zone: --none--

Set Preparing Order Status: Preparing [PayPal IPN]

Set PayPal Acknowledged Order Status: Pending

Gateway Server: Testing

Transaction Type: Aggregate

Page Style: Custom Page

Debug E-Mail Address: other email address

Sort order of display: 30

Enable Encrypted Web Payments: False

Your Private Key: <blank>

Your Public Certificate: <blank>

PayPals Public Certificate: <blank>

Your PayPal Public Certificate ID: <blank>

Working Directory: temp/

OpenSSL Location: /usr/bin/openssl

 

Any advice would be greatly appreciated.

 

Thanks in advance!

 

-al

Share this post


Link to post
Share on other sites

Okay Halbert, let's take this step-by-step. Base assumption is that the IPN is working, so it's either

* your PayPal Settings

* your IPN configuration

* PHP code error

* Server settings (please note that Register Globals must be ON for the IPN to work)

 

PayPal Sandbox - number one is that PayPal Developer Center comes with its own email inbox. When you are creating a new account, you can confirm the sandbox dummy email by going into mail part of the Development Center and clicking the link in the email. There is also a PDF guide and a forum for sandbox users.

 

Secondly your PayPal settings:

- Canadian Business Account, Verified

- Not requested API access or signature

- Shipping Calculations: CAD$, no shipping values set up, transaction-based shipping override allowed

- Shipping Preference: default carrier Canada Post, no ship buttons selected

- Payment Receiving Preferences: Block US non-confirmed, block other currencies (non CAD$), block accidental, block Initiated payments, block eCheck

- IPN Preferences: On, url is http://www.domain.com/catalog/checkout_process.php

IPN must be OFF - the PayPal IPN osCom module is not the same thing as the IPN they talk about on PayPal!

- Website Payment Preferences: Autoreturn On, return url http://www.domain.com/catalog/checkout_success.php,

Return URL is checkout_process.php. if you have a SSL on your site, please use the secure SSL pathway.

Payment Data Transfer On, Encrypted OFF, Contact phone Required

I'd recommend Payment Data Transfer to be OFF - not sure if it causes any issues, it's definitely OFF in my account.

- Encrypted Payment Preferences: default, I don't/can't use it

- using a custom payment page

- Language Encoding: western European

 

Your PayPal configuration looks fine - leave as is.

 

There have been posts on this forum regarding the Canadian currency abbreviation and problems with PayPal. PayPal says its in development guide that the abbreviation should be "CAD" so as long as that's what you have on your website, it *should* work. Please also check your english.php file to make sure the currency is set to "CAD".

 

Please read this post regarding Canadian Currency & 3005 error. It's most likely your Canadian currency abbreviation that needs checking in your Localisation settings:

http://forums.oscommerce.com/index.php?sho...60entry758060

Applauz posted:

For anyone else having this problem with the total not carrying over to PayPal ... It seems to be an issue with the country code for Canada.

OSCommerce is using the code CA ... but PayPal is using the code CAD.

So I took a long shot .. and created a new currency in Localization>>Currencies.... If you edit the current one .. it wont work. You have to create a new currency and set its values... give it the code CAD.

This worked for me!

Please first try the above, have a look on the forum regarding the currency abbreviation and if all fails, please post back & I'll take another look.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
Okay Halbert, let's take this step-by-step. Base assumption is that the IPN is working, so it's either

* your PayPal Settings

* your IPN configuration

* PHP code error

* Server settings (please note that Register Globals must be ON for the IPN to work)

...

all the best, Terra

 

Terra - Thanks! I've finally got it to work!

 

I think my issue was the PayPal Profile settings... because after I changed them things worked swimmingly. Even shipping charges are transferred correctly now.

 

My only issue now is that PayPal Sandbox hasn't triggered OSC to post payment to the database... but I'm hoping that's just Sandbox acting up. The payments are appearing in my Sandbox business account and the orders are in the database so that's good!

 

I'm not sure what version of PP IPN and OSC the guys with the CA vs CAD currency problem were using, but I'm working on a copy of the original MS2 image and it's never been 2-character currency codes so they might have entered their currency codes incorrectly.

 

Thanks again for all the help. I'll write up the PayPal profile settings in a text file and post them in the contributions.

 

-al

Share this post


Link to post
Share on other sites
Terra - Thanks! I've finally got it to work!

Hi Al - that's very good news. And posting the PayPal settings is a good idea, please do that. My next project is to make the PayPal IPN "register globals OFF" compatible but I need a quiet day for that, so please post any updated info in the contribs section in the meantime. all the best, Edith


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

Hello,

 

I've almost successfully installed this contribution. My only problem is...

 

My websites default currency is in Australian currency but when the customer goes through to enter their credit details in PayPal the invoice shows the prices in US currency. How do I fix this problem?

 

Apologies if this has been answered elsewhere...i just haven't been able to find it.

Share this post


Link to post
Share on other sites
My websites default currency is in Australian currency but when the customer goes through to enter their credit details in PayPal the invoice shows the prices in US currency. How do I fix this problem?

What is your currency settting in the admin area for PayPal IPN & your Localisation settings? And which currency abbreviation are you using? PayPal requires AUD - both in your PayPal module settings and on your website under localisation. Also check your PayPal account settings what you specified - US Dollars is the default, so you are missing a specification somewhere.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

hi

i'v installed this paypal contribution and while testing i'v come acros 3 confusing things:

 

1. if i have to log in after clicking on checkout then the order never

apears in the admin section of osc but i get a confirmation e-mail.

 

2. all orders paid for with paypal are missing the order number in the confirmation e-mail.

 

3. the status never changes from preparing no mater how long leave it

 

i would be extreamly gratefull for any help anyone micht be able to give me.

 

thanks in advance

 

 

chris

Share this post


Link to post
Share on other sites

Hi,

 

first of all...I thinks this is sublime mod. But I ran into a error wich I can't resolve cause my PHP knowlege is insufficient.

 

I use Fancier_Invoice_&_Packingslip_v6.2_1 with my osC shop and everything was working fine. But when I integrated this package with osCommmerce_PayPal_IPN_v1.2 the email the customer recieved contained an error wich is as follows;

 

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /data/members/paid/s/y/sylviesoriginals.nl/htdocs/www/includes/functions/general.php on line 46

 

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /data/members/paid/s/y/sylviesoriginals.nl/htdocs/www/includes/functions/general.php on line 46

 

Please help....

 

 

This is the code in paypal_ipn.php wich I've changed:

 

// lets start with the email confirmation

 

// START HTML Invoice

 

if (EMAIL_INVOICE == 'true') {

require(DIR_WS_MODULES . EMAIL_INVOICE_DIR . FILENAME_EMAIL_INVOICE);

} else {

// END HTML Invoice

 

$email_order = STORE_NAME . "\n" .

EMAIL_SEPARATOR . "\n" .

EMAIL_TEXT_ORDER_NUMBER . ' ' . $order_id . "\n" .

EMAIL_TEXT_INVOICE_URL . ' ' . tep_href_link(FILENAME_ACCOUNT_HISTORY_INFO, 'order_id=' . $order_id, 'SSL', false) . "\n" .

EMAIL_TEXT_DATE_ORDERED . ' ' . strftime(DATE_FORMAT_LONG) . "\n\n";

if ($order->info['comments']) {

$email_order .= tep_db_output($order->info['comments']) . "\n\n";

}

$email_order .= EMAIL_TEXT_PRODUCTS . "\n" .

EMAIL_SEPARATOR . "\n" .

$products_ordered .

EMAIL_SEPARATOR . "\n";

 

for ($i=0, $n=sizeof($order_totals); $i<$n; $i++) {

$email_order .= strip_tags($order_totals[$i]['title']) . ' ' . strip_tags($order_totals[$i]['text']) . "\n";

}

 

if ($order->content_type != 'virtual') {

$email_order .= "\n" . EMAIL_TEXT_DELIVERY_ADDRESS . "\n" .

EMAIL_SEPARATOR . "\n" .

tep_address_label($customer_id, $sendto, 0, '', "\n") . "\n";

}

 

$email_order .= "\n" . EMAIL_TEXT_BILLING_ADDRESS . "\n" .

EMAIL_SEPARATOR . "\n" .

tep_address_label($customer_id, $billto, 0, '', "\n") . "\n\n";

 

if (is_object($$payment)) {

$email_order .= EMAIL_TEXT_PAYMENT_METHOD . "\n" .

EMAIL_SEPARATOR . "\n";

$payment_class = $$payment;

$email_order .= $payment_class->title . "\n\n";

if ($payment_class->email_footer) {

$email_order .= $payment_class->email_footer . "\n\n";

}

}

 

tep_mail($order->customer['firstname'] . ' ' . $order->customer['lastname'], $order->customer['email_address'], EMAIL_TEXT_SUBJECT, $email_order, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

 

// send emails to other people

if (SEND_EXTRA_ORDER_EMAILS_TO != '') {

tep_mail('', SEND_EXTRA_ORDER_EMAILS_TO, EMAIL_TEXT_SUBJECT, $email_order, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

}

 

// START HTML Invoice

}

// END HTML Invoice

// load the after_process function from the payment modules

Share this post


Link to post
Share on other sites
What is your currency settting in the admin area for PayPal IPN & your Localisation settings? And which currency abbreviation are you using? PayPal requires AUD - both in your PayPal module settings and on your website under localisation. Also check your PayPal account settings what you specified - US Dollars is the default, so you are missing a specification somewhere.

 

all the best, Terra

 

 

Thanks for getting back to me so quick. I had double checked all the settings that you had suggested and found everything to be in proper order. My localisation setting is in AUD, and my primary paypal account is in AUD. My paypal IPN setting however is in 'selected currency' as there is no option for AUD.

 

In the mean time I have received some information from the PayPal people saying that to fix my issue I need to:

 

In your button code, for a clear text button, include the following line:

 

<input type="hidden" name="currency_code" value="AUD">

 

 

I'm assuming that they are talking about the "confirm order" button. Is this right? If so, where would I find the code for this button?

Share this post


Link to post
Share on other sites

I think this is going to work, and then at the checkout I get this...

1.gif

after I click Continue here

2.gif

 

What did I do wrong?

 

Marc :'(

Edited by mdastous

Marc R. Dastous

Share this post


Link to post
Share on other sites
Thanks for getting back to me so quick. I had double checked all the settings that you had suggested and found everything to be in proper order. My localisation setting is in AUD, and my primary paypal account is in AUD. My paypal IPN setting however is in 'selected currency' as there is no option for AUD.

 

In the mean time I have received some information from the PayPal people saying that to fix my issue I need to:

 

In your button code, for a clear text button, include the following line:

 

<input type="hidden" name="currency_code" value="AUD">

I'm assuming that they are talking about the "confirm order" button. Is this right? If so, where would I find the code for this button?

In /includes/modules/payment/paypal_ipn.php find this code:

 

	  if (MODULE_PAYMENT_PAYPAL_IPN_CURRENCY == 'Selected Currency') {
	$my_currency = $currency;
  } else {
	$my_currency = substr(MODULE_PAYMENT_PAYPAL_IPN_CURRENCY, 5);
  }
  if (!in_array($my_currency, array('CAD', 'EUR', 'GBP', 'JPY', 'USD'))) {
	$my_currency = 'USD';
  }

and replace with this:

 

$my_currency = 'AUD';

 

of of course you could write it like this:

 

	  if (MODULE_PAYMENT_PAYPAL_IPN_CURRENCY == 'Selected Currency') {
	$my_currency = $currency;
  } else {
	$my_currency = substr(MODULE_PAYMENT_PAYPAL_IPN_CURRENCY, 5);
  }
  if (!in_array($my_currency, array('CAD', 'EUR', 'GBP', 'JPY', 'USD'))) {
	$my_currency = 'AUD';
  }

 

 

not tested, so please back up files first! Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
hi

i'v installed this paypal contribution and while testing i'v come acros 3 confusing things:

 

1. if i have to log in after clicking on checkout then the order never

apears in the admin section of osc but i get a confirmation e-mail.

 

2. all orders paid for with paypal are missing the order number in the confirmation e-mail.

 

3. the status never changes from preparing no mater how long leave it

 

i would be extreamly gratefull for any help anyone micht be able to give me.

 

thanks in advance

chris

mmhhhhh, not the usual PayPal IPN behaviour so something has gone wrong on your site. The good news is that it should work once you find the problem. The bad news is that I have no idea about your site & where the problem could be. As long as Registered Globals is ON on your server though, it should work. As a first step, I'd double-check that everyting is installed correctly. Hope you find the problem! Terra

PS: I have never tested chiwawa's contrib version, so my advice is for my own upload only

Edited by Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
mmhhhhh, not the usual PayPal IPN behaviour so something has gone wrong on your site. The good news is that it should work once you find the problem. The bad news is that I have no idea about your site & where the problem could be. As long as Registered Globals is ON on your server though, it should work. As a first step, I'd double-check that everyting is installed correctly. Hope you find the problem! Terra

PS: I have never tested chiwawa's contrib version, so my advice is for my own upload only

 

Thanks for your reply Terra :D

 

Sorry i forgot to mention that Register Globals is OFF on my server and i have the contribution for that installed. So i guess i'm prety much screwed from what i'v been reading in this forums. It kind of works so it will have to do for now, as long as the money gets there then it's alright.

 

Once again thank you very much.

 

Chris

Share this post


Link to post
Share on other sites
Sorry i forgot to mention that Register Globals is OFF on my server and i have the contribution for that installed. So i guess i'm prety much screwed from what i'v been reading in this forums. It kind of works so it will have to do for now, as long as the money gets there then it's alright.

You might be better off with the standard PayPal module wich comes pre-installed with osCommerce. But in any case, it might be worth keeping an eye on this thread, as I'm planning to create a Register Globals OFF compatible version - just need a very quiet day, so can't make any promises with regards to timespan (plus summer has finally arrived in England and it's absolutely glorious in the garden!!)

Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
You might be better off with the standard PayPal module wich comes pre-installed with osCommerce. But in any case, it might be worth keeping an eye on this thread, as I'm planning to create a Register Globals OFF compatible version - just need a very quiet day, so can't make any promises with regards to timespan (plus summer has finally arrived in England and it's absolutely glorious in the garden!!)

Terra

 

 

Yeah so i'v heard. Sommer finaly hit here to. the heat is a bit extreme at times but i'm not complaining. I'll give the standard paypal module a whirl and see how it goes. I'll defenalty be keeping an eye on this thread waiting for your quiet day when the british weather decides to go back to normal and rain for a week :P

Cheers for your help.

Chris

Share this post


Link to post
Share on other sites

Right I wonder if anyone can help, come into a little problem with Paypal. Everything was working fine until yesterday when someone went to make a payment via paypal it would come up as THIS INVOICE HAS ALREADY BEEN PAID, PLEASE CONTACT THE MERCHANT. NOw ive managed to rectify that by deleting the last order and also re-uploaded the Paypal-Ipn files.

 

Now the orders go through fine, but on email confirmation I get int he Subject line EMAIL_TEXT_SUBJECT instead of ORDER PROCESS. Also the actual information in the email is how is shown below with lots os EMAIL_....

 

RTOC Online Shop

EMAIL_SEPARATOR

EMAIL_TEXT_ORDER_NUMBER 55

EMAIL_TEXT_INVOICE_URL http://website/catalog/account_history_info.php?order_id=55

EMAIL_TEXT_DATE_ORDERED Monday 12 June, 2006

 

EMAIL_TEXT_PRODUCTS

EMAIL_SEPARATOR

1 x another test () = ?0.10

EMAIL_SEPARATOR

Sub-Total: ?0.10

Total: ?0.10

 

EMAIL_TEXT_DELIVERY_ADDRESS

EMAIL_SEPARATOR

Pete Robert

1 Langrove road

Rottingdean, BN6 6HG

United Kingdom

 

EMAIL_TEXT_BILLING_ADDRESS

EMAIL_SEPARATOR

Pete Robert

1 Langrove road

Rottingdean, BN6 6HG

United Kingdom

 

EMAIL_TEXT_PAYMENT_METHOD

EMAIL_SEPARATOR

PayPal (Credit Card / Debit

 

A bit frustrating, but no doupt something fairly simple to rectify im hoping, any help or advise would be greatly appreciated

Thanks very much

Sam

Share this post


Link to post
Share on other sites
Right I wonder if anyone can help, come into a little problem with Paypal. Everything was working fine until yesterday when someone went to make a payment via paypal it would come up as THIS INVOICE HAS ALREADY BEEN PAID, PLEASE CONTACT THE MERCHANT. NOw ive managed to rectify that by deleting the last order and also re-uploaded the Paypal-Ipn files.

 

Now the orders go through fine, but on email confirmation I get int he Subject line EMAIL_TEXT_SUBJECT instead of ORDER PROCESS. Also the actual information in the email is how is shown below with lots os EMAIL_....

 

Okay, two things:

 

1. the constants (the bits in upper case EMAIL_TEXT_PAYMENT_METHOD etc.) usually show if the language level file which defines them is missing. Please check your includes/languages/english or whatever/modules/payment/paypal_ipn.php to see if it's there & whether it's the correct file [should have a list of (define.....]

 

2. the "order alreayd paid" problem occurrs if the order number has already been submitted to PayPal by your domain - if you have a second shop on your domain or have been doing testing etc. this can cause trouble. To avoid this in the future, ensure to only run one PayPal IPN per domain and if you have been doing testing, you could change your order numbers to something higher (e.g. 10,000 or whatever) via PHPMyAdmin.

 

All the best, Terra

Edited by Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

I was planning on installing this module, PayPal IPN_v1.2, however I no longer see it listed in the Payment Module contributions? Where has it gone? Which Paypal IPN is most stable?

 

thanks, scot

Share this post


Link to post
Share on other sites

As ever, i continue having so many problems wiht INVALID Procces:

 

- I'v oscommerce 2.2 MS with IPN PayPal Module 1.3.

 

- IPN Paypal module like:

 

"Enable PayPal IPN Module

True

 

Move tax to total amount

True

 

E-Mail Address

seller@email.me

 

Transaction Currency

Selected Currency (ever i use EUR)

 

Payment Zone

--ninguno--

 

Set Preparing Order Status

Preparing [PayPal IPN]

 

Set PayPal Acknowledged Order Status

predeterminado/a

 

Gateway Server

Testing

 

Transaction Type

Aggregate

 

Page Style

Paypal

 

Debug E-Mail Address

myown@email.me

 

Sort order of display.

0

 

Enable Encrypted Web Payments

False

 

Your Private Key

 

Your Public Certificate

 

PayPals Public Certificate

 

Your PayPal Public Certificate ID

 

Working Directory

 

OpenSSL Location

/usr/bin/openssl"

 

 

I'v a Sandbox account. I'v created into it 2 accounts (email verified and Card verified too):

 

- one for the buyer

- one for the seller (same email as the 'false email' seller@email.me in the paypal module config in my oscommerce site).

 

When i confirm and order, i can do so well the payment proccess into Paypal Sandbox. I get the order, with all taxes ok, with the currency ok, and the payment proccess was OK, and i'm returned to my site.

 

Then i get a proccess status like Preparing [PayPal IPN], and so fast another wiht:

 

"PENDING - PayPal IPN Invalid [Completed]"

 

I get too an email to Debug addres (myown@email.me) this email:

 

"Subject: PayPal IPN Invalid Process

 

"Body:

 

$_POST:

 

payment_date=02:16:46 Jun 13, 2006 PDT

txn_type=web_accept

last_name=Last Name

residence_country=ES

item_name=Own Eshop

payment_gross=

mc_currency=EUR

business=seller@email.me

payment_type=instant

verify_sign=AqBqA1nSf.CEBj1d5rbDP.LO-woKAymGMvj.jNmcySV0YdIChZNvR-wL

payer_status=verified

test_ipn=1

tax=0.00

payer_email=buyer@email.me

txn_id=5KY82957986302635

quantity=1

receiver_email=seller@email.me

first_name=Buyer

invoice=3

payer_id=JYFZ9XJGKBCXL

receiver_id=EEG8KMJKKYSKS

item_number=

payment_status=Completed

payment_fee=

mc_fee=0.86

shipping=5.00

mc_gross=15.00

custom=2

charset=windows-1252

notify_version=2.1

 

$_GET:"

 

 

Please n1 here could help me, please? I'm going Crazy cos' i can see there r too many people with this module running so well, but i cannot... and i dont know why..

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Okay, two things:

 

2. the "order alreayd paid" problem occurrs if the order number has already been submitted to PayPal by your domain - if you have a second shop on your domain or have been doing testing etc. this can cause trouble. To avoid this in the future, ensure to only run one PayPal IPN per domain and if you have been doing testing, you could change your order numbers to something higher (e.g. 10,000 or whatever) via PHPMyAdmin.

 

All the best, Terra

 

 

Thanks for the reply Terra, its just started doing that order already paid prob again, so want to go about changing the order numbers to much higher, but not exactly sure which file I would need to edit in PHPMyadmin, thanks again

Sam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×