Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

I uploaded and installed today the osCommerce PayPal IPN Module v1.0 For 2.2MS2, dated 21 May 2006, contribution. I managed to install it with OpenSSL option and Encryption on. It seems to work perfectly except that I cannot see any of the product items in PayPal. I was under the impression that this contribution display a list of all the purchased items in PayPal.

 

Is that correct? I have even seen screenshots of these on this thread. :o

 

One other thing: Looking for the contribution now on the OSC site, it just disappeared from the list. Maybe someone is updating the site. :'(

 

If anyone needs help in configuring this contribution for using OpenSSL and Encryption, I will be pleased to help!

 

I think it's been removed because it's broken. I use the osCommerce PayPal IPN Module v1.1 For 2.2MS2 yet it doesn't update my inventory, it fails to send a confirmation email to the customer about 80% of the time. It fails to update the "products sold report" and the developers refuse to answer questions and posts in this the "Official PayPal IPN Support Thread" For lack of time I have not tried any other PayPal contributions.

 

I have a feeling they are trying to push us to use another contribution without actually admitting they screwed up and wrote a "BAD" contribution or even trying to fix it. If I am wrong I challenge them to prove me wrong by fixing the thing or at the bare minimum answering people questions and concerns about it! I however know from watching this thread they don't give a shit about our questions, or problems with this contribution.

 

If I vanish from the forums members list for stating this you will know I'm right!

Share this post


Link to post
Share on other sites
I think it's been removed because it's broken. I use the osCommerce PayPal IPN Module v1.1 For 2.2MS2 yet it doesn't update my inventory, it fails to send a confirmation email to the customer about 80% of the time. It fails to update the "products sold report" and the developers refuse to answer questions and posts in this the "Official PayPal IPN Support Thread" For lack of time I have not tried any other PayPal contributions.

 

I have a feeling they are trying to push us to use another contribution without actually admitting they screwed up and wrote a "BAD" contribution or even trying to fix it. If I am wrong I challenge them to prove me wrong by fixing the thing or at the bare minimum answering people questions and concerns about it! I however know from watching this thread they don't give a shit about our questions, or problems with this contribution.

 

If I vanish from the forums members list for stating this you will know I'm right!

 

Thanks for your update! I see the contribution is back. I just did a compare between the latest version uploaded by Terra and v 1.1 and the only difference is really in the file: catalog\includes\modules\payment\paypal_ipn.php

 

The note posted by the last states:

You must set the module to send in Aggregate mode and also set 'Move tax to total amount' to True for this module to work properly.

 

I wonder if that is where the problem lies. I am going to continue testing this and if it does not work, will probably try the other PayPal IPN module in a sandbox store, and if all else fails, move back to the basic PayPal option.

 

Just one question: Do you see the ordered products in Paypal at all?

Edited by awolff

Share this post


Link to post
Share on other sites

Have done exactly as it says in the PayPal IPN setup article, I know Im using osCMax 2.0 but the PaypalIPN is the same so this is the right forum I guess.

 

http://oscdox.com/index.php?op=modload&nam...PaypalIpnOscmax

 

and it works fine when I choose to run without encrytion but when I set encryted to true in the paypal modul it wont work.

 

Error: Warning: fread(): Length parameter must be greater than 0. in /catalog/includes/modules/payment/paypal_ipn.php on line 388

 

Do any of you know what this error depends on?

 

just above the checkout button, if I insist on checking out anyway the paypal page says that it has encountered an error and that information is missing. Turn off encrytion and everything works fine again.

 

When the guy in the article testet it he didnt have encryption on so there are probably a thing or two still to say on the subject. I.e if you are to give people advice on how to configure paypal encrypted payments, be sure that you have gotten it to work yourself first.

 

But you can still follow the advice in the article for non-encrypted payments with paypal and of course skip all the make your certs instrutions since it wont work in encrypted mode anyway.

 

 

 

The funny thing is that on my test store at home on Win XP I dont get the fread() error at all but I still get the paypal error (Sandbox mode) that some information seems to be missing but what information?

 

Is there somthing wrong with the certs? I have done it by the book so... fread() tries to read a file called encrypted.txt from the opensll working directory wich is defined in the settings for the paypal IPN, I have set the rights to 777 for that directory, wich is catalog/temp b.t.w.

 

My live store is located on a linux host machine so it might be something that differs, the path to opensll? Rights or?

Edited by robfor

Share this post


Link to post
Share on other sites
Have done exactly as it says in the PayPal IPN setup article, I know Im using osCMax 2.0 but the PaypalIPN is the same so this is the right forum I guess.

 

http://oscdox.com/index.php?op=modload&nam...PaypalIpnOscmax

 

and it works fine when I choose to run without encrytion but when I set encryted to true in the paypal modul it wont work.

 

Error: Warning: fread(): Length parameter must be greater than 0. in /catalog/includes/modules/payment/paypal_ipn.php on line 388

 

Do any of you know what this error depends on?

 

just above the checkout button, if I insist on checking out anyway the paypal page says that it has encountered an error and that information is missing. Turn off encrytion and everything works fine again.

 

When the guy in the article testet it he didnt have encryption on so there are probably a thing or two still to say on the subject. I.e if you are to give people advice on how to configure paypal encrypted payments, be sure that you have gotten it to work yourself first.

 

But you can still follow the advice in the article for non-encrypted payments with paypal and of course skip all the make your certs instrutions since it wont work in encrypted mode anyway.

The funny thing is that on my test store at home on Win XP I dont get the fread() error at all but I still get the paypal error (Sandbox mode) that some information seems to be missing but what information?

 

Is there somthing wrong with the certs? I have done it by the book so... fread() tries to read a file called encrypted.txt from the opensll working directory wich is defined in the settings for the paypal IPN, I have set the rights to 777 for that directory, wich is catalog/temp b.t.w.

 

My live store is located on a linux host machine so it might be something that differs, the path to opensll? Rights or?

 

 

This is what the paypal developer forum has to say about the message 5302 missing information problem, wich is one of the 2 problems I have with encrypted mode in Paypal IPN.

 

---------------

 

get this message when using such a link with IE which truncates URLs at 2083 characters--my encrypted links are longer than this.

 

 

 

 

 

PayPal_FrankIb

 

Posts: 252

Member Since: Mar 27, 2006

 

 

Watch User

 

Re: "Message 5302" - pls. help!

Posted: 23 May 2006 13:38 PM

Rate this! 1|2|3|4|5 Reply

 

 

Hi soysauce1,

 

The 5302 error is being generated because the encrypted button code is not intact on the server. By that I mean the code for an encrypted button must be continuous from the beginning <form> tag to the ending </form> tag.

 

What has happened is either the editor or the server has formatted the button code by adding a line feed or a carriage return to some of the code.

 

This mostly happens at the end of the button code.

 

Two possible solutions, re-edit the code so that it is continuous from start to finish. Or, recreate another button, but this time make it a clear text button. The shorter lines of code will be more manageable by your editor or server.

--

Frank I.

PayPal Merchant Technical Support

https://developer.paypal.com

PayPal, an eBay Company

 

 

 

 

 

soysauce1

 

Posts: 3

Member Since: May 23, 2006

 

 

Watch User

Ignore User

"Message 5302" - pls. help!

Posted: 23 May 2006 11:53 AM

Rate this! 1|2|3|4|5 Reply

 

 

Hello,

 

we are a nonprofit theater organization trying to collect donations thru our pay pal account. Ever since i placed the paypal button, on and off we end up getting "Message 5302" and it doesnt work.

 

I regularly update the pages too as event/festival schedules change and etc. Is that something to do with that or do we have a huge problem with our account settings.

 

Any help is appreciated.

 

ash

Edited by robfor

Share this post


Link to post
Share on other sites

I do not appear to have any problems running encrypted mode. Although I have done a few $0.01 test orders using Credit Card (via PayPal) and a personal PayPal account, I am still waiting to get public orders in that use PayPal.

 

After I installed the module, I first received a string of errors just before or after the CONFIRMATION page, but then I moved my Private Key, Public Certificate and PayPal's Public Certificate into a folder under my catalog's admin folder which is is protected with htaccess. I also chmod the "Working Directory" to 0777. (that should not be in a public folder), but in the root, eg. /home/site/osctemp/.

Share this post


Link to post
Share on other sites
I do not appear to have any problems running encrypted mode. Although I have done a few $0.01 test orders using Credit Card (via PayPal) and a personal PayPal account, I am still waiting to get public orders in that use PayPal.

 

After I installed the module, I first received a string of errors just before or after the CONFIRMATION page, but then I moved my Private Key, Public Certificate and PayPal's Public Certificate into a folder under my catalog's admin folder which is is protected with htaccess. I also chmod the "Working Directory" to 0777. (that should not be in a public folder), but in the root, eg. /home/site/osctemp/.

 

According to the paypal developer forum the problem is with internet explorer that trucates strings. With other browsers like firefox, mozilla e.c.t it is supposed to work. 55% of all surfers use IE so... If you only have tested encrypted mod with a browser other than IE on Windows you should test again from a Windows computer with IE. Let me know if it works or not.

Share this post


Link to post
Share on other sites
According to the paypal developer forum the problem is with internet explorer that trucates strings. With other browsers like firefox, mozilla e.c.t it is supposed to work. 55% of all surfers use IE so... If you only have tested encrypted mod with a browser other than IE on Windows you should test again from a Windows computer with IE. Let me know if it works or not.

 

Forgot to say, I downloaded and installed Mozilla just to try but I still get the same old missing information, Message 5302 on the paypal payment page... Maybe it's not an IE issued after all, but the PayPal people seems to think so.

Edited by robfor

Share this post


Link to post
Share on other sites
Forgot to say, I downloaded and installed Mozilla just to try but I still get the same old missing information, Message 5302 on the paypal payment page... Maybe it's not an IE issued after all, but the PayPal people seems to think so.

 

Ok... The boys at osCMax have obviously don something with the PayPal IPN version 1.1 module that comes preinstalled with that package becasue after ahving tried everything to make it work in encryted mode without result I decided to install the latest official PayPal IPN 1.2 contribution from the oscommerce site and install it on my test shop. Before I did that I wrote down all my settings for the PayPal IPN module.

 

Then I removed the present PayPal IPN module from the administrators panel before installing the new one (VERY IMPORTANT!!!).

 

After that I installed the latest official contribution PayPal IPN 1.2, by unzipping the contribution in a temporary folder, clicking my way down to the catalog folder in the PayPal IPN 1.2 tree, copying from the catalog diretory in the contribution tree.

 

Tehn moving to the folder just above the catalog folder for my test shop i.e the webserver root diretory in my case and pasting the contributions catalog tree over the test shops catalog tree and answering yes when asked if I want to replace the existing. That installs the latests PayPal IPN contribution in the shop.

 

After that I went to the administrators panel again and under payment modules I chose install PayPal IPN again. Edited the settings for it with the EXACT same settings as before (I wrote it down if you remeber). Activated encrypted mode and eureka it worked instantly. So my setting and certificates was correct all the time but it was the preinstalled PayPal IPN module that comes with osCMAX that didnt work correctly i encrypted mode.

 

 

I.e the solution to make encrypted mode work for osCMax is to replace the PAyPal IPN module that comes preinstalled with that package with the latests official occommerce PayPal IPN 1.2 modul.

 

Dont know if this will solve the fread() problem I hav on my live shop to, but I will keep you posted on that!

Share this post


Link to post
Share on other sites
Ok... The boys at osCMax have obviously don something with the PayPal IPN version 1.1 module that comes preinstalled with that package becasue after ahving tried everything to make it work in encryted mode without result I decided to install the latest official PayPal IPN 1.2 contribution from the oscommerce site and install it on my test shop. Before I did that I wrote down all my settings for the PayPal IPN module.

 

Then I removed the present PayPal IPN module from the administrators panel before installing the new one (VERY IMPORTANT!!!).

 

After that I installed the latest official contribution PayPal IPN 1.2, by unzipping the contribution in a temporary folder, clicking my way down to the catalog folder in the PayPal IPN 1.2 tree, copying from the catalog diretory in the contribution tree.

 

Tehn moving to the folder just above the catalog folder for my test shop i.e the webserver root diretory in my case and pasting the contributions catalog tree over the test shops catalog tree and answering yes when asked if I want to replace the existing. That installs the latests PayPal IPN contribution in the shop.

 

After that I went to the administrators panel again and under payment modules I chose install PayPal IPN again. Edited the settings for it with the EXACT same settings as before (I wrote it down if you remeber). Activated encrypted mode and eureka it worked instantly. So my setting and certificates was correct all the time but it was the preinstalled PayPal IPN module that comes with osCMAX that didnt work correctly i encrypted mode.

I.e the solution to make encrypted mode work for osCMax is to replace the PAyPal IPN module that comes preinstalled with that package with the latests official occommerce PayPal IPN 1.2 modul.

 

Dont know if this will solve the fread() problem I hav on my live shop to, but I will keep you posted on that!

 

IMPORTANT NOTE! If you have an installation on windows you cant use c:\path\ when configuring the PayPal IPN because it will remove the backslashes after you have pressed update so it will look like c:path. You have to use unix style c:/path/ slashes instead, strange enought it works with unix style paths, even on a Windows installation. The apache webserver probably translates them to windows style paths or something...

Edited by robfor

Share this post


Link to post
Share on other sites

Hiya friends.... i'v some problems, could u help me? Let me explain:

 

I can imagine that Paypal IP Module 1.2 is working so well to all the people, but i dont understand why, in my case, isnt running ok, and i get allways Pay Pal IPN Invalid (but Completed).

 

I'v tried with EUR as alone Currency, in both sites, mine with osCommerce MS2.2 and Paypal Sandbox (seller user and customer user)

 

In my osCommerce site:

- osCommerce MS2.2

- Paypal IPN module 1.2 installed like AlexStudio posted in his Installation Guide in this forums.

- After triyng with EUR, i would try only with USD. I'v deleted currencies and i have only USD.

- In the configuration of the paypal ipn module, i'v put the Currency to Only USD (tried too with Selected

Currency)

 

In Sandbox:

- I'v a seller account, with only a balance with USD currency.

- I'v a buyer account, with only a balance with USD currency.

 

I log into Sandbox, go to my osCommerce site, i do an order, select Paypal IPN as payment mode, i can check in Sandbox payment pages the order ok, the amounts ok (in USD), i do the payment and all is ok.

 

But i ever get and PayPal IPN Invalid Process.... but completed transaction.

 

I post here the paypal ipn module configuration:

 

Enable PayPal IPN Module True

Move tax to total amount False

Mail Address [sandbox seller email address]

Transaction Currency Only USD (tried too Selected Currency]

Payment Zone None

Set Preparing Order Status Preparing [Paypal IPN]

Set PayPal Acknowledged Order Status Default

Gateway Server Testing

Transaction Type Per Item

Page Style Paypal

Debug E-Mail Address [my real email]

Sort order of display 0

Enable Encrypted Web Payments False

OpenSSL Location /usr/bin/openssl

 

 

Thnx in advance everyboy here!

Share this post


Link to post
Share on other sites
IMPORTANT NOTE! If you have an installation on windows you cant use c:\path\ when configuring the PayPal IPN because it will remove the backslashes after you have pressed update so it will look like c:path. You have to use unix style c:/path/ slashes instead, strange enought it works with unix style paths, even on a Windows installation. The apache webserver probably translates them to windows style paths or something...

 

Nope! It did not solve the error I get on the order confirmation page on my live store thats on a linux host!

 

Warning: fread(): Length parameter must be greater than 0. in ...../html/catalog/includes/modules/payment/paypal_ipn.php on line 407

Edited by robfor

Share this post


Link to post
Share on other sites
Nope! It did not solve the error I get on the order confirmation page on my live store thats on a linux host!

 

Warning: fread(): Length parameter must be greater than 0. in ...../html/catalog/includes/modules/payment/paypal_ipn.php on line 407

 

And I also get the same old Missing information error on my live store even with the 1.2 module installed. But they are probably related and must have something to do with writing permissons or something, but I have set the persmission to 777 on my working directory so... what else can you do?

Share this post


Link to post
Share on other sites

hi

i'm new here and since yesterday i'm trying to install paypal ipn 1.2 on a ms 2.2

 

nearly everything is ok, stock, order is recorded, cart is empty on shop return BUT

 

no way to change status! it worked yesterday but no more !! please help me i slept at 5am because of this bug and begin to be stress

 

here is my admin ipn paypal module configuration

 

PayPal IPN

 

Enable PayPal IPN Module

True

 

Move tax to total amount

False

 

E-Mail Address

web@fashion.fr

 

Transaction Currency

Selected Currency

 

Payment Zone

--none--

 

Set Preparing Order Status

En attente de paiement paypal

 

Set PayPal Acknowledged Order Status

En cours de traitement

 

Gateway Server

Testing

 

Transaction Type

Per Item

 

Page Style

 

 

Debug E-Mail Address

web@fashion.Fr

 

Sort order of display.

0

 

Enable Encrypted Web Payments

False

 

Your Private Key

 

 

Your Public Certificate

 

 

PayPals Public Certificate

 

 

Your PayPal Public Certificate ID

 

 

Working Directory

 

 

OpenSSL Location

/usr/bin/openssl

 

my sandbox paypal preference are reseted to default so no ipn configuration

please help me

thanks !!

Share this post


Link to post
Share on other sites
And I also get the same old Missing information error on my live store even with the 1.2 module installed. But they are probably related and must have something to do with writing permissons or something, but I have set the persmission to 777 on my working directory so... what else can you do?

 

Okej, have found out that the fread() error on the order confirmation page depended on me having spelled tha paypal public certificate name as PayPal_cert.pem when it really is paypal_cert.pem. Linux separates big/small letters as we all know...

 

Well well well, havent launched my live store to the public yet so I have only been testing the payments in paypal sandbox mode witch is suppose to work exactly like real mode. Obviously it dont because with the same certificates and the same settings (almost) encrypted mode dont work in sandbox (test mode) but in live mode so my store now works with encrypted payments in real mode but not sandbox mode, and yes I am using the correct email and certificate number in sandbox mode to so my quess is that paypal aint got it all worked out in sandbox mode. Dont know if it would have worked with the original PayPal IPN module to but probably... or maybe not and its always good to have the latests version anyway.

 

Over and out!

Edited by robfor

Share this post


Link to post
Share on other sites
I use the osCommerce PayPal IPN Module v1.1 For 2.2MS2 yet it doesn't update my inventory, it fails to send a confirmation email to the customer about 80% of the time. It fails to update the "products sold report" and the developers refuse to answer questions and posts in this the "Official PayPal IPN Support Thread"

The PayPal IPN does not solve the problem of "missing" orders - it just offers a workaround. In detail:

If a customer does not return from the PayPal site, then the following does not happen: empty basket, update bestsellers, update stock, send order confirmation email

 

BUT - unlike with the standard PayPal module, at least you have a copy of the order stored in your admin area as "Preparing PayPal IPN" and can fullfill the order.

 

Like I said - it's not a soution, just a workaround. It provides a copy of orders, but does not solve the problem.

 

To maxmise your potential of customers returning to your site:

 

a) in your PayPal account switch on Auto-Return (should link back to checkout_process.php)

 

b) in /includes/modules/payment/paypal.ipn find this code:

 

	  $parameters['notify_url'] = tep_href_link('ext/modules/payment/paypal_ipn/ipn.php', '', 'SSL', false, false);
  $parameters['return'] = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL');

 

replace with this code:

 

	  $parameters['notify_url'] = tep_href_link('ext/modules/payment/paypal_ipn/ipn.php', '', 'SSL', false, false);
  $parameters['cbt'] = CONFIRMATION_BUTTON_TEXT;	  
  $parameters['return'] = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL');

 

 

and in /includes/languages/english/modules/payment/paypal_ipn.php insert this line:

  define('CONFIRMATION_BUTTON_TEXT', 'Complete your Order Confirmation');

repeat for other languages as required.

 

this allows you to specify a text for the return button on PayPal - goes up to 60 characters. Be as scary as you can - only if customers hit that button will the order go through correctly.

 

all the best, Terra

 

NB: the above code for the button is not included in version 1.2 - found this out after I upload the contrib, probably one to include in the next update.

Edited by Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
hi

i'm new here and since yesterday i'm trying to install paypal ipn 1.2 on a ms 2.2

 

nearly everything is ok, stock, order is recorded, cart is empty on shop return BUT

 

no way to change status! it worked yesterday but no more !! please help me i slept at 5am because of this bug and begin to be stress

 

here is my admin ipn paypal module configuration

 

PayPal IPN

 

Enable PayPal IPN Module

True

 

Move tax to total amount

False

 

E-Mail Address

web@fashion.fr

 

Transaction Currency

Selected Currency

 

Payment Zone

--none--

 

Set Preparing Order Status

En attente de paiement paypal

 

Set PayPal Acknowledged Order Status

En cours de traitement

 

Gateway Server

Testing

 

Transaction Type

Per Item

 

Page Style

Debug E-Mail Address

web@fashion.Fr

 

Sort order of display.

0

 

Enable Encrypted Web Payments

False

 

Your Private Key

Your Public Certificate

PayPals Public Certificate

Your PayPal Public Certificate ID

Working Directory

OpenSSL Location

/usr/bin/openssl

 

my sandbox paypal preference are reseted to default so no ipn configuration

please help me

thanks !!

PayPal IPN works best with:

Move tax to total - TRUE

Transaction type - AGGREGATE

 

And - the order status upate with PayPal Sandbox sometimes has a considerable timelag - I've had delays of 12+hours. Drives you crazy when testing. If it's only the order status update, I'd check with a Live environment (real PayPal account - you can always refund yourself!), as this problem might be only related to Sandbox.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

<edit> Post removed - had already been answered </edit> Sorry! Terra

Edited by Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
To maxmise your potential of customers returning to your site:

 

a) in your PayPal account switch on Auto-Return (should link back to checkout_process.php)

 

Should the Auto-return be an SSL URL? ie.. https://www.mycart.com/catalog/checkout_process.php

Share this post


Link to post
Share on other sites
Should the Auto-return be an SSL URL? ie.. https://www.mycart.com/catalog/checkout_process.php

If you have SSL enabled for your site, then yes, the return URL should be https. The file pathway will depend on whether you have a Full or Shared SSL installed on your site.

 

so - if you have a full SSL, SSL is enabled in your configure.php and your site is installed within a catalog folder, then the above return URL is correct.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

Has anybody come up with a fix for this contribution... when using it with a host who insists on having register_globals turned off ?

 

 

Thanks!

 

-= Dave =-

Share this post


Link to post
Share on other sites

I have installed the the PayPal IPN Module 1.2 of 21 May 2006. What I did was copying the same file structure on to the server plus adding the "english files also to the german directories as I run the shop in the german language.

After making a Paypal payment, which so far works fine, I end up at the screen, where the buyer has to enter his email and password to get into the admin section. But no order is registered in the admin section.

 

But was not the purpose of the contribution to get the order registered in the admin part? What did I miss?

 

Thanks for your help.

 

peru

Share this post


Link to post
Share on other sites
After making a Paypal payment, which so far works fine, I end up at the screen, where the buyer has to enter his email and password to get into the admin section. But no order is registered in the admin section.

mhh not sure about what you describe above - when a customer makes a payment via PayPal and returns to your site, the customer should be on the "checkout_successful.php" page.

 

The shop /admin/ area is for the website administrator only, and customers should never be directed to the /admin/ section.

 

Furthermore, with the PayPal IPN, the order is recorded in admin as soon as a customer reaches the "checkout_confirmation.php" page. The german language should not be an issue - I run this contrib on shops with 4 languages.

 

I'm guessing that the IPN was not installed correctly, so I'd double-check that you have copied over all files (inc. the "ext" directory), and that your settings in the PayPal account (www.paypal.com) are correct. There's no reason why it should not work on a German language site, so something has gone wrong in the install. If you can post the URL of the shop might also help.

 

Please post more info on your shop set-up (PayPal IPN configuration, any mods installed?) if the IPN still refuses to work.

 

all the best, Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
The PayPal IPN does not solve the problem of "missing" orders - it just offers a workaround. In detail:

If a customer does not return from the PayPal site, then the following does not happen: empty basket, update bestsellers, update stock, send order confirmation email

 

BUT - unlike with the standard PayPal module, at least you have a copy of the order stored in your admin area as "Preparing PayPal IPN" and can fullfill the order.

 

Like I said - it's not a soution, just a workaround. It provides a copy of orders, but does not solve the problem.

 

To maxmise your potential of customers returning to your site:

 

a) in your PayPal account switch on Auto-Return (should link back to checkout_process.php)

 

B) in /includes/modules/payment/paypal.ipn find this code:

 

	  $parameters['notify_url'] = tep_href_link('ext/modules/payment/paypal_ipn/ipn.php', '', 'SSL', false, false);
  $parameters['return'] = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL');

 

replace with this code:

 

	  $parameters['notify_url'] = tep_href_link('ext/modules/payment/paypal_ipn/ipn.php', '', 'SSL', false, false);
  $parameters['cbt'] = CONFIRMATION_BUTTON_TEXT;	  
  $parameters['return'] = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL');

and in /includes/languages/english/modules/payment/paypal_ipn.php insert this line:

  define('CONFIRMATION_BUTTON_TEXT', 'Complete your Order Confirmation');

repeat for other languages as required.

 

this allows you to specify a text for the return button on PayPal - goes up to 60 characters. Be as scary as you can - only if customers hit that button will the order go through correctly.

 

all the best, Terra

 

NB: the above code for the button is not included in version 1.2 - found this out after I upload the contrib, probably one to include in the next update.

 

 

Well I made these changes and see no change in the way the module works. It still only sends the customer a confirmation email less than 20% of the time and it doesn't update the products sold list nor subtract them from the inventory so the reorder feature doesn't work either. When it does send an email to the customer the oerder number is always "ser"

Share this post


Link to post
Share on other sites

That's strange, I was under the impression the issue was solved. I will be installing paypal ipn in a few days time so maybe I can have a look and give some advice when I actually see it in motion.


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×