Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

Randy,

 

A quick question for you on the sandbox

 

Are you supposed to get an email from PayPal informing you that your a/c has been credited, in addition to PayPal sending the info back to OSCommerce?

 

Steve

Share this post


Link to post
Share on other sites

Here are my paypal IPN module config values:

 

PayPal IPN

 

Enable PayPal IPN Module

True

 

Move tax to total amount

True

 

E-Mail Address

jmail1@san.rr.com

 

Transaction Currency

Only USD

 

Payment Zone

--none--

 

Set Preparing / PayPal Pending Order Status

default

 

Set PayPal Completed Order Status

default

 

Set PayPal Denied/Refunded Order Status

default

 

Gateway Server

Testing

 

Transaction Type

Aggregate

 

Page Style

 

 

Debug E-Mail Address

sukotto@san.rr.com

 

Sort order of display.

1

 

Enable Encrypted Web Payments

True

 

Your Private Key

/home/sukottoi/public_html/tmp/my-prvkey.pem

 

Your Public Certificate

/home/sukottoi/public_html/tmp/my-pubcert.pem

 

PayPals Public Certificate

/home/sukottoi/public_html/tmp/paypal_cert.pem

 

Your PayPal Public Certificate ID

EE8EUZ5DLNHRU

 

Working Directory

/home/sukottoi/public_html/tmp

 

OpenSSL Location

/usr/bin/openssl

 

 

 

Also, I did some additional testing/experimenting. The working directory that I created has been given 777 permissions. (I did this in accordance to some toher threads about "fopen" errors). It still gives me the "page not displayed" error. when I go through the same test sale process on a nother machine running Firefox browser, at the same point, when i select payment method, and then click continue, the page doesn't refresh. It's as if it's just stuck there, and there's no next page to load.

 

also, when I changed permissions to 755, or some other permissions code, when I click continue, it loads the order confirmation page, but it also gives me a whole list of "fopen" errors, and invalid strings could not be retrieved... stuff like that. That type of isse, it seems to be experienced by many other people here on the forums, but each time a question like this is posted, no one replies. sometimes, there are replies to suggest changing the permissions to 777, but the original poster responds back that it has not solved teh issue. I've read through many posts with the "fopen" symptoms and 777 permissions, but no one seems to respond to those questions (or that honestly, not a single person knows)

 

I stumbled across another thread HERE that suggested changing some parameters. Just for kicks and giggles, I did so. Not only did my web store not load properly at all, none of the links worked, and there were maybe 20 or so popups that kept saying "certificate not recognized, do i want to continue?", etc. Being that this avenue of research did not work for me, I changed it back (with a backup copy), and the page loads properly.

 

I made a test sale again, just to check everything, and... OMG!, it worked! I was looking at my fake paypal account in sandbox! I checked my IPN module settings, and encryption was set to "TRUE"!. On my next test sale, it FAILED, bringing me back to square one again.

 

Sadly, I was unable to replicate the situation again. I even closed all my browsers to open new fresh ones, and made the same changes, tested, changed back to originals, tested again (all the same steps I took above), and have not replicated the one success I had above.

 

I am a complete noob to programming, to be sure, but it seems to me that somehow it has to do with shared SSL and my public private keys that I created. It's not compatible somehow, or something.

 

I know that someone out there has to have had this problem and overcome it, can anyone offer help?

 

Scott

Share this post


Link to post
Share on other sites

sukotto,

 

Are you using the latest OSCommerce 1.2.1 version? Have you tried it with the SSL off?

 

You have default for all the values, what is the default?

 

steve

Share this post


Link to post
Share on other sites

About the sandbox, you get an email, but it's a sandbox email. Paypal doesn't actually send it out. You can read it if you log into developer.paypal.com with your developer email and password (these are real, not fake). Then it lists all your sandbox accounts and you can click on them to read "their emails" which is kept locally on paypal servers.

Share this post


Link to post
Share on other sites
About the sandbox, you get an email, but it's a sandbox email. Paypal doesn't actually send it out. You can read it if you log into developer.paypal.com with your developer email and password (these are real, not fake). Then it lists all your sandbox accounts and you can click on them to read "their emails" which is kept locally on paypal servers.

So obvious...Of Course, sometimes......Thank You....

 

Steve

Share this post


Link to post
Share on other sites

Yes, I am using 1.2.1. No, I haven't tried it with SSL off. By that, do you mean to edit the configure files to say SSL = False?

 

 

I left everything as the "default", exept for the requisite email and file locations. The reason is that I did not see a need to change it yet, and let os commerce and IPN do it's thing, instead of overriding it by selecting a pending or shipped option. After I get everything working, I would then consider changing the values to what I need.

 

Scott

 

sukotto,

 

Are you using the latest OSCommerce 1.2.1 version? Have you tried it with the SSL off?

 

You have default for all the values, what is the default?

 

steve

Share this post


Link to post
Share on other sites

Since few days, I tried to install the contribution PayPal IPN Module v1.0 For 2.2MS2.

 

I bought a SSL certificate and installed it on my website. Don't know where the location of my public certificate (*.pem) to use for signing the date and the loation of my Private key (*.pem). Ask my company where my website is and they give me the location for the two files but it's not files with .pem extension but .key and .crt .

 

What I have to do ? I'm so confused ...

Share this post


Link to post
Share on other sites
Since few days, I tried to install the contribution PayPal IPN Module v1.0 For 2.2MS2.

 

I bought a SSL certificate and installed it on my website. Don't know where the location of my public certificate (*.pem) to use for signing the date and the loation of my Private key (*.pem). Ask my company where my website is and they give me the location for the two files but it's not files with .pem extension but .key and .crt .

 

What I have to do ? I'm so confused ...

 

I'm pretty sure the certificates you use for your site's SSL have nothing to do with the Paypal IPN module. You have to follow the paypal IPN procedures for creating an SSL key for use with paypal.

 

The documentation is available at developer.paypal.com. I think they have a document about Instant Payment Notifications and that will tell you what commands to use on your webserver to generate a key with openSSL, extract the text portion of it, upload to paypal, then get Paypal's CertId number.

 

The CertId num is necessary for you to plug into Paypal-IPN's config settings in your Admin Control Panel.

Share this post


Link to post
Share on other sites
I'm pretty sure the certificates you use for your site's SSL have nothing to do with the Paypal IPN module. You have to follow the paypal IPN procedures for creating an SSL key for use with paypal.

 

The documentation is available at developer.paypal.com. I think they have a document about Instant Payment Notifications and that will tell you what commands to use on your webserver to generate a key with openSSL, extract the text portion of it, upload to paypal, then get Paypal's CertId number.

 

The CertId num is necessary for you to plug into Paypal-IPN's config settings in your Admin Control Panel.

 

 

Thanks for your reply. I have downloaded the document and I will read very carfully what I have to do.

Share this post


Link to post
Share on other sites

Hi, Does anybody know how to help with this problem?

I have installed the OSC Paypal IPN V1.1. Works ok but for 1 problem. It doesn't sent the shipping to the paypal payment. I did a test and payed via another paypal account but the shipping is still not added.

 

I have tried to look on the forums for the solution but to no avail...

 

Can any one help???

Share this post


Link to post
Share on other sites
Hi, Does anybody know how to help with this problem?

I have installed the OSC Paypal IPN V1.1. Works ok but for 1 problem. It doesn't sent the shipping to the paypal payment.  I did a test and payed via another paypal account but the shipping is still not added.

 

I have tried to look on the forums for the solution but to no avail...

 

Can any one help???

 

There is no solution. I tried to get the answer from the people in the know on the support thread, but I was mostly ignored. There is some sort of reason for not passing the shipping info, but I can't figure out what it is. I think it's pretty stupid, though I guess they probably know something I don't.

 

The only partial solution is to set the transaction type or something. I remember I changed it from a 0 to a 1 (or vice versa), which meant that it was no longer defaulting to "goods that do not require shipping." In that case, when they go to paypal, they have to supply a shipping address there, and usually they can just pick the one that's already set up on their paypal account.

 

If you pass that parameter paypal will force a shipping address, which is good, but not the best solution.

Share this post


Link to post
Share on other sites
There is no solution. I tried to get the answer from the people in the know on the support thread, but I was mostly ignored. There is some sort of reason for not passing the shipping info, but I can't figure out what it is. I think it's pretty stupid, though I guess they probably know something I don't.

 

The only partial solution is to set the transaction type or something. I remember I changed it from a 0 to a 1 (or vice versa), which meant that it was no longer defaulting to "goods that do not require shipping." In that case, when they go to paypal, they have to supply a shipping address there, and usually they can just pick the one that's already set up on their paypal account.

 

If you pass that parameter paypal will force a shipping address, which is good, but not the best solution.

 

Thanks for the reply..

 

Yes i noticed that the answers were a bit short coming, when i did a search.

 

Its the actual shipping cost that is not being placed in the paypal payment page. the OSC end is working fine, but when you go to pay it just leaves out the shipping charge. The customers address and item charge is ok.

 

If there is no solution is there an alternative PayPal ipn that i could use?

Share this post


Link to post
Share on other sites

just installed paypal ipn (contrib august 6th)! haven't a clue at the moment but i am working my way thru.

 

can someone tell me if i need to have ssl on my site for this to work?

 

my host does not support ssl!

 

what about the keys and certificates, without ssl i take it i can't create these.

 

please help

Share this post


Link to post
Share on other sites

damaclass: oh, shipping COST. No clue about that one... is Paypal trying to calculate shipping on its own? Check your Paypal profile.

 

blagger: you do not need ssl. In fact you should test to see that it works before you even try the ssl bit.

 

Also, at least from the way I did it (and I may be wrong), you do not need an SSL certificate in the sense of paying for one from a trusted authority and so forth. The paypal IPN system uses self-issued certs -- there are instructions somewhere on developer.paypal.com. A big PDF with the whole IPN system documentation in it -- somewhere in there are instructions on how to precisely generate a keypair for your site, how to get the public cert out of it, and how to upload it to paypal. Then paypal will issue you a Certificate ID, and you have to plug that in to your Paypal IPN module. Then everything should work -- but you should first do all this WITHOUT ssl, and only try ssl once things are working.

 

One hint is, you have to make a sandbox account first (or at least should) for testing. But when you SWITCH to live, you have to go through the whole thing of uploading the cert again -- you don't need a new one, just send the pub cert to the live paypal site (in your actual paypal account profile, not the sandbox account profile). There it will issue you a new unique Certificate ID, which you'll need to plug into Paypal IPN. Also you will obviously need to tell IPN you switched from the testing server to the live one.

 

Hope that helps. I'm no expert, I just muddled through it on my own one day for about 14 hours.

Share this post


Link to post
Share on other sites

Help needed,

 

I have purchase without account installed and have tried with it enabled and dissabled.

 

I have installed this IPN module, I am in "test" mode, when I add items to a cart and select the IPN the order shows up in ADMIN ORDERS, then I proceed to check out and complete check out the order disappears from ADMIN.

 

I have switched from test to run mode and tried as well, the order is actually processed by paypal and payment delivered, I recieve the email invoice, but the order still dissapears from ADMIN ORDERS.

 

I never recieve any debug emails and have set my address in the IPN module settings?

 

Any ideas why the orders will not stick in ADMIN?

Share this post


Link to post
Share on other sites
Help needed,

 

I have purchase without account installed and have tried with it enabled and dissabled.

 

I have installed this IPN module, I am in "test" mode, when I add items to a cart and select the IPN the order shows up in ADMIN ORDERS, then I proceed to check out and complete check out the order disappears from ADMIN.

 

I have switched from test to run mode and tried as well, the order is actually processed by paypal and payment delivered, I recieve the email invoice, but the order still dissapears from ADMIN ORDERS.

 

I don't recieve any debug emails and I have set my email address in the IPN module settings?

 

Any ideas why the orders will not stick in ADMIN?

 

I have more details to add:

 

I have not changed anything on the PayPal end such as configuring any IPN from PayPal profile, the instructions from this contribution did not indicate if I need to change anything with in PayPal: Do I need to enter a return address in the IPN configuration of PayPals website?

 

Here is a quote from PayPal help about IPN, does this apply to me? if so where do I point the IPN at my site?

 

How It Works

 

When a customer makes a payment to you or a payment is reversed or refunded, PayPal will post a notification to your server at the URL you specified. Included in this notification will be all of your customer?s payment information (e.g. customer name, payment amount) as well as a piece of encrypted code. When your server receives a notification, it will then post the information, including the encrypted code, back to a secure PayPal URL. PayPal will authenticate the transaction and send confirmation of its validity back to your server.

 

Note: To activate Instant Payment Notification, you will need to enter the URL at which you would like to receive the notification posts from your Profile.

 

After you have activated Instant Payment Notification, your server will be sent a notification every time you receive a payment, this notification will be sent as a hidden "FORM POST" to the URL you specified, and will include all of the payment information. The FORM variables for the notification can be found in the Instant Payment Notification (IPN) Manual.

 

Each time you receive an IPN from PayPal, you must complete the Notification Validation process described below before fulfilling the order. Verifying the information listed will ensure that the transaction is legitimate.

 

 

Please help me understand why my orders are clearing out of ADMIN ORDERS once a paypal transaction is completed.

Share this post


Link to post
Share on other sites
I have more details to add:

 

I have not changed anything on the PayPal end such as configuring any IPN from PayPal profile, the instructions from this contribution did not indicate if I need to change anything with in PayPal: Do I need to enter a return address in the IPN configuration of PayPals website?

 

Here is a quote from PayPal help about IPN, does this apply to me? if so where do I point the IPN at my site?

Please help me understand why my orders are clearing out of ADMIN ORDERS once a paypal transaction is completed.

In PayPal you must specify the return page (checkout_success) and enable it.

 

Steve

Share this post


Link to post
Share on other sites
I have more details to add:

 

I have not changed anything on the PayPal end such as configuring any IPN from PayPal profile, the instructions from this contribution did not indicate if I need to change anything with in PayPal: Do I need to enter a return address in the IPN configuration of PayPals website?

 

Here is a quote from PayPal help about IPN, does this apply to me? if so where do I point the IPN at my site?

Please help me understand why my orders are clearing out of ADMIN ORDERS once a paypal transaction is completed.

 

 

Okay folks.....

 

I started out trying to install paypal_ipn_1.2.1_0.zip and this is when I was loosing my orders from the admin panel.

 

I uninstalled this version and went back to the very first entry. V1 did work for me so I began adding the attributes one at a time:

 

1)Error correction by Gerard Schellekens on 20 Dec 2004 made no sense to me, I have no idea what this is and skipped it.

 

As in so many other contributions (first let me say how much I appreciate these contributions!) I find that the author is so intamate with the work they forget to mention the detials such as if their addition is a full package or just attributes to the original.

 

I stopped at V1.1 and things seem to be working well. V1.2 seems to be a major revision without the "EXT" folder with in CATALOG. I have no idea if I am supposed to completely erase V1.1 or just add V1.2 to it?

 

Any anvice?

Share this post


Link to post
Share on other sites
In PayPal you must specify the return page (checkout_success) and enable it.

 

Steve

 

No you mustn't. At least you don't tell paypal what URL to return to, because the URL is passed in the server-server communication between the IPN module and Paypal itself.

Share this post


Link to post
Share on other sites
No you mustn't. At least you don't tell paypal what URL to return to, because the URL is passed in the server-server communication between the IPN module and Paypal itself.

 

Sorry...I did and it works fine, I filed out all the fields in the PayPal site!!

 

I thought you had to

 

1.2.1 worked great for me. Straight away in both the Sandbox and then again on the Live Server

 

Ah well learn a little more each day!!

 

Apologies for incorrect info

 

Steve

Share this post


Link to post
Share on other sites

Hi all

 

Well I've finally sorted out the age old Paypal IPN email problem with customers not returning to the site and the final section of the ordering process not taking place.

 

I have based this on Paypal IPN v1.1, and before I release the addon to the contribution section, I need some others to test it out. Preferably those with secure connections to Paypal.

 

I have tested this with an unsecure connection and it works fine. Even if a customer doesn't hit that pesky final return to the site button, they and you will get a confirmation email of the order.

 

The method that I have chosen I believe does not have a race condition associated with it, and should solve this problem.

 

Also the good news is that it is like the Paypal IPN mod completely stand alone from the core files.

 

Please send me an email of your interest to test this, because I would like to put this into the contributions.

 

In a nutshell the idea is that on the confirmation button being pushed by the customer, instead of the user being directed to Paypal, they get sent to a new page which then sends the emails etc, then they automatically get sent over to Paypal.

 

Of course the Paypal IPN process area has the emails turned off so that 2 emails aren't sent. Simple eh. But it did take some thinking.

 

 

 

Thanks

Aaron

Edited by Johnson

Aaron Dwyer

Share this post


Link to post
Share on other sites

Hi,

 

I have the IPN 1.0 installed on MS2 and it mostly works well enough for me, although on some posts I get multiple notifications from Paypal which set the order status to "processing" (my selected value). I believe that the problem is probably my firewall which may not be allowing Oscommerce IPn module to respond to paypal and confirm receipt. I am wondering which file actually responds - Is it the ipn.php in ext? And I am also wondering what protocol / port I would require to open?

 

If anyone has any ideas/info then I'd gladly hear them. (Its an Apache / Linux server).

 

Cheers

 

 

Andy


with ten thousand dollars we'll all be millionaires

Share this post


Link to post
Share on other sites

Hey everyone,

 

This contribution looks like it will solve a problem I am currently having:

(I sent this question to Paypal)

Twice, I have received payment from orders that do not appear on my shopping cart (using OS Commerce).

Usually, I see the order placed with the amount of shipping etc.

However, I have gotten 2 customers that I receive payment for (showing

product and shipping payments)

Could it be linked to wether they choose the direct credit card option?

 

 

Paypal answered and said that this would be solved using IPN.

however, from what I understand here, I just need to add the contribution.

 

Is this correct, or do I have to modify anythign in my paypal profile?

 

Thank you!

Share this post


Link to post
Share on other sites

Regarding the Paypal IPN module rounding problems, documented here:

 

http://forums.oscommerce.com/index.php?sho...&hl=ipn&st=500#

 

I would like to fix this myself. I simply don't know where in the code to look, because I assumed the prices were being grabbed from the order total module.

 

All I want to do is a very simple fix, something with the pseudocode like this:

 

if order.total < order.subtotal + order.shipping

then order.total = order.total + 0.01

 

That's all I want to do. Bump the total up by one cent when the rounding issue causes the errors. May not be elegant but it'll work. Can someone tell me which php file to look at to perform this?

 

To recap for those who didn't read my longer bug report, basically if you choose an alternate currency, somewhere in osCommerce there is a rounding error so that the order total is one cent less than the subtotal plus shipping/handling charges. This causes problems because when Paypal sends the IPN, the ipn module gets confused because the amount is for one cent more than the (erroneous) osC total. When this happens, the order status is not automatically updated and the Paypal IPN log info (in the order comments) disappears, causing a duplicate entry and an order that will need a manual status update.

 

Would appreciate someone telling me "look in this file, look for this variable" or something like that.

Share this post


Link to post
Share on other sites

Hello Gurus,

 

I have searched and searched and read and read but to no avial.

 

Everytime I send a transaction through either using sandbox or live with a .01 product I get

 

PayPal IPN Invalid [Completed] on my orders and I get a debug email with the same message.

 

I get the funds in my account and the customer gets a receipt

 

I did find some posts that said that this was just because I am Using the sandbox or I am using an unverifed paypal account to buy.

 

Can someone verfiy this the case or tell me how to fix the problem.

 

I am about ready to go live and I want to make sure this works properly for both my protection and my customers

Please save my sanity!!

 

Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×