Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

OK-

 

Just installed IPN on a CLEAN MS2.2 and I'm getting some funky stuff happening. Cart will not clear. Nothing gets returned from PayPal. Basically useless :( I'm very interested in this module and would like to know what's causing this as I read someone else a couple of pages back had the exact same thing. I've been using the sandbox to test and I have my own SSL certificate. Would wrong cookie settings cause this problem? I have force cookie use set to 'on'.

 

Anyone?

 

Thanks for the module... I really do like the interface, especially in admin :)

 

Paul.

Share this post


Link to post
Share on other sites
Hello all! I am testing this contribution at the moment and I must thank those that have put in their hardwork into it. Great contribution. If at all, the contributors wish to add PayPal graphics to this contribution (eg. the page where the customers are made to select payment method), I think the following image is a great example.

horizontal_solution_PP.gif

Since it is part of the merchant tool and ready for us to use, why not? It can be found at PayPal - Online Logo Center. Other logos are available there too.

 

If I am not wrong, this Online Logo Center is a new thing for merchants (I wasn't able to find it until recently). Do visit it for more information on the Usage Guidelines and agreements. Just my humble opinion.

 

Thank You

I can't figure out how to get this logo to show up on my site. Please explain. Anyone.

Thank you

Edward


I have moved on from oscommerce to magento and no longer monitoring this site.

Share this post


Link to post
Share on other sites
I can't figure out how to get this logo to show up on my site. Please explain. Anyone.

Thank you

Edward

Nevermind

I gots it.

Weren't nuthin


I have moved on from oscommerce to magento and no longer monitoring this site.

Share this post


Link to post
Share on other sites

I've read through this entire thread and can't find any mention of my problem.

 

I installed this module a month ago because my merchandise person was reporting the lost orders problem this was designed to fix. She hasn't reported anything like that happening, but now we've got a new problem.

 

Here is how she describes it:

 

"We seem to be having a problem with folks using Paypal and I'm not sure what it is as it doesn't happen every time but does happen quite often.

 

Someone will place an order and pay through Paypal or at least the order says so.

Some of them will use a debit card and that number may or may not be on the order but in the little box above the comment box, there is no info.

 

It just says No Order History Available.

 

So they think they paid by Paypal but a payment never hits our Paypal account."

 

And after some questioning, here is more info:

 

"Yes, they were intending to place an order.

 

Some must realize they don't go through because they immediately place another order with the card itself and I get both orders, but some don't know."

 

Does this sound familiar to anyone?

Share this post


Link to post
Share on other sites

Good Evening, I need to seek a higher power.

 

I installed the paypal IPN module last night, version 1.1

 

I have a sandbox account. I have one problem and a few questions.

 

Problem: After I complete the paypal order, I click the "Click to Finalize Order" button which is supposed to return me to the website. The link it is trying to return me to is https://www.mydomain.com/checkout_process.php

 

However, when it returns, that page is blank. How can I fix this? (same kind of blank page when you have some php error). This page does work for other modules. Also, no email from paypal is received. Any help here is appreciated.

 

On to the questions:

 

There seem to be 2 areas of paypal that need to be set. One is the "Instant Payment Notification Preferences" where you turn IPN on or off and specify it's url. The other are is "Website Payment Preferences" where you choose autoreturn on/off, autoreturn url, payment data transfer on/off, encryption, and optional account on/off.

 

What are the settings. I have tried a variety. Currently, I have the IPN turned on and left the address blank. This seems to be working ok as my status changes from "Preparing [PayPal IPN]" to "pending".

 

I have the preferences set to autoreturn-off, no url, payment data transfer to off. The reason I have left these off is because the return address seems to be set by the module no matter what I put in here.

 

If you could help me with the return page error specified above, it would be most appreciated. Also, if it helps, the following modules are installed.

 

qtpro 4.2

authorize.net 1.7b

 

thanks.

Edited by tommy11011

Share this post


Link to post
Share on other sites

I've programmed a bit of php and this code is totally uncommented and the ipn thread is dead. Who knows what is going on in that code for the ipn?

If there is no comments to this then I wonder. I'm really trying but do find this code hard to decipher.

Any help with IPN?

I have a question about the IPN docs.

Edited by Johnson

Share this post


Link to post
Share on other sites

Which IPN module? - there are several, including a new one released by the osCommerce Team. You should post questions to the relevant *support* thread.

 

Matti


Matti Ressler

 

We were all once expert at...... nothing

_____

Share this post


Link to post
Share on other sites
Okay, this is what I had to do to get it working. First I had to get my public certificate from the SSL I am running (at the moment I still use a self-signed one but I guess it won't be different when I have decided which official SSL certificate I can best buy and install).

If you are lucky you can get it the easy way. Through my Plesk admin I could just download the .pem file I needed for the Paypal IPN. It was called mydomain.pem and should be used for the entry 'Your Public Certificate' inside the Paypal IPN module. In case you can not do this you will probably need the openSSL part but I can't tell how that works.

 

Then I went to the Paypal Sandbox to look for the other two files I needed. After a little while I found you have to login into your sandbox account and go to the section 'Profile' from which you choose 'Encrypted Payment Settings'. Looking there you will find the option to download the PayPal Public Certificate (paypal_cert_pem.txt) and underneath that you find 'Your Public Certificates' where you choose add and upload the mydomain.pem you got from your own website SSL. Upon return you will find your Cert ID which you use for 'Your PayPal Public Certificate ID' within the Paypal IPN module. Also you can now download a file called 'cert_key_pem.txt'.

This 'cert_key_pem.txt' you use within the Paypal IPN module for the entry 'Your Private Key' and the 'paypal_cert_pem.txt' for the entry 'PayPals Public Certificate'.

 

In short:

From Paypal you have to get 2 files called 'paypal_cert_pem.txt' and 'cert_key_pem.txt' which you use within the osc Paypal IPN module for the above mentioned entries. The Paypal generated Cert.ID goes into 'Your PayPal Public Certificate ID'.

The one file needed from your own server goes into 'Your Public Certificate'.

 

Those three files you upload onto your server to a place at your discretion (I think) and within the Paypal IPN module you direct to them through an absolute path (at least that was what I had to do to get it working). IE. /home/httpdoc/vhosts/mydomain/httpdocs/my directory/cert_key_pem.txt

Similar for the rest. I had to change the working directory to an absolute path also to get rid of the errors I got at first. No need to change the name of the .txt files to .pem !

The entry for openSSL directory I left as it was because I didn't need it obviously and it didn't generate any errors leaving it as it was.

 

I did some test orders and all went fine with these settings.

You probably know most of what I wrote but I thought it could be handy for other people looking for information on this.

 

One thing I noticed after doing a test order is that on the Paypal side you can enter a different shipping address which however does not get returned to the shop. Looking at the transaction details on Paypal there is no address information at all so it could be tricky if the customer doesn't give a different shipping address from within the shop but only from the Paypal payment screen ?!

 

 

Thank you Howard! Thank you.

 

Everything you wrote was absolutely correct and worked for me! I have been running around trying to generate my own private/public keys with openssl via xampp with so much trouble.....

 

Thank you (my SSL issuer gave me the public certifcate in PEM format - and told me to get my private key from webhost [who refused to give it to me] -- all this because I thought it was the way to do it from reading the manual from paypal about encrypted web payments)

 

Thanks again.

Share this post


Link to post
Share on other sites
Good Evening, I need to seek a higher power.

 

I installed the paypal IPN module last night, version 1.1

 

I have a sandbox account.  I have one problem and a few questions.

 

Problem: After I complete the paypal order, I click the "Click to Finalize Order" button which is supposed to return me to the website.  The link it is trying to return me to is https://www.mydomain.com/checkout_process.php

 

However, when it returns, that page is blank.  How can I fix this?  (same kind of blank page when you have some php error).  This page does work for other modules.  Also, no email from paypal is received.  Any help here is appreciated.

 

On to the questions:

 

There seem to be 2 areas of paypal that need to be set.  One is the "Instant Payment Notification Preferences" where you turn IPN on or off and specify it's url.  The other are is "Website Payment Preferences" where you choose autoreturn on/off, autoreturn url, payment data transfer on/off, encryption, and optional account on/off.

 

What are the settings.  I have tried a variety.  Currently, I have the IPN turned on and left the address blank.  This seems to be working ok as my status changes from "Preparing [PayPal IPN]" to "pending".

 

I have the preferences set to autoreturn-off, no url, payment data transfer to off.  The reason I have left these off is because the return address seems to be set by the module no matter what I put in here.

 

If you could help me with the return page error specified above, it would be most appreciated.  Also, if it helps, the following modules are installed.

 

qtpro 4.2

authorize.net 1.7b

 

thanks.

 

Well, I think I fixed the problem of the page not returning to checkout_process.php. Looks like anyone using authorize.net 1.7b will need this fix. Fixing it also fixed the problem of emails not being sent out. After reviewing this lengthy thread, I stumbled across the fix. All credit goes to it's author devosc (Gregory Baboolal).

 

In includes/modules/payment/paypal_ipn.php,

 

find

-----

include(DIR_WS_CLASSES . 'order_total.php');

$order_total_modules = new order_total;

$order_totals = $order_total_modules->process();

 

change to this

----------------

if(!class_exists('order_total')) {

include_once(DIR_WS_CLASSES . 'order_total.php');

$order_total_modules = new order_total;

$order_totals = $order_total_modules->process();

}

 

Has anyone else used this fix? If so, can you verify that authorize.net is not affected?

 

I will be happy to submit this to the contribution but I would like to hear back from the community first on this thread.

Share this post


Link to post
Share on other sites

I had just found the ipn support thread under osCommerce Contributions > Contribution Support and would have moved it before your reply if there was an edit or delete button - sorry. Is there an option I'm missing? Deleting this thread is okay with me.

 

Thanks- it is osCommerce-PayPal_IPN-v1.1

My goal is to clear the users cart for inventory control once the pay button is hit at paypal. My impression is they can close the paypal window without hitting continue.

So far they would need to and they also get a security warning when hitting the continue button.

 

Which IPN module? - there are several, including a new one released by the osCommerce Team.  You should post questions to the relevant *support* thread.

 

Matti

Edited by slofly

Share this post


Link to post
Share on other sites

After several weeks I now have my personal certificate installed on my site via my provider. I asked him for the certificate so that I can install it into the Paypal IPN module.

 

They have emailed it to me but without the key. Am I right in thinking there should be a key?

 

I inserted it into the Paypal IPN module but Paypal complain that my email address is not present in the BLOG!

 

I thought I was at the end of a long journey, but I guess I am just beginning!

 

I have turned off encryption in the module and it woks fine. However, I am sure I read the rules and Paylpal require encrytion, so I need to get it all working.

This is what i have in my paypal IPN please help -

 

Your Private Key

The location of your Private Key to use for signing the data. (*.pem)

* ???

 

Your Public Certificate

The location of your Public Certificate to use for signing the data. (*.pem)

* LOCATION OF MY NEW CERTIFICATE

 

PayPals Public Certificate

The location of the PayPal Public Certificate for encrypting the data.

* DOWNLOADED FROM PAYPAL

 

Your PayPal Public Certificate ID

The Certificate ID to use from your PayPal Encrypted Payment Settings Profile.

* DOWNLOADED FROM PAYPAL

 

Working Directory

The working directory to use for temporary files. (trailing slash needed)

Share this post


Link to post
Share on other sites

21 pages!! My problem hasn't really been answered though, even if the problem has been raised.

 

The module is working fine, except that no emails to customer and shopkeeper from osC, and no stock updates. I have to update the stock quantities manually, which means that it is possible that another customer can purchase the same product, even if it should be out of stock due to the first purchase. Order status update from ipn is working okay though.

 

I don't know what the reason is, whether it's because my customers aren't returning to my site, or the fact that I'm sending a total instead of itemised details to PayPal.

 

The solution is probably to create a dedicated checkout_success page for this, and transfer the email and stock transfer parts to the ipn script, with an evaluation for the PayPal status "Verified" - has anyone done this successfully?

 

Any other suggestions?

 

John

Share this post


Link to post
Share on other sites
21 pages!!  My problem hasn't really been answered though, even if the problem has been raised.

 

The module is working fine, except that no emails to customer and shopkeeper from osC, and no stock updates.  I have to update the stock quantities manually, which means that it is possible that another customer can purchase the same product, even if it should be out of stock due to the first purchase.  Order status update from ipn is working okay though.

 

I don't know what the reason is, whether it's because my customers aren't returning to my site, or the fact that I'm sending a total instead of itemised details to PayPal.

 

The solution is probably to create a dedicated checkout_success page for this, and transfer the email and stock transfer parts to the ipn script, with an evaluation for the PayPal status "Verified" - has anyone done this successfully?

 

Any other suggestions?

 

John

 

Is IPN turned on in your paypal settings?

Share this post


Link to post
Share on other sites

Hello,

 

My issue with the OsCommerce PayPal IPN so far is that my online store is bilingual (English and French), but that whenver a customer is ready to checkout and pay, the PayPal page is only showing in English.

 

Is there a way for the PayPal page to show in the customer's default language ? Or a way to manually go around this issue ?

 

Thank you ;)

Share this post


Link to post
Share on other sites
Is IPN turned on in your paypal settings?

 

No.

 

There have been numerous posts informing me that it shouldn't be turned on, because that's taken care of from my end. Besides, I'm not having any problems with the ipn part - I'm receiving the verifications from PayPal okay, and the order status is updated. Just that there are no osC generated emails and stock updates.

 

Cheers

John

Share this post


Link to post
Share on other sites

Further testing has proven that it is the customer not clicking that last button to return to my site. If they click that, all's okay, but it seems that despite two clear, friendly instructions (one in red lettering on the last page before going to PayPal, and one rewording of the last button on the PayPal site), they are not taking that last step.

 

21 pages!!  My problem hasn't really been answered though, even if the problem has been raised.

 

The module is working fine, except that no emails to customer and shopkeeper from osC, and no stock updates.  I have to update the stock quantities manually, which means that it is possible that another customer can purchase the same product, even if it should be out of stock due to the first purchase.  Order status update from ipn is working okay though.

 

I don't know what the reason is, whether it's because my customers aren't returning to my site, or the fact that I'm sending a total instead of itemised details to PayPal.

 

The solution is probably to create a dedicated checkout_success page for this, and transfer the email and stock transfer parts to the ipn script, with an evaluation for the PayPal status "Verified" - has anyone done this successfully?

 

Any other suggestions?

 

John

Share this post


Link to post
Share on other sites
Further testing has proven that it is the customer not clicking that last button to return to my site.? If they click that, all's okay, but it seems that despite two clear, friendly instructions (one in red lettering on the last page before going to PayPal, and one rewording of the last button on the PayPal site), they are not taking that last step.

 

Well, for me, after I make a paypal payment, if I don't click the paypal button to return me to the store, I don't get the email. However, my order status is updated, that is the purpose of IPN.

 

The fact the email is not being sent out must be a bug of some sort that relies the checkout_success page instead of the IPN.

 

One other bug I notice on mine, with the paypal ipn, I don't have the check box on my checkout success page that says "Please notify me of updates to the products I have selected below:"

 

The text is there, but not the box. The box is there for all other payment options.

 

Maybe Ponce can have a look and fix it.

 

PS - one other thing that screwed me up for a few hours, if you are still in developement, make sure the site is not password protected while testing paypal!! The ipn will never make it through.

Edited by tommy11011

Share this post


Link to post
Share on other sites

I am having a very weird problem with Paypal IPN 1.1 that I haven't been able to find a solution to and i'm hoping someone out there can help me.

 

I install the mod just fine and it works pefectly with the exception of the whole not showing tax bit that others have had problems with. So I install PandA.nl 's mod to the file and follow his instructions to uninstall (remove) Paypal IPN in admin and then upload the changed file and then try to install paypal IPN with the modded tax changes. The only problem is when I click the install button in the admin section all it seems to do is refresh the screen and doesn't display the fields for me to edit. All it does is show the install button again. I've tried checking about everything I can think of to try and see what the problem is but now I'm clueless. I would like to get this working because charging tax is a must! Thanks for any insight!!

 

Aaron

Share this post


Link to post
Share on other sites

It could be a missing apostrophy. I suggest reverting to the old version to prove that the problem is with that file, and if that works, go through the changes you made with a fine-toothed comb.

 

John

 

I am having a very weird problem with Paypal IPN 1.1 that I haven't been able to find a solution to and i'm hoping someone out there can help me.

 

I install the mod just fine and it works pefectly with the exception of the whole not showing tax bit that others have had problems with.  So I install PandA.nl 's mod to the file and follow his instructions to uninstall (remove) Paypal IPN in admin and then upload the changed file and then try to install paypal IPN with the modded tax changes.  The only problem is when I click the install button in the admin section all it seems to do is refresh the screen and doesn't display the fields for me to edit.  All it does is show the install button again.  I've tried checking about everything I can think of to try and see what the problem is but now I'm clueless.  I would like to get this working because charging tax is a must!  Thanks for any insight!!

 

Aaron

Share this post


Link to post
Share on other sites

Rudizoon,

 

I am having that problem.

What I did was installed a fresh osc then put on the contribution 3.15 ipn

They are scattered around and each have updates apparently.

 

When IPN is working they do not need to click continue at paypal (after they click pay) and their cart and invetory gets subtracted!!!

 

I'm not sure which IPN is the 'new one released by OSC' anyone know?

 

So I had it working find and was smart enough to back it up.

Sure enough after modding only 'appearance' pages- nothing in the paypal folder than I can remember it clears the cart but does not do the inventory.

 

I've spent hours today trying to follow the code.

What I'm going to do now is install the working one again- make sure it still works then do a file compare. If nothing comes up that means it is a database setting.

 

Maybe there is an admin setting that affects this?

 

Settings:

Aggregate cart is fine (itemized is bad according to paypal)

Paypal settings not needed for ipn

Autoreturn not needed

The info sent to paypal sets it up.

 

When the IPN works it is so cool.

I tested on the live server, refunded and the status changed.

 

When it doesn't you can kick off your shoes close the door and click for many hours!

Share this post


Link to post
Share on other sites

Thanks Steve

 

I realise that there are many versions kicking around in the contributions section:

PayPal_Shopping_Cart_IPN

osCommerce PayPal IPN Module v1.0 For 2.2MS2

Paypal Express Checkout 1.0 Alpha

PayPal_Shopping_Cart_IPN_v2.6a (addon only)

PayPal IPN v0.981 for Milestone 2

PayPal IPN Gateway for osCommerce

PayPal IPN v0.98 for Milestone 2

PayPal IPN

 

As far as I'm aware, only the second one (the one this support thread relates to) is "official" in that it's developed by the osC team. It's also the simplest to install (AFAIK).

 

I was just hoping that someone had done some work in shifting the email notifications and stock update functions from checkout_success to ipn, and if this was successful.

 

I couldn't find anything with 3.15 (I used +paypal +ipn for my search term) - where is this, and did you get it to work successfully? If so, I can have a look at their code and see if I can integrate it into this one somehow.

 

Cheers

John

 

(SNIP)

What I did was installed a fresh osc then put on the contribution 3.15 ipn

They are scattered around and each have updates apparently.

(SNIP)

I'm not sure which IPN is the 'new one released  by OSC' anyone know?

(SNIP)

Share this post


Link to post
Share on other sites

i'm not good at php script, can anyone help me out.....

 

i record this error:

 

Parse error: parse error, unexpected ';', expecting ')' in /home/virtual/site24/fst/var/www/html/myshop/admin/includes/boxes/customers.php on line 29my customers.php

 

 

 

<?php

 

$Id: customers.php,v 1.1.1.1 2003/08/14 07:59:00 nickle Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright ? 2002 osCommerce

 

Released under the GNU General Public License

*/

?>

<!-- customers //-->

<tr>

<td>

<?php

$heading = array();

$contents = array();

 

$heading[] = array('text' => BOX_HEADING_CUSTOMERS,

'link' => tep_href_link(FILENAME_CUSTOMERS, 'selected_box=customers'));

 

if ($selected_box == 'customers') {

$contents[] = array('text' =>

//Admin begin

// '<a href="' . tep_href_link(FILENAME_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_CUSTOMERS . '</a><br>' .

// '<a href="' . tep_href_link(FILENAME_ORDERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CUSTOMERS_ORDERS . '</a><br>'.

//begin PayPal_Shopping_Cart_IPN

'<a href="' . tep_href_link(FILENAME_PAYPAL, '', 'NONSSL') . '" class="menuBoxContentLink">'. BOX_CUSTOMERS_PAYPAL .'</a>';

//end PayPal_Shopping_Cart_IPN

 

tep_admin_files_boxes(FILENAME_CUSTOMERS, BOX_CUSTOMERS_CUSTOMERS) .

tep_admin_files_boxes(FILENAME_ORDERS, BOX_CUSTOMERS_ORDERS));

//Admin end

}

 

$box = new box;

echo $box->menuBox($heading, $contents);

?>

</td>

</tr>

<!-- customers_eof //-->

Share this post


Link to post
Share on other sites

Installed Credit / Voucher to latest version of OSC. Everything works except...

 

When verifying Discount Coupon.. checkout_confirmation shows correct adjusted total (discount is redemed). But....... when it proceed to PayPal, the discount coupon is NOT reflected.

 

What have I done.

 

Although the confirmation page shows discount AND hidden values passed to PayPal reflect correct values INCLUDING amount equal to the adjusted total, PAYPAL ignores and shows the total WITHOUT the discount.

 

Is there somewhere I can look? Is there a patch? Is anyone else experiencing this?

 

Thanks!

Share this post


Link to post
Share on other sites
i'm not good at php script, can anyone help me out.....

 

i record this error:

 

Parse error: parse error, unexpected ';', expecting ')' in /home/virtual/site24/fst/var/www/html/myshop/admin/includes/boxes/customers.php on line 29my customers.php

(SNIP)

(29) '<a href="' . tep_href_link(FILENAME_PAYPAL, '', 'NONSSL') . '" class="menuBoxContentLink">'. BOX_CUSTOMERS_PAYPAL .'</a>';

(SNIP)

 

You'll see that at the end of this line you haven't included the closing bracket ) before the ; so the line should read:

'<a href="' . tep_href_link(FILENAME_PAYPAL, '', 'NONSSL') . '" class="menuBoxContentLink">'. BOX_CUSTOMERS_PAYPAL .'</a>');

 

the opening bracket is on line 24:

$contents[] = array('text' =>

 

Try that

Cheers

John

Share this post


Link to post
Share on other sites

OSC2.2 MS2 OSC PayPal IPN 12/20/2004

 

2) All of my confirmation emails are now stripped of the product attributes. This is annoying me a lot as I use the email to send to my distributor and the attributes are important. I have to check each order and past it in at the moment.

 

Exactly and it is a pain. Does anyone have this problem or better yet have a fix for it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×