Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

^NVM I do have it.

 

Everytime I go to checkout I don't have an option to purchase without using paypal. It says log in or create account. I have already checked and I have enable purchase without paypal under paypal settings. Any clue what is going on?


Contributions installed: Purchase without Account / STS/ All Products/ Header Tags Controller

Share this post


Link to post
Share on other sites

Also when I am in sandbox I get following error: Paypal does not allow your country of residence to ship to the country you wish to.

 

Any clue on how I can fix this? I am only using CANADA/U.S. addresses..

Edited by sarafina

Contributions installed: Purchase without Account / STS/ All Products/ Header Tags Controller

Share this post


Link to post
Share on other sites

Hi,

 

I recently installed an IPN module and I'm having a weird problem.

 

Logged in with my PayPal Sandbox account, I check-out a product in my store, but it redirects to PayPal's login screen with NO ORDER DETAILS. (e.g. https://www.paypal.com/au/cgi-bin/webscr <- no extra GET parameters

 

If I then hit "back" and check-out again, once again it redirects to PayPal's login screen, but this time with ORDER DETAILS. (e.g. https://www.paypal.com/au/cgi-bin/webscr <- with session parameters)

 

Everything else here after works fine.

 

Anyone knows what's going on behind the scene? I've been on this problem for days!

 

I'll be happy to test anything,

 

THANKS!

 

Seb. :thumbsup:

Share this post


Link to post
Share on other sites

Hi everyone, it appears I am still receiving these strange emails from my store (I think from paypal debug?) with the following content:

 

Subject: PayPal IPN Invalid Process

 

$_POST:

 

 

$_GET:

 

Thats all that in the subject matter..now I havnt had any orders since the weekend, but I am still receiving this odd email.

 

Has anyone come across this debug email error previously, if so any help would be greatly appreciated.

 

Cheers!

Share this post


Link to post
Share on other sites

Hi,

 

Quick question, I've got Paypal IPN V1.4 installed and all was working on the sandbox server. What business acount should we go for...is the 'Website Payments Standard' the one to go for? Thanks

Share this post


Link to post
Share on other sites

I opened up the standard account...now i cannot see 'Paypal Account Optional' anywhere...is it only availiable on certain configurations etc? Thanks

Share this post


Link to post
Share on other sites

Should I get email confirmations while testing in the sandbox? It says IPN invalid but I'm wondering if thats because I'm still testing and not live?


Contributions installed: Purchase without Account / STS/ All Products/ Header Tags Controller

Share this post


Link to post
Share on other sites

Ok I finally got it working. Can anybody tell me where can I customize the emails that are sent out?

 

The order process emails that customer gets..


Contributions installed: Purchase without Account / STS/ All Products/ Header Tags Controller

Share this post


Link to post
Share on other sites

Hello All,

 

I hope someone can update me on the status of the latest PayPal IPN Module. We have had a store for a while now using PayPal IPN as our primary mode of payment and I had a couple of questions:

 

1. What is the latest PayPal IPN Module and what might be the advantages over PayPal IPN v2.3.3 which is what we currently have installed ?

 

2. Is there a contribution or does the latest PayPal Module Transfer the store Order Details to PayPal specifically,

 

a) Items details and not just the total (i.e Itemized order)

Transfer the shipping details to automatically fill the paypal shipping form ?

 

Please do let me know if there is a module that might do this or if there are contributions we could install to make things easier.

 

Thanks in advance for your help.

 

Amit

Share this post


Link to post
Share on other sites

Update has been added to http://addons.oscommerce.com/info/2679 called Paypal_IPN_2_3_4_7 Fix for QTPro v4.51b and/or Discount Coupon Codes 3.32 dated 26 May 2010 which addresses the following:

 

(1) OPTION 1

 

The following update is to address issues whereby any purchase made with Paypal IPN on stock with attributes using QTpro, was not getting updated once the purchase was finailised. QT Doctor alarm was being triggered and manual intervention was required to fix stock levels.

 

### Replacement files with QTPro v4.51b contribution installed ###

 

(2) OPTION 2

 

This option not only has the above ammendment (1) but also includes a fix for discount coupons where the discounted shipping rate was not being passed to paypal. Only use this option if you also have Discount Coupon Codes 3.32 contribution installed.

 

### Replacement files with both QTPro v4.51b and Discount Coupon Codes 3.32 contributions installed ###

 

Credit to Gareth for the effort in providing QTpro code, and Luca for Discount coupon fix. Great job.

 

Regards

George

Share this post


Link to post
Share on other sites

Hello

 

Okay I made my site in 2006 and installed the Paypal IPN. All working fine from that point of view but as things have moved on I find customers increasingly don't want funds collected until dispatch in the same way I use Google and I don't really want them in advance either. I naively thought this wasn't possible with Paypal but googling today has told me that authorisation is possible! It was never on my admin at the time.

 

I have tried looking through part of this thread but it is LARGE so can someone please point me to how to alter things so I can achieve this.

Share this post


Link to post
Share on other sites

Which IPN version was installed.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

Since v2.x the invoice email has been moved to ipn.php under the ext directory. You should find the email building block in ipn.php similar to checkout_process.php where the contribution you mentioned places its code at. The variable (int)$customer_id won't work in ipn.php because the customer's session doesn't exist, you should use (int)$_POST['custom'] instead.

 

Also using your great contribution and the customer extra fields contribution.

Extra fields names which should be displayed in the e-mail are indeed displayed correctly but their associated values for the customer aren't.

Replacing the variable (int)$customer_id by (int)$_POST['custom'] doesn't work.

 

Here is the code (which may have changed since you posted your reply):

   // START extra fields in email
 $it=0;
$semextrfields = tep_db_query("select * from " . TABLE_EXTRA_FIELDS . " where fields_required_email = '1'");
while($dataexfes = tep_db_fetch_array($semextrfields)) {
$cusextrfields = tep_db_query("select * from " . TABLE_CUSTOMERS_TO_EXTRA_FIELDS . " where customers_id = '" . (int)$_POST['custom'] . "' and fields_id = '" . $dataexfes['fields_id'] . "'");
$rescusextrfields = tep_db_fetch_array($cusextrfields);
 if ($it < 1) {
$email_order .= "\n" . CATEGORY_EXTRA_FIELDS . "\n" . EMAIL_SEPARATOR . "\n" ;
   $it++;
 }

$extrfieldsinf = tep_db_query("select fields_name from " . TABLE_EXTRA_FIELDS_INFO . " where fields_id = '" . $dataexfes[fields_id] . "' and languages_id = '" . $languages_id . "'");

$extrfieldsres = tep_db_fetch_array($extrfieldsinf);
$email_order .= $extrfieldsres['fields_name'] . ' : ' .
$rescusextrfields['value'] . "\n";
 }
 $email_order .= "\n";
 // END extra fields in email

 

Thanks in advance for your time trying to help me solve my problem.

Share this post


Link to post
Share on other sites

Replacing the variable (int)$customer_id by (int)$_POST['custom'] doesn't work.

 

Actually it DOES work! My problem lied elsewhere. Sorry for the useless post.

Share this post


Link to post
Share on other sites

I have installed the module but it is not appearing in the list of available payment methods. Does anyone know why this would be happening?

Share this post


Link to post
Share on other sites

Hello,

 

I have some problems with paypal IPN 2.1.0.0 since we upgrade to PHP 5.3.

 

When there is paypal payment, the status of order doesn't update to "Payment clear".

 

We have to validate the order manually.

 

Can someone help me?

 

Thanks and best regards.

 

Fabien.

Edited by royal38

Share this post


Link to post
Share on other sites

I've found the problem. The invoice parameter is missing in the ipn process for 80% of order.

 

mc_gross=9.80

&invoice=26011 <<< Missing for 80% of orders

&protection_eligibility=Ineligible

&payer_id=SVKKHDFSDSFDDFFFDV

&tax=0.00

&payment_date=02:46:06 Jun 23, 2010 PDT

&payment_status=Completed

&charset=windows-1252

&first_name=Prenom2

&mc_fee=0.43

&notify_version=3.0

&custom=15427

&payer_status=unverified

&business=paiement@site.net

&quantity=1

&verify_sign=A9H-r7esfqs3fd5cs564vs3dfv14s

&payer_email=toto@hotmail.fr

&txn_id=0LX0fsq5f664s5qdf79DL8sq

&payment_type=instant

&last_name=Nom2

&receiver_email=site@site.net

&payment_fee=

&receiver_id=W3JQS56AFH

&txn_type=web_accept

&item_name=Site.net

&mc_currency=EUR

&item_number=

&residence_country=FR

&receipt_id=4418-2606-7293-1203

&handling_amount=0.00

&transaction_subject=15427

&payment_gross=

&shipping=0.00

 

Where can I correct this problem of invoice parameter which is missing?

 

Thanks and best regards.

Edited by royal38

Share this post


Link to post
Share on other sites

Hi

 

I have been struggling with a strange bug in the IPN which I hope I can get some help with here.

 

We have been using this IPN (A modified version of 1.1.2.8) For quite some time now and it has always worked well for us. However over the past month or so, some (about 5%) successfully paid for items have not been updating status to processing correctly.

 

I would not receive any of the debugging emails which made tracking down the problem difficult. Reading through the error logs on cpannel didn't shed any light on the problem so I tried the only method I could think of to determine where this problem lied; adding tep_email through the script which would force sending me the debug info and also help me locate the exact line the script was failing at.

 

By doing this I eventually determined that the problem was related to fsock or curl. I checked over the parameters which were being passed in-case something was a miss, it all seemed fine to the eye but I created a test script which I could use to manually send the parameters I was obtaining from my emails. Using those I would successfully obtain a response from paypal over the status of the payment, this ruled out parameters being the cause so I continued looking at other possible causes.

 

As I assumed it was using first fsock and then failing before it got a chance to try curl, I amended the condition in the script to use curl as it's primary method:

 

if (function_exists('curl_exec')) {
$curl = true;
} elseif ((PHP_VERSION >= 4.3) && ($fp = fsockopen('ssl://' . $server, 443, $errno, $errstr, 30)) ) {
$fsocket = true;
} elseif ($fp = fsockopen($server, 80, $errno, $errstr, 30)) {
$fsocket = true;
}

 

Afterwards I experienced the same problem but was able to track down the problem specifically to curl_exec. I have tried changing the curl timeout to 0, set_time_limit() to 0, Suppressing the errors from curl just to try and allow the script to continue. Tried adding try and catch's to make use of curl_error + tep_email but it made no difference. When curl_exec tried to run it would bring the script down regardless.

 

I have searched and searched for related issues with this hoping to find similar stories to help me find a solution with little success. I think I'm pretty much out of options at this point so any help would be greatly appreciated.

 

Thanks

 

Phil

Share this post


Link to post
Share on other sites

Update has been added to http://addons.oscommerce.com/info/2679 called Paypal_IPN_2_3_4_7 Fix for QTPro v4.51b and/or Discount Coupon Codes 3.32 dated 26 May 2010 which addresses the following:

 

(1) OPTION 1

 

The following update is to address issues whereby any purchase made with Paypal IPN on stock with attributes using QTpro, was not getting updated once the purchase was finailised. QT Doctor alarm was being triggered and manual intervention was required to fix stock levels.

 

### Replacement files with QTPro v4.51b contribution installed ###

 

(2) OPTION 2

 

This option not only has the above ammendment (1) but also includes a fix for discount coupons where the discounted shipping rate was not being passed to paypal. Only use this option if you also have Discount Coupon Codes 3.32 contribution installed.

 

### Replacement files with both QTPro v4.51b and Discount Coupon Codes 3.32 contributions installed ###

 

Credit to Gareth for the effort in providing QTpro code, and Luca for Discount coupon fix. Great job.

 

Regards

George

 

 

I have installed this "fix" and run into a problem. Stock is subtracted and the IPN works as it should be but order emails are not being sent.

 

If I upload the ipn.php file from the osCommerce_PayPal_IPN_2_3_4_7 package the emails are being sent but not with the "fixed" ipn.php file.

 

I have no idea what the reason for this could be and don't know where to start looking for a solution. Does anyone else seen this problem?

Share this post


Link to post
Share on other sites

I have osCommerce PayPal IPN Module v1.5 For 2.2MS2 installed. The customer receives about 13 order process emails. I also noticed 13 PayPal IPN Verified notifications on the admin side of the orders. I know the module version I have is not up to date. This version has always worked for me. I looked through this thread for a solution but can't find one. Has anyone ran into this issue before?

Share this post


Link to post
Share on other sites

I have installed this "fix" and run into a problem. Stock is subtracted and the IPN works as it should be but order emails are not being sent.

 

If I upload the ipn.php file from the osCommerce_PayPal_IPN_2_3_4_7 package the emails are being sent but not with the "fixed" ipn.php file.

 

I have no idea what the reason for this could be and don't know where to start looking for a solution. Does anyone else seen this problem?

 

 

Anyone? Please...

Share this post


Link to post
Share on other sites

I have osCommerce PayPal IPN Module v1.5 For 2.2MS2 installed. The customer receives about 13 order process emails. I also noticed 13 PayPal IPN Verified notifications on the admin side of the orders. I know the module version I have is not up to date. This version has always worked for me. I looked through this thread for a solution but can't find one. Has anyone ran into this issue before?

 

 

The correct version I have installed is osCommerce_PayPal_IPN_v2.1 For 2.2MS2.

Share this post


Link to post
Share on other sites

The correct version I have installed is osCommerce_PayPal_IPN_v2.1 For 2.2MS2.

 

 

The customer receives about 13 order process emails. I also noticed 13 PayPal IPN Verified notifications on the admin side of the orders. I know the module version I have is not up to date. This version has always worked for me. I looked through this thread for a solution but can't find one. Has anyone ran into this issue before?

 

 

I got a email from PayPal today stating the following:

 

Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

 

catalog/ext/modules/payment/paypal_ipn/ipn.php

 

 

 

I am not sure if this is a permission issue with access to the ipn.php file. Please help me with this issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×