Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

Thanks Ted!

 

I did try Standard first, it didn't fill the bill for the downloadable content. I need to the transaction to be as close to instant as possible, which is why I am hoping to get paypal to send the encrypted download link upon payment approval. With IPN, I am going through the process and being forwarded back to the site but still not getting the download e-mail with the link. As the buyer I get an "order process" e-mail, and a "Receipt for payment" e-mail, but no DL link, or change to status if I return to the site.

 

As the seller, I receive all of the notifications, but still need to manually change the order status manually(which is what I am hoping to eliminate)

 

Thanks for responding, still could use a hand getting this functional :)

 

 

 

Todd

Share this post


Link to post
Share on other sites
Thanks for responding, still could use a hand getting this functional :)

 

No problem.... here is an easy fix....

 

around line 298 in ipn.php

 

		  $email_order = STORE_NAME . "\n" . 
					 EMAIL_SEPARATOR . "\n" .

 

change to:

 

		  $email_order = STORE_NAME . "\n\n";
	  if ($content_type == 'virtual') {
					 $email_order .= EMAIL_DOWNLOAD_LINK . "\n\n";
	  }
					 $email_order .= EMAIL_SEPARATOR . "\n" .

 

in catalog\includes\languages\english\modules\payment\paypal_ipn.php

 

add before end "?>":

 

  define('EMAIL_DOWNLOAD_LINK', 'Dear Customer, Thanks for purchasing our software. Here is the link to your download: http://www.mysite.com/download/file.zip');

 

Edit as needed. Might want to change the download location or filename now and then too.

 

Now, anyone have any idea about my problem? :)

Edited by t_jones_tech

Share this post


Link to post
Share on other sites
No problem.... here is an easy fix....

 

around line 298 in ipn.php

 

		  $email_order = STORE_NAME . "\n" . 
					 EMAIL_SEPARATOR . "\n" .

 

change to:

 

		  $email_order = STORE_NAME . "\n\n";
	  if ($content_type == 'virtual') {
					 $email_order .= EMAIL_DOWNLOAD_LINK . "\n\n";
	  }
					 $email_order .= EMAIL_SEPARATOR . "\n" .

 

in catalog\includes\languages\english\modules\payment\paypal_ipn.php

 

add before end "?>":

 

  define('EMAIL_DOWNLOAD_LINK', 'Dear Customer, Thanks for purchasing our software. Here is the link to your download: http://www.mysite.com/download/file.zip');

 

Edit as needed. Might want to change the download location or filename now and then too.

 

Now, anyone have any idea about my problem? :)

 

Thanks Ted, if I don't get this to work I will edit the code. I am a little hesitant as it seems it would not be very secure/ the link could be distributed. The whole thing with Paypal IPN doing what it is supposed to is that the DL link would be encrypted.

 

I appreciate your responses, this has been a long frustrating process for me.

If anyone knows how to get the encrypted DL link to work, please post up the info :)

 

 

Todd

Share this post


Link to post
Share on other sites

Hi all

 

I am a complete newbie to this and was recommended this add-on as we were using the PayPal Standard module but it didn't deduct stock form the site.

 

I am running the store on a test site rather than changing the live version. I have spent the entire morning getting more and more confused at PayPal's documentation (probably explains the headache).

 

My question at the moment is: is the cURL Proxy server field necessary? Also where I have the Your PayPal Public Certificate ID I don't have an actual PayPal public certificate. Are these also needed and how do I go about this??

 

I have tried the add-on on my test server and it works but on clicking the pay Now button, then it comes up and says the payment has already been made. Any help would be very much appreciated. :blush:


Debbie Harrison

 

Share this post


Link to post
Share on other sites

i am receiving this error below, i just installed the latest version of this contrib, someone please help!!:

 

 

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, webmaster@paypal.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

 

 

somehow a few orders did make it through, one was an international order the other usa and the transaction was perfect

 

but i lost about 10 other orders because of that error above (i am assuming all the orders that didnt go through goit that error ) because ever since i changed my payment from regular osc paypal to the paypal ipn, i received orders in my OSC panel but the payment status shows "no payment received"

and the payment for those orders shows it was paypal, and no money was received in paypal but the order was logged in OSC ???

 

please someone help im so confused!!

Share this post


Link to post
Share on other sites

OK I have it working again but the values in my SandBox account are "Under review" On reading the PayPal threads this is something that can be corrected in the Sandbox.

 

But my main concern is stock is still not deducting. Is this because the payment hasn't been approved?

 

Please can someone advise or help? Set up screen is as follows:

 

kcppss.gif

Edited by dvharrison

Debbie Harrison

 

Share this post


Link to post
Share on other sites

I have just installed the latest ipn mod to the newest osc (usless with the number bit), I also have STS and the gift card (trad) mod on the site as well.

The problem I have if I use standard and express the checkout totals are moving across to paypal as expected but using ipn the vslue 0.00 is displayed forcing a buyer to fill in the amount themselves.

 

I have a paid ssl cert.

 

I am also getting back a debug email subject PayPal IPN Invalid Process and the message is

$_POST:

 

 

$_GET:

 

Just can appear to nail this - any help - been at this all day.

Share this post


Link to post
Share on other sites
I have just installed the latest ipn mod to the newest osc (usless with the number bit), I also have STS and the gift card (trad) mod on the site as well.

The problem I have if I use standard and express the checkout totals are moving across to paypal as expected but using ipn the vslue 0.00 is displayed forcing a buyer to fill in the amount themselves.

 

I have a paid ssl cert.

 

I am also getting back a debug email subject PayPal IPN Invalid Process and the message is

$_POST:

 

 

$_GET:

 

Just can appear to nail this - any help - been at this all day.

 

I have reloaded the mod an now it appears to work, not so sure on correcting product levels etc, about to give it a good going through now.

Share this post


Link to post
Share on other sites

Before I get buried on this thread as well, could someone be sweet enough to read post #3933? I really have run out of suggestions.

 

Thanks in advance.


Debbie Harrison

 

Share this post


Link to post
Share on other sites

Hi,

 

I have some problems with this module. I installed the last one. But when I want to pay something and I click on the button pay in Paypal. It say someting like "the order is already paid". I don't know the exact words in English because my shop is Dutch. But it is something like this message. How could I fix it.

 

And the second question. Do I need to set up some special things in my Paypal account for this module?

 

It would be glad if someone could help me.

 

 

Thanks!

Share this post


Link to post
Share on other sites
Hi all

 

I am a complete newbie to this and was recommended this add-on as we were using the PayPal Standard module but it didn't deduct stock form the site.

I am running the store on a test site rather than changing the live version. I have spent the entire morning getting more and more confused at PayPal's documentation (probably explains the headache).

 

 

I think you are being annoyed by the fact that PayPal does not automatically send customers back to the shop after paying, if they did not loging to paypal, but just payed with their card.

Let me quote myself:

 

Is there any solution for paying but non-returning customers yet ?

- and order is created, and IPN received , but if customer do not choose to return, no confirmation-email is sent, and the stock is not reduced...

 

 

In the mean time, you could email PayPal and make them change this stupid policy - they prioritize "new members" before delivering the service you pay for.

Share this post


Link to post
Share on other sites

Dear Andre

 

Thanks for your feedback, however the actual post I was referring to was post no #3933 where I am trying to work out why stock isn't deducting. The one you're replying to was my initial gripe about if all these fields were really necessary (which on reading this thread I now realise that I probably am Ok without cURL etc).

 

Not everyone uses PayPal without signing in and I certainly didn't when testing the site to find out. This is why I really need to sort out why stock isn't deducting in the contribution (which is why I downloaded the PayPal IPN contribution it in the first place).

 

If you can offer any help on what the problem might be then i would be very grateful. ;)

Edited by dvharrison

Debbie Harrison

 

Share this post


Link to post
Share on other sites

I have just had to disable email on my test server (as I have no domain name) as I was getting an internal server error. Could this also be an issue for the payPal not working?

 

I have 2 options set up - Cash on delivery works and the stock deducts and payPal IPN and the order stays as processing (payPal IPN) and the stock doesn't deduct. I have only recently disabled the email facilities on my test server so there was an issue before I did this.

 

Could anyone help me please? I really need to resolve this and at hte moment I feel I am getting nowhere. :huh:


Debbie Harrison

 

Share this post


Link to post
Share on other sites

Well looking over this contrib, I am quite confused. Because things are not adding up for me.

I am reading/seeing conflicting things with my layout, upgrading, instructions and so forth.

 

This is the set up and where I am at:

 

I have now this installed (concerns conflicts at bottom):

 

^^^^^^^^^^^^^^^^^>>>>>>>>>

 

I have osCommerce Description: (v2.2ms2-060817)

osCommerce 2.2-MS2.

 

And in that build, I have done changes to the files that the

 

osCommerce 2.2 MS2 PayPal IPN Payment Module v2.3.4.7 contrib refers to, like "shopping_cart.php", and some others, but not have added anything yet for those changes.

Meaning, I have done things with my setup and the current osCommerece I am using. Having to do with other minor adjustments for other contribs. But no other payment type mods.

 

I have NOT installed, or used this contrib yet "osCommerce 2.2 MS2 PayPal IPN Payment Module v2.3.4.7" http://addons.oscommerce.com/info/2679 and have done no changes of any kind, yet.

 

I ran into some conflicts, and know best to come here for help, before really GOOFING something up.

I am quite lousy with PHP, however,

I am good at following step-by-step- instructions.

 

I need your help please.

 

In my current set up, I have this stuff, and my conflicts as to why I am here asking for guiandance.

 

/public_html/osc/admin/includes/modules/newsletters

 

And in that path are two files.

 

newsletter.php And product_notification.php

 

As for payment modules, there all located in here:

 

/public_html/osc/includes/modules/payment

 

And there are three sections in there for three types of modules:

 

/public_html/osc/includes/modules

 

/modules/order_total

/modules/payment

/modules/shipping

 

And in the payment one for the paypal, there is at moment the "paypal.php,v 1.39" in there with other types of various mods.

 

Based on the instructions below. How do I then get to:

 

(http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php?'>http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php?

 

As well I use/have a shared SSL set up, and I look at the path for this file "ipn.php" as needing to be in here:

 

\catalog\ext\modules\payment\paypal_ipn

 

My path on my server is this:

 

/public_html/osc/admin/includes/modules/newsletters

 

And

 

/public_html/osc/includes/modules/payment

 

So when I read this stuff below, I thought (knew better) it best to come ask for help with this.

 

 

Try to open catalog/ext/modules/payment/paypal_ipn/ipn.php in internet browser (http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php

 

 

 

If payments are being received at PayPal but the stock level/orders status is not updated and confirmation emails are not sent, then IPN (Instant Payment Notification) is not working.

Follow the check list below for trouble shooting:

Make sure you have copied the ext folder to your server under your catalog directory.

Try to open catalog/ext/modules/payment/paypal_ipn/ipn.php in internet browser (http://yourdomain.com/catalog/ext/modules/payment/paypal_ipn/ipn.php

change the words marked in red corresponding to your store). A blank page will show up if there is no problem accessing this script.

 

 

 

Follow Up Info:

 

See, at moment, I am trying to want to get this set up, so I can test it in sandbox, I am plaining to upgrade my paypal to an account as needed. But before I do that, I need to badly get this working.

 

I have no other payment modules activated besides the one lone paypal that came with the osCommerce it came with. And I had to get that adjusted by the host, to be sure atleast the paypal was loading.

 

I have yet to be able to test it, but I can see from all I read at paypal, I need a different setup and need to get to Website Payments Standards.

So here I am. :-(

 

 

I am little fellow, in BIG world, and badly need help with this.

I am lousy with code, but great on following instructions IF there given to me step by step and leaving nothing out.

 

Thank you for ALL your help. :-)

Share this post


Link to post
Share on other sites

Hello people.

 

I got some problems with the OsCommerce PayPal module.

 

When i place an order on my webpage, i recieve an email that says:

 

PayPal IPN Invalid Process(title)

 

$_POST:

 

 

$_GET:

 

The order status wont update either. Ive manually made a php.ini file to activate "globals_online". Globals_Online still stands as OFF in the server_info in the administrator panel though. Happends in both sandbox and original modus.

 

Help would be much appreciated.

 

Regards Morten.

Share this post


Link to post
Share on other sites

I have just installed the paypal IPN and it appears to work fine with firebox but if i try to pay with internet explorer, when i am redirected to the paypal website i get the following error "Sorry, an error occurred after you clicked the last link" Any ideas why this would be

 

Thanks

 

Greg

Share this post


Link to post
Share on other sites

Hi all

 

I got it working in Sandbox (don't ask me how, I don't know)

 

But now I am trying on the live site and although the function allows payments, verifications aren't being made and and stock isn't deducting.

 

The only difference I can see is that the payments were via Sandbox. Please help, I have tried everything: CHMODs uninstalling and reinstalling, troubleshooting, support pages.

 

Many thanks in advance.


Debbie Harrison

 

Share this post


Link to post
Share on other sites

And I have noticed that both buyer and client are not receiving their order process emails. I think the 2 problems are related.

 

Any suggestions?


Debbie Harrison

 

Share this post


Link to post
Share on other sites

Could it have anything to do with OSCAdminID? This shows up in the URL in Admin area of my test site but not in the live site's admin area.

 

Please could someone help?


Debbie Harrison

 

Share this post


Link to post
Share on other sites

I have been playing more using this add-on. It works fine on both my test site and the live site, (using my Sandbox account), but when I try the live server, PayPal doesn't verify anything and emails are not being sent. So I am drawing the conclusion that theres something wrong in the PayPal account.

 

I have noticed that the live server also have auctions enabled on their account. Could this be why the pesky thing isn't working?

 

If anyone has any similar experiences with this particular add-on, please help. I really am at the end of my tether.

 

Thanks in advance. :blink:


Debbie Harrison

 

Share this post


Link to post
Share on other sites

Now I am confused.

 

I resorted back to Standard payPal module this morning. (didn't delete anything or uninstall the add-on) and my client has come back saying an order has been placed and stock has been deducted. Can anyone shed any light (or do I merely talk to myself on this thread)?

Edited by dvharrison

Debbie Harrison

 

Share this post


Link to post
Share on other sites
Now I am confused.

 

I resorted back to Standard payPal module this morning. (didn't delete anything or uninstall the add-on) and my client has come back saying an order has been placed and stock has been deducted. Can anyone shed any light (or do I merely talk to myself on this thread)?

 

I believe you have guessed the answer to your question. I have never received a reply on here.

Share this post


Link to post
Share on other sites
Hello people.

 

I got some problems with the OsCommerce PayPal module.

 

When i place an order on my webpage, i recieve an email that says:

 

PayPal IPN Invalid Process(title)

 

$_POST:

 

 

$_GET:

 

The order status wont update either. Ive manually made a php.ini file to activate "globals_online". Globals_Online still stands as OFF in the server_info in the administrator panel though. Happends in both sandbox and original modus.

 

Help would be much appreciated.

 

Regards Morten.

 

 

Dear Morton,

 

I have exactly the same problem since mid of April, I wonder whether Paypal or my host Strato changed something. except for adding new articles I have not change anything else.

I have tried the IPN simulator in the sandbox toolbox but that seems not to reach me IPN.php, the simulator say html error 503 although if I enter the full address in the browser I do get an empty page.

One strange issue I found is that once I change the CMOD of the EXT path into 755 and a minute later I check the CMOD of this again it shows 600 instead.

 

Anyone facing the same issue? Please post your solution.

 

John

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×